[KDE] comment démarrer kde (résolu)

Xorg, Compiz, KDE / Gnome / Xfce / Fluxbox / e17 / fvwm ... GDM/KDM/XDM...
Répondre
JeanMichel
Hankyu
Messages : 16
Inscription : sam. 04 avr. 2009, 19:56

[KDE] comment démarrer kde (résolu)

Message par JeanMichel » lun. 06 avr. 2009, 10:10

Bonjour,

je démarre sous Arch après 2 ans d'iitiation à la culture Linux avec Ubuntu.

Je suis dans l'intallation. J'ai installé xorg et kdemod.

Code : Tout sélectionner

# pacman -S kdemod
# pacman -S kdemod-kde-l10n-fr
Maintenant je fais :

Code : Tout sélectionner

# /etc/rc.d/kdm start
et la console me répond :
:: starting kde desktop manager [done]
et me rend la main ... je suis donc toujours en console, kde n'a pas démarré ... quelle étape ais-je oublié ?

merci d'avance
Dernière modification par JeanMichel le lun. 06 avr. 2009, 18:15, modifié 1 fois.

Ledahu
Hankyu
Messages : 19
Inscription : sam. 04 avr. 2009, 10:23
Localisation : Paris

Re: [KDE] comment démarrer kde

Message par Ledahu » lun. 06 avr. 2009, 10:35

Bienvenue sous Arch!
Tente de taper seulement kdm dans la console, normalement ça va lancer le gestionnaire de connexion si xorg est bien configuré (au fait tu as pensé à ajouter hal dans les deamons du rc.conf pour la gestion de la souris et du clavier?). Ensuite pour ne plus avoir à le retaper tout le temps, tu peux ajouter kdm à la liste des deamons du fichier rc.conf ce qui le lancera au démarrage.

maxi_jac
Daikyu
Messages : 94
Inscription : dim. 15 juin 2008, 17:43

Re: [KDE] comment démarrer kde

Message par maxi_jac » lun. 06 avr. 2009, 10:50

Ctrl + Alt + F7 pour verifier que X n'est pas démarré sur la console 7.



++ B.

Cactus
Maître du Kyudo
Messages : 2073
Inscription : sam. 16 sept. 2006, 10:39
Localisation : 31 - Toulouse Nord

Re: [KDE] comment démarrer kde

Message par Cactus » lun. 06 avr. 2009, 12:04

mouais, quand on a des soucis de démarrage de X, il vaut mieux le lancer depuis /etc/inittab plutôt que de mettre kdm en daemon dans /etc/rc.conf...
Ca permet de démarrer en init 3 (console) en éditant grub au démarrage...

JeanMichel
Hankyu
Messages : 16
Inscription : sam. 04 avr. 2009, 19:56

Re: [KDE] comment démarrer kde

Message par JeanMichel » lun. 06 avr. 2009, 15:17

maxi_jac a écrit :Ctrl + Alt + F7 pour verifier que X n'est pas démarré sur la console 7.
alors Ctrl+Alt+F7 ne fait rien chez moi. Par contre Alt+F7 me bascule sur une fenêtre toute noire, à l'exception d'un "_" en haut à gauche.

@Ledahu : kdm en direct ne fait rien, ça bascule sur un écran noir pendant quelques secondes, puis ça revient sur mon tty1

@Cactus : ça, ça dépasse mes compétences. Je dois creuser cette piste ?

dans mon rc.conf, j'ai :
DAEMONS=(syslog-ng network netfs crond hal)

Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Re: [KDE] comment démarrer kde

Message par tuxce » lun. 06 avr. 2009, 15:30

salut,
juste après avoir lancer

Code : Tout sélectionner

/etc/rc.d/kdm start
lance:

Code : Tout sélectionner

tail -10 /var/log/daemon.log
tu devrais avoir, entre autre, les messages de kdm, ça donnera une piste.

sinon, t'as vérifié d'abord si X démarre ?
si c'est pas le cas, poste le /var/log/Xorg.0.log

Cactus
Maître du Kyudo
Messages : 2073
Inscription : sam. 16 sept. 2006, 10:39
Localisation : 31 - Toulouse Nord

Re: [KDE] comment démarrer kde

Message par Cactus » lun. 06 avr. 2009, 15:30

D'abord, fais une recherche sur inittab, puis en fonction de ce que tu auras compris, édites le fichier avec :
sudo nano /etc/inittab

Il y a 2 lignes importantes :
- vers le début : l'init par défaut (à régler sur 5 pour lancer X)
- vers la fin : la ligne de commande qui lancera KDE

Je n'ai pas tout en tête, donc poste ton inittab si tu veux que je t'aide à la volée (mais le mieux est que tu cherches par toi-même pour comprendre ce que tu fais) ;)

Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Re: [KDE] comment démarrer kde

Message par tuxce » lun. 06 avr. 2009, 15:33

pour l'instant, inittab est une alternative (ou plutot les daemons sont une alternative à inittab) mais ce n'est pas ce qui empêche kdm de démarrer.

JeanMichel
Hankyu
Messages : 16
Inscription : sam. 04 avr. 2009, 19:56

Re: [KDE] comment démarrer kde

Message par JeanMichel » lun. 06 avr. 2009, 15:39

tuxce a écrit :salut,
juste après avoir lancer

Code : Tout sélectionner

/etc/rc.d/kdm start
lance:

Code : Tout sélectionner

tail -10 /var/log/daemon.log
tu devrais avoir, entre autre, les messages de kdm, ça donnera une piste.
Salut tuxce, voici le résultat (recopié à la main) :

Code : Tout sélectionner

 myhost kdm[2120] : X server died during startup
myhost kdm[2120] : X server for display:0 cannot be started, session disabled
bon avce ça c'est pas prêt de fonctionner ...
tuxce a écrit : sinon, t'as vérifié d'abord si X démarre ?
si c'est pas le cas, poste le /var/log/Xorg.0.log
comment puis-je vérifier si X démarre ? (je suis un peu perdu entre X, Xorg et kdm ...mais je suis là pour apprendre, sinon je n'aurais pas quitté mon Ubuntu ... donc merci à tous pour vos indications)
Dernière modification par JeanMichel le lun. 06 avr. 2009, 15:48, modifié 1 fois.

Cactus
Maître du Kyudo
Messages : 2073
Inscription : sam. 16 sept. 2006, 10:39
Localisation : 31 - Toulouse Nord

Re: [KDE] comment démarrer kde

Message par Cactus » lun. 06 avr. 2009, 15:47

tuxce a écrit :pour l'instant, inittab est une alternative (ou plutot les daemons sont une alternative à inittab) mais ce n'est pas ce qui empêche kdm de démarrer.
Si je ne dis pas de c***erie, ça permet de lancer startx (gros doute à cause du ~/.xinitrc)

Ah tiens, pour notre ami JeanMichel : et si tu lances simplement startx ? (au pire, ça lance twm, mais au moins, tu vérifies que le xorg est bon).

JeanMichel
Hankyu
Messages : 16
Inscription : sam. 04 avr. 2009, 19:56

Re: [KDE] comment démarrer kde

Message par JeanMichel » lun. 06 avr. 2009, 15:54

Cactus a écrit :
Ah tiens, pour notre ami JeanMichel : et si tu lances simplement startx ? (au pire, ça lance twm, mais au moins, tu vérifies que le xorg est bon).
startx bascule un bref instant sur une fenêtre qui me semble être graphique, mais qui reste toute noire (avec des "caractères japonais, ou pseudo-japonais, ou stochastiques" rouges en haut) puis revient à la console avec plein de Warnings et une erreure finale :

Code : Tout sélectionner

Fatal server error : could not open font "fixed"
giving up
xinit : no such file or directory : unable to connect to X server


Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Re: [KDE] comment démarrer kde

Message par tuxce » lun. 06 avr. 2009, 15:56

JeanMichel a écrit :

Code : Tout sélectionner

 myhost kdm[2120] : X server died during startup
myhost kdm[2120] : X server for display:0 cannot be started, session disabled
bon avce ça c'est pas prêt de fonctionner ...
ça, ça veut dire que ton X ne fonctionne même pas, et moi ça me dit que tu n'as pas suivi:
http://wiki.archlinux.fr/howto:indispensable:xorg
et plus précisément la section configuration de la carte graphique, où il y a des indications sur comment tester ;)

au lieu de copier à la main, tu peux utiliser "pastebin" qui est présent dans le dépot "archlinuxfr" et:

Code : Tout sélectionner

pastebin /var/log/Xorg.0.log
Cactus a écrit :
tuxce a écrit :pour l'instant, inittab est une alternative (ou plutot les daemons sont une alternative à inittab) mais ce n'est pas ce qui empêche kdm de démarrer.
Si je ne dis pas de c***erie, ça permet de lancer startx (gros doute à cause du ~/.xinitrc)
pas compris :? tu veux dire qu'inittab lance startx ??

JeanMichel
Hankyu
Messages : 16
Inscription : sam. 04 avr. 2009, 19:56

Re: [KDE] comment démarrer kde

Message par JeanMichel » lun. 06 avr. 2009, 16:09

tuxce a écrit : ça, ça veut dire que ton X ne fonctionne même pas, et moi ça me dit que tu n'as pas suivi:
http://wiki.archlinux.fr/howto:indispensable:xorg
et plus précisément la section configuration de la carte graphique, où il y a des indications sur comment tester ;)
OK je vais reprendre à partir de là
tuxce a écrit : au lieu de copier à la main, tu peux utiliser "pastebin" qui est présent dans le dépot "archlinuxfr" et:

Code : Tout sélectionner

pastebin /var/log/Xorg.0.log
j'ai fait

Code : Tout sélectionner

pacman -S pastebin
et ça me renvoie :

Code : Tout sélectionner

erreur : pastebin non trouvé dans les dépots
??
Dernière modification par JeanMichel le lun. 06 avr. 2009, 23:02, modifié 1 fois.

Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Re: [KDE] comment démarrer kde

Message par tuxce » lun. 06 avr. 2009, 16:15

ahhhh, s'il y avait pas le wiki...

ajoute:

Code : Tout sélectionner

[archlinuxfr]
Server = http://repo.archlinux.fr/i686
dans /etc/pacman.conf

x86_64 au lieu de i686 si tu es en 64

puis:

Code : Tout sélectionner

pacman -Sy pastebin
mais stp, une recherche sur le wiki avant de se jeter à poser une question, ça serait sympa.

Cactus
Maître du Kyudo
Messages : 2073
Inscription : sam. 16 sept. 2006, 10:39
Localisation : 31 - Toulouse Nord

Re: [KDE] comment démarrer kde

Message par Cactus » lun. 06 avr. 2009, 16:23

Tuxce : non, inittab ne lance pas startx, mais j'ai cru un moment que startx se basait dessus pour lancer le wm par défaut.
Après coup, je pense que c'est ne ~/.xinitrc qui définit le wm par défaut, pas inittab... enfin, à vérifier, ça fait bien longtemps que je n'ai pas eu à tripatouiller ces fichiers de conf... ;)

Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Re: [KDE] comment démarrer kde

Message par tuxce » lun. 06 avr. 2009, 16:28

non mais là, y a rien à vérifier :P
inittab n'est pas lié à X, il lance un programme selon un niveau d'exécution et c'est un fichier système, il n'y a pas de paramètres utilisateur.

JeanMichel
Hankyu
Messages : 16
Inscription : sam. 04 avr. 2009, 19:56

Re: [KDE] comment démarrer kde

Message par JeanMichel » lun. 06 avr. 2009, 17:19

tuxce a écrit :ahhhh, s'il y avait pas le wiki...

ajoute:

Code : Tout sélectionner

[archlinuxfr]
Server = http://repo.archlinux.fr/i686
dans /etc/pacman.conf

x86_64 au lieu de i686 si tu es en 64

puis:

Code : Tout sélectionner

pacman -Sy pastebin
ok merci
tuxce a écrit : mais stp, une recherche sur le wiki avant de se jeter à poser une question, ça serait sympa.
Je comprends que ça puisse énerver de répondre à mes questions de débutant :oops: ... néanmoins, j'ai arpenté la plupart des pages relatives à pacman du wiki sans trouver la manip :shock: .

Je ne doute pas qu'elle soit mentionnée, mais malheureusement je ne suis pas tombé dessus quand j'ai cherché... :roll:
D'ailleurs, même Google n'est pas toujours mon ami :wink: : http://www.google.fr/search?hl=fr&clien ... cher&meta=ne m'a pas aidé beaucoup...pas plus qu'une recherche sur pastebin

Juste pour dire que je suis moi-même un fervent défenseur de la règle : "on cherche d'abord, on pose la question ensuite", mais là j'ai tout à apprendre... je pars un peu de zéro, et des fois le wiki est un peu obscur pour le débutant que je suis ... j'en apprécie d'autant plus l'aide de la communauté en général, et la tienne en particulier :D .

Au passage : génial l'outil "pastebin" !!!

Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Re: [KDE] comment démarrer kde

Message par tuxce » lun. 06 avr. 2009, 17:45

no problem :)
j'ai rajouté une note dans le wiki d'install pour pointer vers -> http://wiki.archlinux.fr/howto/archlinu ... r_le_depot

JeanMichel
Hankyu
Messages : 16
Inscription : sam. 04 avr. 2009, 19:56

Re: [KDE] comment démarrer kde

Message par JeanMichel » lun. 06 avr. 2009, 18:13

tuxce a écrit :no problem :)
j'ai rajouté une note dans le wiki d'install pour pointer vers -> http://wiki.archlinux.fr/howto/archlinu ... r_le_depot
tuxce, merci pour tout ...

Bon, c'est le moment pour moi de résumer :
- mon problème n'est pas de démarrer kde, mais de configurer xorg :?
- grace à vous tous, j'ai bien progressé ... :D

-> résolu (mais probablement à suivre ...)

Répondre