[Fluxbox, WMII, Openbox, Pekwm]couldn't open display(RÉSOLU)

Xorg, Compiz, KDE / Gnome / Xfce / Fluxbox / e17 / fvwm ... GDM/KDM/XDM...
Répondre
Florimond
Hankyu
Messages : 11
Inscription : ven. 07 août 2009, 00:20

[Fluxbox, WMII, Openbox, Pekwm]couldn't open display(RÉSOLU)

Message par Florimond » sam. 08 août 2009, 20:42

Bonjour,

Jusqu'ici j'ai utilisé Ubuntu et puis Debian, et je suis heureux de bricoler avec Archlinux depuis quelques jours. J'essaie de me débrouiller tout seul mais j'ai maintenant quelques soucis dont je ne viens pas à bout. Outre le petit problème avec XFCE que j'expose dans les derniers messages de ce sujet ->http://forums.archlinux.fr/topic4263.html
...je rencontre des difficultés avec nombre d'autres gestionnaires de fenêtres. En effet, je suis curieux et veux essayer beaucoup de choses. J'ai voulu installer Fluxbox, WMII (sur le conseil d'un ami), Openbox, et Pekwm. Voici les messages d'erreur

Fluxbox (exec startfluxbox): j'ai juste le temps de lire "unable to open display" avant d'être renvoyé au login.

WMII: "fatal error: couldn't open display"

Openbox:

Code : Tout sélectionner

Openbox-Message: Couldn't set locale to environment.
Openbox-Message: Failed to open the display from the DISPLAY environment variable.
Pekwm:

Code : Tout sélectionner

Can not open display!
Your DISPLAY variable currently is set to: 
Si je fais "export DISPLAY=:0.0" (en ne comprenant pas bien encore à quoi ça sert, mais je l'ai vu quelque part...), j'obtiens les mêmes erreurs.

Je suis sûr que la solution n'est pas loin, mais sûrement juste un peu plus loin que mon expertise en la matière :roll:

Merci de votre aide :)
Dernière modification par Florimond le lun. 10 août 2009, 21:42, modifié 1 fois.

Avatar de l’utilisateur
mum1989
Chu Ko Nu
Messages : 454
Inscription : sam. 11 oct. 2008, 23:19

Re: [Fluxbox, WMII, Openbox, Pekwm] couldn't open display

Message par mum1989 » sam. 08 août 2009, 23:02

Openbox-Message: Couldn't set locale to environment.
poste ton rc.conf (pour voir justement les locales)

Florimond
Hankyu
Messages : 11
Inscription : ven. 07 août 2009, 00:20

Re: [Fluxbox, WMII, Openbox, Pekwm] couldn't open display

Message par Florimond » sam. 08 août 2009, 23:23

désolé d'avoir tardé mais j'avais pas encore installé et configuré openssh (pour faciliter le copier coller :D)


/etc/rc.conf

Code : Tout sélectionner

#
# /etc/rc.conf - Main Configuration for Arch Linux
#

# -----------------------------------------------------------------------
# LOCALIZATION
# -----------------------------------------------------------------------
#
# LOCALE: available languages can be listed with the 'locale -a' command
# HARDWARECLOCK: set to "UTC" or "localtime"
# USEDIRECTISA: use direct I/O requests instead of /dev/rtc for hwclock
# TIMEZONE: timezones are found in /usr/share/zoneinfo
# KEYMAP: keymaps are found in /usr/share/kbd/keymaps
# CONSOLEFONT: found in /usr/share/kbd/consolefonts (only needed for non-US)
# CONSOLEMAP: found in /usr/share/kbd/consoletrans
# USECOLOR: use ANSI color sequences in startup messages
#
LOCALE="fr_BE.utf8"
HARDWARECLOCK="local"
USEDIRECTISA="no"
TIMEZONE="Europe/Brussels"
KEYMAP="be-latin1"
CONSOLEFONT=
CONSOLEMAP=
USECOLOR="yes"

# -----------------------------------------------------------------------
# HARDWARE
# -----------------------------------------------------------------------
#
# MOD_AUTOLOAD: Allow autoloading of modules at boot and when needed
# MOD_BLACKLIST: Prevent udev from loading these modules
# MODULES: Modules to load at boot-up. Prefix with a ! to blacklist.
#
# NOTE: Use of 'MOD_BLACKLIST' is deprecated. Please use ! in the MODULES array.
#
MOD_AUTOLOAD="yes"
#MOD_BLACKLIST=() #deprecated
MODULES=()

# Scan for LVM volume groups at startup, required if you use LVM
USELVM="no"

# -----------------------------------------------------------------------
# NETWORKING
# -----------------------------------------------------------------------
#
# HOSTNAME: Hostname of machine. Should also be put in /etc/hosts
#
HOSTNAME="florimond.duron800.archlinux"

# Use 'ifconfig -a' or 'ls /sys/class/net/' to see all available interfaces.
#
# Interfaces to start at boot-up (in this order)
# Declare each interface then list in INTERFACES
#   - prefix an entry in INTERFACES with a ! to disable it
#   - no hyphens in your interface names - Bash doesn't like it
#
# DHCP:     Set your interface to "dhcp" (eth0="dhcp")
# Wireless: See network profiles below
#
eth0="eth0 192.168.0.2 netmask 255.255.255.0 broadcast 192.168.0.255"
INTERFACES=(eth0)


# Routes to start at boot-up (in this order)
# Declare each route then list in ROUTES
#   - prefix an entry in ROUTES with a ! to disable it
#
gateway="default gw 192.168.0.1"
ROUTES=(!gateway)

# Enable these network profiles at boot-up.  These are only useful
# if you happen to need multiple network configurations (ie, laptop users)
#   - set to 'menu' to present a menu during boot-up (dialog package required)
#   - prefix an entry with a ! to disable it
#
# Network profiles are found in /etc/network.d
#
# This now requires the netcfg package
#
#NETWORKS=(main)

# -----------------------------------------------------------------------
# DAEMONS
# -----------------------------------------------------------------------
#
# Daemons to start at boot-up (in this order)
#   - prefix a daemon with a ! to disable it
#   - prefix a daemon with a @ to start it up in the background
#
DAEMONS=(syslog-ng network netfs crond hal fam esd)
Voilà, à part pour ajouter les démons hal, fam, et esd, je ne crois pas y avoir touché.

Avatar de l’utilisateur
warnaud
Maître du Kyudo
Messages : 1640
Inscription : ven. 11 août 2006, 17:05
Localisation : Collonges (01) France
Contact :

Re: [Fluxbox, WMII, Openbox, Pekwm] couldn't open display

Message par warnaud » sam. 08 août 2009, 23:31

En gros t'as installé xorg, est-ce que X se lance (avec rien de décommenté dans ton ~/.xinitrc) déjà?
Si ça fonctionne en root et pas avec ton user c'est que t'es pas dans le groupe video.
Sinon, que donne le résultat de la commande locale?
Plus ça rate, plus ça a de chance de réussir. En somme, un succès n'est qu'une erreur qui a finit par réussir (même par erreur). Ne déséspérez donc pas et perseverez. Utilisez La Rache™
Patientia quod lard quod barrus planto diligo ut licentia
—¤÷(`[¤*Powered By *¤]´)÷¤—
Archlinux ~ Fvwm ~ Irssi ~ URxvt

Avatar de l’utilisateur
ddup1
Chu Ko Nu
Messages : 338
Inscription : lun. 15 sept. 2008, 20:59
Localisation : Toulouse
Contact :

Re: [Fluxbox, WMII, Openbox, Pekwm] couldn't open display

Message par ddup1 » sam. 08 août 2009, 23:53

A mon avis il y a déjà un xorg de lancé (gestionnaire gdm/kdm ou session xorg)

Tente startx -- :1 pour voir ;)
Un clavier azerty en vaut deux :D
http://www.dupnet.org/dotclear/

Florimond
Hankyu
Messages : 11
Inscription : ven. 07 août 2009, 00:20

Re: [Fluxbox, WMII, Openbox, Pekwm] couldn't open display

Message par Florimond » sam. 08 août 2009, 23:59

Si je tape "startx", le gestionnaire de fenêtre par défaut de xorg se lance sans soucis - et ce, que je sois connecté avec mon login ou root. Si je tape "X" (oui j'en suis là: moi pas vraiment savoir la différence [encore]) l'écran devient tout noir, le système en répond plus.

Concernant le fameux .xinitrc : on en parle souvent sur les forums, pourtant je ne l'ai pas encore vu passer dans la documentation! c'est un peu comme le .bashrc ... il faudrait que je le crée! pour l'instant je ne vois nulle part de .xinitrc - c'était d'ailleurs assez déstabilisant de pas avoir de .bashrc, et de devoir faire exec bash à chaque démarrage pour qu'il soit lu par dessus le marché... ou alors j'ai manqué quelque chose de fondamental???

Enfin:

Code : Tout sélectionner

[root@florimond ~]# locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=fr_BE.utf8
LC_CTYPE="fr_BE.utf8"
LC_NUMERIC="fr_BE.utf8"
LC_TIME="fr_BE.utf8"
LC_COLLATE=C
LC_MONETARY="fr_BE.utf8"
LC_MESSAGES="fr_BE.utf8"
LC_PAPER="fr_BE.utf8"
LC_NAME="fr_BE.utf8"
LC_ADDRESS="fr_BE.utf8"
LC_TELEPHONE="fr_BE.utf8"
LC_MEASUREMENT="fr_BE.utf8"
LC_IDENTIFICATION="fr_BE.utf8"
LC_ALL=
EDIT: startx --:1 débouche sur une "Fatal server error: Caught signal 11. Serveur aborting

benjarobin
Maître du Kyudo
Messages : 15446
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Fluxbox, WMII, Openbox, Pekwm] couldn't open display

Message par benjarobin » dim. 09 août 2009, 03:58

Oula...
Bon c'est normal si tu lance X que l'écran devient noir, tu vient de lancer X... Mais si tu ne lance rien d'autre après c'est sur l'écran restera noir... Si startx marche je ne vois pas ou est le problème...
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
warnaud
Maître du Kyudo
Messages : 1640
Inscription : ven. 11 août 2006, 17:05
Localisation : Collonges (01) France
Contact :

Re: [Fluxbox, WMII, Openbox, Pekwm] couldn't open display

Message par warnaud » dim. 09 août 2009, 13:49

Pour lancer un Window Manager ou un Desktop Environment, tu as deux méthode:
- utiliser un login manager (xdm/slim/gdm/kdm) que tu configures soit dans /etc/inittab OU en le lançant en temps que DAEMON dans /etc/rc.conf
- ne pas utiliser de login manager et là il te faut un fichier .xinitrc dans la racine de ton répertoire personnel /home/<ton/login/.xinitrc
Si ce fichier n'existe pas (attention les fichiers répertoires commençant par un '.' sont cachés ous Unix) c'est que t'as pas créé ton utilisateur comme il faut. Il manque tout ce qui se trouve dans /etc/skel

Code : Tout sélectionner

cp /etc/skel/.??* ~/.
pour récupérer tout ce qu'il faut.
Sinon tes locales... c'est pas bon :)
-> edites en tant que root /etc/locale.gen
Tu décommentes la ligne fr_BE.utf8 puis tu les regénères:

Code : Tout sélectionner

locale-gen
Dans ton rc.conf tu dois avoir:

Code : Tout sélectionner

LOCALE="fr_BE.utf8"
Pour vraiment tout passer en fr_BE édites/rajoutes la ligne suivante dans /etc/profile:

Code : Tout sélectionner

export LC_ALL=fr_BE.utf8
Plus ça rate, plus ça a de chance de réussir. En somme, un succès n'est qu'une erreur qui a finit par réussir (même par erreur). Ne déséspérez donc pas et perseverez. Utilisez La Rache™
Patientia quod lard quod barrus planto diligo ut licentia
—¤÷(`[¤*Powered By *¤]´)÷¤—
Archlinux ~ Fvwm ~ Irssi ~ URxvt

Florimond
Hankyu
Messages : 11
Inscription : ven. 07 août 2009, 00:20

Re: [Fluxbox, WMII, Openbox, Pekwm] couldn't open display

Message par Florimond » dim. 09 août 2009, 16:39

Merci beaucoup! quelques explications qui m'avancent beaucoup :)


XFCE semble maintenant se lancer correctement, ainsi que Fluxbox, et WMII. Arranger les locales a résolu aussi un problème avec Perl qui ne voulait pas se lancer non plus.

Par contre Openbox et Pekwm ne veulent rien entendre, quand je décommente l'un ou l'autre dans le .xinitrc et que je demande un startx... j'obtiens juste un écran noir avec le pointeur de la souris au milieu. Dans la tty ça donne:

Code : Tout sélectionner

(==) Using default built-in configuration (30 lines)
(EE) Failed to load module "nv" (module does not exist, 0)
(EE) Failed to load module "fbdev (module does not exist, 0)
(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
 *** WARNING: missing WORKSPACEINDICATOR section!
...je suppose qu'il faut que je revoie l'installation de mes drivers...

Il faut aussi le clavier azerty belge dans X. Di je ne me trompe pas, tout est détecté automatiquement, je n'ai toujours pas de xorg.conf, et je devrais même pouvoir spécifier mon clavier sans passer pas le xorg.conf...

Bref, je crois que je vais replonger dans la doc! :chinois:

Avatar de l’utilisateur
warnaud
Maître du Kyudo
Messages : 1640
Inscription : ven. 11 août 2006, 17:05
Localisation : Collonges (01) France
Contact :

Re: [Fluxbox, WMII, Openbox, Pekwm] couldn't open display

Message par warnaud » dim. 09 août 2009, 18:16

En effet il faut installer ton driver(module) pour carte graphique (dans ton cas nv ou nouveau ou nvidia). Ca ira mieux après, pour le clavier c'est avec hal maintenant cf: http://wiki.archlinux.fr/howto/indispen ... _de_saisie

Et hop :)
Plus ça rate, plus ça a de chance de réussir. En somme, un succès n'est qu'une erreur qui a finit par réussir (même par erreur). Ne déséspérez donc pas et perseverez. Utilisez La Rache™
Patientia quod lard quod barrus planto diligo ut licentia
—¤÷(`[¤*Powered By *¤]´)÷¤—
Archlinux ~ Fvwm ~ Irssi ~ URxvt

Florimond
Hankyu
Messages : 11
Inscription : ven. 07 août 2009, 00:20

Re: [Fluxbox, WMII, Openbox, Pekwm] couldn't open display

Message par Florimond » dim. 09 août 2009, 20:50

ok, j'ai le clavier belge :)

Pour ma carte graphique, ce qui est bizarre c'est que je l'ai théoriquement installée depuis longtemps. C'est une geforce2... j'ai installé les drivers propriétaires comme indiqué sur cette page http://wiki.archlinux.fr/xorg/nvidia/pr ... d2f04ad25c :

Code : Tout sélectionner

pacman -S nvidia-96xx
Va-t-il falloir que j'en passe par le xorg.conf finalement? :mrgreen:

benjarobin
Maître du Kyudo
Messages : 15446
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Fluxbox, WMII, Openbox, Pekwm] couldn't open display

Message par benjarobin » dim. 09 août 2009, 21:00

Je dirai que oui, utilise nvidia-settings
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
cycyx
yeomen
Messages : 222
Inscription : dim. 02 mars 2008, 19:53

Re: [Fluxbox, WMII, Openbox, Pekwm] couldn't open display

Message par cycyx » lun. 10 août 2009, 18:02

Florimond a écrit :Par contre Openbox et Pekwm ne veulent rien entendre, quand je décommente l'un ou l'autre dans le .xinitrc et que je demande un startx... j'obtiens juste un écran noir avec le pointeur de la souris au milieu.
D'un autre côté, OpenBOX et PekWM sont tellement dépouillés par défaut que si tu as "juste" un écran noir avec on pointeur de souris, il y a de fortes chances que ton WM soit lancé !

Essaye juste de cliquer avec le bouton droit ou le bouton du milieu (ou les deux ensembles) pour voir si tu as un menu...
Laptop1 : Clevo W110ER, core i5-3210M, 8Gb RAM, Intel® Ivybridge Mobile (GT2)/NVIDIA GT 650M, x86_64
Laptop2 : Sony Vaio SR41M, Core 2 Duo T6400, 4Gb RAM, ATI Radeon HD 4750, x86_64

Florimond
Hankyu
Messages : 11
Inscription : ven. 07 août 2009, 00:20

Re: [Fluxbox, WMII, Openbox, Pekwm] couldn't open display

Message par Florimond » lun. 10 août 2009, 20:05

:bouletdujour:

pas bête :roll:

c'est très déroutant la première fois :mrgreen:

un problème qui n'en était pas un, désolé :oops:


mais bon, à part dans Openbox, qui reste utilisable, l'affichage "freeze" énormément, je crois bien que je vais devoir utiliser le minimum d'accélération que peut offrir ma gerfoce2...
Dernière modification par Florimond le lun. 10 août 2009, 21:40, modifié 1 fois.

Florimond
Hankyu
Messages : 11
Inscription : ven. 07 août 2009, 00:20

Re: [Fluxbox, WMII, Openbox, Pekwm] couldn't open display

Message par Florimond » lun. 10 août 2009, 21:38

Bon voilà :D
Dans le cas de l'utilisation d'un pilote propriétaire, vous pouvez créer un fichier /etc/X11/xorg.conf minimal pour indiquer le chargement de ce pilote, exemple:
j'ai bêtement copié-collé l'exemple dans un xorg.conf créé pour l'occasion, et ça semble fonctionner pas trop mal! Ça ne "freeze" plus autant, ça devient tout à fait utilisable. D'un côté, je ne suis pas habitué à passer autant de temps à l'installation d'un système et je suis content que ça fonctionne! D'un autre côté, ma compréhension du xorg.conf reste superficielle... enfin je suppose que ça viendra... C'est magique quand même... suffit de mettre « Driver "nvidia" » et hop tout d'un coup il se met à exister, x sait ou le trouver et tout! Ma fascination pour se fichier n'a d'égale que la profondeur de mon ignorance quant à ses rouages internes...

Bon ben vraiment merci à tous :D

Me restera surtout la carte son, et arranger le petit problème d'accents qui arrive quelques fois (j'ai bien vu qu'on en parlait dans le wiki), mais ça sera pas pour ce soir. Et puis si je peux lire tous le wiki, je crois que ça ne peut pas me faire de mal :cocktail:

Avatar de l’utilisateur
warnaud
Maître du Kyudo
Messages : 1640
Inscription : ven. 11 août 2006, 17:05
Localisation : Collonges (01) France
Contact :

Re: [Fluxbox, WMII, Openbox, Pekwm]couldn't open display(RÉSOLU)

Message par warnaud » mar. 11 août 2009, 10:06

Sinon t'as des outils nvidia pour créer des fichiers xorg.conf (nvidia-xconfigure et après sous X nvidia-xsettings)
Plus ça rate, plus ça a de chance de réussir. En somme, un succès n'est qu'une erreur qui a finit par réussir (même par erreur). Ne déséspérez donc pas et perseverez. Utilisez La Rache™
Patientia quod lard quod barrus planto diligo ut licentia
—¤÷(`[¤*Powered By *¤]´)÷¤—
Archlinux ~ Fvwm ~ Irssi ~ URxvt

Répondre