[Xorg] Problème de résolution et de pilote

Xorg, Compiz, KDE / Gnome / Xfce / Fluxbox / e17 / fvwm ... GDM/KDM/XDM...
Répondre
nonolapero
Daikyu
Messages : 68
Inscription : mar. 30 juin 2009, 19:26

[Xorg] Problème de résolution et de pilote

Message par nonolapero » lun. 10 août 2009, 23:39

Pour mémoire le début de mes déboires sont dans ce topic. Par la suite je me suis dit que ça ne serait pas un mal de tester KDE4.3 suite à une expérience pas terrible de KDE3.5.

Par contre chat échaudé craint l'eau chaude, je me dis que ça serait une bonne occasion de tester un liveCD Archlinux. Mon choix c'est porté sur Arch-Live. D'ailleurs il faudrait mettre à jour cette page car le lien ne pointe plus sur la bonne adresse du blog qui désormais http://godane.wordpress.com/ .

Le liveCD marche à merveille et se montre rapide donc c'est très bien. Et la résolution est la bonne.

Je me lance dans une installation en dur et depuis impossible d'avoir un affichage correct. Avec le pilote propriétaire (dernière et avant dernière version) et le xorg.conf issue de nvidia-xconfig ça me donne un écran noir. Avec le pilote libre nouveau je n'ai pas mieux que du 800x600.

Voici mon xorg.conf (dans device j'ai mis vesa pour ne pas avoir un écran noir) :

Code : Tout sélectionner

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder63)  Tue Jul 28 16:20:20 PDT 2009


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "vesa"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
Le rc.conf mais je ne sais pas si ça sera bien utile

Code : Tout sélectionner

#
# /etc/rc.conf - Main Configuration for Arch Linux
#

# -----------------------------------------------------------------------
# LOCALIZATION
# -----------------------------------------------------------------------
#
# LOCALE: available languages can be listed with the 'locale -a' command
# HARDWARECLOCK: set to "UTC" or "localtime"
# USEDIRECTISA: use direct I/O requests instead of /dev/rtc for hwclock
# TIMEZONE: timezones are found in /usr/share/zoneinfo
# KEYMAP: keymaps are found in /usr/share/kbd/keymaps
# CONSOLEFONT: found in /usr/share/kbd/consolefonts (only needed for non-US)
# CONSOLEMAP: found in /usr/share/kbd/consoletrans
# USECOLOR: use ANSI color sequences in startup messages
#
LOCALE="fr_FR.utf8"
HARDWARECLOCK="localtime"
USEDIRECTISA="no"
TIMEZONE="Europe>Paris"
KEYMAP="fr-latin9"
CONSOLEFONT="lat9w-16"
CONSOLEMAP=
USECOLOR="yes"

# -----------------------------------------------------------------------
# HARDWARE
# -----------------------------------------------------------------------
#
# MOD_AUTOLOAD: Allow autoloading of modules at boot and when needed
# MOD_BLACKLIST: Prevent udev from loading these modules
# MODULES: Modules to load at boot-up. Prefix with a ! to blacklist.
#
# NOTE: Use of 'MOD_BLACKLIST' is deprecated. Please use ! in the MODULES array.
#
MOD_AUTOLOAD="yes"
#MOD_BLACKLIST=() #deprecated
MODULES=(nvidia)

# Scan for LVM volume groups at startup, required if you use LVM
USELVM="no"

# -----------------------------------------------------------------------
# NETWORKING
# -----------------------------------------------------------------------
#
# HOSTNAME: Hostname of machine. Should also be put in /etc/hosts
#
HOSTNAME="arch-live"

# Use 'ifconfig -a' or 'ls /sys/class/net/' to see all available interfaces.
#
# Interfaces to start at boot-up (in this order)
# Declare each interface then list in INTERFACES
#   - prefix an entry in INTERFACES with a ! to disable it
#   - no hyphens in your interface names - Bash doesn't like it
# 
# DHCP:     Set your interface to "dhcp" (eth0="dhcp")
# Wireless: See network profiles below
#

#Static IP example
#eth0="eth0 192.168.0.2 netmask 255.255.255.0 broadcast 192.168.0.255"
eth0="dhcp"
INTERFACES=(eth0)

# Routes to start at boot-up (in this order)
# Declare each route then list in ROUTES
#   - prefix an entry in ROUTES with a ! to disable it
#
gateway="default gw 192.168.0.1"
ROUTES=(!gateway)
 
# Enable these network profiles at boot-up.  These are only useful
# if you happen to need multiple network configurations (ie, laptop users)
#   - set to 'menu' to present a menu during boot-up (dialog package required)
#   - prefix an entry with a ! to disable it
#
# Network profiles are found in /etc/network.d
#
# This now requires the netcfg package
#
#NETWORKS=(main)

# -----------------------------------------------------------------------
# DAEMONS
# -----------------------------------------------------------------------
#
# Daemons to start at boot-up (in this order)
#   - prefix a daemon with a ! to disable it
#   - prefix a daemon with a @ to start it up in the background
#
DAEMONS=(syslog-ng netfs @network @hal oss alsa netfs crond)
Quand je lance startx avec nvidia dans device j'ai droit à un no screens found.

Après j'ai un autre bug ou mauvais réglage, la barre des tâches ne fait pas toute la largeur de l'écran. Mais ça n'est pas le plus gros des problèmes.

benjarobin
Maître du Kyudo
Messages : 15446
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Xorg] Problème de résolution et de pilote

Message par benjarobin » lun. 10 août 2009, 23:57

Après j'ai un autre bug ou mauvais réglage, la barre des tâches ne fait pas toute la largeur de l'écran
Ça c'est facile a répondre. Tu fait : "Déverrouiller plasmoide" puis "Option pour le tableau de bord -> Configuration du tableau de bord" puis "plus de paramètres" puis "Maximiser le panneau"

Tu vois hal c'est le seul daemon que je ne mettrais surtout pas en backgroud (Il y a un @). Il est trop important. Je veux être sur qu'il se lance bien.

Tu as bien suivi le wiki :
http://wiki.archlinux.org/index.php/NVIDIA (eng)
http://wiki.archlinux.fr/xorg/nvidia/proprio?s[]=nvidia
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

nonolapero
Daikyu
Messages : 68
Inscription : mar. 30 juin 2009, 19:26

Re: [Xorg] Problème de résolution et de pilote

Message par nonolapero » mar. 11 août 2009, 01:02

J'ai regardé à divers endroit, j'ai regénéré un xorg.conf avec X -configure.

J'ai remplacé vesa par nv dans device et maintenant je suis en 1280x800. Je suis content ça marche mais je n'ai pas trop compris pourquoi.

En tout cas les derniers pilotes proprio nvidia ont l'air de créer pas mal d'ennui.

Désolé du dérangement, je ne vais plus toucher à rien tant que ça marche !

Avatar de l’utilisateur
warnaud
Maître du Kyudo
Messages : 1640
Inscription : ven. 11 août 2006, 17:05
Localisation : Collonges (01) France
Contact :

Re: [Xorg] Problème de résolution et de pilote

Message par warnaud » mar. 11 août 2009, 09:37

nonolapero a écrit : D'ailleurs il faudrait mettre à jour cette page car le lien ne pointe plus sur la bonne adresse du blog qui désormais http://godane.wordpress.com/
Done :)
nonolapero a écrit :
Quand je lance startx avec nvidia dans device j'ai droit à un no screens found.
Après j'ai un autre bug ou mauvais réglage, la barre des tâches ne fait pas toute la largeur de l'écran. Mais ça n'est pas le plus gros des problèmes.
C'est zarbe, perso 0 soucis sur 3 config avec du nvidia partout. Je me fais mon xorg.conf de base avec nvdia-xconfig puis j'affine (plusieurs écrans toussa) avec nvidia-xsettings. Avec juste les pilotes nvidia et sans xorg.conf ça se débrouille pas tout seul?
Plus ça rate, plus ça a de chance de réussir. En somme, un succès n'est qu'une erreur qui a finit par réussir (même par erreur). Ne déséspérez donc pas et perseverez. Utilisez La Rache™
Patientia quod lard quod barrus planto diligo ut licentia
—¤÷(`[¤*Powered By *¤]´)÷¤—
Archlinux ~ Fvwm ~ Irssi ~ URxvt

Avatar de l’utilisateur
mélodie
Maître du Kyudo
Messages : 2785
Inscription : lun. 30 oct. 2006, 02:06
Localisation : Pyrénées
Contact :

Re: [Xorg] Problème de résolution et de pilote

Message par mélodie » mar. 11 août 2009, 10:41

Ben moi j'ai toujours des plantages aléatoires de X. J'ai la flemme de poster pour ça ces temps-ci, avec les messages d'erreur, tout ça, mais j'y reviendrais.

(nvidia 8400 gs)

Avatar de l’utilisateur
Calimero
Elfe
Messages : 692
Inscription : ven. 02 mai 2008, 18:16
Localisation : Nantes (44)

Re: [Xorg] Problème de résolution et de pilote

Message par Calimero » mer. 19 août 2009, 15:08

warnaud a écrit :Avec juste les pilotes nvidia et sans xorg.conf ça se débrouille pas tout seul?
Nan, faut ça comme xorg.conf avec les pilotes nvidia :

Code : Tout sélectionner

Section "Device"
	Identifier	"Card0"
	Driver		"nvidia"
EndSection
nonolapero : quel est le modèle de ta carte nvidia ?
Parce que selon la version c'est peut-être les pilotes nvidia-96xx ou nvidia-173xx qu'il te faut. cf http://wiki.archlinux.fr/xorg/nvidia/proprio
Si tu ne sais pas, poste-nous le résultat de lspci |grep VGA
Mes trucs : LiveCD http://ctkarch.org/ ; Blog, guide Arch, etc… http://calimeroteknik.free.fr/
In a world without walls and fences, who needs windows and gates ?

Avatar de l’utilisateur
CroK
Elfe
Messages : 607
Inscription : dim. 26 juil. 2009, 14:27
Localisation : France > Auxerre

Re: [Xorg] Problème de résolution et de pilote

Message par CroK » jeu. 20 août 2009, 00:34

Étrange ces "problêmes" avec Xorg et les pilotes propriétaires, moi j'ai une 9600M, et j'ai aucun problème avec /
Save the penguins, burn the flags ! -- c[] <- beeeeeeeeer!

Avatar de l’utilisateur
warnaud
Maître du Kyudo
Messages : 1640
Inscription : ven. 11 août 2006, 17:05
Localisation : Collonges (01) France
Contact :

Re: [Xorg] Problème de résolution et de pilote

Message par warnaud » ven. 21 août 2009, 15:13

Dans un xorg.conf minimal comme celui posté par Calimero, tu peux aussi forcer la résolution:

Code : Tout sélectionner

Section "Screen"
    Identifier	"Card0"
    Device	"Nvidia0"
    DefaultDepth 24
    Subsection "Display"
        Depth 24
        Modes "1280x1024" "1024x768" "800x600"
    EndSubsection
EndSection
J'ai mis "1280x1024" "1024x768" "800x600" mais on peut en mettre qu'un seul
Plus ça rate, plus ça a de chance de réussir. En somme, un succès n'est qu'une erreur qui a finit par réussir (même par erreur). Ne déséspérez donc pas et perseverez. Utilisez La Rache™
Patientia quod lard quod barrus planto diligo ut licentia
—¤÷(`[¤*Powered By *¤]´)÷¤—
Archlinux ~ Fvwm ~ Irssi ~ URxvt

Murzan
archer
Messages : 123
Inscription : sam. 06 juin 2009, 14:29

Re: [Xorg] Problème de résolution et de pilote

Message par Murzan » ven. 21 août 2009, 22:37

Forcer la résolution est bien souvent la méthode la plus efficace et rapide.
De toute manière, c'est préférable et on évite les mauvaises surprises après une maj...

gagzou
newbie
Messages : 3
Inscription : ven. 21 août 2009, 23:38

Re: [Xorg] Problème de résolution et de pilote

Message par gagzou » sam. 22 août 2009, 00:01

+1 pour benjarobin : pas de @ à hal
bizarre aussi de lancer le module nvidia direct depuis le rc.conf puisque xorg s'en charge au demarrage(bien sur si tu as un xorg.conf avec Driver "nvidia"sinon hal s'occupe de tout et se sont les pilotes libres presents qui sont chargés par defaut)
Sinon pour avoir une belle console tu met un vga=795 dans ton menu.lst(mode 1280*1024 16M)
En même temps les section "input devices" de ton xorg.conf peuvent être supprimées(hal s'en charge:seul truc:
clavier en francais > cp /usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi /etc/hal/fdi/policy et mettre fr à la place de us)
Pour les plantages aléatoires de X , si tu est sous kde le backingstore de X fait tous planter aleatoirement(à voir dans ton Xorg.0.log)
Bonne chance :mrgreen:

gagzou
newbie
Messages : 3
Inscription : ven. 21 août 2009, 23:38

Re: [Xorg] Problème de résolution et de pilote

Message par gagzou » sam. 22 août 2009, 00:08

Sinon je tiens à signaler que le wiki est vraiment bien fait et étant ancien gentooiste je pense que cette distib.est excellente (legere et optimisée) et mérite d'être mieux connus. :chinois:

Avatar de l’utilisateur
mélodie
Maître du Kyudo
Messages : 2785
Inscription : lun. 30 oct. 2006, 02:06
Localisation : Pyrénées
Contact :

Re: [Xorg] Problème de résolution et de pilote

Message par mélodie » sam. 22 août 2009, 00:44

CroK a écrit :Étrange ces "problêmes" avec Xorg et les pilotes propriétaires, moi j'ai une 9600M, et j'ai aucun problème avec /
La mienne est une pci-e fanless. La pièce où est la machine n'est pas climatisée... ceci peut expliquer cela. (Mais ne peut pas tout expliquer quand même, au vu d'un certain passif)

Répondre