[Xorg] Ati Radeon, drivers libres, pas mal de bugs

Xorg, Compiz, KDE / Gnome / Xfce / Fluxbox / e17 / fvwm ... GDM/KDM/XDM...
Répondre
Ubitux
Daikyu
Messages : 55
Inscription : jeu. 28 déc. 2006, 17:14

[Xorg] Ati Radeon, drivers libres, pas mal de bugs

Message par Ubitux »

Salut tout le monde

J'ai une carte ATI 9600 Pro (Gigabyte), sur un desktop PC.

Je souhaite utiliser les drivers libres (les proprio ne me permettant pas de faire tourner Beryl sans XGL, j'ai des FPS minables avec glxgears, et j'ai les mêmes problèmes qu'avec les drivers libres).

J'ai donc installé toutes les lib nécéssaires, mais voilà, j'ai des problèmes : Nexuiz plante au bout de 30 sec de jeu, Warzone ne gère pas l'affichage briefing de mission, et la fonction Blur (flou) ne marche pas avec Beryl.
D'autres part, le serveur X met beaucoup de temps à démarrer (autour de 20 sec)

Voici les warnings de mon /var/log/Xorg.0.log (il n'y a pas de lignes d'erreurs) :
(WW) The directory "/usr/share/fonts/PEX" does not exist.
(WW) The directory "/usr/share/lib/X11/fonts/latin2/75dpi" does not exist.
(WW) The directory "/usr/share/lib/X11/fonts/latin2/100dpi" does not exist.
(WW) The directory "/usr/share/fonts/ttf/western" does not exist.
(WW) The directory "/usr/share/fonts/ttf/decoratives" does not exist.
(WW) The directory "/usr/share/fonts/truetype" does not exist.
(WW) The directory "/usr/share/fonts/truetype/openoffice" does not exist.
(WW) The directory "/usr/share/fonts/truetype/ttf-bitstream-vera" does not exist.
(WW) The directory "/usr/share/fonts/latex-ttf-fonts" does not exist.
(WW) The directory "/usr/share/fonts/defoma/CID" does not exist.
(WW) The directory "/usr/share/fonts/defoma/TrueType" does not exist.
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(WW) RADEON: No matching Device section for instance (BusID PCI:1:0:1) found
(WW) RADEON(0): Failed to detect secondary monitor, MergedFB/Clone mode disabled
(WW) RADEON(0): DRI init changed memory map, adjusting ...
(WW) RADEON(0): MC_FB_LOCATION was: 0xe7ffe000 is: 0xe7ffe000
(WW) RADEON(0): MC_AGP_LOCATION was: 0xffffffc0 is: 0xf3fff000
(WW) RADEON(0): Option "DRI" is not used
(WW) AIGLX: 3D driver claims to not support visual 0x23
(WW) AIGLX: 3D driver claims to not support visual 0x24
(WW) AIGLX: 3D driver claims to not support visual 0x25
(WW) AIGLX: 3D driver claims to not support visual 0x26
(WW) AIGLX: 3D driver claims to not support visual 0x27
(WW) AIGLX: 3D driver claims to not support visual 0x28
(WW) AIGLX: 3D driver claims to not support visual 0x29
(WW) AIGLX: 3D driver claims to not support visual 0x2a
(WW) AIGLX: 3D driver claims to not support visual 0x2b
(WW) AIGLX: 3D driver claims to not support visual 0x2c
(WW) AIGLX: 3D driver claims to not support visual 0x2d
(WW) AIGLX: 3D driver claims to not support visual 0x2e
(WW) AIGLX: 3D driver claims to not support visual 0x2f
(WW) AIGLX: 3D driver claims to not support visual 0x30
(WW) AIGLX: 3D driver claims to not support visual 0x31
(WW) AIGLX: 3D driver claims to not support visual 0x32
et voici mon /etc/X11/xorg.conf :

Code : Tout sélectionner

Section "ServerLayout"
        Identifier     "Xorg Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "USB Mouse" "CorePointer"
        Option         "AIGLX" "true"
EndSection

Section "ServerFlags"
        Option "AllowMouseOpenFail"  "true"
EndSection

Section "Files"
        RgbPath      "/usr/share/X11/rgb"
        ModulePath   "/usr/lib/xorg/modules"
        FontPath     "/usr/share/fonts/misc:unscaled"
        FontPath     "/usr/share/fonts/misc"
        FontPath     "/usr/share/fonts/75dpi:unscaled"
        FontPath     "/usr/share/fonts/75dpi"
        FontPath     "/usr/share/fonts/100dpi:unscaled"
        FontPath     "/usr/share/fonts/100dpi"
        FontPath     "/usr/share/fonts/PEX"
        FontPath     "/usr/share/fonts/cyrillic"
        FontPath     "/usr/share/lib/X11/fonts/latin2/75dpi"
        FontPath     "/usr/share/lib/X11/fonts/latin2/100dpi"
        FontPath     "/usr/share/fonts/Type1"
        FontPath     "/usr/share/fonts/ttf/western"
        FontPath     "/usr/share/fonts/ttf/decoratives"
        FontPath     "/usr/share/fonts/truetype"
        FontPath     "/usr/share/fonts/truetype/openoffice"
        FontPath     "/usr/share/fonts/truetype/ttf-bitstream-vera"
        FontPath     "/usr/share/fonts/latex-ttf-fonts"
        FontPath     "/usr/share/fonts/defoma/CID"
        FontPath     "/usr/share/fonts/defoma/TrueType"
EndSection

Section "Module"
        Load  "ddc"  # ddc probing of monitor
        Load  "dbe"
        Load  "dri"
        Load  "drm"
        Load  "extmod"
        Load  "glx"
        Load  "bitmap" # bitmap-fonts
        Load  "type1"
        Load  "freetype"
        Load  "int10"
        Load  "vbe"
        Load  "record"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "keyboard"
        Option      "CoreKeyboard"
        Option "XkbRules" "xorg"
        Option "XkbModel" "pc105"
        Option "XkbLayout" "fr"
        #Option "XkbVariant" ""
EndSection

Section "InputDevice"
        Identifier  "Serial Mouse"
        Driver      "mouse"
        Option      "Protocol" "Microsoft"
        Option      "Device" "/dev/ttyS0"
        Option      "Emulate3Buttons" "true"
        Option      "Emulate3Timeout" "70"
        Option      "SendCoreEvents"  "true"
EndSection

Section "InputDevice"
        Identifier  "PS/2 Mouse"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option          "ZAxisMapping" "4 5"
        Option      "Device" "/dev/psaux"
        Option      "Emulate3Buttons" "true"
        Option      "Emulate3Timeout" "70"
        Option      "SendCoreEvents" "true"
EndSection

Section "InputDevice"
        Identifier      "USB Mouse"
        Driver          "mouse"
        Option          "Device"                "/dev/input/mice"
        Option          "SendCoreEvents"                "true"
        Option          "Protocol"              "IMPS/2"
        Option          "ZAxisMapping"          "4 5"
        Option          "Buttons"               "5"
EndSection

Section "Monitor"
        Identifier "Monitor0"
        Option "DPMS" "true"
        HorizSync    28.0 - 96.0
        VertRefresh  50.0 - 75.0
EndSection

Section "Device"
        Identifier  "Card0"
        Driver      "radeon"
        BusID           "PCI:1:0:0"
        Option "AccelMethod" "XAA"
        Option "AccelDFS" "0"
        Option "AGPMode" "8"
        Option "AGPSize" "128"
        Option "GARTSize" "64"
        Option "RingSize" "8"
        Option "BufferSize" "2"
        Option "EnablePageFlip" "on"
        Option "EnableDepthMoves" "yes"
        Option "UseFBDev" "false"
        Option "ColorTiling" "on"
        Option "RenderAccel" "true"
        Option "mtrr" "on"
        Option "SubPixelOrder" "none"
        Option "XAANoOffscreenPixmaps" "true"
        Option "DRI" "true"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        DefaultColorDepth 24
        SubSection "Display"
                Depth     1
                Modes "1440x900" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth     4
                Modes "1440x900" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth     8
                Modes "1440x900" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth     15
                Modes "1440x900" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth     16
                Modes "1440x900" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth     24
                Modes "1440x900" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth     32
                Modes "1440x900" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

Section "Extensions"
        Option "RENDER" "enable"
        Option "Composite" "Enable"
EndSection

Section "DRI"
        Group   "video"
        Mode 0666
EndSection
Vous pourriez me filer un petit coup de main svp ? :oops:
Windows, c'est comme la cigarette : on paye cher pour se faire beaucoup de mal...
_alexmyself
Chu Ko Nu
Messages : 405
Inscription : lun. 18 sept. 2006, 16:21
Localisation : france, yvelines 78

Message par _alexmyself »

faut pas se fier a glxgears, ça veut rien dire du tout:
driver libre:
sans accélération-2800 fps, a un détail près: utilisation processeur 100%
avec-1800fps mais processeur au raz des paquerettes

le seul test: un bon gros jeu, et là le driver libre est à des années lumières encore aujourd'hui

pour ce qui est du xorg.conf tu devrait peut etre penser a en retirer plutot qu'en rajouter, cela dit ça reste une science très obscure.
Avatar de l’utilisateur
marc[i1]
Maître du Kyudo
Messages : 1753
Inscription : ven. 27 oct. 2006, 10:48
Localisation : Nantes (44)
Contact :

Message par marc[i1] »

Salut,

j'ai moi aussi une carte ATI 9600 et j'avais fait une page de wiki pour elle :)
http://wiki.archlinux.fr/howto:video:ati

Pour ce qui est de la qualité de la 3D, t'attends pas à un miracle ! Le pilote ATI est meilleur (enfin pour la 3D)
Ne vous emmerdez plus, emmerdez les autres.
Avatar de l’utilisateur
warnaud
Maître du Kyudo
Messages : 1640
Inscription : ven. 11 août 2006, 17:05
Localisation : Rolle (CH)
Contact :

Message par warnaud »

_alexmyself a écrit :faut pas se fier a glxgears, ça veut rien dire du tout
Clairement c'est pas un logiciel de benchmarks, mais bon quand on a 200 fps on sait tout de suite que l'accélération graphique est HS
_alexmyself a écrit : le seul test: un bon gros jeu, et là le driver libre est à des années lumières encore aujourd'hui
Ce qui semble normal vu l'aide que fournisse les constructeur pour faire des drivers libres ... (Ati est pas l'un des pires certes :) )
_alexmyself a écrit : pour ce qui est du xorg.conf tu devrait peut être penser a en retirer plutôt qu'en rajouter, cela dit ça reste une science très obscure.
C'est vrai qu'en klingon ancien ça resterait aussi "facile" à configurer ... :bananerxor:
Plus ça rate, plus ça a de chance de réussir. En somme, un succès n'est qu'une erreur qui a finit par réussir (même par erreur). Ne déséspérez donc pas et perseverez. Utilisez La Rache™
Patientia quod lard quod barrus planto diligo ut licentia
—¤÷(`[¤*Powered By *¤]´)÷¤—
Archlinux ~ Fvwm ~ Irssi ~ URxvt
Ubitux
Daikyu
Messages : 55
Inscription : jeu. 28 déc. 2006, 17:14

Message par Ubitux »

Ouais bon dnc je suis dans une impasse... si je veux Beryl je garde les drivers libres (sachant que je fais l'impasse sur XGL) tout buggés et si je veux jouer à des jeux 3D, je dois me contenter du pilote proprio ?

marc, j'ai utilisé cet article justement, mais pour Beryl j'ai besoin de Aiglx... et donc j'ai les erreurs que j'ai citées plus haut...
Windows, c'est comme la cigarette : on paye cher pour se faire beaucoup de mal...
Avatar de l’utilisateur
marc[i1]
Maître du Kyudo
Messages : 1753
Inscription : ven. 27 oct. 2006, 10:48
Localisation : Nantes (44)
Contact :

Message par marc[i1] »

Tu devrais penser à abandonner Aixgl avec les pilotes proprio ...
https://linuxfr.org/~plagiats/24169.html

Reste à attendre une évolution du pilote libre avec Xorg 7.2 ...
Ne vous emmerdez plus, emmerdez les autres.
Ubitux
Daikyu
Messages : 55
Inscription : jeu. 28 déc. 2006, 17:14

Message par Ubitux »

Non mais en fait c'est bon j'ai resolu le pb... j'ai vendu ma 9600 pro et j'ai acheté une nvidia.
Certes, cette solution n'est pas envisageable pour tout le monde, mais bon... étant donné que Beryl est tout de même un luxe, autant s'en donner les moyens.
Windows, c'est comme la cigarette : on paye cher pour se faire beaucoup de mal...
saintshakajin
Daikyu
Messages : 53
Inscription : ven. 11 août 2006, 22:05

Message par saintshakajin »

Et tu as une quoi maintenant? Je compte m'en acheter une nouvelle (8600 GTS) quand le magasin sera ouvert (il a fait le pont hier :( )
Ubitux
Daikyu
Messages : 55
Inscription : jeu. 28 déc. 2006, 17:14

Message par Ubitux »

euh j'ai pris un modèle supérieur : une 7600 GS à 100€.
Windows, c'est comme la cigarette : on paye cher pour se faire beaucoup de mal...
Avatar de l’utilisateur
warnaud
Maître du Kyudo
Messages : 1640
Inscription : ven. 11 août 2006, 17:05
Localisation : Rolle (CH)
Contact :

Message par warnaud »

\o/ à toi le bonheur d'avoir une carte qui arrache :p
Plus ça rate, plus ça a de chance de réussir. En somme, un succès n'est qu'une erreur qui a finit par réussir (même par erreur). Ne déséspérez donc pas et perseverez. Utilisez La Rache™
Patientia quod lard quod barrus planto diligo ut licentia
—¤÷(`[¤*Powered By *¤]´)÷¤—
Archlinux ~ Fvwm ~ Irssi ~ URxvt
saintshakajin
Daikyu
Messages : 53
Inscription : ven. 11 août 2006, 22:05

Message par saintshakajin »

Je trouve aussi... vive la 8600 GTS avec les drivers beta. D'ailleurs on le sent un peu, beryl est un rien moins réactif, surtout quand on minimise une fenêtre
Avatar de l’utilisateur
marc[i1]
Maître du Kyudo
Messages : 1753
Inscription : ven. 27 oct. 2006, 10:48
Localisation : Nantes (44)
Contact :

Message par marc[i1] »

Un espoir est né !
http://www.pcinpact.com/actu/news/36328 ... source.htm

on verra bien !
Ne vous emmerdez plus, emmerdez les autres.
Répondre