[Compiz] groupe Compiz09 : où trouver les dépendances ?

Xorg, Compiz, KDE / Gnome / Xfce / Fluxbox / e17 / fvwm ... GDM/KDM/XDM...
mika34
newbie
Messages : 3
Inscription : dim. 23 oct. 2011, 22:06

[Compiz] groupe Compiz09 : où trouver les dépendances ?

Message par mika34 » dim. 23 oct. 2011, 22:22

Bonjour,

Je viens d'installer archlinux. J'essaie d'installer le groupe Compiz09 (dépôt archlinuxfr) mais un message m'est systématiquement retourné concernant des dépendances manquantes :

Code : Tout sélectionner

[michael@ordi ~]$ yaourt -S compiz09
Mot de passe : 
:: Il y a 5 membres dans le groupe compiz09
:: Dépôt archlinuxfr
   1) compizconfig-python  2) compiz-plugins-extra  3) compiz-plugins-main  4) compiz-plugins-unsupported  5) emerald-git

Entrez une sélection (par défaut, tout est sélectionné): 
résolution des dépendances...
Avertissement: impossible de résoudre "compiz-core=0.9.2", une dépendance de "compizconfig-python"
Avertissement: impossible de résoudre "libcompizconfig=0.9.2", une dépendance de "compizconfig-python"
Avertissement: impossible de résoudre "compiz-core=0.9.2", une dépendance de "compiz-plugins-extra"
Avertissement: impossible de résoudre "compiz-core=0.9.2", une dépendance de "compiz-plugins-main"
Avertissement: impossible de résoudre "compiz-core=0.9.2", une dépendance de "compiz-plugins-main"
Avertissement: impossible de résoudre "compiz-core=0.9.2", une dépendance de "compiz-plugins-unsupported"
Avertissement: impossible de résoudre "compiz-core>=0.9", une dépendance de "emerald-git"
:: Les paquets suivants ne peuvent pas être mis à jour à cause de dépendances insatisfaisables:
      compizconfig-python  compiz-plugins-extra  compiz-plugins-main  compiz-plugins-unsupported  emerald-git

Voulez-vous ignorer les paquets ci-dessus pour cette mise à jour ? [o/N] n
Erreur: la préparation de la transaction a échoué (la satisfaction des dépendances a échoué)
:: compizconfig-python: requiert compiz-core=0.9.2
:: compizconfig-python: requiert libcompizconfig=0.9.2
:: compiz-plugins-extra: requiert compiz-core=0.9.2
:: compiz-plugins-main: requiert compiz-core=0.9.2
:: compiz-plugins-main: requiert compiz-core=0.9.2
:: compiz-plugins-unsupported: requiert compiz-core=0.9.2
:: emerald-git: requiert compiz-core>=0.9
[michael@ordi ~]$ 
Est-il prévu que compiz-core et libcompizconfig soient intégrés au dépôt archlinuxfr ?

benjarobin
Maître du Kyudo
Messages : 15615
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Compiz] groupe Compiz09 : où trouver les dépendances ?

Message par benjarobin » dim. 23 oct. 2011, 22:46

Ils sont sur AUR pour la version 0.9.2, sinon le dépôt officiel ne fournit que la version 0.8
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

mika34
newbie
Messages : 3
Inscription : dim. 23 oct. 2011, 22:06

Re: [Compiz] groupe Compiz09 : où trouver les dépendances ?

Message par mika34 » dim. 23 oct. 2011, 22:57

Sur AUR j'ai ça :

Code : Tout sélectionner

[michael@ordi ~]$ yaourt -Ss compiz-core
community/compiz-core 0.8.8-2 (compiz compiz-kde compiz-gtk compiz-fusion)
    Composite manager for Aiglx and Xgl
aur/compiz-core-dev 0.9.5.0-3 (Out of Date) (8)
    Core package of the current Compiz development release, with optional GNOME integration.
aur/compiz-core-git 20110827-1 (29)
    Compiz core components - Latest Git Version
aur/compiz-core-ubuntu 0.9.6.0ubuntu3-1 (0)
    Compiz core components - Ubuntu version
aur/compiz-core-unity-git 20110614-1 (16)
    Compiz is an extensible window manager utilizing opengl for effects and usability. Package meant for use with Unity.
[michael@ordi ~]$ yaourt -Ss libcompizconfig
community/libcompizconfig 0.8.8-1
    Compiz configuration system library
aur/libcompizconfig-dev 0.9.5.0-2 (Out of Date) (6)
    Compiz configuration system library
aur/libcompizconfig-git 20110827-1 (65)
    Compiz configuration system library - Latest Git Version
aur/libcompizconfig-ubuntu 0.9.5.94-1 (0)
    Compiz configuration system library - Ubuntu version
aur/libcompizconfig-unity-git 20110210-1 (10)
    Compiz configuration system library. Package meant for use with Unity.
Mais ça n'a pas l'air de fonctionner. Par exemple en installant compiz-core-dev et libcompizconfig-dev le message d'erreur du premier post apparaît à nouveau quand je tente d'installer compiz09

Avatar de l’utilisateur
Calimero
Elfe
Messages : 692
Inscription : ven. 02 mai 2008, 18:16
Localisation : Nantes (44)

Re: [Compiz] groupe Compiz09 : où trouver les dépendances ?

Message par Calimero » dim. 23 oct. 2011, 23:46

Pourquoi installer compiz09 ? Je l'avais en fait compilé parce que compiz 0.8.6 était cassé.
Mais compiz 0.8.8 est dans [extra], pourquoi ne pas utiliser compiz donc ? (le groupe compiz-fusion-gtk sauf le backend gconf peut convenir pour une install de base)
Mes trucs : LiveCD http://ctkarch.org/ ; Blog, guide Arch, etc… http://calimeroteknik.free.fr/
In a world without walls and fences, who needs windows and gates ?

mika34
newbie
Messages : 3
Inscription : dim. 23 oct. 2011, 22:06

Re: [Compiz] groupe Compiz09 : où trouver les dépendances ?

Message par mika34 » lun. 24 oct. 2011, 00:04

parce que certains plugins manquent, comme le plugin "grid" qui permet de faire les effets "aerosnap" à la windows 7 (les fenêtre maximisées sur une moitié de l'écran quand on les déplace à gauche et à droite). J'aime bien cette fonctionnalité, je la trouve super-pratique, et je ne la retrouve pas dans le paquet de [extra]

Avatar de l’utilisateur
exzemat
Daikyu
Messages : 64
Inscription : jeu. 19 mai 2011, 10:17

Re: [Compiz] groupe Compiz09 : où trouver les dépendances ?

Message par exzemat » mer. 26 oct. 2011, 06:21

personnellement j'"ai installé compiz git via aur, il y a toutes les dependances pour o.9 (dont grid, effectivement c'est sympa).
maintenant si c'est pour faire un compiz standalone avec un menu/clic droit sur le desktop laisse tomber : compiz boxmenu fait planter le gestionnaire (à cause du plugin viewport switch)

Répondre