[Lollypop] ne marche plus

Applications multimedia / jeux
Répondre
Avatar de l’utilisateur
Blableau-5979
Hankyu
Messages : 22
Inscription : mar. 18 oct. 2016, 16:00

[Lollypop] ne marche plus

Message par Blableau-5979 » ven. 03 févr. 2017, 06:05

Bonjour, suite à la dernière mise à jour, Lollypop ne se lance plus. J'ai tout réinstallé et toujours rien. En lançant Lollypop depuis la console, ça donne ceci :

Code : Tout sélectionner

[pablo@pablo-archlinux ~]$ lollypop
No module named 'pylast'
    - Scrobbler disabled
    - Auto cover download disabled
    - Artist informations disabled
$ sudo pip3 install pylast
/usr/lib/python3.6/site-packages/lollypop/lio.py:13: PyGIWarning: Soup was imported without specifying a version first. Use gi.require_version('Soup', '2.4') before import to ensure that the right version gets loaded.
  from gi.repository import Gio, GObject, Soup
/usr/lib/python3.6/site-packages/gi/module.py:178: Warning: g_array_append_vals: assertion 'array' failed
  g_type = info.get_g_type()
/usr/lib/python3.6/site-packages/gi/module.py:178: Warning: g_hash_table_lookup: assertion 'hash_table != NULL' failed
  g_type = info.get_g_type()
/usr/lib/python3.6/site-packages/gi/module.py:178: Warning: g_hash_table_insert_internal: assertion 'hash_table != NULL' failed
  g_type = info.get_g_type()
Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/lollypop/GioNotify.py", line 57, in on_GetCapabilities_finish
    caps = self.call_finish(result).unpack()[0]
GLib.Error: g-dbus-error-quark: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Notifications was not provided by any .service files (2)
[pablo@pablo-archlinux ~]$ 
Quelqu'un aurait rencontré le même problème que moi et aurait une solution à proposer ?

Merci par avance

Avatar de l’utilisateur
papajoke
Chu Ko Nu
Messages : 365
Inscription : sam. 30 août 2014, 19:54
Contact :

Re: [Lollypop] ne marche plus

Message par papajoke » ven. 03 févr. 2017, 06:42

bonjour,

tu installes tes paquets avec pip3 :roll: pourquoi ne pas utiliser les paquets officiels ?
Arch stable - Kde 5 / zsh - btrfs/mbr - Intel Core i3 - 6Go RAM - GeForce 405 video-nouveau

Avatar de l’utilisateur
Blableau-5979
Hankyu
Messages : 22
Inscription : mar. 18 oct. 2016, 16:00

Re: [Lollypop] ne marche plus

Message par Blableau-5979 » ven. 03 févr. 2017, 07:02

papajoke a écrit :bonjour,

tu installes tes paquets avec pip3 :roll: pourquoi ne pas utiliser les paquets officiels ?
J'ai fait "pacman -S lollypop". Je crois que cela télécharge les paquets officiels, n'est ce pas ?

Avatar de l’utilisateur
papajoke
Chu Ko Nu
Messages : 365
Inscription : sam. 30 août 2014, 19:54
Contact :

Re: [Lollypop] ne marche plus

Message par papajoke » ven. 03 févr. 2017, 07:34

regarde mon lien ou dépendances optionnelles de lollypop
Arch stable - Kde 5 / zsh - btrfs/mbr - Intel Core i3 - 6Go RAM - GeForce 405 video-nouveau

Avatar de l’utilisateur
Blableau-5979
Hankyu
Messages : 22
Inscription : mar. 18 oct. 2016, 16:00

Re: [Lollypop] ne marche plus

Message par Blableau-5979 » ven. 03 févr. 2017, 07:50

papajoke a écrit :regarde mon lien ou dépendances optionnelles de lollypop
Je viens de supprimer dans mon dossier perso tout ce qu'aurait pu rester de Lollypop (sur une install toute fraîche, je n'ai gardé que mon /home) j'ai donné un coup de Bleachbit, j'ai réinstallé Lollypop + les dépendances de ton lien et voici ce que j'obtiens en lançant Lollypop en console :

Code : Tout sélectionner

[pablo@pablo-archlinux ~]$ lollypop
No module named 'pylast'
    - Scrobbler disabled
    - Auto cover download disabled
    - Artist informations disabled
$ sudo pip3 install pylast
/usr/lib/python3.6/site-packages/lollypop/lio.py:13: PyGIWarning: Soup was imported without specifying a version first. Use gi.require_version('Soup', '2.4') before import to ensure that the right version gets loaded.
  from gi.repository import Gio, GObject, Soup
/usr/lib/python3.6/site-packages/gi/module.py:178: Warning: g_array_append_vals: assertion 'array' failed
  g_type = info.get_g_type()
/usr/lib/python3.6/site-packages/gi/module.py:178: Warning: g_hash_table_lookup: assertion 'hash_table != NULL' failed
  g_type = info.get_g_type()
/usr/lib/python3.6/site-packages/gi/module.py:178: Warning: g_hash_table_insert_internal: assertion 'hash_table != NULL' failed
  g_type = info.get_g_type()
Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/lollypop/GioNotify.py", line 57, in on_GetCapabilities_finish
    caps = self.call_finish(result).unpack()[0]
GLib.Error: g-dbus-error-quark: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Notifications was not provided by any .service files (2)
[pablo@pablo-archlinux ~]$ 

Avatar de l’utilisateur
papajoke
Chu Ko Nu
Messages : 365
Inscription : sam. 30 août 2014, 19:54
Contact :

Re: [Lollypop] ne marche plus

Message par papajoke » ven. 03 févr. 2017, 09:06

une fois installé python2-pylast tu ne devrais plus avoir le message avec pylast ???

Pour le reste , j'ai les mêmes messages d'avertissement mais le logiciel fonctionne très bien.

Code : Tout sélectionner

lollypop                                                        
/usr/lib/python3.6/site-packages/lollypop/lio.py:13: PyGIWarning: Soup was imported without specifying a version first. Use gi.require_version('Soup', '2.4') before import to ensure that the right version gets loaded.
  from gi.repository import Gio, GObject, Soup
/usr/lib/python3.6/site-packages/gi/module.py:178: Warning: g_array_append_vals: assertion 'array' failed
  g_type = info.get_g_type()
/usr/lib/python3.6/site-packages/gi/module.py:178: Warning: g_hash_table_lookup: assertion 'hash_table != NULL' failed
  g_type = info.get_g_type()
/usr/lib/python3.6/site-packages/gi/module.py:178: Warning: g_hash_table_insert_internal: assertion 'hash_table != NULL' failed
  g_type = info.get_g_type()
** Message: Remote error from secret service: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.secrets was not provided by any .service files
Lastfm::__on_password_lookup(): g-dbus-error-quark: The name org.freedesktop.secrets was not provided by any .service files (2)

(lollypop:26829): GStreamer-CRITICAL **: gst_date_time_new: assertion 'year > 0 && year <= 9999' failed
ps: la config utilisateur est dans $HOME/.local/share/lollypop/
Arch stable - Kde 5 / zsh - btrfs/mbr - Intel Core i3 - 6Go RAM - GeForce 405 video-nouveau

Avatar de l’utilisateur
Blableau-5979
Hankyu
Messages : 22
Inscription : mar. 18 oct. 2016, 16:00

Re: [Lollypop] ne marche plus

Message par Blableau-5979 » ven. 03 févr. 2017, 12:18

papajoke a écrit :une fois installé python2-pylast tu ne devrais plus avoir le message avec pylast ???

Pour le reste , j'ai les mêmes messages d'avertissement mais le logiciel fonctionne très bien.

Code : Tout sélectionner

lollypop                                                        
/usr/lib/python3.6/site-packages/lollypop/lio.py:13: PyGIWarning: Soup was imported without specifying a version first. Use gi.require_version('Soup', '2.4') before import to ensure that the right version gets loaded.
  from gi.repository import Gio, GObject, Soup
/usr/lib/python3.6/site-packages/gi/module.py:178: Warning: g_array_append_vals: assertion 'array' failed
  g_type = info.get_g_type()
/usr/lib/python3.6/site-packages/gi/module.py:178: Warning: g_hash_table_lookup: assertion 'hash_table != NULL' failed
  g_type = info.get_g_type()
/usr/lib/python3.6/site-packages/gi/module.py:178: Warning: g_hash_table_insert_internal: assertion 'hash_table != NULL' failed
  g_type = info.get_g_type()
** Message: Remote error from secret service: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.secrets was not provided by any .service files
Lastfm::__on_password_lookup(): g-dbus-error-quark: The name org.freedesktop.secrets was not provided by any .service files (2)

(lollypop:26829): GStreamer-CRITICAL **: gst_date_time_new: assertion 'year > 0 && year <= 9999' failed
ps: la config utilisateur est dans $HOME/.local/share/lollypop/
Toujours rien. Je viens de faire une install sur un autre disque, avec un /home tout vierge et voila ce que j'obtiens (en ayant téléchargé les dépendances) :

Code : Tout sélectionner

[pablo@pablo-archlinux ~]$ lollypop
No module named 'pylast'
    - Scrobbler disabled
    - Auto cover download disabled
    - Artist informations disabled
$ sudo pip3 install pylast
/usr/lib/python3.6/site-packages/lollypop/lio.py:13: PyGIWarning: Soup was imported without specifying a version first. Use gi.require_version('Soup', '2.4') before import to ensure that the right version gets loaded.
  from gi.repository import Gio, GObject, Soup
/usr/lib/python3.6/site-packages/gi/module.py:178: Warning: g_array_append_vals: assertion 'array' failed
  g_type = info.get_g_type()
/usr/lib/python3.6/site-packages/gi/module.py:178: Warning: g_hash_table_lookup: assertion 'hash_table != NULL' failed
  g_type = info.get_g_type()
/usr/lib/python3.6/site-packages/gi/module.py:178: Warning: g_hash_table_insert_internal: assertion 'hash_table != NULL' failed
  g_type = info.get_g_type()
Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/lollypop/GioNotify.py", line 57, in on_GetCapabilities_finish
    caps = self.call_finish(result).unpack()[0]
GLib.Error: g-dbus-error-quark: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Notifications was not provided by any .service files (2)

Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 13833
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Lollypop] ne marche plus

Message par benjarobin » ven. 03 févr. 2017, 12:43

Quel est la sortie de :

Code : Tout sélectionner

pacman -Q lollypop flatpak gst-libav kid3-qt libsecret python-pylast python-wikipedia youtube-dl
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
Blableau-5979
Hankyu
Messages : 22
Inscription : mar. 18 oct. 2016, 16:00

Re: [Lollypop] ne marche plus

Message par Blableau-5979 » ven. 03 févr. 2017, 12:53

benjarobin a écrit :Quel est la sortie de :

Code : Tout sélectionner

pacman -Q lollypop flatpak gst-libav kid3-qt libsecret python-pylast python-wikipedia youtube-dl
Voici la sortie (je précise que j'ai installé, sur ce disque, que Lollypop et Totem, histoire de voir ) :

Code : Tout sélectionner

lollypop 0.9.229-1
erreur : le paquet « flatpak » n’a pas été trouvé.
gst-libav 1.10.3-1
erreur : le paquet « kid3-qt » n’a pas été trouvé.
libsecret 0.18.5-1
erreur : le paquet « python-pylast » n’a pas été trouvé.
erreur : le paquet « python-wikipedia » n’a pas été trouvé.
erreur : le paquet « youtube-dl » n’a pas été trouvé.
Lorsque je lance une première fois Lollypop, l'écran cligne et ensuite rien. Si je le fais une deuxième fois dans la même session rien ne se passe.
Ces paquets sont installés sur l'autre disque et il me joue le même coup.

Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 13833
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Lollypop] ne marche plus

Message par benjarobin » ven. 03 févr. 2017, 14:53

Je suis bête et méchant mais je veux voir les dépendances optionnelles avec leurs versions et ensuite le lancement en console du programme. Ici clairement il n'y a pas d'installé python-pylast
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
Blableau-5979
Hankyu
Messages : 22
Inscription : mar. 18 oct. 2016, 16:00

Re: [Lollypop] ne marche plus

Message par Blableau-5979 » ven. 03 févr. 2017, 15:07

benjarobin a écrit :Je suis bête et méchant mais je veux voir les dépendances optionnelles avec leurs versions et ensuite le lancement en console du programme. Ici clairement il n'y a pas d'installé python-pylast
Oui, j'ai installé python-pylast après ton message précédent. Voici les nouvelles :

Code : Tout sélectionner

[pablo@pablo-archlinux ~]$ lollypop
/usr/lib/python3.6/site-packages/lollypop/lio.py:13: PyGIWarning: Soup was imported without specifying a version first. Use gi.require_version('Soup', '2.4') before import to ensure that the right version gets loaded.
  from gi.repository import Gio, GObject, Soup
/usr/lib/python3.6/site-packages/gi/module.py:178: Warning: g_array_append_vals: assertion 'array' failed
  g_type = info.get_g_type()
/usr/lib/python3.6/site-packages/gi/module.py:178: Warning: g_hash_table_lookup: assertion 'hash_table != NULL' failed
  g_type = info.get_g_type()
/usr/lib/python3.6/site-packages/gi/module.py:178: Warning: g_hash_table_insert_internal: assertion 'hash_table != NULL' failed
  g_type = info.get_g_type()
** Message: Remote error from secret service: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.secrets was not provided by any .service files
Lastfm::__on_password_lookup(): g-dbus-error-quark: The name org.freedesktop.secrets was not provided by any .service files (2)
Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/lollypop/GioNotify.py", line 57, in on_GetCapabilities_finish
    caps = self.call_finish(result).unpack()[0]
GLib.Error: g-dbus-error-quark: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Notifications was not provided by any .service files (2)
[pablo@pablo-archlinux ~]$ 

Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 13833
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Lollypop] ne marche plus

Message par benjarobin » ven. 03 févr. 2017, 16:57

Il te manque quelque chose qui gère les notifications, tu as quoi comme environnement de bureau ?
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
Blableau-5979
Hankyu
Messages : 22
Inscription : mar. 18 oct. 2016, 16:00

Re: [Lollypop] ne marche plus

Message par Blableau-5979 » ven. 03 févr. 2017, 18:17

benjarobin a écrit :Il te manque quelque chose qui gère les notifications, tu as quoi comme environnement de bureau ?
LXDE avec quelques pointes de Gnome (avec bcp de parcimonie, histoire de tirer le maximum de profit de ma petite bécane).

Avatar de l’utilisateur
Blableau-5979
Hankyu
Messages : 22
Inscription : mar. 18 oct. 2016, 16:00

Re: [Lollypop] ne marche plus

Message par Blableau-5979 » ven. 10 févr. 2017, 16:00

Lollypop marche sous Gnome. C'est sous LXDE qu'il ne veut pas.

Avatar de l’utilisateur
Blableau-5979
Hankyu
Messages : 22
Inscription : mar. 18 oct. 2016, 16:00

Re: [Lollypop] ne marche plus

Message par Blableau-5979 » lun. 13 févr. 2017, 16:13

Bon, tant pis. En recherchant et réinstallant, j'ai pas mal appris. J'ai boosté mon ordi côté RAM, j'ai fait une install avec le tout Gnome (que je croyais allait ralentir ma vieille bécane mais non, elle court toujours très vite) et j'ai découvert Clémentine qui remplace très bien Lollypop (et en mieux car il a un bel égaliseur). Du coup je constate que Arch avec LXDE me fournit tout ce dont j'ai besoin en plus rapide que par exemple Lubuntu (longtemps ma distro).
Je tenterai peut être un jour Lollypop, histoire de voir si ce n'était qu'un bug passager mais pour l'instant tout va bien comme ça.

Répondre

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité