[smplayer] extinction de l'écran (abandonné)

Applications multimedia / jeux
Avatar de l’utilisateur
mimile
Maître du Kyudo
Messages : 1507
Inscription : lun. 14 nov. 2011, 10:21
Localisation : Seraing (Belgique)

[smplayer] extinction de l'écran (abandonné)

Message par mimile » lun. 15 oct. 2012, 10:18

Bonjour,

Voici quelques mois, j'ai déjà posté à ce sujet : quand je visionne une vidéo avec smplayer, l'écran s'éteint après écoulement de la durée indiquée dans l'option "luminosité et verrouillage" de gnome-control-center (Eteindre l'écran si inactif pendant ... une durée qui va de 1 minute à 1 heure, sans option "jamais"), la bande-son restant toutefois audible comme si de rien n'était.

A l'époque, le problème avait disparu sans que je sache exactement pourquoi (une mise à jour de smplayer peut-être ?).

Pour une raison que je ne m'explique pas, le problème est réapparu hier soir.

Je précise que, dans l'onglet énergie, l'option de mise en veille est réglée sur : ne jamais mettre en veille et que dans les réglages de smplayer (général > video), la case "désactiver l'écran de veille" est bien cochée).

La dernière mise à jour de smplayer remonte au 6 octobre dernier et jusqu'à hier soir tout allait bien (j'ai pu visionner un long métrage de plus de deux heures dans l'après-midi sans rencontrer ce problème).

A tout hasard, j'ai restauré la version précédente de smplayer mais ça n'y change rien.

J'ai arpenté le net avec Google et n'ai pas trouvé de solution.

Je précise que Gnome-mplayer et vlc ne rencontrent pas ce problème

Vous me direz : laisse tomber smplayer mais ce n'est pas une solution qui me satisfait car je visionne essentiellement des vidéos avec sous-titres séparés (fichiers *.srt) et que c'est avec smplayer que j'obtiens les réglages qui me conviennent le mieux.

A tout hasard, je vous reproduis les dernières lignes de mon pacman.log :

http://pastebin.archlinux.fr/450173

EDIT : Je m'explique pourquoi gnome-mplayer ne rencontre pas ce problème.

Quand je lance dconf-editor, je remarque dans la liste de configuration de gnome-mplayer que la case use-xscrnsaver n'est pas cochée ce qui, à mon avis, bloque le screen-saver de gnome-control-center.

Malheureusement, smplayer n'est pas repris dans la liste des applications où se trouve gnome-mplayer.
Dernière modification par mimile le dim. 21 oct. 2012, 12:00, modifié 3 fois.
La TV ? J'adore la TV. Je peux rester des heures devant la TV ... et même, parfois, il m'arrive de l'allumer ...
Image
(Jean-Luc GODARD)

Avatar de l’utilisateur
cdemoulins
Chu Ko Nu
Messages : 310
Inscription : mar. 11 mars 2008, 04:15
Localisation : Paris

Re: [smplayer] extinction de l'écran

Message par cdemoulins » lun. 15 oct. 2012, 16:30

Est-ce que par hasard tu n'aurais pas un «screensaver» qui tourne genre xscreensaver ou gnome-screensaver ?

Avatar de l’utilisateur
mimile
Maître du Kyudo
Messages : 1507
Inscription : lun. 14 nov. 2011, 10:21
Localisation : Seraing (Belgique)

Re: [smplayer] extinction de l'écran

Message par mimile » mar. 16 oct. 2012, 17:44

J'ai effectivement gnome-screensaver mais a priori, l'option "désactiver l'économiseur d'écran" est cochée dans smplayer et jusqu'à il y a quelque jours, je n'avais pas de problème (problème qui ne se pose d'ailleurs pas avec gnome-mplayer).

Hormis la solution radicale qui consisterait à le supprimer, y-a-t'il un moyen de le neutraliser ?
La TV ? J'adore la TV. Je peux rester des heures devant la TV ... et même, parfois, il m'arrive de l'allumer ...
Image
(Jean-Luc GODARD)

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10564
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [smplayer] extinction de l'écran

Message par FoolEcho » mar. 16 oct. 2012, 18:06

À tout hasard, tu peux essayer de repartir d'une configuration neuve de smplayer (mais vu que repasser à la version précédente n'a rien fait, c'est probablement pas ça :| ). Elle devrait être dans ~/.config/smplayer/.
«The following statement is not true. The previous statement is true.» :nage:

Avatar de l’utilisateur
cdemoulins
Chu Ko Nu
Messages : 310
Inscription : mar. 11 mars 2008, 04:15
Localisation : Paris

Re: [smplayer] extinction de l'écran

Message par cdemoulins » mar. 16 oct. 2012, 18:54

Tu vas pouvoir utiliser la même astuce que moi.

Ajoute la conf suivante au fichier «~/.mplayer/config» :

Code : Tout sélectionner

[default]
heartbeat-cmd="gnome-screensaver-command -deactivate &"
Cela permet de réinitialiser le décompte de gnome-screensaver.
Et normalement, lorsque mplayer est chargé par smplayer, la configuration est lue.

Si ça ne fonctionne pas, c'est que ce n'est pas de la faute de gnome-screensaver.

Avatar de l’utilisateur
mimile
Maître du Kyudo
Messages : 1507
Inscription : lun. 14 nov. 2011, 10:21
Localisation : Seraing (Belgique)

Re: [smplayer] extinction de l'écran

Message par mimile » ven. 19 oct. 2012, 09:50

Bonjour et désolé de répondre avec un peu de retard.

J'ai ajouté tes lignes dans mplayer.config mais malheureusement, ça ne résoud pas le problème : l'écran passe au noirà l'expiration du délai indiqué.

Dommage ...
La TV ? J'adore la TV. Je peux rester des heures devant la TV ... et même, parfois, il m'arrive de l'allumer ...
Image
(Jean-Luc GODARD)

Avatar de l’utilisateur
Ypnose
Maître du Kyudo
Messages : 1363
Inscription : sam. 01 mai 2010, 13:17
Contact :

Re: [smplayer] extinction de l'écran

Message par Ypnose » ven. 19 oct. 2012, 14:52

J'ai aussi ajouté dans mon mplayer.cfg, l'option suivante:

Code : Tout sélectionner

stop-xscreensaver = yes
En effet, cette option est censé aussi désactiver le "screensaver". Essaie aussi:

Code : Tout sélectionner

stop-gnome-screensaver = yes

Avatar de l’utilisateur
mimile
Maître du Kyudo
Messages : 1507
Inscription : lun. 14 nov. 2011, 10:21
Localisation : Seraing (Belgique)

Re: [smplayer] extinction de l'écran

Message par mimile » ven. 19 oct. 2012, 16:13

Merci pour tes suggestions mais aucune d'elle ne donne de résultat : l'écran finit par s'éteindre à l'expiration du laps de temps indiqué.

Accessoirement, le fait d'ajouter ces lignes (l'une après l'autre évidemment) provoque des saccades de l'image.

Tant pis, j'utiliserai dorénavant gnome-mplayer qui ne rencontre pas de problème.
La TV ? J'adore la TV. Je peux rester des heures devant la TV ... et même, parfois, il m'arrive de l'allumer ...
Image
(Jean-Luc GODARD)

Avatar de l’utilisateur
Ypnose
Maître du Kyudo
Messages : 1363
Inscription : sam. 01 mai 2010, 13:17
Contact :

Re: [smplayer] extinction de l'écran

Message par Ypnose » ven. 19 oct. 2012, 17:20

Attention, je pense que tu auras quand même besoin d'ajouter la ligne de cdemoulins avec gnome-mplayer. Chez moi, avec Fedora 17 + gnome-mplayer + XFCE + xscreensaver, je suis obligé d'ajouter les lignes suivantes:

Code : Tout sélectionner

heartbeat-cmd="/usr/bin/xscreensaver-command -deactivate"
stop-xscreensaver = yes

Avatar de l’utilisateur
mimile
Maître du Kyudo
Messages : 1507
Inscription : lun. 14 nov. 2011, 10:21
Localisation : Seraing (Belgique)

Re: [smplayer] extinction de l'écran (résolu)

Message par mimile » sam. 20 oct. 2012, 10:14

Merci pour votre acharnement à me venir en aide mais ce matin, après avoir effectué une mise à jour système complète :

Code : Tout sélectionner

[2012-10-20 10:00] upgraded ppp (2.4.5-4 -> 2.4.5-5)
[2012-10-20 10:00] upgraded xorg-server-common (1.13.0-2 -> 1.13.0-3)
[2012-10-20 10:00] upgraded xorg-server (1.13.0-2 -> 1.13.0-3)
[2012-10-20 10:00] upgraded xorg-server-devel (1.13.0-2 -> 1.13.0-3)
mon problème a mystérieusement disparu et apparemment son origine se situait au niveau de xorg et non pas de smplayer.

Il reste quand même deux points obscurs :

a) pourquoi, alors que tout allait bien, ce problème d'extinction d'écran est-il apparu du jour au lendemain avec smplayer

b) pourquoi gnome-mplayer n'était-il pas confronté au même problème ?

Cela dit, peu me chaut puisque tout est rentré dans l'ordre.

Encore merci à tous.

Je marque ce sujet comme résolu.
La TV ? J'adore la TV. Je peux rester des heures devant la TV ... et même, parfois, il m'arrive de l'allumer ...
Image
(Jean-Luc GODARD)

Avatar de l’utilisateur
mimile
Maître du Kyudo
Messages : 1507
Inscription : lun. 14 nov. 2011, 10:21
Localisation : Seraing (Belgique)

Re: [smplayer] extinction de l'écran (NON résolu)

Message par mimile » dim. 21 oct. 2012, 10:34

déception !

Hier, j'ai fait un test avec smplayer en fixant à une minute le délai après lequel l'économiseur d'écran entrait en action en cas d'inactivité de ce dernier.

J'ai laissé tourner pendant 4 à 5 minutes et j'en ai déduit que le problème avait disparu spontanément, peut-être après mise à jour de xorg.

Pour en être bien certain, j'ai laissé tourner smplayer toute la nuit grâce à une liste de lecture suffisamment longue pour durer une vingtaine d'heures.

Ce matin, j'ai bien dû constater que mon écran était noir (le son continuant toutefois à tourner).

Un simple déplacement de la souris ou une pression sur la barre d'espacement suffit à restaurer l'image pour la durée fixée.

Ce problème n'est donc pas résolu et j'ai donc modifié le titre de mon poste initial.

J'ai ajouté les lignes suggérées par cdemoulin et ypnose dans le fichier de configuration de mplayer mais en vain.

Seul gnome-mplayer ne rencontre pas ce problème.

Grrrr :evil:
La TV ? J'adore la TV. Je peux rester des heures devant la TV ... et même, parfois, il m'arrive de l'allumer ...
Image
(Jean-Luc GODARD)

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10564
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [smplayer] extinction de l'écran (NON résolu)

Message par FoolEcho » dim. 21 oct. 2012, 10:53

Je le dis parce que je sais que tu ne vas pas le prendre mal, mais pourquoi ça ne me surprend pas ? :copain: :pastaper: :merci:
(j'ai failli réagir hier quand tu faisais le lien avec tes mises à jour et la supposée correction du problème -- ne voyant pas trop moi-même le lien avec les mises à jour en question... mais bon, vu que la résolution de tes sujets sont parfois... bizarres, j'ai préféré ne pas insister :mrgreen: )

Plus constructif j'espère :wink: : as-tu essayé avec un utilisateur test ?
C'est-à-dire:
-juste lancer gnome (à tout hasard, tu passes par gdm ?),
-vérifier que le screensaver fonctionne normalement
-puis faire le test après avoir coché la case appropriée dans smplayer
-Rien d'autre surtout (y a sans doutes des bonnes raisons que chacun veuille triturer la configuration de mplayer comme l'utiliser sans ces interfaces plus évoluées, mais à moins que qu'il y ait un bug spécifique, smplayer est censé le faire correctement, au moins avec kscreensaver/xscreensaver pour ce qui me concerne) ?
«The following statement is not true. The previous statement is true.» :nage:

Avatar de l’utilisateur
mimile
Maître du Kyudo
Messages : 1507
Inscription : lun. 14 nov. 2011, 10:21
Localisation : Seraing (Belgique)

Re: [smplayer] extinction de l'écran

Message par mimile » dim. 21 oct. 2012, 12:00

Comme je l'ai dit précédemment, j'ai dûment constater qu'après avoir fixé une durée de une minute avant l'extinction de l'écran, j'ai pu visionner hier un *.avi pendant 4 à 5 minutes sans interruption.

Comme la seule chose que j'avais faite était une mise à jour au cours de laquelle xorg (server et autres) avait été mis à jour, j'en ai déduit un lien de cause à effet, ce qui m'a incité à commenté mon poste initial comme étant résolu, ce qui, finalement, n'était pas le cas.

Dans smplayer, la case "désactiver l'économiseur d'écran" est effectivement cochée.

En vrac, pour répondre à tes questions :

oui, gnome est lancé par gdm.service

Le screensaver fonctionne normalement puisque à l'expiration du délai fixé, il éteint l'écran (et cela, que j'utilise ou non smplayer dont je n'ai absolument pas modifié les réglages, le problème étant survenu inopinément).

De toute évidence, c'est la fonction de désactivation du screensaver de smplayer qui ne fonctionne pas vu que je ne rencontre pas de problème avec gnome-mplayer, ni avec VLC, ni quand je visionne des vidéos sur Youtube.

Cela dit, étant totalement excédé par ce problème qui résiste à toutes les suggestions, j'ai carrément viré smplayer et j'ai configuré VLC qui fonctionne parfaitement.

Je clôture dès lors définitivement ce sujet.

Encore merci à tous.
La TV ? J'adore la TV. Je peux rester des heures devant la TV ... et même, parfois, il m'arrive de l'allumer ...
Image
(Jean-Luc GODARD)

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10564
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [smplayer] extinction de l'écran (abandonné)

Message par FoolEcho » dim. 21 oct. 2012, 12:19

mimile a écrit :De toute évidence, c'est la fonction de désactivation du screensaver de smplayer qui ne fonctionne pas vu que je ne rencontre pas de problème avec gnome-mplayer, ni avec VLC, ni quand je visionne des vidéos sur Youtube.
De toute évidence, tu réponds surtout aux questions qu'on ne te pose pas, tu occultes celles auxquelles on voudrait des réponses et tu conclues trop vite. :mrgreen:
La manipulation par un compte utilisateur test (créé pour l'occasion puis supprimé) permet d'isoler s'il n'y a pas quelque chose qui coince dans ton propre home ou si, effectivement c'est le programme qui a un bug.
Pour suivre le fond de ma pensée: comme il me semble me rappeler que tu utilises différents systèmes en plus d'Arch, pour peu que tu partages les configurations utilisateurs entre eux (ça je ne sais plus si tu en avais parlé sur d'autres sujets), ça peut poser des soucis sur des versions différentes de programmes (et justement des choses de ce goût-là qui sont très difficilement décelables).

Mais tu fais comme tu veux, pas de problème. Il n'était pas rare à une époque qu'effectivement les programmes Qt/Kde passaient mal dans un environnement gnome... aucune idée de ce qu'il en est avec gnome 3. ;-)
«The following statement is not true. The previous statement is true.» :nage:

Avatar de l’utilisateur
mimile
Maître du Kyudo
Messages : 1507
Inscription : lun. 14 nov. 2011, 10:21
Localisation : Seraing (Belgique)

Re: [smplayer] extinction de l'écran (abandonné)

Message par mimile » dim. 21 oct. 2012, 13:00

Mes différentes distributions possèdent chacune leur /home propre ; il ne peut donc pas y avoir d'interférences entre elles.

Créer un utilisateur test ? en pratique comment faire ?

Parce que, pour tout avouer, entre adduser et useradd ainsi que les options qui les accompagnent, je m'y perds complètement, les différents sites qui j'ai visités étant souvent contradictoires (il y a en même qui disent que adduser et useradd c'est bonnet blanc et blanc bonnet).

Peux-tu m'éclairer ?
La TV ? J'adore la TV. Je peux rester des heures devant la TV ... et même, parfois, il m'arrive de l'allumer ...
Image
(Jean-Luc GODARD)

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10564
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [smplayer] extinction de l'écran (abandonné)

Message par FoolEcho » dim. 21 oct. 2012, 13:57

mimile a écrit :Parce que, pour tout avouer, entre adduser et useradd ainsi que les options qui les accompagnent, je m'y perds complètement, les différents sites qui j'ai visités étant souvent contradictoires (il y a en même qui disent que adduser et useradd c'est bonnet blanc et blanc bonnet).
Le résultat est le même sauf que adduser te pose des questions. Je préfère useradd. Tu le fais avec les mêmes groupes que ton utilisateur normal, tu testes et quand c'est fini tu le supprimes ainsi que son home.
Utilisateurs_et_Groupes

... sur ce que tu dis, ça ne changera rien, mais le mieux est d'en être sûr avec ce test. :chinois:
«The following statement is not true. The previous statement is true.» :nage:

Avatar de l’utilisateur
mimile
Maître du Kyudo
Messages : 1507
Inscription : lun. 14 nov. 2011, 10:21
Localisation : Seraing (Belgique)

Re: [smplayer] extinction de l'écran (abandonné)

Message par mimile » dim. 21 oct. 2012, 17:13

Bon, j'ai créé un utilisateur (sudo useradd -m -s /bin/bash test - je me suis servi du wiki d'installation d'Arch d'avant systemd) que j'ai ajouté aux mêmes groupes que ceux de mon utilisateur principal (usermod -G users,wheel,audio,optical,lp,scanner,log,power,floppy,storage,video test)

Reboot et choix de l'utilisateur test

Tentative avec smplayer : pas de changement : l'écran s'éteint toujours à l'expiration du délai fixé (gnome-control-center > luminosité et verrouillage)
sauf qu'avec ce nouvel utilisateur, pour "ranimer" l'écran, il faut que je donne mon mot de passe (sans doute parce que je me suis dispensé de mot de passe dans sudoers pour mon utilisateur normal).

Alors ? bug de smplayer (qui n'avait pas été mis à jour depuis des semaines avant que le problème n'apparaisse du jour au lendemain et dont je n'ai pas modifié les réglages) ?

Je vais donc supprimer cet utilisateur test.

Code : Tout sélectionner

sudo userdel -r test
La TV ? J'adore la TV. Je peux rester des heures devant la TV ... et même, parfois, il m'arrive de l'allumer ...
Image
(Jean-Luc GODARD)

benjarobin
Maître du Kyudo
Messages : 15615
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [smplayer] extinction de l'écran (abandonné)

Message par benjarobin » dim. 21 oct. 2012, 17:15

Pour la suppression c'est en effet la bonne commande
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10564
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [smplayer] extinction de l'écran (abandonné)

Message par FoolEcho » dim. 21 oct. 2012, 17:19

mimile a écrit :Alors ? bug de smplayer (qui n'avait pas été mis à jour depuis des semaines avant que le problème n'apparaisse du jour au lendemain et dont je n'ai pas modifié les réglages) ?
Bien possible. En tous cas, tu n'es pas le seul (ça fait un moment que je ne m'en suis pas servi sous KDE donc je ne sais pas): https://bbs.archlinux.org/viewtopic.php?pid=1178125.
«The following statement is not true. The previous statement is true.» :nage:

Avatar de l’utilisateur
mimile
Maître du Kyudo
Messages : 1507
Inscription : lun. 14 nov. 2011, 10:21
Localisation : Seraing (Belgique)

Re: [smplayer] extinction de l'écran (abandonné)

Message par mimile » lun. 22 oct. 2012, 09:24

Salut

Si j'ai bien compris les échanges du topic auquel tu renvoies, ce serait une mise à jour de mplayer qui pourrait être à l'origine du problème.

Code : Tout sélectionner

I noticed this stopped working after a recent update (using mplayer). Havn't looked into it too much, but hacked together a workaround:
Pour ce qui est du script de contournement fourni dans la foulée, je n'ai aucune idée de la façon de m'en servir.

Cela dit, et finalement, VLC donne de bons résultats et n'est pas sensible à l'extinction de l'écran (bien que je n'aie trouvé aucune option du genre "désactiver l'économiseur d'écran").

Je vais donc continuer d'utiliser VLC car je suppose que, n'étant pas seul dans le cas, il y aura des retours auprès des développeurs et que ceux-ci se pencheront sur le problème.

Amicalement,
La TV ? J'adore la TV. Je peux rester des heures devant la TV ... et même, parfois, il m'arrive de l'allumer ...
Image
(Jean-Luc GODARD)

Répondre