[MPD] Failed to set groups of user... (RÉSOLU)

Applications multimedia / jeux
Skwad
archer de cavalerie
Messages : 195
Inscription : mar. 14 déc. 2010, 20:00

Re: [MPD] Failed to set groups of user... (en cours)

Message par Skwad » mer. 06 nov. 2013, 16:56

Non, ça veut pas...

Voici ce que j'ai fait

Code : Tout sélectionner

$ mv ~/.mpdconf ~/.mpdconf.old

Code : Tout sélectionner

# mv /etc/mpdconf /mpdconf.old

Code : Tout sélectionner

# nano /etc/mpdconf
J'ai collé le tien, je l'ai adapté à ma config.

Code : Tout sélectionner

$ reboot
au démarrage

Code : Tout sélectionner

$ mpd --verbose
config_file: loading file /etc/mpd.conf
fatal_error: Failed to set supplementary groups of user "skwad": Operation not permitted
Le bon fichier de conf est pris mais même punition.
Et y a de grande chance qu'avec l'utilisateur test qui a ses propres fichiers de config (pid, log, etc.) et son propre "repertory_music" ça fasse pareil. Je l'ai déjà fait mais c'était avec un autre exemple de /etc/mpd.conf.

Systemd c'est uniquement lorsqu'on veut lancer mpd en root non ? J'ai "systemctl disable mpd.service" de mon côté. Rhoo si c'est ça...


Sinon j'ai remarqué ça par hasard

Code : Tout sélectionner

mpd --kill
fatal_error: unable to read the pid from file "/home/skwad/.mpd/pid"
Je ne sais pas si c'est à cause d'un problème de droit ou bien parce que mpd n'est pas lancé.


EDIT: Ça refonctionne avec

Code : Tout sélectionner

systemctl enable mpd.service

Code : Tout sélectionner

systemctl start mpd.service
Depuis quand c'est comme ça ? Je continuais à le lancer via l'autostart de mon openbox moi. On ne peut plus utiliser de ~/.mpdconf ? On fait comment en multi-user avec des bibliothèques différentes ?
Y a vraiment pas moyen de passer par mon ~/.mpdconf ? Je dois mettre résolu ou contourné ? :P
OS : Archlinux / Debian
DE : Gnome / KDE
Serveur : OpenMediaVault

Avatar de l’utilisateur
fran
yeomen
Messages : 219
Inscription : lun. 27 déc. 2010, 18:47
Localisation : breizh

Re: [MPD] Failed to set groups of user... (en cours)

Message par fran » mer. 06 nov. 2013, 18:00

EDIT: Ça refonctionne avec
systemctl enable mpd.service
systemctl start mpd.service
Depuis quand c'est comme ça ?
novembre 2012
Depuis la mise en place de systemd , voir wiki mpd
Je continuais à le lancer via l'autostart de mon openbox moi. On ne peut plus utiliser de ~/.mpdconf ? On fait comment en multi-user avec des bibliothèques différentes ?
Y a vraiment pas moyen de passer par mon ~/.mpdconf ? Je dois mettre résolu ou contourné ?
extrait du wiki mpd :
Vous pouvez aussi démarrer le démon au démarrage:

systemctl enable mpd

(pensez à créer un lien /etc/mpd.conf qui pointe vers votre fichier de configuration personnel si vous n'avez pas modifié directement le fichier /etc/mpd.conf).

Sinon je sais pas
HP elitebook 2570P : arch xfce
intelNuc :debian 10 xfce media center

Skwad
archer de cavalerie
Messages : 195
Inscription : mar. 14 déc. 2010, 20:00

Re: [MPD] Failed to set groups of user... (en cours)

Message par Skwad » mer. 06 nov. 2013, 18:14

Pour le passage à systemd, ça j'étais au courant. Qui ne l'est pas ? Je voulais dire, depuis quand mpd utilise-t-il systemd ?

Quant au wiki oui je l'avais mal lu, je pensais que systemd c'était réservé à l'utilisation de mpd via root.


Bon allez, je passe en résolu.

Merci pour l'aide.
OS : Archlinux / Debian
DE : Gnome / KDE
Serveur : OpenMediaVault

Répondre