[Wine] Ne fonctionne absolument pas et n'iinstalle rien du tout

Applications multimedia / jeux
Répondre
Ishac-sama
newbie
Messages : 5
Inscription : sam. 01 juin 2019, 14:48

[Wine] Ne fonctionne absolument pas et n'iinstalle rien du tout

Message par Ishac-sama » sam. 01 juin 2019, 15:05

Salut j'ai installé ArchLinux il y a de ça 5 jours, je suis donc un gros noob mais je souhaite quand meme apprendre !
J'ai réussi à presque tout configurer et faire fonctionner correctement sauf Wine qui ne fonctionne pas
Quand j'essaie d'installer un fichier.exe il y'a l'erreur "/usr/lib32/libc.so.6: version `glibc_2.29' not found"
Quelle est la solution à ce problème ?
Est ce moi qui ne sait pas comment m'y prendre ? à noter que meme avec PLayOnLinux ça affiche une erreur :/
Je vous prie de m'expliquer assez simplement vu que je ne suis pas très familier avec le jargon
Merci beaucoup !
Image

laurent85
Elfe
Messages : 613
Inscription : mar. 16 oct. 2018, 21:05

Re: [Wine] Ne fonctionne absolument pas et n'iinstalle rien du tout

Message par laurent85 » sam. 01 juin 2019, 15:17

Bonjour,
Arch Linux est en 64 bit. Pour les applications 32 bit as-tu consulté le wiki ?
Wiki français https://wiki.archlinux.fr/Wine
Wiki anglais traduit https://translate.google.com/translate? ... l=en&tl=fr
Tuto Kde Plasma + gestionnaire de fenêtres i3
Mon développement en cours Archuseriso

benjarobin
Maître du Kyudo
Messages : 15923
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Wine] Ne fonctionne absolument pas et n'iinstalle rien du tout

Message par benjarobin » sam. 01 juin 2019, 15:32

Bonjour,
Ton système est intégralement à jour ?
Tu n'aurais pas essayé d'installé wine de cette façon : pacman -Sy wine ?
Pour rappel utiliser l'option -y sans l'option -u est plus que non recommandé !
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Ishac-sama
newbie
Messages : 5
Inscription : sam. 01 juin 2019, 14:48

Re: [Wine] Ne fonctionne absolument pas et n'iinstalle rien du tout

Message par Ishac-sama » sam. 01 juin 2019, 15:54

Meme en installant la version x64 ça m'affiche la meme erreur :/
Et on met le système à jour avec la commande "pacman -Sy"? dans ce cas oui il est à jour
Image

benjarobin
Maître du Kyudo
Messages : 15923
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Wine] Ne fonctionne absolument pas et n'iinstalle rien du tout

Message par benjarobin » sam. 01 juin 2019, 15:57

Non, on ne met pas son système à jour via l'option -y, mais avec l'option -u. Pour être exacte les 2 options vont de paire, voir la documentation de pacman.
Met à jour ton système avant : pacman -Syu

Pour rappel il ne faut jamais utiliser l'option -y seule (donc sans l'option -u), à moins de vraiment savoir ce que l'on fait ! En effet Arch Linux ne supporte pas du tout les mise à jour partielles (mettre à jour uniquement certains paquets). Ce n'est pas comme une Debian / Ubuntu qui sont bien plus robuste sur ce point là.

Je te conseille vivement de te documenter et de lire le Wiki (français comme anglophone) avant d'aller plus loin.

PS: Il est préférable de copier la sortie du terminal que de faire un screenshot...
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
liOnux
Hankyu
Messages : 41
Inscription : sam. 09 févr. 2019, 11:46
Localisation : Bordeaux

Re: [Wine] Ne fonctionne absolument pas et n'iinstalle rien du tout

Message par liOnux » sam. 01 juin 2019, 16:05

Quand tu dis que tu es débutant, c'est débutant sur Arch ou débutant sur Linux en général ?
OpenBox et noyau LTS sur un HP-ENVY 17" de 2014

Ishac-sama
newbie
Messages : 5
Inscription : sam. 01 juin 2019, 14:48

Re: [Wine] Ne fonctionne absolument pas et n'iinstalle rien du tout

Message par Ishac-sama » sam. 01 juin 2019, 16:39

J'ai fait toutes les mises à jour mais ça n'a pas résolu l'erreur :/
Et débutant sur Linux en général

laurent85
Elfe
Messages : 613
Inscription : mar. 16 oct. 2018, 21:05

Re: [Wine] Ne fonctionne absolument pas et n'iinstalle rien du tout

Message par laurent85 » sam. 01 juin 2019, 16:41

Ishac-sama a écrit :
sam. 01 juin 2019, 15:54
Meme en installant la version x64 ça m'affiche la meme erreur :/
Les rar sont gérés par Linux, pourquoi veux-tu installer winrar ?
Tuto Kde Plasma + gestionnaire de fenêtres i3
Mon développement en cours Archuseriso

Ishac-sama
newbie
Messages : 5
Inscription : sam. 01 juin 2019, 14:48

Re: [Wine] Ne fonctionne absolument pas et n'iinstalle rien du tout

Message par Ishac-sama » sam. 01 juin 2019, 16:44

C'est pas juste Winrar mais ABSOLUMENT TOUS les fichier.exe qui ne s'installent pas avec Wine
Il n'y a pas d'alternative à wine ou une solution à cette erreur,

laurent85
Elfe
Messages : 613
Inscription : mar. 16 oct. 2018, 21:05

Re: [Wine] Ne fonctionne absolument pas et n'iinstalle rien du tout

Message par laurent85 » sam. 01 juin 2019, 16:54

Il faudrait creuser au cas par cas. Là pour winrar c'est visiblement une bibliothèque 32 bit manquante, sur du 64 bit c'est pas étonnant. Pour les autres exe donne les erreurs pour chacun.
Tuto Kde Plasma + gestionnaire de fenêtres i3
Mon développement en cours Archuseriso

benjarobin
Maître du Kyudo
Messages : 15923
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Wine] Ne fonctionne absolument pas et n'iinstalle rien du tout

Message par benjarobin » sam. 01 juin 2019, 16:56

L'erreur n'a aucun lien avec le fichier .exe qu'il essaye d'être lancé, mais bien avec la librairie /usr/lib32/wine/ntdll.dll.so fournit par wine.
Et il n'y a pas non plus de rapport entre 64 bits vs 32 bits...
Le message est relativement claire, il dit que le fichier ntdll.dll.so à besoin de libm.so.6 (32 bits) en version 2.29. Hors le message indique qu'il trouve bien la libraire libm.so.6 mais quelle est trop vielle.

Peux tu donner la sortie de :

Code : Tout sélectionner

pacman -Qo /usr/lib32/wine/ntdll.dll.so /usr/lib32/libpthread.so.0 /usr/lib32/libwine.so.1 /usr/lib32/libm.so.6 /usr/lib32/libc.so.6 /usr/lib/ld-linux.so.2
ldd /usr/lib32/wine/ntdll.dll.so
uname -a
pacman -Q linux
Mais je pense toujours que tu n'es pas à jour...
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
liOnux
Hankyu
Messages : 41
Inscription : sam. 09 févr. 2019, 11:46
Localisation : Bordeaux

Re: [Wine] Ne fonctionne absolument pas et n'iinstalle rien du tout

Message par liOnux » sam. 01 juin 2019, 17:11

Ishac-sama a écrit :
sam. 01 juin 2019, 16:39
J'ai fait toutes les mises à jour mais ça n'a pas résolu l'erreur :/
Et débutant sur Linux en général
Mon expérience personnelle de 15 ans de Linux :
1- Wine n'est pas simple à installer et configurer;
2- Archlinux n'est pas non plus simple à installer et configurer.

Cela te fait donc cumuler les difficultés, mais bon, je ne suis pas un pro de l'informatique et chacun est libre dans ces expériences :)
OpenBox et noyau LTS sur un HP-ENVY 17" de 2014

benjarobin
Maître du Kyudo
Messages : 15923
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Wine] Ne fonctionne absolument pas et n'iinstalle rien du tout

Message par benjarobin » sam. 01 juin 2019, 17:16

Il y a littéralement rien à configurer pour Wine... En tout cas je n'ai jamais rien configurer et tout fonctionne très bien. Après l'installation de Arch Linux possède ses difficultés, oui, mais on s'égare :-)
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
liOnux
Hankyu
Messages : 41
Inscription : sam. 09 févr. 2019, 11:46
Localisation : Bordeaux

Re: [Wine] Ne fonctionne absolument pas et n'iinstalle rien du tout

Message par liOnux » sam. 01 juin 2019, 17:24

Dès l'instant où Wine ne fonctionne pas correctement c'est donc il y a quelque chose à configurer, j'en sais quelque chose pour être passé par là.
OpenBox et noyau LTS sur un HP-ENVY 17" de 2014

Ishac-sama
newbie
Messages : 5
Inscription : sam. 01 juin 2019, 14:48

Re: [Wine] Ne fonctionne absolument pas et n'iinstalle rien du tout

Message par Ishac-sama » sam. 01 juin 2019, 17:45

benjarobin a écrit :
sam. 01 juin 2019, 16:56
L'erreur n'a aucun lien avec le fichier .exe qu'il essaye d'être lancé, mais bien avec la librairie /usr/lib32/wine/ntdll.dll.so fournit par wine.
Et il n'y a pas non plus de rapport entre 64 bits vs 32 bits...
Le message est relativement claire, il dit que le fichier ntdll.dll.so à besoin de libm.so.6 (32 bits) en version 2.29. Hors le message indique qu'il trouve bien la libraire libm.so.6 mais quelle est trop vielle.

Peux tu donner la sortie de :

Code : Tout sélectionner

pacman -Qo /usr/lib32/wine/ntdll.dll.so /usr/lib32/libpthread.so.0 /usr/lib32/libwine.so.1 /usr/lib32/libm.so.6 /usr/lib32/libc.so.6 /usr/lib/ld-linux.so.2
ldd /usr/lib32/wine/ntdll.dll.so
uname -a
pacman -Q linux
Mais je pense toujours que tu n'es pas à jour...
Image

Avatar de l’utilisateur
liOnux
Hankyu
Messages : 41
Inscription : sam. 09 févr. 2019, 11:46
Localisation : Bordeaux

Re: [Wine] Ne fonctionne absolument pas et n'iinstalle rien du tout

Message par liOnux » sam. 01 juin 2019, 19:26

4.14 non lts ? c'est pas récent comme noyau ça...
OpenBox et noyau LTS sur un HP-ENVY 17" de 2014

benjarobin
Maître du Kyudo
Messages : 15923
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Wine] Ne fonctionne absolument pas et n'iinstalle rien du tout

Message par benjarobin » sam. 01 juin 2019, 19:36

Je ne sais pas ce que c'est comme distribution mais ce n'est pas une arch Linux
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
CoudUr
yeomen
Messages : 201
Inscription : sam. 06 avr. 2013, 17:12

Re: [Wine] Ne fonctionne absolument pas et n'iinstalle rien du tout

Message par CoudUr » sam. 01 juin 2019, 19:57

Bonjour,

Il faudra t'armer de plus de patience pour installer ton Archlinux alors, parce que là tu as du prendre un raccourci vu que ton noyau nous indique que tu as installé une distribution prévu pour une console PS4 si je ne m'abuse (^_^)

Bref on efface tout et on recommence mais si je peux me permettre, commences par quelque chose de plus "simple" qu'une Archlinux, si ton intention est de vouloir installer de suite ta logitheque Windows ça démontre peut-être qu'il est un peu tôt pour sauter le pas de suite sur Linux et plus particulièrement sur Arch.
Commences en douceur avec une distribution plus "user friendly" comme LinuxMint ou Ubuntu qui s'occupe de tout pour toi, et ensuite tu progresseras au fil du temps, parce sinon là tu vas galerer sur toutes les commandes, les concepts, l'environnement graphique c'est pas infaisable mais ça fait beaucoup d'un seul coup à digérer c'est mon avis mais je peux me tromper, c'est juste un conseil tu feras bien comme tu veux ;)

Sinon le lien pour télécharger ton iso Archlinux, la vraie, c'est ici:
https://www.archlinux.org/download/

Et pour l'installer correctement tu as le wiki ici:
https://wiki.archlinux.fr/Installation
https://wiki.archlinux.fr/Debuter

Avatar de l’utilisateur
liOnux
Hankyu
Messages : 41
Inscription : sam. 09 févr. 2019, 11:46
Localisation : Bordeaux

Re: [Wine] Ne fonctionne absolument pas et n'iinstalle rien du tout

Message par liOnux » sam. 01 juin 2019, 20:27

CoudUr confirme mes précédents écrits : Arch est peu conseillée pour les premiers pas sous Linux.
Mais à très bientôt 😉
OpenBox et noyau LTS sur un HP-ENVY 17" de 2014

Répondre