[xmms] Problèmes avec les lettres accentuées

Applications multimedia / jeux
Répondre
ggeykun
Hankyu
Messages : 13
Inscription : sam. 26 juin 2010, 16:37

[xmms] Problèmes avec les lettres accentuées

Message par ggeykun » dim. 21 nov. 2010, 22:18

Bonjour, j'utilise le lecteur XMMS car il est simple, rapide et efficace. Cependant, je rencontre un problème avec les lettres accentuées qui ne s'affichent pas correctement, que ce soient dans les menus que dans la liste de lecture.
J'ai déjà essayé de changer la police, mais rien n'y fait.
Je demande donc votre aide pour régler ce problème plutôt gênant !

Merci d'avance.

Avatar de l’utilisateur
ddup1
Chu Ko Nu
Messages : 338
Inscription : lun. 15 sept. 2008, 20:59
Localisation : Toulouse
Contact :

Re: [xmms] Problèmes avec les lettres accentuées

Message par ddup1 » lun. 22 nov. 2010, 13:30

A mon avis ce n'est pas un problème d'accent mais d'encodage.
Ton système est sans doute en UTF8 et je ne pense pas qu'xmms gère l'utf8 il n'est pas tout récent le petit.

A vérifier cependant.
Un clavier azerty en vaut deux :D
http://www.dupnet.org/dotclear/

Refuznik
Chu Ko Nu
Messages : 447
Inscription : dim. 22 nov. 2009, 17:06

Re: [xmms] Problèmes avec les lettres accentuées

Message par Refuznik » lun. 22 nov. 2010, 14:35

Si si c'est un problème d'accent étant donné que l'on a la même chose dans le menu déroulant et les options.

ggeykun
Hankyu
Messages : 13
Inscription : sam. 26 juin 2010, 16:37

Re: [xmms] Problèmes avec les lettres accentuées

Message par ggeykun » lun. 22 nov. 2010, 21:16

Bon, finalement, après avoir lu le message de ddup1, j'ai vu que XMMS est vraiment très vieux. J'ai donc décidé de passer à son successeur actuel, audacious qui lui supporte les accents, et donc l'UTF8 ;)
Désolé pour ce post.

Résolu :D

Avatar de l’utilisateur
mélodie
Maître du Kyudo
Messages : 2785
Inscription : lun. 30 oct. 2006, 02:06
Localisation : Pyrénées
Contact :

Re: [xmms] Problèmes avec les lettres accentuées

Message par mélodie » mar. 23 nov. 2010, 16:05

Salut,

Ce n'est pas résolu mais contourné. Et le xmms de Archlinux a un encodage à la noix, même dans un système bien configuré, alors que dans une autre distribution, l'encodage de xmms est tip top.

Xmms en pleine forme:Image

ggeykun
Hankyu
Messages : 13
Inscription : sam. 26 juin 2010, 16:37

Re: [xmms] Problèmes avec les lettres accentuées

Message par ggeykun » mar. 23 nov. 2010, 16:50

Oui c'est bizarre, parce que j'ai vérifié plusieurs fois l'encodage de ma distrib.
Et merci pour la précision, il est vrai que je n'ai fait que contourner le problème, mais audacious est vraiment cool et est surtout encore en développement.

Avatar de l’utilisateur
mélodie
Maître du Kyudo
Messages : 2785
Inscription : lun. 30 oct. 2006, 02:06
Localisation : Pyrénées
Contact :

Re: [xmms] Problèmes avec les lettres accentuées

Message par mélodie » mar. 23 nov. 2010, 17:44

Mon avis, xmms n'est plus en développement parce qu'il est abouti. Sur une de mes machines (portable Nec 160M, proc Celeron 1,46 ghz) Audacious ne fait pas merveille et plante assez souvent, alors que xmms fonctionne de manière fluide).

ggeykun
Hankyu
Messages : 13
Inscription : sam. 26 juin 2010, 16:37

Re: [xmms] Problèmes avec les lettres accentuées

Message par ggeykun » mar. 23 nov. 2010, 18:15

Je verrais à l'usage... Donc à votre avis, c'est le XMMS fourni par Archlinux qui serait codé avec les pieds en ce qui concerne l'encodage. La seule solution serait alors de trouver un autre dépôt ou de compiler à la main dans ce cas...

Avatar de l’utilisateur
mélodie
Maître du Kyudo
Messages : 2785
Inscription : lun. 30 oct. 2006, 02:06
Localisation : Pyrénées
Contact :

Re: [xmms] Problèmes avec les lettres accentuées

Message par mélodie » mar. 23 nov. 2010, 18:57

Il me semble que j'avais déjà essayé de le compiler à la main, et que le résultat avait été identique. Peut-être que en comparant un paquet Archlinux et un paquet PCLinuxOS (rpmextract pourrait être à l'œuvre) permettrait de découvrir ce qui est différent ?

Avatar de l’utilisateur
ddup1
Chu Ko Nu
Messages : 338
Inscription : lun. 15 sept. 2008, 20:59
Localisation : Toulouse
Contact :

Re: [xmms] Problèmes avec les lettres accentuées

Message par ddup1 » mar. 23 nov. 2010, 19:38

En effet c'est bizarre, ou alors ce sont les autres distrib qui patch xmms pour supporter l'utf8.

Sinon précision xmms n'est plus en developpement mais xmms2 l'est toujours, cependant ce sera plus un équivalent à mpd.
Un clavier azerty en vaut deux :D
http://www.dupnet.org/dotclear/

Avatar de l’utilisateur
karhu
Maître du Kyudo
Messages : 1112
Inscription : lun. 27 sept. 2010, 14:32
Localisation : Ile de France
Contact :

Re: [xmms] Problèmes avec les lettres accentuées

Message par karhu » mar. 23 nov. 2010, 19:50

Bonjour

J'ai recompilé xmms pour ma distribution Ubuntu Hardy et modifié un paquet de Dapper pour pouvoir l'installer, parce que j'aime moins xmms2. Dans les menus j'ai bien l'accentuation, mais pour les titres et les commentaires des fichiers, cela dépend surtout avec quel encodage ils ont été écrits.
Si tu es intéressé, je peux te le passer (2M), par contre il compilé i386 mais pas x86_64.

Karhu.
S'il n'y a pas de solution, c'est qu'il n'y a pas de problème.

ggeykun
Hankyu
Messages : 13
Inscription : sam. 26 juin 2010, 16:37

Re: [xmms] Problèmes avec les lettres accentuées

Message par ggeykun » mar. 23 nov. 2010, 21:25

C'est très gentil karhu, je veux bien que tu me le passes, même si je pense que je vais rester sous audacious s'il ne plante pas ;)
Mais à des fins de tests je veux bien :D
Envoie-le moi par MP.
Merci beaucoup ^^

Répondre