[alsa] headphone (résolu)

Applications multimedia / jeux
Répondre
Avatar de l’utilisateur
karhu
Maître du Kyudo
Messages : 1140
Inscription : lun. 27 sept. 2010, 14:32
Localisation : Ile de France
Contact :

[alsa] headphone (résolu)

Message par karhu » sam. 15 oct. 2011, 20:04

Parfait pour toi.
Maintenant je me retrouve dans ton cas, en pire !!!
Je ne me sers (théoriquement) pas de pulseaudio, mais pourtant dès que je veux écouter de la musique j'ai droit au silence.
je lance alsamixer et j'obtiens :
carte : pulseaudio et control juste master.
Je selectionne ma carte, fais les réglages et je sors par Esc.
Je relance alsamixer et plouf je retombe sur pulseaudio et juste control master.
Dans mon plugin j'ai bien ma bonne carte, mais comme toi, avant, plus de casque ! :evil:
J'ai fais un alsaconf, c'est pareil :evil:
Comment virer pulseaudio, que je n'ai pas installé ?
Comment sauver mes réglages avec alsactl puisque quand je sors d'alsamixer il n'en tiens pas compte ?
Karhu.
Dernière modification par karhu le dim. 13 nov. 2011, 19:48, modifié 3 fois.
S'il n'y a pas de solution, c'est qu'il n'y a pas de problème.

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10579
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [ALSA]Son Casque + Enceinte

Message par FoolEcho » sam. 15 oct. 2011, 20:16

karhu a écrit :Comment virer pulseaudio, que je n'ai pas installé ?
Impossible, forcément.

Que renvoient:

Code : Tout sélectionner

ps ax|grep pulse
pacman -Qs pulse
(pour ce dernier un libpulse n'est pas significatif)
«The following statement is not true. The previous statement is true.» :nage:

Avatar de l’utilisateur
karhu
Maître du Kyudo
Messages : 1140
Inscription : lun. 27 sept. 2010, 14:32
Localisation : Ile de France
Contact :

Re: [ALSA]Son Casque + Enceinte

Message par karhu » sam. 15 oct. 2011, 20:57

Code : Tout sélectionner

yaourt -Qs pulse
extra/libao 1.1.0-1
    A cross-platform audio output library and plugins
extra/libcanberra-pulse 0.28-2
    PulseAudio plugin for libcanberra
extra/libpulse 1.0-3
    A featureful, general-purpose sound server (client library)
extra/pulseaudio 1.0-3
    A featureful, general-purpose sound server
extra/pulseaudio-alsa 1-2 (pulseaudio-gnome)
    ALSA Configuration for PulseAudio

Code : Tout sélectionner

 ps ax | grep pulse
 1857 ?        S<l    0:01 /usr/bin/pulseaudio --start --log-target=syslog
 1860 ?        S      0:00 /usr/lib/pulse/gconf-helper
 2188 pts/0    S+     0:00 grep pulse
J'ai aussi remonté en partie qui a besoin de pulseaudio, et pour l'instant je suis arrivé à gdm.
Comme j'utilise slim, maintenant, je pensais (peut-être à tord) pouvoir virer tout ça.
Karhu.
S'il n'y a pas de solution, c'est qu'il n'y a pas de problème.

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10579
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [ALSA]Son Casque + Enceinte

Message par FoolEcho » sam. 15 oct. 2011, 21:15

Sinon, si tu es contraint de le garder, un simple:

Code : Tout sélectionner

pulseaudio --kill
devrait te ficher la paix.
«The following statement is not true. The previous statement is true.» :nage:

Avatar de l’utilisateur
karhu
Maître du Kyudo
Messages : 1140
Inscription : lun. 27 sept. 2010, 14:32
Localisation : Ile de France
Contact :

Re: [ALSA]Son Casque + Enceinte

Message par karhu » sam. 15 oct. 2011, 21:18

pendant ta réponse, c'est ce que j'ai voulu faire !

Code : Tout sélectionner

root # pulseaudio --kill
E: [pulseaudio] main.c: Impossible de tuer le démon : Aucun processus de ce type
root # ps ax | grep pulse
 1857 ?        S<l    0:01 /usr/bin/pulseaudio --start --log-target=syslog
 1860 ?        S      0:00 /usr/lib/pulse/gconf-helper
 2269 pts/3    R+     0:00 grep pulse
Karhu.

Edit: Pardon, mais si je le tue avec mon user (mais pas root !!!!), ça marche. :oops:
par contre pas de changement de comportement d'alsamixer.
S'il n'y a pas de solution, c'est qu'il n'y a pas de problème.

Avatar de l’utilisateur
karhu
Maître du Kyudo
Messages : 1140
Inscription : lun. 27 sept. 2010, 14:32
Localisation : Ile de France
Contact :

Re: [ALSA]Son Casque + Enceinte

Message par karhu » sam. 15 oct. 2011, 22:14

En fait c'était xfce qui lançait pulseaudio au démarrage et je suppose à chaque fois aussi que je lançais xmms même en tuant pulseaudio avant (et il continue le bougre).
Donc j'ai de a musique actuellement.
MAIS
- alsamixer continue son ciméma
- xmms ne passe plus à la chanson suivante (même en lui cochant le greffon) mais est bien sur tous les bureaux et relance pulseaudio !!!!!!!!!!!!!!!!
- audacious passe à la chanson suivante mais reste boqué sur un seul bureau, et utilise pulseaudio même si j'essaye de forcer alsa dans la configuration.

Cette situation est récente (une quinzaine de jours environ) pulseaudio a d'ailleurs été mis à jour le 4/10/11 y aurait il un rapport ? et xfce a subit aussi quelques mises à jour ?
Enfin j'ai de la musique à présent et je vais essayer d'y voir plus clair.
Au fait, je n'ai plus le réglage du casque avec xfce-plugin, mais j'ai quand même le son. Presque comme Ypnose au début. :lol:
Karhu.
S'il n'y a pas de solution, c'est qu'il n'y a pas de problème.

Avatar de l’utilisateur
karhu
Maître du Kyudo
Messages : 1140
Inscription : lun. 27 sept. 2010, 14:32
Localisation : Ile de France
Contact :

Re: [ALSA]Son Casque + Enceinte

Message par karhu » mar. 25 oct. 2011, 19:44

Bonjour
J'ai fini par virer pulseaudio (gdm, pulseaudio-alsa et gnome-settings-daemon).
Maintenant xmms passe bien à la chanson suivante et alsamixer a une meilleur tête.
Cependant headphone n'est toujours pas présent dans le plugin xfce-mixer, pourtant le casque fonctionne correctement et il coupe bien les enceintes (sauf que le réglage de la puissance n'est donc pas possible).
Karhu.
S'il n'y a pas de solution, c'est qu'il n'y a pas de problème.

Avatar de l’utilisateur
Ypnose
Maître du Kyudo
Messages : 1363
Inscription : sam. 01 mai 2010, 13:17
Contact :

Re: [ALSA]Son Casque + Enceinte

Message par Ypnose » mer. 26 oct. 2011, 10:55

As-tu le canal "Headphones" dans Alsamixer?

Avatar de l’utilisateur
karhu
Maître du Kyudo
Messages : 1140
Inscription : lun. 27 sept. 2010, 14:32
Localisation : Ile de France
Contact :

Re: [ALSA]Son Casque + Enceinte

Message par karhu » mer. 26 oct. 2011, 11:21

Oui pour alsamixer (00 vert).
Et oui il est coché dans xfce-mixer mais non il ne s'affiche pas (plus).
Karhu.
S'il n'y a pas de solution, c'est qu'il n'y a pas de problème.

Avatar de l’utilisateur
milouse
Hankyu
Messages : 24
Inscription : dim. 14 août 2011, 17:56
Localisation : Nantes
Contact :

Re: [alsa] headphone

Message par milouse » mar. 01 nov. 2011, 23:19

Alors je ne sais pas si ça va pouvoir t'aider, mais je viens de régler mon problème d'une manière à peu près satisfaisante \o/

En gros suite à l'installation de Gnome 3, PulseAudio s'est invité chez moi et depuis impossible de gérer correctement le son, même sous awesome. Si pulseaudio est kické, ben alsamixer refuse de s'ouvrir et si pulseaudio fonctionne, je n'avais par défaut qu'une vue toute pourrite avec un seul canal "master" et rien pour contrôler la sortie casque.

Et le graal est arrivé pour moi des forums Fedora-fr (comme quoi ;) faut toujours savoir regarder à droite et à gauche ^^). En gros l'installation de pulseaudio standard place un fichier /etc/asound.conf contenant :

Code : Tout sélectionner

# Use PulseAudio by default
pcm.!default {
  type pulse
}

ctl.!default {
  type pulse
}

# Explicit PulseAudio device
pcm.pulse {
  type pulse
}

ctl.pulse {
  type pulse
}
Et la magie a été de remplacer les deux premières catégories comme suit :

Code : Tout sélectionner

# Use PulseAudio by default
pcm.!default {
  type hw
  card 0
}

ctl.!default {
  type hw
  card 0
}

# Explicit PulseAudio device
pcm.pulse {
  type pulse
}

ctl.pulse {
  type pulse
}
La traduction, d'après ce que j'ai compris, c'est « utilise directement les ressources de la carte audio numéro 0 quand l'appli ne gère pas pulseaudio » d'où le

Code : Tout sélectionner

type hw
pour hardware suivi de

Code : Tout sélectionner

card 0
pour indiquer la carte son.

Et au redémarrage, la première vue toute pourrite avait disparu pour ne laisser que la vue que j'avais avant grâce à laquelle je peux gérer différents canaux. Seule ombre au tableau, je ne peux pas mettre le canal « Speaker » en mute sans faire taire tout le son (et donc le casque également). Si je ne veux du son que depuis le casque je dois baisser le volume de speaker à 0 mais le laisser en on. Pas trop compris pourquoi, mais « ça fait le job » donc j'arrête de chercher.

Ça peux t'aider ?

Edit: problème de bbcode

Avatar de l’utilisateur
karhu
Maître du Kyudo
Messages : 1140
Inscription : lun. 27 sept. 2010, 14:32
Localisation : Ile de France
Contact :

Re: [alsa] headphone

Message par karhu » mer. 02 nov. 2011, 10:05

La désinstallation de pulseaudio et de ses dépendances a du me supprimer aussi /etc/asound.conf car je ne l'ai plus. Je garderai quand même exemple de fichier asound.conf au cas où je serai améné à devoir utiliser pulseaudio. Merci @milouse.
Le problème n'est pas résolu, mais d'un autre coté il n'est pas non plus clairement identifié.
Xfce-mixer-plugin ? Alsa ? Pollution de pulseaudio ? J'ai envie de fermer ce post dans l'attente d'une meilleur identification, quelle raison de fermeture indiquée : suspendu, abandonné ... ?
S'il n'y a pas de solution, c'est qu'il n'y a pas de problème.

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10579
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [alsa] headphone

Message par FoolEcho » mer. 02 nov. 2011, 13:20

Question naïve: tu as vérifié dans xfce4-mixer que le contrôle du casque est bien coché ? :|
Si oui, ça ne donnera pas grand-chose à mon avis mais tu peux mettre de côté la configuration du mixer (~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-mixer.xml ) ou essayer avec un utilisateur test...

Sinon effectivement mettre le sujet en suspendu... en attendant (espérant) du neuf ? ...
«The following statement is not true. The previous statement is true.» :nage:

Avatar de l’utilisateur
karhu
Maître du Kyudo
Messages : 1140
Inscription : lun. 27 sept. 2010, 14:32
Localisation : Ile de France
Contact :

Re: [alsa] headphone

Message par karhu » mer. 02 nov. 2011, 13:53

La question n'est pas naïve mais hélas la réponse est oui.
Tu as raison je vais mettre en suspendu.
Je vais continuer à regarder seulement comme ce n'est pas bloquant mais plutôt dérangeant, je crains que mon ardeur s'estompe avec le temps. :mrgreen:
J'ai ressorti un vieux casque qui a un contrôle de volume intégré. :oops:
S'il n'y a pas de solution, c'est qu'il n'y a pas de problème.

Avatar de l’utilisateur
karhu
Maître du Kyudo
Messages : 1140
Inscription : lun. 27 sept. 2010, 14:32
Localisation : Ile de France
Contact :

Re: [alsa] headphone (suspendu)

Message par karhu » dim. 13 nov. 2011, 19:47

Suite à mes dernières mises à jour, tout est revenu comme avant. :mrgreen:
Je ne sais pas ce qui a été modifié dans les logiciels de xfce (ou autres ?) mais j'ai de nouveau le contrôle du casque dans xfce-mixer.
Je vais mettre ce post en résolu, mais je n'aime pas quand ça tombe en marche. :wink:
S'il n'y a pas de solution, c'est qu'il n'y a pas de problème.

Répondre