[Framebuffer] Fbsplash, Framebuffer, résolution (Adandonné)

Xorg, Compiz, KDE / Gnome / Xfce / Fluxbox / e17 / fvwm ... GDM/KDM/XDM...
Avatar de l’utilisateur
Xorg
Maître du Kyudo
Messages : 1930
Inscription : dim. 22 janv. 2012, 19:25
Localisation : Entre le clavier et la chaise.
Contact :

[Framebuffer] Fbsplash, Framebuffer, résolution (Adandonné)

Message par Xorg » dim. 02 déc. 2012, 10:36

Bonjour.

Après avoir cherché et encore cherché, je m'en remets à vous : Fbsplash ne s'affiche plus au démarrage.
J’utilise le pilote propriétaire Catalyst (fglrx) pour information.

Voici le contenu de mon /etc/default/grub :

Code : Tout sélectionner

GRUB_DEFAULT=0
GRUB_TIMEOUT=2
GRUB_DISTRIBUTOR="ArchLinux"
GRUB_CMDLINE_LINUX_DEFAULT="logo.nologo quiet console=tty1 loglevel=3 splash=silent,fadein,fadeout,theme:arch-black"
GRUB_CMDLINE_LINUX="quiet"

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable Hidden Menu, and optionally hide the timeout count
#GRUB_HIDDEN_TIMEOUT=5
#GRUB_HIDDEN_TIMEOUT_QUIET=true

# Uncomment to use basic console
#GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=1360x768

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter 
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx" 
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper 
# modes only.  Entries specified as foreground/background.
#GRUB_COLOR_NORMAL="light-blue/black"
#GRUB_COLOR_HIGHLIGHT="light-cyan/blue"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/path/to/wallpaper"
GRUB_THEME="/boot/grub/themes/starfield/theme.txt"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

#GRUB_SAVEDEFAULT="true"
De mon /etc/conf.d/splash :

Code : Tout sélectionner

#
# /etc/conf.d/splash
#

####  WARNING!
## This file is also sourced in the initcpio hook.
## No BASH-code (like arrays) is allowed here!

####  initcpio and Fbsplash daemon  ##########################################

## Themes to include into initcpio
## For a smaller initcpio you may try theme cfg files instead of directories.
SPLASH_THEMES="
    arch-black/1366x768.cfg
"

## Override the initial silent splash screen status message defaults.
## Note: '$progress' will be replaced by Fbsplash itself.
## * initcpio - (no effect with fbcondecor kernel)
SPLASH_INIT_MESSAGE="Initializing the kernel"
## * bootup
SPLASH_BOOT_MESSAGE="Booting '$HOSTNAME' (\$progress%)"
## * reboot
SPLASH_REBOOT_MESSAGE="Rebooting '$HOSTNAME' (\$progress%)"
## * shutdown
SPLASH_SHUTDOWN_MESSAGE="Shutting down '$HOSTNAME' (\$progress%)"

## Include and use the Fbsplash daemon (1.5 MiB) in the initcpio
## instead of the small helper only.
## Usefull to show animations early.
## Note: Themes with 'scripts/rc_init-pre' like 'arch-banner-icons' are
##       supported now if fbsplash-extras>=2.0.10 is installed, but there
##       might still be some sophisticated ones which break when using this.
SPLASH_DAEMON="early"

## Make the splash daemon use fade effects.
## Note: The initcpio helper does only use the kernel parameter!
# Just use fadein on bootup and fadeout on shutdown/reboot
case $PREVLEVEL in  N   ) SPLASH_EFFECTS="fadein" ; esac
case  $RUNLEVEL in [06] ) SPLASH_EFFECTS="fadeout"; esac
# Uncomment this line to allways use both
# SPLASH_EFFECTS="fadein,fadeout"

## Enable the textbox when starting the Fbsplash daemon.
## Useful if the theme provides a message log or other textbox.
## The scripts write any initscripts [FAIL] messages to the log.
## Note: The textbox can also be toggled by pressing F3-key.
SPLASH_TEXTBOX="yes"

## Splash progress timeout
## If set to a positive value, Fbsplash will automatically switch to verbose
## mode if there is no progress for the specified number of seconds.
SPLASH_AUTOVERBOSE=0

####  scripts behaviour  #####################################################

## Change to verbose mode on any initscripts [FAIL] message
## Useful with very simple themes and also when starting Xorg from DAEMONS
SPLASH_VERBOSE_ON_ERRORS="no"

## Name of the DAEMONS script starting Xorg if any
## Set this to avoid virtual terminal change struggle between X and Fbsplash.
#SPLASH_XSERVICE="gdm"
#SPLASH_XSERVICE="kdm"
#SPLASH_XSERVICE="xdm"
#SPLASH_XSERVICE="lxdm"
#SPLASH_XSERVICE="slim"

## Push initscripts [BUSY] messages to the splash status message line.
SPLASH_PUSH_MESSAGES="no"

# EOF #
Mes thèmes disponibles :

Code : Tout sélectionner

$ ls /etc/splash/arch-black
1024x600.cfg   1280x768.cfg   1440x1050.cfg  1920x1200.cfg  images
1024x768.cfg   1280x800.cfg   1440x900.cfg   2048x1080.cfg  metadata.xml
1152x720.cfg   1280x854.cfg   1440x960.cfg   2048x1536.cfg
1152x768.cfg   1280x960.cfg   1600x1200.cfg  768x576.cfg
1280x1024.cfg  1366x768.cfg   1680x1050.cfg  800x600.cfg
1280x720.cfg   1400x1050.cfg  1920x1080.cfg
De plus, il me semble qu'il y a une erreur au démarrage, mais je n'ai pas le temps de la voir.
Je crois qu'il ne trouve pas le fichier //etc/splash/arch-black/800x600.cfg (avec le double slash, hum).
Du coup, je ne sais pas quoi je dois regarder, ni comment je peux voir les logs concernés. :?

Merci d'avance. :)

EDIT : Changement de titre.
Dernière modification par Xorg le ven. 13 déc. 2013, 22:03, modifié 2 fois.
Arch Linux x86_64 - Gnome 3 (Wayland)
- Desktop : Intel® Core™ i5 2500K - 8Go de DDR3 - SSD 250Go + 2 HDD 500Go
- Laptop : Intel® Pentiuml® 4405U - 4Go de DDR4 - SSD 120Go
Image AUR___Image Wiki___Image GitHub
Tux est un manchot, et non un pingouin. :marche:

benjarobin
Maître du Kyudo
Messages : 15404
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Fbsplash] Ne fonctionne plus après le passage à Systemd

Message par benjarobin » dim. 02 déc. 2012, 10:59

Ceci est logique non ?
Comme tu utilises le driver propriétaire alors tu n'as pas KMS de lancé, donc la résolution est très faible.
Tu peux corriger ceci de 2 façons (il va peut être combiner les 2) :
- Utilisation de l'option vga=ask puis vga=0x... pour définir la résolution que tu désires
- Modification / génération du thème dans la bonne résolution
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
Xorg
Maître du Kyudo
Messages : 1930
Inscription : dim. 22 janv. 2012, 19:25
Localisation : Entre le clavier et la chaise.
Contact :

Re: [Fbsplash] Ne fonctionne plus après le passage à Systemd

Message par Xorg » dim. 02 déc. 2012, 13:42

J'utilise Grub 2. :)

Bon, j'ai modifié comme ceci mon /etc/default/grub :

Code : Tout sélectionner

GRUB_DEFAULT=0
GRUB_TIMEOUT=2
GRUB_DISTRIBUTOR="ArchLinux"
GRUB_CMDLINE_LINUX_DEFAULT="quiet vga=789 loglevel=3 console=tty1 splash=silent,fadein,fadeout,theme:arch-black"
GRUB_CMDLINE_LINUX="radeon.modeset=0"

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable Hidden Menu, and optionally hide the timeout count
#GRUB_HIDDEN_TIMEOUT=5
#GRUB_HIDDEN_TIMEOUT_QUIET=true

# Uncomment to use basic console
#GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=800x600x32

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter 
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx" 
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper 
# modes only.  Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-blue/black"
GRUB_COLOR_HIGHLIGHT="light-cyan/blue"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/path/to/wallpaper"
#GRUB_THEME="/boot/grub/themes/starfield/theme.txt"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

#GRUB_SAVEDEFAULT="true"
/etc/conf.d/splash :

Code : Tout sélectionner

#
# /etc/conf.d/splash
#

####  WARNING!
## This file is also sourced in the initcpio hook.
## No BASH-code (like arrays) is allowed here!

####  initcpio and Fbsplash daemon  ##########################################

## Themes to include into initcpio
## For a smaller initcpio you may try theme cfg files instead of directories.
SPLASH_THEMES="
    arch-black/800x600.cfg
"

## Override the initial silent splash screen status message defaults.
## Note: '$progress' will be replaced by Fbsplash itself.
## * initcpio - (no effect with fbcondecor kernel)
SPLASH_INIT_MESSAGE="Initializing the kernel"
## * bootup
SPLASH_BOOT_MESSAGE="Booting '$HOSTNAME' (\$progress%)"
## * reboot
SPLASH_REBOOT_MESSAGE="Rebooting '$HOSTNAME' (\$progress%)"
## * shutdown
SPLASH_SHUTDOWN_MESSAGE="Shutting down '$HOSTNAME' (\$progress%)"

## Include and use the Fbsplash daemon (1.5 MiB) in the initcpio
## instead of the small helper only.
## Usefull to show animations early.
## Note: Themes with 'scripts/rc_init-pre' like 'arch-banner-icons' are
##       supported now if fbsplash-extras>=2.0.10 is installed, but there
##       might still be some sophisticated ones which break when using this.
SPLASH_DAEMON="early"

## Make the splash daemon use fade effects.
## Note: The initcpio helper does only use the kernel parameter!
# Just use fadein on bootup and fadeout on shutdown/reboot
case $PREVLEVEL in  N   ) SPLASH_EFFECTS="fadein" ; esac
case  $RUNLEVEL in [06] ) SPLASH_EFFECTS="fadeout"; esac
# Uncomment this line to allways use both
SPLASH_EFFECTS="fadein,fadeout"

## Enable the textbox when starting the Fbsplash daemon.
## Useful if the theme provides a message log or other textbox.
## The scripts write any initscripts [FAIL] messages to the log.
## Note: The textbox can also be toggled by pressing F3-key.
SPLASH_TEXTBOX="yes"

## Splash progress timeout
## If set to a positive value, Fbsplash will automatically switch to verbose
## mode if there is no progress for the specified number of seconds.
SPLASH_AUTOVERBOSE=0

####  scripts behaviour  #####################################################

## Change to verbose mode on any initscripts [FAIL] message
## Useful with very simple themes and also when starting Xorg from DAEMONS
SPLASH_VERBOSE_ON_ERRORS="yes"

## Name of the DAEMONS script starting Xorg if any
## Set this to avoid virtual terminal change struggle between X and Fbsplash.
#SPLASH_XSERVICE="gdm"
#SPLASH_XSERVICE="kdm"
#SPLASH_XSERVICE="xdm"
#SPLASH_XSERVICE="lxdm"
#SPLASH_XSERVICE="slim"

## Push initscripts [BUSY] messages to the splash status message line.
SPLASH_PUSH_MESSAGES="no"

# EOF #
/etc/mkinitcpio.conf :

Code : Tout sélectionner

# vim:set ft=sh
# MODULES
# The following modules are loaded before any boot hooks are
# run.  Advanced users may wish to specify all system modules
# in this array.  For instance:
#     MODULES="piix ide_disk reiserfs"
MODULES="fglrx dm_mod raid0 raid1"

# BINARIES
# This setting includes any additional binaries a given user may
# wish into the CPIO image.  This is run first, so it may be used to
# override the actual binaries used in a given hook.
# (Existing files are NOT overwritten if already added)
# BINARIES are dependency parsed, so you may safely ignore libraries
BINARIES=""

# FILES
# This setting is similar to BINARIES above, however, files are added
# as-is and are not parsed in any way.  This is useful for config files.
# Some users may wish to include modprobe.conf for custom module options
# like so:
#    FILES="/etc/modprobe.d/modprobe.conf"
FILES="/etc/modprobe.d/modprobe.conf"

# HOOKS
# This is the most important setting in this file.  The HOOKS control the
# modules and scripts added to the image, and what happens at boot time.
# Order is important, and it is recommended that you do not change the
# order in which HOOKS are added.  Run 'mkinitcpio -H <hook name>' for
# help on a given hook.
# 'base' is _required_ unless you know precisely what you are doing.
# 'udev' is _required_ in order to automatically load modules
# 'filesystems' is _required_ unless you specify your fs modules in MODULES
# Examples:
##   This setup specifies all modules in the MODULES setting above.
##   No raid, lvm2, or encrypted root is needed.
#    HOOKS="base"
#
##   This setup will autodetect all modules for your system and should
##   work as a sane default
#    HOOKS="base udev autodetect pata scsi sata filesystems"
#
##   This is identical to the above, except the old ide subsystem is
##   used for IDE devices instead of the new pata subsystem.
#    HOOKS="base udev autodetect ide scsi sata filesystems"
#
##   This setup will generate a 'full' image which supports most systems.
##   No autodetection is done.
#    HOOKS="base udev pata scsi sata usb filesystems"
#
##   This setup assembles a pata mdadm array with an encrypted root FS.
##   Note: See 'mkinitcpio -H mdadm' for more information on raid devices.
#    HOOKS="base udev pata mdadm encrypt filesystems"
#
##   This setup loads an lvm2 volume group on a usb device.
#    HOOKS="base udev usb lvm2 filesystems"
#
##   NOTE: If you have /usr on a separate partition, you MUST include the
#    fsck and shutdown hooks.
HOOKS="base udev fbsplash autodetect sata mdadm filesystems usbinput fsck"

# COMPRESSION
# Use this to compress the initramfs image. With kernels earlier than
# 2.6.30, only gzip is supported, which is also the default. Newer kernels
# support gzip, bzip2 and lzma. Kernels 2.6.38 and later support xz
# compression.
#COMPRESSION="gzip"
#COMPRESSION="bzip2"
#COMPRESSION="lzma"
#COMPRESSION="xz"
#COMPRESSION="lzop"

# COMPRESSION_OPTIONS
# Additional options for the compressor
#COMPRESSION_OPTIONS=""
/etc/modprobe.d/modprobe.conf :

Code : Tout sélectionner

options radeon modeset=0
J'ai réinstallé Fbsplash. Au final maintenant j'ai bien le splash qui apparait, mais il reste bloqué sur "Initialing the kernel", et il ne va pas sur mon tty1 automatiquement. :?
Arch Linux x86_64 - Gnome 3 (Wayland)
- Desktop : Intel® Core™ i5 2500K - 8Go de DDR3 - SSD 250Go + 2 HDD 500Go
- Laptop : Intel® Pentiuml® 4405U - 4Go de DDR4 - SSD 120Go
Image AUR___Image Wiki___Image GitHub
Tux est un manchot, et non un pingouin. :marche:

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10508
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [Fbsplash] Ne fonctionne plus après le passage à Systemd

Message par FoolEcho » dim. 02 déc. 2012, 14:05

Regarde avec F2 ce qui coince ?
«The following statement is not true. The previous statement is true.» :nage:

Avatar de l’utilisateur
Xorg
Maître du Kyudo
Messages : 1930
Inscription : dim. 22 janv. 2012, 19:25
Localisation : Entre le clavier et la chaise.
Contact :

Re: [Fbsplash] Ne fonctionne plus après le passage à Systemd

Message par Xorg » dim. 02 déc. 2012, 14:43

Il y a rien qui coince, ça démarre normalement. Juste Fbsplash qui pose soucis. :?
Il faut que j'essaie de repartir sur quelque chose de propre.
Arch Linux x86_64 - Gnome 3 (Wayland)
- Desktop : Intel® Core™ i5 2500K - 8Go de DDR3 - SSD 250Go + 2 HDD 500Go
- Laptop : Intel® Pentiuml® 4405U - 4Go de DDR4 - SSD 120Go
Image AUR___Image Wiki___Image GitHub
Tux est un manchot, et non un pingouin. :marche:

Avatar de l’utilisateur
Xorg
Maître du Kyudo
Messages : 1930
Inscription : dim. 22 janv. 2012, 19:25
Localisation : Entre le clavier et la chaise.
Contact :

Re: [Framebuffer] Fbsplash, Framebuffer et résolution.

Message par Xorg » ven. 28 déc. 2012, 14:37

Je remonte le sujet, je pense avoir localisé le soucis, je pense que c'est un problème de Framebuffer !

J'ai donc suivi la page du wiki (En) ici. Je le reprends pour vous montrer ce que j'ai fait :

Code : Tout sélectionner

$ pacman -Qs v86d
local/v86d 0.1.10-4
    userspace helper for uvesafb that runs x86 code in an emulated environment

Code : Tout sélectionner

$ cat /etc/default/grub
GRUB_DEFAULT=0
GRUB_TIMEOUT=1
GRUB_DISTRIBUTOR="Arch"
GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=/dev/md1 nomodeset  console=tty1 splash=silent,theme:arch-black"
GRUB_CMDLINE_LINUX=""

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable Hidden Menu, and optionally hide the timeout count
#GRUB_HIDDEN_TIMEOUT=5
#GRUB_HIDDEN_TIMEOUT_QUIET=true

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=1920x1080x32

# Uncomment to allow the kernel use the same resolution used by grub
#GRUB_GFXPAYLOAD_LINUX=1920x1080x32

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter 
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx" 
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper 
# modes only.  Entries specified as foreground/background.
#GRUB_COLOR_NORMAL="light-blue/black"
#GRUB_COLOR_HIGHLIGHT="light-cyan/blue"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/path/to/wallpaper"
GRUB_THEME="/boot/grub/themes/Archlinux/theme.txt"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

#GRUB_SAVEDEFAULT="true"

Code : Tout sélectionner

$ cat /etc/mkinitcpio.conf | grep FILES && cat /etc/mkinitcpio.conf | grep HOOK
# FILES
FILES="/etc/modprobe.d/uvesafb.conf"
# HOOKS
HOOKS="base udev v86d fbsplash keymap fsck autodetect block usbinput mdadm resume filesystems"

Code : Tout sélectionner

$ cat /usr/lib/modprobe.d/uvesafb.conf
#
# This file sets the parameters for uvesafb module.
# The following format should be used:
# options uvesafb mode=<xres>x<yres>[-<bpp>][@<refresh>] scroll=<ywrap|ypan|redraw> ...
#
# For more details see:
# http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=blob;f=Documentation/fb/uvesafb.txt
#
 
options uvesafb mode_option=1920x1080-32 scroll=ywrap
Et j'ai bien reconstruit les initramfs. :)

Après reboot, j'ai fait :

Code : Tout sélectionner

$ cat /sys/bus/platform/drivers/uvesafb/uvesafb.0/vbe_modes
cat: /sys/bus/platform/drivers/uvesafb/uvesafb.0/vbe_modes: Aucun fichier ou dossier de ce type

Code : Tout sélectionner

$ cat /sys/devices/virtual/graphics/fbcon/subsystem/fb0/virtual_size
800,600

Code : Tout sélectionner

$ cat /sys/class/graphics/fb0/virtual_size
800,600
Pendant le boot, j'ai un message d'erreur qui concerne Uvesafb :

Code : Tout sélectionner

uvesafb: cannot reserve video memory at 0xe0000000
En complément :

Code : Tout sélectionner

# fbset -i

mode "800x600-75"
    # D: 48.001 MHz, H: 46.876 kHz, V: 75.121 Hz
    geometry 800 600 800 600 32
    timings 20833 96 32 16 4 96 4
    rgba 8/16,8/8,8/0,8/24
endmode

Frame buffer device information:
    Name        : EFI VGA
    Address     : 0xe0000000
    Size        : 1966080
    Type        : PACKED PIXELS
    Visual      : TRUECOLOR
    XPanStep    : 0
    YPanStep    : 0
    YWrapStep   : 0
    LineLength  : 3200
    Accelerator : No
En gros, je suis coincé en 800x600, alors que ma carte-graphique et mon écran supportent bel et bien le 1920x1080 maximum. :?

Merci d'avance à ceux qui ont des pistes, là je sèche.
Arch Linux x86_64 - Gnome 3 (Wayland)
- Desktop : Intel® Core™ i5 2500K - 8Go de DDR3 - SSD 250Go + 2 HDD 500Go
- Laptop : Intel® Pentiuml® 4405U - 4Go de DDR4 - SSD 120Go
Image AUR___Image Wiki___Image GitHub
Tux est un manchot, et non un pingouin. :marche:

benjarobin
Maître du Kyudo
Messages : 15404
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Framebuffer] Fbsplash, Framebuffer et résolution.

Message par benjarobin » ven. 28 déc. 2012, 15:28

Attention ne pas confondre framebuffer et le reste... Il y a de très forte chance que ta carte ne supporte pas plus de 800*600 en framebuffer...
Sur mon PC fixe je suis coincé en 1024x768 alors que Xorg est bien en 1920x1080

Et j'avais essayé v86d et cela n’apportai pas de solution non plus :-)

As tu essayé sans v86d et avec l'option vga=ask ? Cela ne te propose pas une résolution un peu meilleur ? (Tu peux déjà oublier 1920x1080, ce n'est pas possible, ou alors si quelqu’un connait une astuce je suis preneur)
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
Xorg
Maître du Kyudo
Messages : 1930
Inscription : dim. 22 janv. 2012, 19:25
Localisation : Entre le clavier et la chaise.
Contact :

Re: [Framebuffer] Fbsplash, Framebuffer et résolution.

Message par Xorg » ven. 28 déc. 2012, 16:09

J'ai viré v86d de l'initramfs, j'ai ajouté vga=ask dans Grub avant le boot, mais c'est pareil. :?

EDIT : Le problème est abandonné.
Dernière modification par Xorg le ven. 13 déc. 2013, 22:03, modifié 1 fois.
Arch Linux x86_64 - Gnome 3 (Wayland)
- Desktop : Intel® Core™ i5 2500K - 8Go de DDR3 - SSD 250Go + 2 HDD 500Go
- Laptop : Intel® Pentiuml® 4405U - 4Go de DDR4 - SSD 120Go
Image AUR___Image Wiki___Image GitHub
Tux est un manchot, et non un pingouin. :marche:

benjarobin
Maître du Kyudo
Messages : 15404
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Framebuffer] Fbsplash, Framebuffer et résolution.

Message par benjarobin » ven. 28 déc. 2012, 17:56

Cela ne peut pas être pareil ! vga=ask te demande la résolution que tu désires, donc il y a forcément un changement !
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Répondre