[CTKArch] Problème de déconnexion (résolu)

Xorg, Compiz, KDE / Gnome / Xfce / Fluxbox / e17 / fvwm ... GDM/KDM/XDM...
Tatsuya
yeomen
Messages : 281
Inscription : ven. 28 janv. 2011, 15:58

[CTKArch] Problème de déconnexion (résolu)

Message par Tatsuya » lun. 07 mars 2011, 19:32

Tiens, voilà encore un problème à régler:

sous CTK, depuis que je suis passé sous compiz en wm, quand je tente de relancer ou éteindre la machine rien ne se passe.

J'ai donc lancé la commande qui ... commande ces actions que l'on peut trouver dans le fichier de config de fbpanel et j'obtiens ceci:

Code : Tout sélectionner

# dbus-send --system --print-reply --dest="org.freedesktop.ConsoleKit" /org/freedesktop/ConsoleKit/Manager org.freedesktop.ConsoleKit.Manager.Restart

Error org.freedesktop.ConsoleKit.Manager.NotPrivileged: Not Authorized
C'est quand même navrant: sous openbox, il ne fait pas de manières, mais là il me demande d'être root!! Que faire??
Dernière édition par Tatsuya le jeu. 10 mars 2011, 13:14, édité 1 fois.

Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 15216
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [CTKArch] Problème de déconnexion (en cours)

Message par benjarobin » lun. 07 mars 2011, 19:45

Tu lances comment Compiz ?
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Tatsuya
yeomen
Messages : 281
Inscription : ven. 28 janv. 2011, 15:58

Re: [CTKArch] Problème de déconnexion (en cours)

Message par Tatsuya » lun. 07 mars 2011, 19:49

Code : Tout sélectionner

exec ck-launch-session fusion-icon
Faut que je rajoute dbus-launch ?

EDIT: j'ai essayé avec dbus-launch et ça ne marche pas^^

Tatsuya
yeomen
Messages : 281
Inscription : ven. 28 janv. 2011, 15:58

Re: [CTKArch] Problème de déconnexion (en cours)

Message par Tatsuya » mar. 08 mars 2011, 12:21

Je viens de regarder plus en détail mon xinitrc (qui est plutôt élaboré de base sous CTK, Calimero est un hacker de rc dans l'âme :P) et j'ai ça:

Code : Tout sélectionner

# D-bus session
if which dbus-launch >/dev/null && test -z "$DBUS_SESSION_BUS_ADDRESS"; then
       eval `dbus-launch --sh-syntax --exit-with-session`
fi
Donc grâce à ça normalement pas besoin de dbus-launch dans la ligne exec xxx-session.

Bizarre que les commandes de déconnexion ne marchent plus du coup... à moins que ce morceau de script ne soit bon que pour Openbox, mais je ne penses pas.

De plus, le montage depuis n'importe quel navigateur de fichiers (nautilus, pcmanfm...) ne se fait qu'en root, et je penses que c'est lié avec mon problème de déconnexion qui ne se fait elle même qu'en root.

Mon nom d'utilisateur est dans les groupes "storage" et "power" pourtant. J'ai du mal à suivre, ça pourrait être si simple ^^

Tatsuya
yeomen
Messages : 281
Inscription : ven. 28 janv. 2011, 15:58

Re: [CTKArch] Problème de déconnexion (en cours)

Message par Tatsuya » jeu. 10 mars 2011, 13:13

Bon, pour ceux que ça interesse, la réponse est dans cette page: il faut avoir mis à jour en commentant le dépot ARM.

http://ctkarch.org/forum/viewtopic.php?id=2&t_id=2

Répondre