[Wifi] Lenteur depuis kernel 2.6.38 (résolu)

Applications, problèmes de configuration réseau
benjarobin
Maître du Kyudo
Messages : 15446
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

[Wifi] Lenteur depuis kernel 2.6.38 (résolu)

Message par benjarobin » mar. 12 avr. 2011, 23:18

Bonjour,

Je viens de mettre à jour mes 2 PC sous ArchLinux qui sont tous les 2 connectés en wifi.
Mon PC fixe possède cette carte :

Code : Tout sélectionner

0a:02.0 Network controller: Atheros Communications Inc. AR922X Wireless Network Adapter (rev 01)
Tandis que mon PC portable :

Code : Tout sélectionner

03:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
Donc en faite c'est la même puce ou presque :D (je viens tout juste de le découvrir...)

Code : Tout sélectionner

lsmod | grep -i ath
ath9k                  72310  0 
mac80211              178372  1 ath9k
ath9k_common            1433  1 ath9k
ath9k_hw              249396  2 ath9k,ath9k_common
ath                    10929  2 ath9k,ath9k_hw
cfg80211              120401  3 ath9k,mac80211,ath
Et au surprise depuis la mise à jour de 2.6.37.5-1 => 2.6.38 ma connexion Wifi est très lente, 50-200 Ko/s alors que d’habitude c'est de l'ordre de 900Ko/s
Donc je downgrade et je retrouve de suite la vitesse d'origine

Merci...

Voila le résultat de mes recherches :

http://aptosid.com/index.php?name=PNphp ... pic&p=6499
https://bbs.archlinux.org/viewtopic.php?id=115173
https://bugs.launchpad.net/archlinux/+s ... bug/735171
https://bugzilla.redhat.com/show_bug.cgi?id=682561

=> https://bugzilla.kernel.org/show_bug.cgi?id=31452
=> https://bugs.archlinux.org/task/23743

La solution de contournement :

Code : Tout sélectionner

echo "options ath9k nohwcrypt=1" > /etc/modprobe.d/ath9k.conf
Résolu avec la version 2.6.38.6 du kernel
Dernière modification par benjarobin le jeu. 12 mai 2011, 22:56, modifié 5 fois.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
Ypnose
Maître du Kyudo
Messages : 1363
Inscription : sam. 01 mai 2010, 13:17
Contact :

Re: [Wifi] Lenteur depuis kernel 2.6.38 (en cours)

Message par Ypnose » mer. 13 avr. 2011, 01:28

As tu essayé avec le 2.6.37.6 disponible ici: http://dev.archlinux.org/~tpowa/kernel26-2.6.37/

Envoie ton retour :)

benjarobin
Maître du Kyudo
Messages : 15446
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Wifi] Lenteur depuis kernel 2.6.38 (en cours)

Message par benjarobin » mer. 13 avr. 2011, 08:53

J'ai un peu du mal a comprendre pourquoi tu me demande d'essayer un kernel en .37 (certes un peu plus récent que le mien), le .37 fonctionne très bien, mais le .38 non.
Le sujet est plus pour faire une remontée d'information rapide avant rapport de bug
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
Wisthler
Hankyu
Messages : 36
Inscription : lun. 23 mars 2009, 09:40
Localisation : Belgique, Ciney

Re: [Wifi] Lenteur depuis kernel 2.6.38 (en cours)

Message par Wisthler » mer. 13 avr. 2011, 09:37

Histoire de compléter les informations, j'ai une carte wifi similaire :

Code : Tout sélectionner

01:00.0 Network controller: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) (rev 01)
et la même valeur dans lsmod :

Code : Tout sélectionner

lsmod | grep -i ath
ath9k                  72310  0 
mac80211              178372  1 ath9k
ath9k_common            1433  1 ath9k
ath9k_hw              249396  2 ath9k,ath9k_common
ath                    10929  2 ath9k,ath9k_hw
cfg80211              120401  3 ath9k,mac80211,ath
J'ai le kernel 2.6.38 depuis hier soir. J'ai utilisé le wifi ce matin pour du web, je n'ai pas vu de lenteur. J'ai pas accès à un wifi au boulot, je testerai le débit au soir en rentrant.
« Si la matière grise était plus rose, le monde aurait moins les idées noires »

benjarobin
Maître du Kyudo
Messages : 15446
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Wifi] Lenteur depuis kernel 2.6.38 (en cours)

Message par benjarobin » mer. 13 avr. 2011, 09:44

Attention suite à la lecture des rapport de bug (Que j'ai mis dans le premier post), cela n'arrive qu'avec une connexion 802.11n. Donc si tu es toujours en 802.11g tu n'auras pas de problème.
Sinon ce n'est pas que des lenteur il arrive que naviguer sur internet soit totalement impossible.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
Wisthler
Hankyu
Messages : 36
Inscription : lun. 23 mars 2009, 09:40
Localisation : Belgique, Ciney

Re: [Wifi] Lenteur depuis kernel 2.6.38 (en cours)

Message par Wisthler » mer. 13 avr. 2011, 12:18

Je suis en 802.11g donc ça répond à la question en ce qui me concerne
« Si la matière grise était plus rose, le monde aurait moins les idées noires »

JohnyJohn
newbie
Messages : 6
Inscription : mer. 14 juil. 2010, 00:46

Re: [Wifi] Lenteur depuis kernel 2.6.38 (en cours)

Message par JohnyJohn » ven. 15 avr. 2011, 23:57

Même problème avec ath9k et un kernel 2.6.38, un débit 10 fois inférieur à ce qu'il était en temps normal.

La solution se trouvait dans les tickets d'incident ouverts à ce propos ou encore sur le forum d'archlinux.org :
Pour éviter à d'autre de devoir fouiller, voici ce qui met le souci de côté :

Créer un fichier /etc/modprobe.d/ath9k.conf avec le contenu suivant :

Code : Tout sélectionner

options ath9k nohwcrypt=1

benjarobin
Maître du Kyudo
Messages : 15446
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Wifi] Lenteur depuis kernel 2.6.38 (en cours)

Message par benjarobin » sam. 16 avr. 2011, 00:27

Ce n'est pas comme si j'avais mis tous les liens expliquant cela dans le premier post :D , mais c'est vrai j'aurais pu mettre cette solution qui n'est que temporaire je le rappel :copain:
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Répondre