[pm-suspend] : resume impossible depuis dernière mise à jour

Applications, problèmes de configuration réseau
skai
Hankyu
Messages : 32
Inscription : lun. 11 mai 2009, 08:47

[pm-suspend] : resume impossible depuis dernière mise à jour

Message par skai » mer. 13 avr. 2011, 23:28

Bonjour !

Après une semaine mouvementée (dont de nombreux allers/retours à la maternité ;-) )
j'ai fait un "pacman -Syu" sans trop regarder ce qui se passait.

(mon dernier pacman -Syu datait en réalité du 26 mars).

Depuis : si je fais une mise en veille, lors du retour de veille,
ça coince.
Ca commence bien avec "décompression de l'image", le petit compteur de pourcentage qui s'incrémente...
Ca progresse bien jusqu'au message "desactivation des consoles, use no_console_machin_chouette to debug" (je ne sais lus exactement la tête du msg)

Et là : mes diodes "Ver Maj" et "Disque Dur" sont toutes les deux allumées et clignotent,
et pus rien,
et reboot forcé.

J'ai regardé si il y avait eu du neuf, revérifié ma conf pm-utils (le "resume" dans les hooks, mkinitcpio refait dans la foulée juste au cas où...) rien trouvé.

Je sèche.

Dans la liste des packages upgradés, en gros morceau y a le kernel, je n'ai rien vu de "suspect" par ailleurs.


au cas où je mes ici la liste tirée du pacman.log.

Pas spécialement vu d'autre anomalie dans les logs ... ptet faudrait justemen active cette histoire de "debug" pour ne pas desactiver les consoles au resume ? si seulement je savais comment faire.


Quoi qu'il en soit : AU SECOURS !

merci d'avance

Code : Tout sélectionner

a[2011-04-13 14:26] Running 'pacman -Sy'
[2011-04-13 14:26] synchronizing package lists
[2011-04-13 14:27] Running 'pacman -S -u'
[2011-04-13 14:27] starting full system upgrade
[2011-04-13 14:35] upgraded gstreamer0.10-base (0.10.32-2 -> 0.10.32-4)
[2011-04-13 14:35] upgraded libdrm (2.4.23-2 -> 2.4.25-1)
[2011-04-13 14:35] upgraded libgpg-error (1.9-2 -> 1.9-3)
[2011-04-13 14:35] upgraded libgcrypt (1.4.6-1 -> 1.4.6-2)
[2011-04-13 14:35] upgraded xkeyboard-config (2.1-1 -> 2.2.1-1)
[2011-04-13 14:35] upgraded xorg-server-common (1.9.4.901-1 -> 1.10.0.902-1)
[2011-04-13 14:35] upgraded xf86-input-evdev (2.6.0-2 -> 2.6.0-3)
[2011-04-13 14:35] upgraded xorg-server (1.9.4.901-1 -> 1.10.0.902-1)
[2011-04-13 14:35] upgraded nvidia-utils (270.30-1 -> 270.41.03-1)
[2011-04-13 14:35] upgraded wxgtk (2.8.11-2 -> 2.8.12-1)
[2011-04-13 14:35] upgraded audacity (1.3.12-3 -> 1.3.13-1)
[2011-04-13 14:35] upgraded avahi (0.6.29-1 -> 0.6.30-1)
[2011-04-13 14:35] upgraded xproto (7.0.20-1 -> 7.0.21-1)
[2011-04-13 14:35] upgraded libx11 (1.4.2-1 -> 1.4.3-2)
[2011-04-13 14:35] upgraded consolekit (0.4.3-2 -> 0.4.3-3)
[2011-04-13 14:35] upgraded crda (1.1.1-1 -> 1.1.1-3)
[2011-04-13 14:35] upgraded dhcpcd (5.2.11-1 -> 5.2.12-1)
[2011-04-13 14:35] upgraded eventlog (0.2.12-1 -> 0.2.12-2)
[2011-04-13 14:35] upgraded xvidcore (1.3.0-1 -> 1.3.1-1)
[2011-04-13 14:35] upgraded x264 (20110115-1 -> 20110327-1)
[2011-04-13 14:35] upgraded xextproto (7.1.2-1 -> 7.2.0-1)
[2011-04-13 14:35] upgraded fixesproto (4.1.2-1 -> 5.0-1)
[2011-04-13 14:35] upgraded libxfixes (4.0.5-1 -> 5.0-1)
[2011-04-13 14:35] upgraded libva (1.0.8-1 -> 1.0.12-1)
[2011-04-13 14:35] upgraded ffmpeg (20110121-2 -> 20110330-1)
[2011-04-13 14:35] warning: /etc/gshadow installed as /etc/gshadow.pacnew
[2011-04-13 14:35] warning: /etc/profile installed as /etc/profile.pacnew
[2011-04-13 14:35] warning: /etc/group installed as /etc/group.pacnew
[2011-04-13 14:35] upgraded filesystem (2010.12-1 -> 2011.04-1)
[2011-04-13 14:35] upgraded gdm (2.32.0-5 -> 2.32.1-1)
[2011-04-13 14:35] upgraded libtiff (3.9.4-1 -> 3.9.5-1)
[2011-04-13 14:35] upgraded ghostscript (9.01-1 -> 9.02-1)
[2011-04-13 14:35] upgraded giflib (4.1.6-3 -> 4.1.6-4)
[2011-04-13 14:35] upgraded libtasn1 (2.8-1 -> 2.9-1)
[2011-04-13 14:35] upgraded gnutls (2.10.5-1 -> 2.12.2-1)
[2011-04-13 14:35] upgraded gstreamer0.10-bad (0.10.21-2 -> 0.10.21-3)
[2011-04-13 14:35] upgraded libdc1394 (2.1.2-2 -> 2.1.3-1)
[2011-04-13 14:35] upgraded gstreamer0.10-bad-plugins (0.10.21-2 -> 0.10.21-3)
[2011-04-13 14:35] upgraded libthai (0.1.14-1 -> 0.1.15-1)
[2011-04-13 14:35] upgraded pango (1.28.3-1 -> 1.28.4-2)
[2011-04-13 14:35] upgraded gstreamer0.10-base-plugins (0.10.32-2 -> 0.10.32-4)
[2011-04-13 14:35] upgraded gstreamer0.10-good (0.10.27-2 -> 0.10.28-1)
[2011-04-13 14:35] upgraded taglib (1.6.3-1 -> 1.7-1)
[2011-04-13 14:36] upgraded gstreamer0.10-good-plugins (0.10.27-2 -> 0.10.28-1)
[2011-04-13 14:36] upgraded gstreamer0.10-ugly (0.10.17-1 -> 0.10.17-2)
[2011-04-13 14:36] upgraded gstreamer0.10-ugly-plugins (0.10.17-1 -> 0.10.17-2)
[2011-04-13 14:36] upgraded hwdetect (2010.08-1 -> 2011.03-1)
[2011-04-13 14:36] upgraded xz (5.0.1-1 -> 5.0.2-1)
[2011-04-13 14:36] upgraded imagemagick (6.6.8.5-1 -> 6.6.9.4-1)
[2011-04-13 14:36] >>> Updating module dependencies. Please wait ...
[2011-04-13 14:36] >>> MKINITCPIO SETUP
[2011-04-13 14:36] >>> ----------------
[2011-04-13 14:36] >>> If you use LVM2, Encrypted root or software RAID,
[2011-04-13 14:36] >>> Ensure you enable support in /etc/mkinitcpio.conf .
[2011-04-13 14:36] >>> More information about mkinitcpio setup can be found here:
[2011-04-13 14:36] >>> http://wiki.archlinux.org/index.php/Mkinitcpio
[2011-04-13 14:36] 
[2011-04-13 14:36] >>> Generating initial ramdisk, using mkinitcpio.  Please wait...
[2011-04-13 14:36] ==> Building image "default"
[2011-04-13 14:36] ==> Running command: /sbin/mkinitcpio -k 2.6.38-ARCH -c /etc/mkinitcpio.conf -g /boot/kernel26.img
[2011-04-13 14:36] :: Begin build
[2011-04-13 14:36] :: Parsing hook [base]
[2011-04-13 14:36] :: Parsing hook [udev]
[2011-04-13 14:36] :: Parsing hook [autodetect]
[2011-04-13 14:36] :: Parsing hook [pata]
[2011-04-13 14:36] :: Parsing hook [scsi]
[2011-04-13 14:36] :: Parsing hook [sata]
[2011-04-13 14:36] :: Parsing hook [usbinput]
[2011-04-13 14:36] :: Parsing hook [keymap]
[2011-04-13 14:36] :: Parsing hook [resume]
[2011-04-13 14:36] :: Parsing hook [filesystems]
[2011-04-13 14:36] :: Generating module dependencies
[2011-04-13 14:36] :: Generating image '/boot/kernel26.img'...SUCCESS
[2011-04-13 14:36] ==> SUCCESS
[2011-04-13 14:36] ==> Building image "fallback"
[2011-04-13 14:36] ==> Running command: /sbin/mkinitcpio -k 2.6.38-ARCH -c /etc/mkinitcpio.conf -g /boot/kernel26-fallback.img -S autodetect
[2011-04-13 14:36] :: Begin build
[2011-04-13 14:36] :: Parsing hook [base]
[2011-04-13 14:36] :: Parsing hook [udev]
[2011-04-13 14:36] :: Parsing hook [pata]
[2011-04-13 14:36] :: Parsing hook [scsi]
[2011-04-13 14:37] :: Parsing hook [sata]
[2011-04-13 14:37] :: Parsing hook [usbinput]
[2011-04-13 14:37] :: Parsing hook [keymap]
[2011-04-13 14:37] :: Parsing hook [resume]
[2011-04-13 14:37] :: Parsing hook [filesystems]
[2011-04-13 14:37] :: Generating module dependencies
[2011-04-13 14:37] :: Generating image '/boot/kernel26-fallback.img'...SUCCESS
[2011-04-13 14:37] ==> SUCCESS
[2011-04-13 14:37] upgraded kernel26 (2.6.37.4-1 -> 2.6.38.2-1)
[2011-04-13 14:37] upgraded libbonobo (2.32.0-1 -> 2.32.1-1)
[2011-04-13 14:37] upgraded libbonoboui (2.24.4-1 -> 2.24.5-1)
[2011-04-13 14:38] upgraded libburn (1.0.4.pl00-1 -> 1.0.6.pl00-1)
[2011-04-13 14:38] upgraded libisofs (1.0.4-1 -> 1.0.6-1)
[2011-04-13 14:38] upgraded libmysqlclient (5.5.10-2 -> 5.5.11-1)
[2011-04-13 14:38] upgraded libproxy (0.4.6-4 -> 0.4.6-6)
[2011-04-13 14:38] upgraded startup-notification (0.10-1 -> 0.10-2)
[2011-04-13 14:38] upgraded libxfcegui4 (4.8.1-1 -> 4.8.1-2)
[2011-04-13 14:38] installed libirman (0.4.5-2)
[2011-04-13 14:38] upgraded lirc-utils (0.9.0.pre1-2 -> 1:0.9.0-2)
[2011-04-13 14:38] upgraded lm_sensors (3.2.0-1 -> 3.3.0-1)
[2011-04-13 14:38] upgraded mdadm (3.1.4-1 -> 3.2.1-1)
[2011-04-13 14:38] upgraded mesa (7.10.1-1 -> 7.10.2-2)
[2011-04-13 14:38] upgraded mlocate (0.23.1-2 -> 0.24-1)
[2011-04-13 14:38] installed keyutils (1.4-1)
[2011-04-13 14:38] installed cifs-utils (4.9-2)
[2011-04-13 14:38] upgraded tdb (1.2.1-2 -> 1.2.9-1)
[2011-04-13 14:38] upgraded talloc (2.0.1-1 -> 2.0.5-1)
[2011-04-13 14:38] upgraded smbclient (3.5.8-1 -> 3.5.8-2)
[2011-04-13 14:38] upgraded mplayer (32792-3 -> 33159-1)
[2011-04-13 14:38] installed xorg-xset (1.2.1-2)
[2011-04-13 14:38] upgraded xdg-utils (1.1.0rc1-1 -> 1.1.0rc1-2)
[2011-04-13 14:38] upgraded qt (4.7.2-5 -> 4.7.2-6)
[2011-04-13 14:38] 
[2011-04-13 14:38] ==> Set the SuperUser password with (as root):
[2011-04-13 14:38] ==>   murmurd -ini /etc/murmur.ini -supw PASSWORD
[2011-04-13 14:38] upgraded murmur (1.2.3-1 -> 1.2.3-3)
[2011-04-13 14:38] upgraded ncurses (5.8-1 -> 5.9-1)
[2011-04-13 14:38] upgraded ntp (4.2.6.p3-1 -> 4.2.6.p3-3)
[2011-04-13 14:38] ERROR: Module nvidia is in use
[2011-04-13 14:38] In order to use the new nvidia module, exit Xserver and unload it manually.
[2011-04-13 14:38] upgraded nvidia (270.30-3 -> 270.41.03-1)
[2011-04-13 14:38] upgraded poppler (0.16.3-1 -> 0.16.4-1)
[2011-04-13 14:38] upgraded poppler-glib (0.16.3-1 -> 0.16.4-1)
[2011-04-13 14:38] upgraded python2-distribute (0.6.14-2 -> 0.6.15-3)
[2011-04-13 14:38] upgraded python-distribute (0.6.14-7 -> 0.6.15-3)
[2011-04-13 14:38] upgraded quodlibet (2.2.1-3 -> 2.3-1)
[2011-04-13 14:38] upgraded quodlibet-plugins (2.2.1-2 -> 2.3-1)
[2011-04-13 14:38] upgraded sudo (1.8.0-4 -> 1.8.1-1)
[2011-04-13 14:38] upgraded syslog-ng (3.2.2-1 -> 3.2.2-2)
[2011-04-13 14:38] upgraded terminal (0.4.6-1 -> 0.4.7-1)
[2011-04-13 14:38] upgraded tzdata (2011d-1 -> 2011e-1)
[2011-04-13 14:38] upgraded usbutils (001-2 -> 002-1)
[2011-04-13 14:38] upgraded vdpau-video (0.7.3-1 -> 0.7.3-2)
[2011-04-13 14:38] upgraded vlc (1.1.7-6 -> 1.1.9-1)
[2011-04-13 14:38] upgraded xf86-input-keyboard (1.6.0-1 -> 1.6.0-2)
[2011-04-13 14:38] upgraded xf86-input-mouse (1.7.0-1 -> 1.7.0-2)
[2011-04-13 14:38] upgraded xf86-input-synaptics (1.4.0-1 -> 1.4.0-2)
[2011-04-13 14:38] upgraded xfburn (0.4.3-3 -> 0.4.3-4)
[2011-04-13 14:38] upgraded xfce4-panel (4.8.2-1 -> 4.8.3-1)
[2011-04-13 14:38] upgraded xfce4-session (4.8.1-1 -> 4.8.1-2)
[2011-04-13 23:23] Running 'pacman -Sy'
[2011-04-13 23:23] synchronizing package lists


skai
Hankyu
Messages : 32
Inscription : lun. 11 mai 2009, 08:47

Re: [pm-suspend] : resume impossible depuis dernière mise à

Message par skai » jeu. 14 avr. 2011, 08:15

Complément d'info délirant : poweroff impossible !

/sbin/halt me fait ... un semblant d'arrêt mais un redémarrage.

(même chose avec le "logout" de xfce4).

Donc :
- je ne peux pls arrêter mon pc
- je ne peux plus le mettre en veille sans me prendre un resume inutile et un reoot forcé.
- pas pratique :)

:-(

J'ai vu ça dans dmesg :

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10529
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [pm-suspend] : resume impossible depuis dernière mise à

Message par FoolEcho » jeu. 14 avr. 2011, 09:04

skai a écrit :/sbin/halt me fait ... un semblant d'arrêt mais un redémarrage.

(même chose avec le "logout" de xfce4).
Et directement avec "shutdown -r now", ça s'arrête, quand même ?
skai a écrit :J'ai vu ça dans dmesg :
Tu n'aurais pas oublié quelque chose ?
«The following statement is not true. The previous statement is true.» :nage:

skai
Hankyu
Messages : 32
Inscription : lun. 11 mai 2009, 08:47

Re: [pm-suspend] : resume impossible depuis dernière mise à

Message par skai » jeu. 14 avr. 2011, 13:52

Ach, posté trop vite ;-)

shutdown -fh now a en effet fonctionné.

le bout de log trouvé était finalement inutile je pense : ce sont les "deprecated" ci dessous.
A priori jute un message en prévision du kernel 2.6.39 où ce sera de toute façon viré et pris en charge par défaut.

Je vois aussi plein de trucs "asus_machin" alors que j'ai un brave vieux lenovo Y510, mais je pense que ça a toujours été comme ça.

Pour résumer : je ne suis pas plu avancé. Si qqun sais où préciser le no_console_suspend (dans grub dans les options de chargement du kernel ?), j'ai eu un peu de mal à trouver cette info là. (ok, j'y ai pas encire passé 15 minutes ^^)

Code : Tout sélectionner

ACPI: Deprecated procfs I/F for AC is loaded, please retry with CONFIG_ACPI_PROCFS_POWER cleared
ACPI: AC Adapter [AC0] (on-line)
firewire_ohci 0000:08:03.0: PCI INT A -> GSI 21 (level, low) -> IRQ 21
Asus Laptop ACPI Extras version 0.30
  BSTS called, 0xc848 returned
  unsupported model SPEEDY, trying default values
  send /proc/acpi/dsdt to the developers
input: Ideapad extra buttons as /devices/platform/ideapad/input/input5
thermal LNXTHERM:00: registered as thermal_zone0
ACPI: Thermal Zone [THRM] (37 C)
firewire_ohci: Added fw-ohci device 0000:08:03.0, OHCI v1.0, 4 IR + 4 IT contexts, quirks 0x1
Bluetooth: Core ver 2.15
NET: Registered protocol family 31
Bluetooth: HCI device and connection manager initialized
Bluetooth: HCI socket layer initialized
ACPI: Deprecated procfs I/F for battery is loaded, please retry with CONFIG_ACPI_PROCFS_POWER cleared
ACPI: Battery Slot [BAT0] (battery present)
asus_laptop: Asus Laptop Support version 0.42
asus_laptop: BSTS called, 0xc848 returned
asus_laptop:   SPEEDY model detected
asus_laptop: Backlight controlled by ACPI video driver
input: Asus Laptop extra buttons as /devices/platform/asus_laptop/input/input6
cfg80211: Calling CRDA to update world regulatory domain
Bluetooth: Generic Bluetooth USB driver ver 0.6
usbcore: registered new interface driver btusb
acpi device:06: registered as cooling_device2
input: Video Bus as /devices/LNXSYSTM:00/device:00/PNP0A08:00/device:02/LNXVIDEO:00/input/input7
ACPI: Video Device [VGA] (multi-head: yes  rom: no  post: no)
Linux video capture interface: v2.00
sdhci: Secure Digital Host Controller Interface driver
sdhci: Copyright(c) Pierre Ossman
sdhci-pci 0000:08:03.1: SDHCI controller found [1180:0822] (rev 22)
sdhci-pci 0000:08:03.1: PCI INT B -> GSI 20 (level, low) -> IRQ 20
sdhci-pci 0000:08:03.1: Will use DMA mode even though HW doesn't fully claim to support it.
Registered led device: mmc0::
mmc0: SDHCI controller on PCI [0000:08:03.1] using DMA
firewire_core: created device fw0: GUID 001e8c0000165a49, S400
Synaptics Touchpad, model: 1, fw: 6.2, id: 0xa580b1, caps: 0xa04713/0x200000/0x0
input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio4/input/input8
uvcvideo: Found UVC 1.00 device Lenovo EasyCamera (046d:09b6)
input: Lenovo EasyCamera as /devices/pci0000:00/0000:00:1d.7/usb2/2-6/2-6:1.0/input/input9
usbcore: registered new interface driver uvcvideo


Guiux
Elfe
Messages : 870
Inscription : sam. 04 avr. 2009, 00:04
Localisation : Paris

Re: [pm-suspend] : resume impossible depuis dernière mise à

Message par Guiux » jeu. 14 avr. 2011, 13:59

J'ai aussi le problème de "resume" depuis la dernière mise à jour du kernel.
En revanche je n'ai pas remarqué les autres problèmes.

Décidément, cette version du noyau ne vaut pas un clou...
Arch 64 bits KDE 4 + Windows 7 sur Dell XPS M1530 [Core 2 Duo 2,4 GHz | 3 Go RAM | nVidia Geforce 8600M GT]

skai
Hankyu
Messages : 32
Inscription : lun. 11 mai 2009, 08:47

Re: [pm-suspend] : resume impossible depuis dernière mise à

Message par skai » jeu. 14 avr. 2011, 14:11

Des niouzes : j'ai bien mis tout bêtement le no_console_suspend sur la ligne des options du kernel dans grub.

Vlà le résultat :

Code : Tout sélectionner

Disable non-boot cpus
CPU 1 is now Offline
general protection fault : 0000 [#1] PREEMPT SMP
une bonne piste en tout cas.

Google va être mon ami ... après le retour à la maternité (cette dernière ayant en ce moment un renice plus important ^^)

Bizarrement j'ai l'impression que le shutdown -h now ne fait son office qu'une fois sur deux ???
Ne mélangeons pas tout celà dit ;-)

skai
Hankyu
Messages : 32
Inscription : lun. 11 mai 2009, 08:47

Re: [pm-suspend] : resume impossible depuis dernière mise à

Message par skai » jeu. 14 avr. 2011, 14:15


skai
Hankyu
Messages : 32
Inscription : lun. 11 mai 2009, 08:47

Re: [pm-suspend] : resume impossible depuis dernière mise à

Message par skai » jeu. 14 avr. 2011, 23:44

UNE solution (temporaire) : le downgrade kernel.

Une dépendance en entrainant une autre, j'ai reinstallé les packages suivants :

Code : Tout sélectionner

kernel26-2.6.37.4-1-x86_64.pkg.tar.xz
kernel26-headers-2.6.37.4-1-x86_64.pkg.tar.xz
nvidia-260.19.44-1-x86_64.pkg.tar.xz
nvidia-utils-260.19.44-1-x86_64.pkg.tar.xz
xf86-input-evdev-2.6.0-2-x86_64.pkg.tar.xz
xf86-input-keyboard-1.6.0-1-x86_64.pkg.tar.xz
xf86-input-mouse-1.7.0-1-x86_64.pkg.tar.xz
xf86-input-synaptics-1.4.0-1-x86_64.pkg.tar.xz
xorg-server-1.9.4.901-1-x86_64.pkg.tar.xz
xorg-server-common-1.9.4.901-1-x86_64.pkg.tar.xz
trouvés ici : http://arm.konnichi.com/

et installés avec u pacman -U *.xz

et voilà, ça refonctionne.



J'ignore finalement quel package est en cause vraiment, présomptio sur kernel à cause de l'erreur signalée.

Faut il signaler un bug Arch qque part ?

Répondre