[kernel] blackscreen pendant le boot après un update(resolu)

Reconnaissance et configuration du matériel / kernel linux
Répondre
RoToRx88
Hankyu
Messages : 19
Inscription : mar. 21 oct. 2014, 10:20

[kernel] blackscreen pendant le boot après un update(resolu)

Message par RoToRx88 » mar. 21 oct. 2014, 10:52

Bonjour à tous,

Voilà j'ai effectué une recherche sur le net et sur ce forum sans grand succès, j'ai cependant quelques pistes.
Mais d'habord, je vous explique mon problème.

Hier matin, yaourt --sucre pour faire mes mises à jours comme j'ai l'habitude de le faire disons toutes les deux semaines.
Tout ce passe bien, je continue de travailler. Puis à un moment je dois reboot mon ordi. Et la, tout commence comme d'habitude au boot, les infos s'affiche à l'écran en 800x600, puis normalement après le texte doit passer en 1920x1080 mais la plus rien. Et je crois appercevoir juste avant une phrase avec le mot kernel. J'appel un ami avec qui on avait installé arch ensemble, il me dit avoir eu le même problème que moi et que lui c'était pas pris le tête et avait re-installé arch. (Pour info nous avons tout deux exactement le même pc, un hp EliteBook 8570p).

Après des recherches sur le web, cela pourrait éventuellement venir du kernel qui se serait mis à jour et qui aurait posé problème ?

Je me fais donc un ubuntuLiveUSB, monte ma partition arch et me chroot dessus. Je tente alors cela (vu sur internet):

Code : Tout sélectionner

[root@ubuntu /]# find /var/cache/pacman/pkg/ -name 'linux-3.*'
/var/cache/pacman/pkg/linux-3.16.4-1-x86_64.pkg.tar.xz
/var/cache/pacman/pkg/linux-3.16.3-1-x86_64.pkg.tar.xz
/var/cache/pacman/pkg/linux-3.16.2-1-x86_64.pkg.tar.xz
[root@ubuntu /]# pacman -U /var/cache/pacman/pkg/linux-3.16.2-1-x86_64.pkg.tar.xz loading packages...
warning: downgrading package linux (3.16.4-1 => 3.16.2-1)
resolving dependencies...
looking for inter-conflicts...

Packages (1): linux-3.16.2-1

Total Installed Size:   71.41 MiB
Net Upgrade Size:       -0.07 MiB

:: Proceed with installation? [Y/n] Y
(1/1) checking keys in keyring                                  [-----------------------------------] 100%
(1/1) checking package integrity                                [-----------------------------------] 100%
(1/1) loading package files                                     [-----------------------------------] 100%
(1/1) checking for file conflicts                               [-----------------------------------] 100%
error: could not open file: /etc/mtab: No such file or directory
error: could not determine filesystem mount points
error: not enough free disk space
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.
[root@ubuntu /]# 
L'idée était donc de downgrader le kernel mais je n'y arrive pas.
Je vous demande donc si quelqu'un à eu le même problème que moi ou bien si vous avez une idée du pourquoi du comment ?
Je ne sais pas quel log je pourrais joindre pour vous aider un peu plus donc demandez moi je les posterais sans souci.

Voilà j'éspère que je ne suis pas tout simplement passé à coté d'un post identique, si c'est le cas veuillez m'en excuser.

En espérant que vous pourrez m'aider;
Bonne journée,

RoToR
Dernière modification par RoToRx88 le jeu. 23 oct. 2014, 13:31, modifié 1 fois.

benjarobin
Maître du Kyudo
Messages : 15472
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [kernel HS?] blackscreen pendant le boot après un update

Message par benjarobin » mar. 21 oct. 2014, 10:55

Ne jamais, mais jamais utiliser l'option --sucre, c'était une blague, un jeu de mot... Mais cette option est ultra dangereuse, la probabilité de casser son système avec une telle option est très élevé !!!
J'avais fait la demande pour supprimer l'option, mais cela avait été refusé...

Bref, pour résoudre ton souci, prend un CD d'archlinux et fait un choot comme indiqué dans le Wiki
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

RoToRx88
Hankyu
Messages : 19
Inscription : mar. 21 oct. 2014, 10:20

Re: [kernel HS?] blackscreen pendant le boot après un update

Message par RoToRx88 » mar. 21 oct. 2014, 16:09

re-bonjour,

Je suis allé faire un tour sur le wiki fr et en fait pour me chroot comme il faut il me manquais quelques lignes... En fait je faisais juste:

Code : Tout sélectionner

mount /dev/sda10 /mnt/
mount /dev/sda11 /mnt/home/
chroot /mnt /bin/bash
Mais il fallait aussi faire :

Code : Tout sélectionner

mount -t proc proc /mnt/proc
mount -t sysfs sys /mnt/sys/
mount -o bind /dev/ mnt/dev/
Bon, du coup une fois que tout était monté, je me suis chroot, j'ai réitéré l'opération de mon précédent poste, et OH ! Ca a fonctionné, j'ai pu downgrader mon kernel en version 3.16.2-1 d'abord, puis maintenant en 3.16.3-1.
Tout reboot comme il faut maintenant. J'ai justes quelques soucis avec cinnamon mais c'est mineur.
Cependant il me reste une dernière question:
Qu'est-ce qu'il peut se passer quand on downgrade un kernel comme je viens de le faire ? niveau compatibilité avec des choses nouvellement installées etc...
Oh et benjarobin, si --sucre est à surtout éviter, que pourrais-tu me conseiller à la place et pourquoi ca plutôt que --sucre ?
Sinon, avez-vous une expliquation de pourquoi le nouveau kernel peut poser problème ? Car j'ai retenté de faire un yaourt --sucre une fois que tout était remis en ordre et ca à de nouveau tout cassé.


Pour rester dans l'ésprit du forum je ré-explique ici tout ce qu'il c'est passé et comment résoudre le problème:

Donc, si quand vous avez fait un yaourt --sucre, votre arch ne reboot pas complètement, c'est que celà peut venir du kernel.

1- Dans ce cas la, faites vous un liveUSB de ubuntu ou toute autre distro

2- Bootez dessus

3- Montez la/les partitions de votre arch sans oublier les mount que je cite plus haut dans ce post

4- Chrootez vous sur votre point de montage et cherchez les images qu'il y a en cache de pacman avec find comme je le fais dans mon premier post

5- Utilisez pacman pour restaurer l'image du kernel voulu.

6- sortez du chroot et démontez les points un à un.

Exemple: si on prend mon cas, je suis sur un liveUSB ubuntu14 avec sda10 la partition système de mon arch et sda11 le /home de mon arch.

Code : Tout sélectionner

mount /dev/sda10 /mnt/
mount /dev/sda11 /mnt/home/
mount -t proc proc /mnt/proc
mount -t sysfs sys /mnt/sys/
mount -o bind /dev/ mnt/dev/
chroot /mnt/ /bin/bash
find /var/cache/pacman/pkg/ -name 'linux-3.*'
pacman -U /var/cache/pacman/pkg/linux-3.16.2-1-x86_64.pkg.tar.xz
exit
umount /mnt/proc 
umount /mnt/sys 
umount /mnt/dev 
umount /mnt/home 
umount /mnt
Pour seux que ca peut aider, voilà mon shell une fois l'opération fini:

Code : Tout sélectionner

root@ubuntu:/# mount /dev/sda10 /mnt/
root@ubuntu:/# mount /dev/sda11 /mnt/home/
root@ubuntu:/# mount -t proc proc /mnt/proc
root@ubuntu:/# mount -t sysfs sys /mnt/sys/
root@ubuntu:/# mount -o bind /dev/ mnt/dev/ 
root@ubuntu:/# chroot /mnt/ /bin/bash 
[root@ubuntu /]# find /var/cache/pacman/pkg/ -name 'linux-3.*'
/var/cache/pacman/pkg/linux-3.16.4-1-x86_64.pkg.tar.xz
/var/cache/pacman/pkg/linux-3.16.3-1-x86_64.pkg.tar.xz
/var/cache/pacman/pkg/linux-3.16.2-1-x86_64.pkg.tar.xz
[root@ubuntu /]# pacman -U /var/cache/pacman/pkg/linux-3.16.2-1-x86_64.pkg.tar.xz 
loading packages...
warning: downgrading package linux (3.16.4-1 => 3.16.2-1)
resolving dependencies...
looking for inter-conflicts...

Packages (1): linux-3.16.2-1

Total Installed Size:   71.41 MiB
Net Upgrade Size:       -0.07 MiB

:: Proceed with installation? [Y/n] Y
(1/1) checking keys in keyring                                [---------------------------------] 100%
(1/1) checking package integrity                              [---------------------------------] 100%
(1/1) loading package files                                   [---------------------------------] 100%
(1/1) checking for file conflicts                             [---------------------------------] 100%
(1/1) checking available disk space                           [---------------------------------] 100%
(1/1) downgrading linux                                       [---------------------------------] 100%
>>> Updating module dependencies. Please wait ...
>>> Generating initial ramdisk, using mkinitcpio.  Please wait...
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 3.16.2-1-ARCH
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
==> Starting build: 3.16.2-1-ARCH
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: aic94xx
==> WARNING: Possibly missing firmware for module: smsmdtv
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-fallback.img
==> Image generation successful
[root@ubuntu /]# exit
root@ubuntu:/# umount /mnt/proc 
root@ubuntu:/# umount /mnt/sys 
root@ubuntu:/# umount /mnt/dev 
root@ubuntu:/# umount /mnt/home 
root@ubuntu:/# umount /mnt 
root@ubuntu:/# 
PS: comment mettre le sujet en (resolu) ?

Bonne journée,

RoToR

benjarobin
Maître du Kyudo
Messages : 15472
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [kernel HS?] blackscreen pendant le boot après un update

Message par benjarobin » mar. 21 oct. 2014, 16:24

Voir le Wiki sur l'option --sucre : https://wiki.archlinux.fr/Yaourt#Utilis ... on_--sucre
Wiki a écrit :Cette option est un alias de -Syyua --force --devel --noconfirm. C'est-à-dire qu'elle va forcer toutes les mises à jour.
Pour information cette option n'est plus dans le man ni dans la sortie de l'aide de yaourt, car elle ne doit absolument pas être utilisée !

Pour une mise à jour quotidienne, j'utilise toujours ceci : yaourt -Syua

Et pour mettre à jour le sujet, il suffit d'éditer ton premier message.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
Blue Harp
Daikyu
Messages : 68
Inscription : ven. 25 juil. 2014, 16:05

Re: [kernel HS?] blackscreen pendant le boot après un update

Message par Blue Harp » mar. 21 oct. 2014, 16:51

benjarobin a écrit :Pour une mise à jour quotidienne, j'utilise toujours ceci : yaourt -Syua
Bonjour,
Est-ce que ça vient en plus de

Code : Tout sélectionner

pacman -Syu
ou est-ce que ça l'englobe ?
Sony Vaio Intel Core i3 M330 2.13 GHz
4 Go RAM - Carte ATI Mobility Radeon 5400
ArchLinux 64 XFCE / Windows 10 Pro 64

Avatar de l’utilisateur
anhaedre
Hankyu
Messages : 12
Inscription : mar. 13 mai 2014, 13:05

Re: [kernel HS?] blackscreen pendant le boot après un update

Message par anhaedre » mar. 21 oct. 2014, 16:55

ThinkPad X260
Archlinux Plasma

benjarobin
Maître du Kyudo
Messages : 15472
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [kernel HS?] blackscreen pendant le boot après un update

Message par benjarobin » mar. 21 oct. 2014, 16:55

La commande yaourt -Syua fait en résumé ceci :
  • Lance : pacman -Sy
  • Recherche des paquets AUR nécessitant une mise à jour
  • Affichage d'un résumé des mises à jour : Liste des paquets qui vont êtes mise à jour
  • Lance : pacman -Su
  • Lance les mises à jour des paquets AUR : Téléchargement des PKGBUILD, ...
Donc en 2 mots, c'est comme si tu avais exécuté pacman -Syu, puis mise à jour des paquets AUR à la main, mais bien sur sans affichage du joli résumé des mises à jour à appliquer.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
Blue Harp
Daikyu
Messages : 68
Inscription : ven. 25 juil. 2014, 16:05

Re: [kernel HS?] blackscreen pendant le boot après un update

Message par Blue Harp » mar. 21 oct. 2014, 17:00

C'est clair, merci ! Ca me permettra donc d'aller + vite (je tapais les 2 commandes successivement).
Sony Vaio Intel Core i3 M330 2.13 GHz
4 Go RAM - Carte ATI Mobility Radeon 5400
ArchLinux 64 XFCE / Windows 10 Pro 64

RoToRx88
Hankyu
Messages : 19
Inscription : mar. 21 oct. 2014, 10:20

Re: [kernel] blackscreen pendant le boot après un update(res

Message par RoToRx88 » jeu. 23 oct. 2014, 13:44

Salut !

Merci à vous de votre aide et pour ce petit cours sur pacman et yaourt !
Il me reste cependant une dernière question... Ok la version 3.16.4 du kernel ne fonctionne pas pour moi (allez savoir pourquoi ?!) mais pensez vous que celle qui vient de sortir (la 3.17.1) peut fonctionner ?
Et est-ce risqué de l'installer ?

RoToR

benjarobin
Maître du Kyudo
Messages : 15472
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [kernel] blackscreen pendant le boot après un update(res

Message par benjarobin » jeu. 23 oct. 2014, 13:49

Il n'y a aucun risque tant que l'on utilise pacman (sans utiliser des options foireuses :-) )
Au pire tu reviens en arrière...
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

RoToRx88
Hankyu
Messages : 19
Inscription : mar. 21 oct. 2014, 10:20

Re: [kernel] blackscreen pendant le boot après un update(res

Message par RoToRx88 » jeu. 23 oct. 2014, 14:47

Bon, ben marche pas non plus... j'espère que ca change rien que ca ai mis aussi à jour les headers linux si je retourne sur l'encien kernel 3.16.3 ?
Ta une idée de pourquoi ca marche pas ?

ijahman
newbie
Messages : 2
Inscription : dim. 26 oct. 2014, 14:18

Re: [kernel] blackscreen pendant le boot après un update(res

Message par ijahman » dim. 26 oct. 2014, 14:45

Bonjour à tous,

Je me permets de prendre la suite de ce fil car je pense que mon problème est très similaire. Si vous pensez qu'il vaut mieux que je crée un nouveau fil parce que celui-ci est "résolu", je le ferai.

Pour commencer, mon niveau en Arch Linux est dilettante qui se débrouille. Depuis 5 ans que je l'utilise, j'ai toujours réussi à trouver la solution à mes problèmes en appliquant ce que je trouvais sur les forums (c'est la première fois que je me manifeste directement). Par contre, je n'ai pas forcément une bonne connaissance de l'architecture globale.

Après plusieurs essais, j'ai pu conclure que ce qui m'amenait à l'écran noir que RoToRx88 a mentionné exactement au même moment du boot (passage de la résolution de base à la résolution plus élevé, donc, si je ne m'abuse, à un moment où le KMS se lance), était l'upgrade du noyau 3.16.4 au 3.17.1. J'ai en effet fait pas mal de downgrade sur les drivers mesa et essayer de réinstaller xorg-server comme c'était suggéré sur certains forums. La seule chose qui m'a fait retrouver un boot normal a été le retour à linux 3.16.4. J'ai ensuite remis à jour tous les autres packages auxquels j'avais touché et ça a très bien marché. Enfin, j'ai mis à jour le kernel vers le 3.17.1 et je suis retombé sur l'écran noir au même moment.

En éditant la commande gummiboot pour lui ajouter "nomodeset" (idée que j'ai trouvée sur les pages traitant du KMS), j'arrive à éviter l'écran noir. Cependant le boot se bloque quand même dans la liste de l'activation des modules peu après "reaching graphical interface" et une étape concernant le "network". A ce moment on peut faire un Ctrl+Alt+F5 pour récupérer une console tty, ce qui m'a permis d'éviter d'être obligé de booter sur cd et d'utiliser chroot à chaque fois que je faisais un test.

Je suis allé voir du côté du log

Code : Tout sélectionner

/var/log/Xorg.0.log
et je suis tombé sur les lignes suivantes :

Code : Tout sélectionner

Fatal server error:
[  1931.999] (EE) no screens found(EE) 
[  1931.999] (EE) 
Ca fait plusieurs heures que j'ai regardé les forums et je pense que je n'arriverai pas à bout de ce problème tout seul. Peut-être que la solution y est, mais je n'arrive pas à faire la synthèse. Pour l'instant, je ne suis pas dans le besoin, car Arch Linux marche. Par contre, je suis prêt à vous donner toutes les informations possibles pour trouver le fin mot de l'histoire. Si vous avez besoin d'extraits de logs, merci de bien me préciser, où je peux les trouver. J'avoue être un peu mauvais pour connaître et savoir où sont tous ces fichiers pourtant très pratiques pour débugger.

benjarobin
Maître du Kyudo
Messages : 15472
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [kernel] blackscreen pendant le boot après un update(res

Message par benjarobin » dim. 26 oct. 2014, 15:18

C'est définitivement un problème avec KMS (mauvaise détection de la résolution ?). nomodeset permet de diagnostiquer le problème, mais ne peut pas être utilisé avec des drivers libres, car ils nécessitent KMS. Tu es obligé d'utiliser des drivers propriétaires avec nomodeset.
Il faudrait chercher un rapport de bug du kernel, ou créer un si tu n'en as pas trouvé.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

RoToRx88
Hankyu
Messages : 19
Inscription : mar. 21 oct. 2014, 10:20

Re: [kernel] blackscreen pendant le boot après un update(resolu)

Message par RoToRx88 » lun. 22 déc. 2014, 10:10

Salut,

Merci pour vos précisions.... Et dommage que l'on ai pas de solution car cela signifie qu'il va falloir attendre une mise à jour kernel qui corrige cette erreur c'est ca ? En espérant que ca arrive vite.
Quelqu'un à plus d'info à ce propos ?

Bonne journée,

RoToR

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 1994
Inscription : jeu. 15 mars 2012, 05:08

Re: [kernel] blackscreen pendant le boot après un update(resolu)

Message par waitnsea » lun. 22 déc. 2014, 18:29

Rassuré de ne pas être seul, après mise à jour (yaourt -Syua, pas de sucre, merci), mêmes soucis, mais comme je clone chaque semaine...
LENOVO Y700-341SH i7-6700 3.4gHZ 1 SSD + 2HDD - Arch/KDE - NVidia GeForce GTX 750 T
Sauvegardes quotidiennes de mes système et données par BORG

sebichou
Hankyu
Messages : 14
Inscription : jeu. 19 juin 2014, 17:42

Re: [kernel] blackscreen pendant le boot après un update(resolu)

Message par sebichou » ven. 02 janv. 2015, 19:46

Ca sent les mecs d'EPITECH !
j'ai le meme problème avec mon HP et je ne peux donc installer ubuntu ou Fedora qui sont livrés avec le kernel 3.16. Que me conseillez vous ?

Merci d'avance.

Seb

ijahman
newbie
Messages : 2
Inscription : dim. 26 oct. 2014, 14:18

Re: [kernel] blackscreen pendant le boot après un update(resolu)

Message par ijahman » dim. 08 févr. 2015, 10:33

Bonjour,

Aujourd'hui j'ai mis à jour linux de 3.16.4 à 3.18.5 et je n'ai pas eu de souci. Je me souviens avoir fait un test avec une 3.17 et j'avais encore le problème de blackscreen.

Mais maintenant, c'est bon. Ca semble réparé.

Répondre