[xorg-server 1.20] Nvidia-340xx Arch ne démarre plus (RESOLU)

Questions et astuces concernant l'installation et la configuration d'archlinux
Avatar de l’utilisateur
FenDanT
Chu Ko Nu
Messages : 481
Inscription : mer. 25 avr. 2007, 09:04
Localisation : Chamoson VS/CH

[xorg-server 1.20] Nvidia-340xx Arch ne démarre plus (RESOLU)

Message par FenDanT » sam. 19 mai 2018, 09:47

Coucoux ;)

Petit souci ce matin, en voulant démarrer Arch. En virant l'option quiet dans grub, le démarrage reste bloqué sur : "Started Authorization Manager". Le curseur clignote pendant de longues minutes, mais ensuite... Plus rien.

J'ai vaguement vu passer un message à un moment donné, qui parlait de udpate man-db cache ou un truc du genre...

J'essaie de faire une ctrl+alt+F2 et j'accède à la console, mais l'affichage clignote et c'est presque inutilisable...

Je suis sous kde avec un portable avec une carte nvidia et je ne sais pas trop de quel côté chercher.

Si vous avez des idées... :roll:
Dernière modification par FenDanT le ven. 15 juin 2018, 08:04, modifié 2 fois.
Windows à des pépins ? Linux a un noyau ! :)

JuanicoV
Daikyu
Messages : 64
Inscription : mar. 07 nov. 2017, 20:59
Localisation : Espagne-Valencia

Re: [Authorization Manager] Arch bloque au démarrage...(en cours)

Message par JuanicoV » sam. 19 mai 2018, 11:34

Bonjour,

il faudrait connaitre la références de ta carte et si tu utilises le driver nvidia, car depuis la semaine dernière certaines cartes doivent utiliser nvidia390xx (voir le wiki anglais

nvidia
HP Pavillon - AMD Phenom 9600 - 6Go - SSD
Nvidia GT 520
Dual boot : Archlinux Gnome -Ubuntu Mate

Avatar de l’utilisateur
onyx67
Elfe
Messages : 744
Inscription : dim. 06 nov. 2011, 18:12
Localisation : Alsace

Re: [Authorization Manager] Arch bloque au démarrage...(en cours)

Message par onyx67 » sam. 19 mai 2018, 13:09

As-tu remplacé l'option "quiet" par "3" afin de démarrer en console?
J'ai également eu un souci après la dernière màj Nvidia et j'ai dû installer les paquets nvidia-390xx et nvidia-390xx-lts.
Comme te le conseille JuanicoV, vérifie la version de ta carte.
"La complication est un effet de la simplicité mal acquise"

Intel i5-2320; Nvidia GeForce GT 520; ATA Hitachi 2To; Windows7/ArchLinux-Kde5

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 2014
Inscription : jeu. 15 mars 2012, 05:08

Re: [Authorization Manager] Arch bloque au démarrage...(en cours)

Message par waitnsea » sam. 19 mai 2018, 14:05

JuanicoV a écrit :
sam. 19 mai 2018, 11:34
Bonjour,

il faudrait connaitre la références de ta carte et si tu utilises le driver nvidia, car depuis la semaine dernière certaines cartes doivent utiliser nvidia390xx (voir le wiki anglais

nvidia
Bonjour,
Bravo, c'est une modification du Wiki du 8 Mai qui n'a fait l'objet d'aucune annonce !
et un grand merci car je m'interrogeais précisément sur le blocage de mon Asus (carte 425M) !

Avatar de l’utilisateur
onyx67
Elfe
Messages : 744
Inscription : dim. 06 nov. 2011, 18:12
Localisation : Alsace

Re: [Authorization Manager] Arch bloque au démarrage...(en cours)

Message par onyx67 » sam. 19 mai 2018, 14:26

waitnsea a écrit :
sam. 19 mai 2018, 14:05
Bonjour,
Bravo, c'est une modification du Wiki du 8 Mai qui n'a fait l'objet d'aucune annonce !
et un grand merci car je m'interrogeais précisément sur le blocage de mon Asus (carte 425M) !
Oui moi idem. C'est un peu problématique sans annonce d'autant plus que le driver lts ne fonctionnait non plus. J'ai attendu en vain une nouvelle version (qui est venue mais n'a rien résolu). C'est grâce à ce post que j'ai résolu mon souci.
"La complication est un effet de la simplicité mal acquise"

Intel i5-2320; Nvidia GeForce GT 520; ATA Hitachi 2To; Windows7/ArchLinux-Kde5

Avatar de l’utilisateur
FenDanT
Chu Ko Nu
Messages : 481
Inscription : mer. 25 avr. 2007, 09:04
Localisation : Chamoson VS/CH

Re: [Authorization Manager] Arch bloque au démarrage...(en cours)

Message par FenDanT » sam. 19 mai 2018, 18:48

Re coucoux ;)

Ma carte est une nvidia GT216M GEFORCE GT230M rev a2.
Jusqu'à maintenant j'utilisais le driver nvidia-340xx.
J'ai essayé avec le nvidia-390xx mais même punition... :(
Windows à des pépins ? Linux a un noyau ! :)

JuanicoV
Daikyu
Messages : 64
Inscription : mar. 07 nov. 2017, 20:59
Localisation : Espagne-Valencia

Re: [Authorization Manager] Arch bloque au démarrage...(en cours)

Message par JuanicoV » sam. 19 mai 2018, 19:32

fais un essais en revenant à la version 1.19 de Xorg-server ( avec nvidia-340xx c'est bien celui qui correspond à ta carte).

En fouillant sur le forum us il y a ce lien dans ce post qui traite du problème avec nvidia-390xx.

Bref entre le 390xx et le passage a Xorg 1.20 il semblerait qu'il y ait eu quelques blocages de sessions graphiques :D

Et c'est vrai qu'une annonce aurait été bien venue. Et du coup j'ai viré gdm et j'utilise startx...
HP Pavillon - AMD Phenom 9600 - 6Go - SSD
Nvidia GT 520
Dual boot : Archlinux Gnome -Ubuntu Mate

Avatar de l’utilisateur
FenDanT
Chu Ko Nu
Messages : 481
Inscription : mer. 25 avr. 2007, 09:04
Localisation : Chamoson VS/CH

Re: [Authorization Manager] Arch bloque au démarrage...(en cours)

Message par FenDanT » mer. 23 mai 2018, 07:01

Coucoux ;)

Bon ben j'attendais beaucoup de la maj du noyau et de nvidia-340xx, mais rien n'a changé... :(
Windows à des pépins ? Linux a un noyau ! :)

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 2014
Inscription : jeu. 15 mars 2012, 05:08

Re: [Authorization Manager] Arch bloque au démarrage...(en cours)

Message par waitnsea » mer. 23 mai 2018, 08:21

FenDanT a écrit :
mer. 23 mai 2018, 07:01
Coucoux ;)

Bon ben j'attendais beaucoup de la maj du noyau et de nvidia-340xx, mais rien n'a changé... :(
Tu as essayé avec nvidia-390xx et le nvidia-390xx-utils ?

Avatar de l’utilisateur
FenDanT
Chu Ko Nu
Messages : 481
Inscription : mer. 25 avr. 2007, 09:04
Localisation : Chamoson VS/CH

Re: [Authorization Manager] Arch bloque au démarrage...(en cours)

Message par FenDanT » mer. 23 mai 2018, 17:02

Re ;)

Oui essai fait également avec le 390xx, mais pas de changement.

Je suis revenu au 340xx, si je lance un startx, un message d'erreur apparaît en parlant de ABI pas supporté et demandant de downgrader xorg... Mais c'est un peu du chinois...

Dois-je attendre une maj de xorg ?
Windows à des pépins ? Linux a un noyau ! :)

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 2014
Inscription : jeu. 15 mars 2012, 05:08

Re: [Authorization Manager] Arch bloque au démarrage...(en cours)

Message par waitnsea » mer. 23 mai 2018, 17:42

FenDanT a écrit :
mer. 23 mai 2018, 17:02
Oui essai fait également avec le 390xx, mais pas de changement.
Je suis revenu au 340xx, si je lance un startx, un message d'erreur apparaît en parlant de ABI pas supporté et demandant de downgrader xorg... Mais c'est un peu du chinois...
Dois-je attendre une maj de xorg ?
Vu le forum inter solutions de hamelg ?

Avatar de l’utilisateur
FenDanT
Chu Ko Nu
Messages : 481
Inscription : mer. 25 avr. 2007, 09:04
Localisation : Chamoson VS/CH

Re: [Authorization Manager] Arch bloque au démarrage...(en cours)

Message par FenDanT » mer. 23 mai 2018, 18:05

Re ;)

Bon ben le seul truc qui fonctionne pour le moment est de downgrader xorg-server avec cette commande :

Code : Tout sélectionner

# pacman -U https://archive.archlinux.org/packages/x/xorg-server/xorg-server-1.19.6-2-x86_64.pkg.tar.xz
Ensuite j'ai ajouté ceci dans /etc/pacman.conf :
IgnorePkg = xorg-server xorg-server-common xorg-server-devel xorg-server-xdmx xorg-server-xephyr xorg-server-xnest xorg-server-xvfb xorg-server-xwayland
Et je suis de retour sous arch... Mais je ne sais pas si j'ai bien fait ou pas... Et quand retirer ces packages de la ignore list... :shock:
Windows à des pépins ? Linux a un noyau ! :)

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 2014
Inscription : jeu. 15 mars 2012, 05:08

Re: [Authorization Manager] Arch bloque au démarrage...(en cours)

Message par waitnsea » mer. 23 mai 2018, 18:43

Comme dit V1del : "I do agree with the notion that it would've been nice to have an announcement, but we haven't had that for similar breakages with the nvidia modules"
autrement dit, y-z-auraient pu prévenir, ces c..
Ça ne dit pas si ou quand ça va être réglé... restera la solution du pilote nouveau

benjarobin
Maître du Kyudo
Messages : 15565
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Authorization Manager] Arch bloque au démarrage...(en cours)

Message par benjarobin » mer. 23 mai 2018, 20:19

En résumé, aujourd’hui 23 mai, les cartes compatibles avec un driver nvidia en version 396.24-4 ou 390.59-3 devraient fonctionner avec un Xorg 1.20.
Par contre pour les versions antérieurs du driver nvidia, c'est à dire la branche 340, il n'y a pas encore de compatibilité que je sache avec un Xorg 1.20.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
FenDanT
Chu Ko Nu
Messages : 481
Inscription : mer. 25 avr. 2007, 09:04
Localisation : Chamoson VS/CH

Re: [xorg-server 1.20] Nvidia-340xx Arch ne démarre plus (en cours)

Message par FenDanT » jeu. 24 mai 2018, 07:31

Re coucoux ;)

Plutôt embêtant si le driver nvidia-340xx n'est plus mis à jour... Il restera à passer à nouveau... Mais bon, vu les performances...

PS : j'ai édité le titre pour que ce soit un peu plus parlant... ;)
Windows à des pépins ? Linux a un noyau ! :)

Avatar de l’utilisateur
FenDanT
Chu Ko Nu
Messages : 481
Inscription : mer. 25 avr. 2007, 09:04
Localisation : Chamoson VS/CH

Re: [xorg-server 1.20] Nvidia-340xx Arch ne démarre plus (en cours)

Message par FenDanT » ven. 25 mai 2018, 08:14

Re ;)

Ce matin maj à la version nvidia-340xx 340.106-37... Reinstall de xorg-server 1.2 et même punition...

Donc re downgrade de xorg-server et re ignore list... :(
Windows à des pépins ? Linux a un noyau ! :)

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 2014
Inscription : jeu. 15 mars 2012, 05:08

Re: [xorg-server 1.20] Nvidia-340xx Arch ne démarre plus (en cours)

Message par waitnsea » ven. 25 mai 2018, 09:34

FenDanT a écrit :
ven. 25 mai 2018, 08:14
Re ;)

Ce matin maj à la version nvidia-340xx 340.106-37... Reinstall de xorg-server 1.2 et même punition...

Donc re downgrade de xorg-server et re ignore list... :(
et sur le forum inter, une remarque sur nouveau...

benjarobin
Maître du Kyudo
Messages : 15565
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [xorg-server 1.20] Nvidia-340xx Arch ne démarre plus (en cours)

Message par benjarobin » ven. 25 mai 2018, 09:42

FenDanT a écrit :
ven. 25 mai 2018, 08:14
Ce matin maj à la version nvidia-340xx 340.106-37
Il n'y a pas eu de mise à jour du paquet, c'est juste le paquet qui a été recompilé. Il ne faut pas regarder l'id de release, juste la version fournit par Nvidia, qui est ici 340.106. Quand ce numéro changera tu pourras tester de nouveau.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
FenDanT
Chu Ko Nu
Messages : 481
Inscription : mer. 25 avr. 2007, 09:04
Localisation : Chamoson VS/CH

Re: [xorg-server 1.20] Nvidia-340xx Arch ne démarre plus (en cours)

Message par FenDanT » ven. 25 mai 2018, 11:31

Re ;)

Cool, merci pour l'info benjarobin ;)
Windows à des pépins ? Linux a un noyau ! :)

Manarch
Hankyu
Messages : 24
Inscription : dim. 16 juil. 2017, 09:39

Re: [xorg-server 1.20] Nvidia-340xx Arch ne démarre plus (en cours)

Message par Manarch » sam. 26 mai 2018, 10:56

Je tombe sur ce post après coup (Vieux DELL e6400 / Quadro NVS 160M) :( , début de semaine blocage au boot après maj, ctrl+alt+f4 clignotant etc... J'ai quand même réussi a downgrader le coupable dans cet état après quelques tatonements (j'ai plus de cheveux ça va, il n'y a plus rien à arracher :D ) bref... Je suis abonné au rss, ça aurai été sympa une petite annonce en effet, comme pour js52... J'espère qu'il vont pas abandonner le 340 :( Wait and see...
Bonne journée à vous
Arch/Fluxbox - DELL Latitude E6430

Répondre