[boot] blocage pendant environ 2 minutes (résolu)

Reconnaissance et configuration du matériel / kernel linux
Avatar de l’utilisateur
Kristen
Elfe
Messages : 629
Inscription : ven. 14 oct. 2011, 10:24
Localisation : Finistère France

[boot] blocage pendant environ 2 minutes (résolu)

Message par Kristen » dim. 17 févr. 2019, 09:59

Bonjour
Sur une nouvelle installation sur mon portable de archlinux- KDE, le démarrage reste bloqué pendant environ 2 minutes après affichage de

Code : Tout sélectionner

starting version 240
systeme: clean 247002/1316720 files 3221954/5242880 blocks
Je ne sais pas trop où chercher ?
Si vous avez des idées, n'hésitez pas.
Voici mon Xorg.0.log
Dernière modification par Kristen le mer. 20 févr. 2019, 15:49, modifié 1 fois.
Depuis le 14 octobre 2011 sur archlinux avec actuellement GNOME sur :
PC fixe i5 - CG GeForce GTX 750 Ti - Mémoire 12 Go - SSD128 Go - DD1000 Go
et
PC portable : Lenovo ThinkPad T520i et Lenovo Ideapad S130-14IGM

Avatar de l’utilisateur
papajoke
Elfe
Messages : 544
Inscription : sam. 30 août 2014, 19:54
Contact :

Re: [boot] blocage pendant environ 2 minutes

Message par papajoke » dim. 17 févr. 2019, 11:02

bonjour,
Kristen a écrit :
dim. 17 févr. 2019, 09:59
Je ne sais pas trop où chercher ?
- systemd-analyze
- journalctl
Arch stable - Kde 5 / zsh - btrfs/mbr - Intel Core i3 - 6Go RAM - GeForce 405 video-nouveau

Avatar de l’utilisateur
Kristen
Elfe
Messages : 629
Inscription : ven. 14 oct. 2011, 10:24
Localisation : Finistère France

Re: [boot] blocage pendant environ 2 minutes

Message par Kristen » dim. 17 févr. 2019, 16:01

J'avais déjà regardé avec systemd-analyze mais je n'ai rien vu d'anormal

Code : Tout sélectionner

$ systemd-analyze
Startup finished in 3.456s (kernel) + 1.219s (userspace) = 4.676s 
graphical.target reached after 1.022s in userspace
Pour journalctl, le voici en partage vu que j'ai dépassé mon quota sur pastebin https://framadrive.org/s/BSZiEPtyk4eiWPW

Système fraîchement installé avec le minimum plasma kate konsole et dolphin
Depuis le 14 octobre 2011 sur archlinux avec actuellement GNOME sur :
PC fixe i5 - CG GeForce GTX 750 Ti - Mémoire 12 Go - SSD128 Go - DD1000 Go
et
PC portable : Lenovo ThinkPad T520i et Lenovo Ideapad S130-14IGM

Avatar de l’utilisateur
papajoke
Elfe
Messages : 544
Inscription : sam. 30 août 2014, 19:54
Contact :

Re: [boot] blocage pendant environ 2 minutes

Message par papajoke » dim. 17 févr. 2019, 20:07

pour systemd, tu boot en 5 secondes ! donc tes 2 minutes sont avant systemd ?
je pensait que lorsque l'on voyait ce message il était déjà lancé :?

ton log debute à : févr. 17 15:07:51
login raté : févr. 17 15:08:36 archport login[374]: pam_unix(login:auth): authentication failure;

Tu n'aurais pas un login automatique ?
sinon il n'y a rien à voir sinon que tu te log mal au bout de 50 secondes donc tu as apparemment le dm rapidement
Arch stable - Kde 5 / zsh - btrfs/mbr - Intel Core i3 - 6Go RAM - GeForce 405 video-nouveau

Avatar de l’utilisateur
Kristen
Elfe
Messages : 629
Inscription : ven. 14 oct. 2011, 10:24
Localisation : Finistère France

Re: [boot] blocage pendant environ 2 minutes

Message par Kristen » dim. 17 févr. 2019, 20:38

papajoke a écrit :
dim. 17 févr. 2019, 20:07
pour systemd, tu boot en 5 secondes ! donc tes 2 minutes sont avant systemd ?
je pensait que lorsque l'on voyait ce message il était déjà lancé :?
Non rien n'est encore lancé, c'est vraiment au démarrage du PC
ton log debute à : févr. 17 15:07:51
login raté : févr. 17 15:08:36 archport login[374]: pam_unix(login:auth): authentication failure;

Tu n'aurais pas un login automatique ?
sinon il n'y a rien à voir sinon que tu te log mal au bout de 50 secondes donc tu as apparemment le dm rapidement
Pas de login auto non plus

J'ai essayé avec le noyau linux-lts mais ça n'a rien changé.
Depuis le 14 octobre 2011 sur archlinux avec actuellement GNOME sur :
PC fixe i5 - CG GeForce GTX 750 Ti - Mémoire 12 Go - SSD128 Go - DD1000 Go
et
PC portable : Lenovo ThinkPad T520i et Lenovo Ideapad S130-14IGM

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10534
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [boot] blocage pendant environ 2 minutes

Message par FoolEcho » dim. 17 févr. 2019, 21:41

Kristen a écrit :
dim. 17 févr. 2019, 20:38
J'ai essayé avec le noyau linux-lts mais ça n'a rien changé.
D'après ton journal:

Code : Tout sélectionner

févr. 17 15:11:08 archport kernel: device-mapper: uevent: version 1.0.3
févr. 17 15:11:08 archport kernel: device-mapper: ioctl: 4.39.0-ioctl (2018-04-03) initialised: dm-devel@redhat.com
févr. 17 15:12:51 archport useradd[911]: new group: name=christian, GID=1000
Ce n'est pas plutôt au niveau du message triggering uevents que ça coince ? As-tu le même problème avec l'image fallback ? (si ça démarre rapidement, le souci peut venir d'un module non intégré à l'image «réduite»)
«The following statement is not true. The previous statement is true.» :nage:

sukolyn
Daikyu
Messages : 84
Inscription : mar. 11 juil. 2017, 09:56

Re: [boot] blocage pendant environ 2 minutes

Message par sukolyn » dim. 17 févr. 2019, 22:09

salut,

on pourrait aussi reconfigurer GrUB provisoirement pour enlever le quiet.
le démarrage sera alors plus "parlant" ;) et tu verras tout de suite sur quelle étape ça coince...

Avatar de l’utilisateur
Kristen
Elfe
Messages : 629
Inscription : ven. 14 oct. 2011, 10:24
Localisation : Finistère France

Re: [boot] blocage pendant environ 2 minutes

Message par Kristen » lun. 18 févr. 2019, 09:44

Bonjour
J'ai supprimé le lancement automatique de sddm

Code : Tout sélectionner

systemctl disable sddm.service
Le PC démarre en moins de temps qu'il ne faut pour le dire !!!
FoolEcho a écrit :
dim. 17 févr. 2019, 21:41
Ce n'est pas plutôt au niveau du message triggering uevents que ça coince ? As-tu le même problème avec l'image fallback ? (si ça démarre rapidement, le souci peut venir d'un module non intégré à l'image «réduite»)
Non pour triggering uevents et oui pareil avec l'image fallback
sukolyn a écrit :
dim. 17 févr. 2019, 22:09
on pourrait aussi reconfigurer GrUB provisoirement pour enlever le quiet.
le démarrage sera alors plus "parlant" ;) et tu verras tout de suite sur quelle étape ça coince...
Je viens de démarrer en enlevant le quiet et ça bloque sur

Code : Tout sélectionner

Started Hostname Service
Je regarde à tout hazard
/etc/hosname > archport
/etc/hosts > 127.0.1.1 archport.localdomain archport

Apparemment rien d'anormal !?
Depuis le 14 octobre 2011 sur archlinux avec actuellement GNOME sur :
PC fixe i5 - CG GeForce GTX 750 Ti - Mémoire 12 Go - SSD128 Go - DD1000 Go
et
PC portable : Lenovo ThinkPad T520i et Lenovo Ideapad S130-14IGM

Avatar de l’utilisateur
Kristen
Elfe
Messages : 629
Inscription : ven. 14 oct. 2011, 10:24
Localisation : Finistère France

Re: [boot] blocage pendant environ 2 minutes

Message par Kristen » lun. 18 févr. 2019, 10:47

Code : Tout sélectionner

systemctl disable sddm.service
+ lancement de KDE par .xinitrc pas de problème
Depuis le 14 octobre 2011 sur archlinux avec actuellement GNOME sur :
PC fixe i5 - CG GeForce GTX 750 Ti - Mémoire 12 Go - SSD128 Go - DD1000 Go
et
PC portable : Lenovo ThinkPad T520i et Lenovo Ideapad S130-14IGM

sukolyn
Daikyu
Messages : 84
Inscription : mar. 11 juil. 2017, 09:56

Re: [boot] blocage pendant environ 2 minutes

Message par sukolyn » lun. 18 févr. 2019, 15:12

"Started", quel est le service qui démarre à la suite de "Hostname Service" ?

mais si ça démarre rapidement sans sddm, change de Display Manager. ;)

benjarobin
Maître du Kyudo
Messages : 15537
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [boot] blocage pendant environ 2 minutes

Message par benjarobin » lun. 18 févr. 2019, 17:56

Sinon cela serait plus simple d'utiliser systemd-analyze pour voir ce qui se passe... Re active sddm, et donne nous le fichier .svg résultant. Bien que ce soit une image, c'est un fichier texte, donc partage le via un site de partage de fichiers
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
Kristen
Elfe
Messages : 629
Inscription : ven. 14 oct. 2011, 10:24
Localisation : Finistère France

Re: [boot] blocage pendant environ 2 minutes

Message par Kristen » lun. 18 févr. 2019, 20:56

À force de tout bidouiller, j'ai du faire une connerie donc j'ai refait une installation propre.
Toujours le même problème.
Voici le .svg https://framadrive.org/s/zrRCkG7PpF86QXE
Depuis le 14 octobre 2011 sur archlinux avec actuellement GNOME sur :
PC fixe i5 - CG GeForce GTX 750 Ti - Mémoire 12 Go - SSD128 Go - DD1000 Go
et
PC portable : Lenovo ThinkPad T520i et Lenovo Ideapad S130-14IGM

benjarobin
Maître du Kyudo
Messages : 15537
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [boot] blocage pendant environ 2 minutes

Message par benjarobin » lun. 18 févr. 2019, 21:32

Comprends pas trop, systemd indique que tu démarres en un temps record...
Quelle est la sortie (en root), suite à un redémarrage, sans le quiet dans les paramètres kernel, de :

Code : Tout sélectionner

journalctl -b -u sddm
journalctl -b
systemd-analyze
cat /var/log/Xorg.0.log
Je sais que tu as déjà donné tout cela, mais c'est pour avoir des informations cohérente d'un seul démarrage
Peux tu nous décrire le plus précisément à la seconde près si possible ce qui se passe
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
Kristen
Elfe
Messages : 629
Inscription : ven. 14 oct. 2011, 10:24
Localisation : Finistère France

Re: [boot] blocage pendant environ 2 minutes

Message par Kristen » lun. 18 févr. 2019, 23:18

Voilà tout en root après un redémarrage sans quiet
journalctl -b -u sddm
https://framadrive.org/s/wzwRJAQHYYbwAqM

journalctl -b
https://framadrive.org/s/yxY2ZCj73fSPsaN

systemd-analyze

Code : Tout sélectionner

# systemd-analyze
Startup finished in 4.417s (kernel) + 2.283s (userspace) = 6.701s 
graphical.target reached after 2.160s in userspace
cat /var/log/Xorg.0.log
https://framadrive.org/s/5c7AZY69i5TxXaN

Pour le chronométrage, j'ai oublié, je recommence
Depuis le 14 octobre 2011 sur archlinux avec actuellement GNOME sur :
PC fixe i5 - CG GeForce GTX 750 Ti - Mémoire 12 Go - SSD128 Go - DD1000 Go
et
PC portable : Lenovo ThinkPad T520i et Lenovo Ideapad S130-14IGM

Avatar de l’utilisateur
Kristen
Elfe
Messages : 629
Inscription : ven. 14 oct. 2011, 10:24
Localisation : Finistère France

Re: [boot] blocage pendant environ 2 minutes

Message par Kristen » lun. 18 févr. 2019, 23:29

Voilà le chrono à compter du moment où je lance le boot après avoir enlever le quiet
en 13 secondes, j'arrive à
https://framadrive.org/s/Gj3mQ86iRiKWc7x

puis ça bloque jusqu'à 2 minutes 3secondes pour arriver à l'écran de connexion de sddm.
Depuis le 14 octobre 2011 sur archlinux avec actuellement GNOME sur :
PC fixe i5 - CG GeForce GTX 750 Ti - Mémoire 12 Go - SSD128 Go - DD1000 Go
et
PC portable : Lenovo ThinkPad T520i et Lenovo Ideapad S130-14IGM

benjarobin
Maître du Kyudo
Messages : 15537
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [boot] blocage pendant environ 2 minutes

Message par benjarobin » lun. 18 févr. 2019, 23:33

En gros je pense que c'est lié à la génération de "random".

Code : Tout sélectionner

random: systemd: uninitialized urandom read (16 bytes read)
La question c'est qui le coupable : sddm ? Qt ? Xorg ?
Je continue de regarder... Mais peut tu tester avec LightDM en attendant ?

Edit 1:
As tu installé le paquet haveged et démarré/activé le service haveged.service
Peux tu refaire le test avec sddm et haveged d'activés et nous donner la sortie (après reboot) de :

Code : Tout sélectionner

journalctl -b
systemd-analyze
Edit 2:
J'ai bien trouvé le problème, il est indirectement dans sddm:

Code : Tout sélectionner

std::random_device rd;
std::mt19937 gen(rd());
La question c'est que faire dans ton cas... Car pour des questions de sécurité ce n'est pas terrible de ne pas attendre suffisamment longtemps d'avoir assez d'entropie pour généré un nombre random...

Edit 3:
Peux tu donner le contenu de /proc/cpuinfo

Edit 4:
Ok, ton CPU, un Intel Core i3-2310M n'a pas d'instruction rdrand (lien intéressant : https://github.com/linuxkit/linuxkit/issues/3096)

Edit 5:
Peux tu donner la sortie de

Code : Tout sélectionner

ls -l /var/lib/systemd/random-seed
systemctl status -l systemd-random-seed.service  
Édit 6: Si tu bouges la souris et tape au clavier n'importe quoi, le plus rapidement possible durant le démarrage du pc celui-ci devrait démarrer beaucoup plus vite.... Essaye :-)
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
Kristen
Elfe
Messages : 629
Inscription : ven. 14 oct. 2011, 10:24
Localisation : Finistère France

Re: [boot] blocage pendant environ 2 minutes

Message par Kristen » mar. 19 févr. 2019, 07:50

Whaou quel boulot !!!
Alors je commence par le Edit 1
Edit 1:
As tu installé le paquet haveged et démarré/activé le service haveged.service
Peux tu refaire le test avec sddm et haveged d'activés et nous donner la sortie (après reboot) de :

Code : Tout sélectionner

journalctl -b
systemd-analyze
Installation de haveged et activation du service haveged.service
Redémarrage de la machine et BINGO en 20/25 secondes je suis sur l'écran de connexion de sddm !
Je fais 3 stopage et lancement de la machine et pareil à chaque fois :D :D :D

Code : Tout sélectionner

systemd-analyze
Startup finished in 3.530s (kernel) + 1.447s (userspace) = 4.977s 
graphical.target reached after 1.214s in userspace
Je pense que c'est bon et que ça ne sert pas à grand chose de poursuivre. À moins que tu ne le souhaites ?

Je reste un peu comme ça avant de passer le sujet en résolu.

Édit 6: Si tu bouges la souris et tape au clavier n'importe quoi, le plus rapidement possible durant le démarrage du pc celui-ci devrait démarrer beaucoup plus vite.... Essaye :-)
Ça je pouvais répondre car effectivement, j'avais remarqué quand tapotant sur le clavier, j'arrivais plus vite à l'écran de connexion. J'aurai peut-être du le signaler mais je n'y ai pas pensé, désolé :(
Depuis le 14 octobre 2011 sur archlinux avec actuellement GNOME sur :
PC fixe i5 - CG GeForce GTX 750 Ti - Mémoire 12 Go - SSD128 Go - DD1000 Go
et
PC portable : Lenovo ThinkPad T520i et Lenovo Ideapad S130-14IGM

benjarobin
Maître du Kyudo
Messages : 15537
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [boot] blocage pendant environ 2 minutes

Message par benjarobin » mar. 19 févr. 2019, 08:42

Tu as un pc super rapide, mais malheureusement n'a pas assez de source d'entropie, c'est dommage car tu pourrais démarrer encore plus vite de 5 à 10s je pense
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
Kristen
Elfe
Messages : 629
Inscription : ven. 14 oct. 2011, 10:24
Localisation : Finistère France

Re: [boot] blocage pendant environ 2 minutes

Message par Kristen » mar. 19 févr. 2019, 09:28

Merci pour tout benjarobin
Un question encore, est-ce qu'il faut mieux que j'installe haveged sur mon autre PC ? Ou comment savoir si on doit l'installer ou pas ?
Depuis le 14 octobre 2011 sur archlinux avec actuellement GNOME sur :
PC fixe i5 - CG GeForce GTX 750 Ti - Mémoire 12 Go - SSD128 Go - DD1000 Go
et
PC portable : Lenovo ThinkPad T520i et Lenovo Ideapad S130-14IGM

benjarobin
Maître du Kyudo
Messages : 15537
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [boot] blocage pendant environ 2 minutes

Message par benjarobin » mar. 19 févr. 2019, 12:52

Je suis en train de me poser la même question... Car je l'ai d'activé suite à une vielle news de 2014 (https://archlinux.fr/news/gnupg-2-1-et- ... -de-pacman)...

Tient d’ailleurs ton problème était documenté dans le Wiki https://wiki.archlinux.org/index.php/SD ... he_greeter

Un autre lien intéressant : https://wiki.archlinux.org/index.php/Rng-tools
Donc personnellement je pense que je devrait utiliser le service rngd à la place de Haveged
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Répondre