[Interface graphique] Erreur divers sur chromebook (ouvert)

Architecture ARM, archlinuxarm, raspberrypi ...
OverSu
newbie
Messages : 2
Inscription : sam. 13 juil. 2019, 18:42

[Interface graphique] Erreur divers sur chromebook (ouvert)

Message par OverSu » sam. 13 juil. 2019, 18:55

Bonsoir tout le monde,

Voilà quelques semaines que je lutte avec mon Chromebook HP G1 qui est actuellement sous Arch ARM. Impossible pour moi d'installer une interface graphique.
Je me suis farcie un paquet de tutoriel et de message sur les diverses plateformes, à chaque fois j'avance, mais je me retrouve bloqué à un état donné.

Donc je fais appel à vous.

Je ne suis pas un expert en Arch, ni même en Linux d'ailleurs, mais je connais et comprends les bases++.
Mon Arch est à jour (avec la commande Syu) et XFCE4 est installé. D'aprés tous les forums parcouru, j'ai testé plusieurs drivers vidéos.
Aujourd'hui, quand je démarre linux avec startxfce4, je me retrouve avec un

Code : Tout sélectionner

NO SCREENS FOUND (EE)
Giving up
Unable to connect to x server: connection refused
On peut procédé à un diagnostic afin de pouvoir avancer ? ;)

Merci à tous !

Edit: Comment uploader un log via la ligne de command afin de vous faire parvenir quoi que ce soit ?

Nophke
Hankyu
Messages : 30
Inscription : lun. 03 juin 2019, 01:14

Re: [Interface graphique] Erreur divers sur chromebook (ouvert)

Message par Nophke » dim. 14 juil. 2019, 10:58

Bonjour,

Essaie de supprimer tous les fichiers de configuration que tu aurais pu creer/modifier dans ton installation.

( tous ce qui est dans /etc/X11/xorg.conf.d ainsi que le fichier /etc/X11/xorg.conf )

désinstalle tous les drivers que tu auras installé. Et ré-essaie.

Sans certitudes, mais je crois que tu es dans le cas suivant: (voir la note en bas de paragraphe) https://wiki.archlinux.org/index.php/In ... stallation

OverSu
newbie
Messages : 2
Inscription : sam. 13 juil. 2019, 18:42

Re: [Interface graphique] Erreur divers sur chromebook (ouvert)

Message par OverSu » mar. 16 juil. 2019, 10:34

Et bah c'était du rapide.

Après nettoyage complet, XFCE se lance bien à coup de startxfce4.

Par contre, je me retrouve avec le bureau sans aucune icone (ou du moins seulement une ou deux), des icones manquantes (le fameux "X") ainsi que la font ressemblant au Times.

Voici un screenshot horrible :

https://cloud.oversu.fr/nextcloud/index ... qYNHeJTAbd

Edit: Après un logout, je viens de voir diverses erreurs dans les logs. Notamment des choses concernants le theme hicolor ainsi que des keycodes non supportés. Je vais essayer de voir ça. Une idée de votre côté ?

Nophke
Hankyu
Messages : 30
Inscription : lun. 03 juin 2019, 01:14

Re: [Interface graphique] Erreur divers sur chromebook (ouvert)

Message par Nophke » mar. 16 juil. 2019, 17:27

Et bah c'était du rapide.
Quand c'est possible! :D
Après nettoyage complet, XFCE se lance bien à coup de startxfce4.
Marque ce fil comme résolu, et donne lui un titre un peu plus évocateur, (genre "[Xorg] configuration chromebook (résolu)").
Par contre, je me retrouve avec le bureau sans aucune icone (ou du moins seulement une ou deux), des icones manquantes (le fameux "X") ainsi que la font ressemblant au Times.
Regarde si tu as bien installé le *groupe* xfce4 et pas juste des paquets isolés. Pour l'instant, je ne sais pas quoi dire de plus...

En tous cas, il s'agit là d'un autre sujet, et çà mérite donc un l'ouverture d'un autre thread...


EDIT:

J'ai ajouté ce fameux paragrapghe à la version fr, et repris les pages du wiki qui concernent [[Xorg]], pour introduire le Kernel Mode Setting, et crée la page [[KMS]] en conséquence.

Je pense qu'il reste pas mal de travail du coté des pages Xorg, wayland, et les différents pilotes ([[AMDGPU]] par exemple...) pour gagner en structure et en clarté.... :(

Répondre