[Pacman] impossile de faire la mise a jour

Questions et astuces concernant l'installation et la configuration d'archlinux
benjibasson
Hankyu
Messages : 22
Inscription : sam. 01 mars 2014, 17:17

[Pacman] impossile de faire la mise a jour

Message par benjibasson »

Bonjour
il y a un nouveau bug qui empeche pacman de faire les mises à jours alors que la dernière mise a jour dattant de il y a 4 semaine s'est bien passé, que j'ai rien grabotté depuis
sudo pacman -Syu
:: Synchronisation des bases de données de paquets…
core est à jour
extra 1721,1 KiB 1608 KiB/s 00:01 [----------------------] 100%
community 6,6 MiB 2,07 MiB/s 00:03 [----------------------] 100%
multilib est à jour
archlinuxfr est à jour
:: Début de la mise à jour complète du système…
:: Remplacer sdl par community/sdl12-compat ? [O/n] O
résolution des dépendances…
:: Il y a 5 fournisseurs disponibles pour xdg-desktop-portal-impl :
:: Dépôt extra
1) xdg-desktop-portal-gnome 2) xdg-desktop-portal-gtk
3) xdg-desktop-portal-kde
:: Dépôt community
4) xdg-desktop-portal-lxqt 5) xdg-desktop-portal-wlr

Entrer un nombre (par défaut, 1 est sélectionné): 1
recherche des conflits entre paquets…
avertissement : cycle de dépendances détecté :
avertissement : libglvnd sera installé avant sa dépendance mesa
avertissement : cycle de dépendances détecté :
avertissement : harfbuzz sera installé avant sa dépendance freetype2
avertissement : cycle de dépendances détecté :
avertissement : smbclient sera installé avant sa dépendance cifs-utils
avertissement : cycle de dépendances détecté :
avertissement : lib32-mesa sera installé avant sa dépendance lib32-libglvnd
avertissement : cycle de dépendances détecté :
avertissement : lib32-harfbuzz sera installé avant sa dépendance lib32-freetype2

Paquets (266) akonadi-contacts-22.04.1-1 alsa-card-profiles-1:0.3.51-1
android-tools-31.0.3-5 appstream-glib-0.7.18-2
archlinux-keyring-20220424-1 at-spi2-core-2.44.1-1
audit-3.0.8-1 binutils-2.38-5 bison-3.8.2-4 brotli-1.0.9-8
btrfs-progs-5.17-1 bubblewrap-0.6.2-1
ca-certificates-mozilla-3.78-1 calibre-5.42.0-2
chromium-101.0.4951.64-1 cifs-utils-6.15-1
clementine-1.4.0rc1+776+gcefe81d0c-2 clutter-gst-3.0.27-4
coin-or-cbc-2.10.8-1 coin-or-cgl-0.60.6-1 conky-1.12.2-2
cronie-1.6.1-1 curl-7.83.1-1 dav1d-1.0.0-1
dialog-1:1.3_20220414-1 digikam-7.6.0-2 elfutils-0.187-1
enchant-2.3.3-1 eog-42.1-1 epiphany-42.2-1
evolution-data-server-3.44.1-1 exiv2-0.27.5-3 faudio-22.05-1
ffmpeg-2:5.0-7 ffmpeg4.4-4.4.1-5 firefox-100.0-1
flatpak-1:1.12.7-1 fluidsynth-2.2.7-1 freetype2-2.12.1-1
fribidi-1.0.12-1 fuse-common-3.11.0-1 fuse3-3.11.0-1
gavl-1.4.0-6 gcab-1.4-1 gcc-12.1.0-1 gcc-libs-12.1.0-1
gd-2.3.3-4 gimp-2.10.30-3 git-2.36.1-1 glew-2.2.0-3
glib2-2.72.1-1 glibc-2.35-5 glibmm-2.66.4-1 glslang-11.9.0-1
glu-9.0.2-3 gnome-control-center-42.1-2 gnome-desktop-1:42.1-1
gnome-desktop-4-1:42.1-1 gnome-desktop-common-1:42.1-1
gnome-shell-1:42.1-1 gnome-shell-extensions-42.1-1
gnupg-2.2.35-2 gnutls-3.7.4-3 grantleetheme-22.04.1-1
gspell-1.10.0-2 gst-libav-1.20.2-1 gst-plugin-gtk-1.20.2-1
gst-plugin-pipewire-1:0.3.51-1 gst-plugins-bad-1.20.2-1
gst-plugins-bad-libs-1.20.2-1 gst-plugins-base-1.20.2-1
gst-plugins-base-libs-1.20.2-1 gst-plugins-good-1.20.2-1
gst-plugins-ugly-1.20.2-1 gstreamer-1.20.2-1
gtk-update-icon-cache-1:4.6.4-1 gtk3-1:3.24.33+r28+g01edbfb976-1
gtk4-1:4.6.4-1 gtkmm3-3.24.6-1 gtksourceview5-5.4.1-1
gvfs-1.50.1-1 gvfs-smb-1.50.1-1 harfbuzz-4.2.1-1
harfbuzz-icu-4.2.1-1 hplip-1:3.22.4-1 hwdata-0.359-1
iana-etc-20220427-1 imagemagick-7.1.0.33-1 imlib2-1.9.0-3
intel-ucode-20220510-1 iproute2-5.17.0-3 jansson-2.14-2
jasper-2.0.33-2 json-c-0.16-1 k3b-1:22.04.1-1
kaccounts-integration-22.04.1-1 kmime-22.04.1-1 kodi-19.4-5
kpimtextedit-22.04.1-1 lib32-curl-7.83.1-1 lib32-faudio-22.05-1
lib32-freetype2-2.12.1-1 lib32-gcc-libs-12.1.0-1
lib32-glib2-2.72.1-1 lib32-glibc-2.35-5 lib32-glu-9.0.2-3
lib32-harfbuzz-4.2.1-1 lib32-libcap-2.64-1 lib32-libelf-0.187-1
lib32-libglvnd-1.4.0-2 lib32-libltdl-2.4.7-2
lib32-libnl-3.6.0-1 lib32-libtiff-4.3.0-2
lib32-libunistring-1.0-1 lib32-libx11-1.8-1 lib32-libxcb-1.15-1
lib32-libxcursor-1.2.1-1 lib32-libxml2-2.9.14-1
lib32-mesa-22.0.3-1 lib32-openal-1.22.0-1 lib32-sdl2-2.0.22-1
lib32-sqlite-3.38.3-1 lib32-systemd-250.5-1
lib32-vulkan-icd-loader-1.3.213-1 lib32-zlib-1.2.12-1
libadwaita-1:1.1.1-1 libaio-0.3.113-1 libakonadi-22.04.1-1
libappindicator-gtk3-12.10.0.r296-2 libavif-0.10.1-1
libbsd-0.11.6-2 libcap-2.64-1 libcap-ng-0.8.3-1
libcgif-0.3.0-1 libdbusmenu-glib-16.04.0-5
libdbusmenu-gtk3-16.04.0-5 libelf-0.187-1
libfilezilla-1:0.37.2-1 libglvnd-1.4.0-2 libgudev-237-2
libhandy-1.6.2-1 libindicator-gtk3-12.10.1-10 libinih-55-2
libinput-1.20.1-1 libkcddb-22.04.1-1 libkleo-22.04.1-1
libksane-22.04.1-1 libmanette-0.2.6-3 libmbim-1.26.4-1
libmm-glib-1.18.8-1 libnautilus-extension-42.1.1-1
libnice-0.1.19-1 libnl-3.6.0-3 libnotify-0.7.12-1
libopenmpt-0.6.3-1 libpgm-5.3.128-2 libphonenumber-1:8.12.47-1
libpipeline-1.5.6-1 libqmi-1.30.6-1 libqrtr-glib-1.2.2-2
libreoffice-fresh-7.3.3-2 librsvg-2:2.54.3-1 libsasl-2.1.28-1
libseccomp-2.5.4-1 libshout-1:2.4.6-1 libsynctex-2022.62885-1
libtool-2.4.7-2 libunistring-1.0-1 libunrar-1:6.1.7-1
libx11-1.8-1 libxcb-1.15-1 libxml2-2.9.14-1
libxnvctrl-515.43.04-1 libyuv-r2322+3aebf69d-1
linux-5.17.7.arch1-1 linux-api-headers-5.17.5-2
linux-lts-5.15.39-1 lrzip-0.641-2 lua52-expat-1.4.1-2
luajit-2.1.0.beta3.r404.g3ee3c9cf-1 luit-20220111-1
malcontent-0.10.3-2 marble-common-22.04.1-1 mesa-22.0.3-1
minizip-1:1.2.12-2 mobile-broadband-provider-info-20220511-1
modemmanager-1.18.8-1 mpg123-1.29.3-2 mutter-42.1-1 nano-6.3-1
nautilus-42.1.1-1 ncurses-6.3-3 ndctl-73-1 nss-3.78-1
openal-1.22.0-1 opencv-4.5.5-5 openssl-1.1.1.o-1
opera-86.0.4363.59-1 ostree-2022.3-1 pacman-6.0.1-5
pacman-mirrorlist-20220501-1 pciutils-3.8.0-1 pcre2-10.40-1
pipewire-1:0.3.51-1 pipewire-media-session-1:0.4.1-2
podofo-0.9.8-1 polkit-gnome-0.105-9 poppler-22.05.0-1
poppler-glib-22.05.0-1 poppler-qt5-22.05.0-1
power-profiles-daemon-0.11.1-1 protobuf-3.20.1-2 psmisc-23.5-1
python-cryptography-37.0.0-1 python-dnspython-1:2.2.1-1
python-markdown-3.3.7-1 python-more-itertools-8.12.0-2
python-packaging-21.3-1 python-psutil-5.9.0-2
python-py7zr-0.18.5-1 python-pygments-2.12.0-1
python-setuptools-1:60.3.1-1 qt5-base-5.15.3+kde+r145-1
samba-4.16.1-3 sdl-1:1.2.15+r406+gf1caf909-1 [suppression]
sdl12-compat-1.2.52-2 sdl2-2.0.22-1 shaderc-2022.1-3
signal-desktop-5.43.0-1 signon-kwallet-extension-22.04.1-1
smbclient-4.16.1-3 sqlite-3.38.5-1 systemd-250.5-1
systemd-libs-250.5-1 systemd-sysvcompat-250.5-1
thunar-4.16.11-2 thunar-archive-plugin-0.5.0-2
thunderbird-91.9.0-1 tinyxml-2.6.2-9 tor-0.4.7.7-1
transmission-gtk-3.00-4 unixodbc-2.3.10-1 unrar-1:6.1.7-1
virtualbox-6.1.34-2 virtualbox-host-modules-arch-6.1.34-6
vlc-3.0.17.4-3 vulkan-headers-1:1.3.213-1
vulkan-icd-loader-1.3.213-1 waylandpp-1.0.0-1
webkit2gtk-2.36.1-1 webkit2gtk-4.1-2.36.1-1 wine-7.7-1
xcb-proto-1.15-1 xdg-dbus-proxy-0.1.4-1
xdg-desktop-portal-1.14.4-1 xdg-desktop-portal-gnome-42.1-1
xdg-desktop-portal-gtk-1.14.0-1 xfce4-settings-4.16.2-2
xfce4-terminal-1.0.3-1 xfsprogs-5.16.0-1 xmlsec-1.2.34-1
xorg-xauth-1.1.2-1 xorgproto-2022.1-1 zenity-3.42.1-1
zlib-1:1.2.12-2 zxing-cpp-1.3.0-1

Taille totale du téléchargement : 0,02 MiB
Taille totale installée : 5121,33 MiB
Taille de mise à jour nette : 22,69 MiB

:: Procéder à l’installation ? [O/n] O
:: Récupération des paquets…
libinih-55-2-x86_64 15,4 KiB 270 KiB/s 00:00 [----------------------] 100%
(265/265) vérification des clés dans le trousseau [----------------------] 100%
téléchargement des clés requises…
:: Importer la clé PGP 0F65C7D881506130, « Maxime Gauduin <alucryd@archlinux.org> » ? [O/n] O
(265/265) vérification de l’intégrité des paquets [----------------------] 100%
erreur : libinih : la clé « 95220BE99CE6FF778AE0DC670F65C7D881506130 » est inconnue
:: Importer la clé PGP 95220BE99CE6FF778AE0DC670F65C7D881506130 ? [O/n] O
erreur : la clé « 95220BE99CE6FF778AE0DC670F65C7D881506130 » ne peut être recherchée à distance
:: Le fichier /var/cache/pacman/pkg/libinih-55-2-x86_64.pkg.tar.zst est corrompu (paquet non valide ou corrompu (signature PGP)).
Voulez-vous le supprimer ? [O/n] O
erreur : la validation de la transaction a échoué (paquet non valide ou corrompu)
Des erreurs se sont produites, aucun paquet n’a été mis à jour.

Comment faire pour faire les mises à jours SVP? comment faire pour que cela ne se reproduise plus?
Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10685
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [Pacman] impossile de faire la mise a jour

Message par FoolEcho »

Salut,

Commence par mettre à jour archlinux-keyring avant le reste du système:

Code : Tout sélectionner

pacman -Sy archlinux-keyring && pacman -Su
«The following statement is not true. The previous statement is true.» :nage:
Avatar de l’utilisateur
Chon
Daikyu
Messages : 86
Inscription : jeu. 15 févr. 2018, 09:31

Re: [Pacman] impossile de faire la mise a jour

Message par Chon »

Bonjour à tous,
Même problème de MaJ que benjibasson pour mon système et la MaJ préliminaire donnée par FoolEcho a résolu le pb.
Merci.
ArchLinux/SysLinux/XFce en MonoBoot et MonoUser
GIGABYTE Brix GB-BXi3-4010 - RAM 8Go - SSD 120Go - Video Intel HD Graphics 4400 - Audio Realtek ALC269
Répondre