[MàJ] Plus de noyau aprés MàJ ??

Questions et astuces concernant l'installation et la configuration d'archlinux
Avatar de l’utilisateur
LuX
yeomen
Messages : 214
Inscription : lun. 17 mai 2010, 13:56
Localisation : Angers (France)

[MàJ] Plus de noyau aprés MàJ ??

Message par LuX »

Bonjour

Mise à jour d'Arch aujourd'hui. La dernière datait du 30 avril. L'ordi s'éteint en cours de route, je n'ai pas vu pourquoi (je ne le regardais pas à ce moment-là). Au redémarrage, une fois passé le menu de Grub :

Code : Tout sélectionner

Chargement de Linux linux...
erreur : fichier « /boot/vmlinuz-linux » non disponible.
Chargement du disque memoire initial...
erreur : le noyau doit d'abord être chargé.
J'ai essayé de démarrer à partir de l'entrée suivante dans le menu de Grub :

Code : Tout sélectionner

Options avancée pour Arch Linux
Ça donne sur un sous-menu avec deux entrées :

Code : Tout sélectionner

Arch Linux, avec Linux linux
Arch Linux, avec Linux linux (fallback initramfs)
Mais l'une comme l'autre produit la même erreur rapportée plus haut.

En demarrant sur un OS d'une autre partition, j'ai pu monter celle d'Arch et inspecter son contenu. Je constate que le répertoire /boot ne contient effectivement pas de fichier vmlinuz-linux. En fait, il ne contient rien d'autre que le répertoire /boot/grub.

Voici la trace laissée par pacman de cette mise à jour :

Code : Tout sélectionner

[2022-06-02T16:37:41+0200] [PACMAN] Running 'pacman -Suy'
[2022-06-02T16:37:41+0200] [PACMAN] synchronizing package lists
[2022-06-02T16:37:46+0200] [PACMAN] starting full system upgrade
[2022-06-02T16:49:03+0200] [ALPM] running '60-mkinitcpio-remove.hook'...
[2022-06-02T16:49:04+0200] [ALPM] transaction started
[2022-06-02T16:49:04+0200] [ALPM] removed sdl (1:1.2.15+r406+gf1caf909-1)
[2022-06-02T16:49:04+0200] [ALPM] upgraded linux-api-headers (5.16.8-1 -> 5.17.5-2)
[2022-06-02T16:49:05+0200] [ALPM] upgraded glibc (2.35-3 -> 2.35-5)
[2022-06-02T16:49:05+0200] [ALPM-SCRIPTLET] Generating locales...
[2022-06-02T16:49:10+0200] [ALPM-SCRIPTLET]   es_US.UTF-8... done
[2022-06-02T16:49:14+0200] [ALPM-SCRIPTLET]   fr_FR.UTF-8... done
[2022-06-02T16:49:14+0200] [ALPM-SCRIPTLET] Generation complete.
[2022-06-02T16:49:16+0200] [ALPM] upgraded gcc-libs (11.2.0-4 -> 12.1.0-2)
[2022-06-02T16:49:17+0200] [ALPM] upgraded openssl (1.1.1.n-1 -> 1.1.1.o-1)
[2022-06-02T16:49:18+0200] [ALPM] upgraded ncurses (6.3-2 -> 6.3-3)
[2022-06-02T16:49:18+0200] [ALPM] upgraded libsasl (2.1.27-3 -> 2.1.28-1)
[2022-06-02T16:49:18+0200] [ALPM] upgraded libldap (2.6.1-1 -> 2.6.2-2)
[2022-06-02T16:49:18+0200] [ALPM] upgraded systemd-libs (250.5-1 -> 251.1-1)
[2022-06-02T16:49:18+0200] [ALPM] upgraded gmp (6.2.1-1 -> 6.2.1-2)
[2022-06-02T16:49:18+0200] [ALPM] upgraded ca-certificates-mozilla (3.77-1 -> 3.79-1)
[2022-06-02T16:49:18+0200] [ALPM] upgraded libunistring (0.9.10-3 -> 1.0-1)
[2022-06-02T16:49:18+0200] [ALPM] upgraded curl (7.83.0-1 -> 7.83.1-1)
[2022-06-02T16:49:18+0200] [ALPM] upgraded libelf (0.186-5 -> 0.187-1)
[2022-06-02T16:49:19+0200] [ALPM] upgraded binutils (2.38-4 -> 2.38-5)
[2022-06-02T16:49:29+0200] [ALPM] upgraded btrfs-progs (5.17-1 -> 5.18-1)
[2022-06-02T16:49:30+0200] [ALPM] upgraded clucene (2.3.3.4-11 -> 2.3.3.4-12)
[2022-06-02T16:49:30+0200] [ALPM] upgraded gnutls (3.7.4-2 -> 3.7.6-1)
[2022-06-02T16:49:30+0200] [ALPM] upgraded glib2 (2.72.1-1 -> 2.72.2-1)
[2022-06-02T16:49:30+0200] [ALPM] upgraded libjpeg-turbo (2.1.3-1 -> 2.1.3-2)
[2022-06-02T16:49:30+0200] [ALPM] upgraded libcups (1:2.4.1-1 -> 1:2.4.2-1)
[2022-06-02T16:49:31+0200] [ALPM] upgraded iptables (1:1.8.7-1 -> 1:1.8.8-1)
[2022-06-02T16:49:31+0200] [ALPM] upgraded hwdata (0.358-1 -> 0.359-1)
[2022-06-02T16:49:31+0200] [ALPM] upgraded pcre2 (10.39-1 -> 10.40-1)
[2022-06-02T16:49:31+0200] [ALPM] upgraded device-mapper (2.03.15-1 -> 2.03.16-1)
[2022-06-02T16:49:33+0200] [ALPM] upgraded systemd (250.5-1 -> 251.1-1)
[2022-06-02T16:49:36+0200] [ALPM] upgraded libpaper (1.1.28-1 -> 1.1.28-2)
[2022-06-02T16:49:36+0200] [ALPM] upgraded openjpeg2 (2.4.0-1 -> 2.5.0-1)
[2022-06-02T16:49:36+0200] [ALPM] upgraded sqlite (3.38.3-1 -> 3.38.5-1)
[2022-06-02T16:49:36+0200] [ALPM] upgraded nspr (4.33-2 -> 4.34-1)
[2022-06-02T16:49:36+0200] [ALPM] upgraded nss (3.77-1 -> 3.79-1)
[2022-06-02T16:49:36+0200] [ALPM] upgraded graphite (1:1.3.14-1 -> 1:1.3.14-2)
[2022-06-02T16:49:36+0200] [ALPM] upgraded harfbuzz (4.2.1-1 -> 4.3.0-1)
[2022-06-02T16:49:37+0200] [ALPM] upgraded freetype2 (2.12.0-2 -> 2.12.1-1)
[2022-06-02T16:49:37+0200] [ALPM] upgraded xcb-proto (1.14.1-5 -> 1.15-1)
[2022-06-02T16:49:37+0200] [ALPM] upgraded libxdmcp (1.1.3-3 -> 1.1.3-4)
[2022-06-02T16:49:37+0200] [ALPM] upgraded libxau (1.0.9-3 -> 1.0.9-4)
[2022-06-02T16:49:37+0200] [ALPM] upgraded libxcb (1.14-1 -> 1.15-1)
[2022-06-02T16:49:38+0200] [ALPM] upgraded libx11 (1.7.5-1 -> 1.8-1)
[2022-06-02T16:49:38+0200] [ALPM] upgraded libxext (1.3.4-3 -> 1.3.4-4)
[2022-06-02T16:49:38+0200] [ALPM] upgraded libxrender (0.9.10-4 -> 0.9.10-5)
[2022-06-02T16:49:38+0200] [ALPM] upgraded pixman (0.40.0-1 -> 0.40.0-2)
[2022-06-02T16:49:38+0200] [ALPM] upgraded poppler (22.03.0-1 -> 22.05.0-2)
[2022-06-02T16:49:38+0200] [ALPM] upgraded ijs (0.35-3 -> 0.35-4)
[2022-06-02T16:49:38+0200] [ALPM] upgraded libxml2 (2.9.13-2 -> 2.9.14-1)
[2022-06-02T16:49:38+0200] [ALPM] upgraded libtool (2.4.7-1 -> 2.4.7-2)
[2022-06-02T16:49:39+0200] [ALPM] upgraded imagemagick (7.1.0.31-1 -> 7.1.0.36-2)
[2022-06-02T16:49:39+0200] [ALPM] upgraded cups (1:2.4.1-1 -> 1:2.4.2-1)
[2022-06-02T16:49:39+0200] [ALPM] upgraded dav1d (0.9.2-1 -> 1.0.0-1)
[2022-06-02T16:49:40+0200] [ALPM] upgraded elfutils (0.186-5 -> 0.187-1)
[2022-06-02T16:49:40+0200] [ALPM] upgraded fakeroot (1.28-1 -> 1.29-1)
[2022-06-02T16:49:42+0200] [ALPM] upgraded libasyncns (0.8+3+g68cd5af-3 -> 1:0.8+r3+g68cd5af-1)
[2022-06-02T16:49:42+0200] [ALPM] upgraded libice (1.0.10-3 -> 1.0.10-4)
[2022-06-02T16:49:42+0200] [ALPM] upgraded libsm (1.2.3-2 -> 1.2.3-3)
[2022-06-02T16:49:42+0200] [ALPM] upgraded libpulse (15.0-4 -> 16.0-1)
[2022-06-02T16:49:42+0200] [ALPM] upgraded librsvg (2:2.54.1-1 -> 2:2.54.3-1)
[2022-06-02T16:49:42+0200] [ALPM] upgraded libxv (1.0.11-4 -> 1.0.11-5)
[2022-06-02T16:49:42+0200] [ALPM] upgraded libxxf86vm (1.1.4-4 -> 1.1.4-5)
[2022-06-02T16:49:42+0200] [ALPM] upgraded libxdamage (1.1.5-3 -> 1.1.5-4)
[2022-06-02T16:49:42+0200] [ALPM] upgraded libxshmfence (1.3-2 -> 1.3-3)
[2022-06-02T16:49:45+0200] [ALPM] upgraded llvm-libs (13.0.1-2 -> 13.0.1-6)
[2022-06-02T16:49:46+0200] [ALPM] upgraded vulkan-icd-loader (1.3.208-1 -> 1.3.213-1)
[2022-06-02T16:49:46+0200] [ALPM] upgraded libpciaccess (0.16-2 -> 0.16-3)
[2022-06-02T16:49:56+0200] [ALPM] upgraded mesa (22.0.2-1 -> 22.1.0-1)
[2022-06-02T16:49:56+0200] [ALPM] upgraded libglvnd (1.4.0-1 -> 1.4.0-2)
[2022-06-02T16:49:56+0200] [ALPM] upgraded hidapi (0.11.2-1 -> 0.12.0-1)
[2022-06-02T16:49:56+0200] [ALPM] upgraded sdl2 (2.0.22-1 -> 2.0.22-2)
[2022-06-02T16:50:02+0200] [ALPM] upgraded ffmpeg (2:5.0-6 -> 2:5.0-7)
[2022-06-02T16:50:12+0200] [ALPM] upgraded ffmpeg4.4 (4.4.1-4 -> 4.4.1-5)
[2022-06-02T16:50:12+0200] [ALPM] upgraded libxinerama (1.1.4-3 -> 1.1.4-4)
[2022-06-02T16:50:12+0200] [ALPM] upgraded libxrandr (1.5.2-3 -> 1.5.2-4)
[2022-06-02T16:50:13+0200] [ALPM] upgraded libxcomposite (0.4.5-3 -> 0.4.5-4)
[2022-06-02T16:50:13+0200] [ALPM] upgraded libxkbcommon (1.4.0-1 -> 1.4.1-1)
[2022-06-02T16:50:20+0200] [ALPM] upgraded iso-codes (4.9.0-1 -> 4.10.0-1)
[2022-06-02T16:50:21+0200] [ALPM] upgraded libproxy (0.4.17-6 -> 0.4.17-7)
[2022-06-02T16:50:21+0200] [ALPM] upgraded tracker3 (3.3.0-2 -> 3.3.1-1)
[2022-06-02T16:50:21+0200] [ALPM] upgraded gtk-update-icon-cache (1:4.6.3-1 -> 1:4.6.5-1)
[2022-06-02T16:50:21+0200] [ALPM] upgraded libxtst (1.2.3-4 -> 1.2.3-5)
[2022-06-02T16:50:28+0200] [ALPM] upgraded gtk3 (1:3.24.33-3 -> 1:3.24.34-1)
[2022-06-02T16:50:37+0200] [ALPM] upgraded noto-fonts (20201226-2 -> 20220502-3)
Je ne comprends pas ce qui a pu se passer. J'aimerais éviter de tout ré-installer à partir de zéro... Une suggestion ?

Cordialement,
LuX
benjarobin
Maître du Kyudo
Messages : 16481
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [MàJ] Plus de noyau aprés MàJ ??

Message par benjarobin »

Bonjour,
C'est parfaitement "normal" que si tu interrompt la mise à jour en plein milieu de ne plus avoir de kernel dans /boot. C'est suite à un changement "récent" (environ 1 an).
Bref, pour réparer, c'est assez "simple", tu chroot avec arch-chroot et relances la mise à jour en spécifiant tous les paquets qui n'ont pas été mise à jour (le paquet linux, ...)
Zsh | KDE | PC fixe : core i7, carte nvidia
Titre d'un sujet : [Thème] Sujet (état) / Règles du forum
Avatar de l’utilisateur
LuX
yeomen
Messages : 214
Inscription : lun. 17 mai 2010, 13:56
Localisation : Angers (France)

Re: [MàJ] Plus de noyau aprés MàJ ??

Message par LuX »

Bonjour Benjrobin

Merci pour ta réponse.

Avant de l'avoir vue, j'ai tenté une manip' barbare : copier dans /boot les fichiers vmlinuz-linux et initramfs-linux.img pris dans le répertoire boot/x86_64/ de la dernière iso.

Résultat : l'étape qui bloquait passe, l'ordi affiche "Starting version 251.1-1-arch", puis noir une demi-seconde, mais malheureusement revient sur "Starting version 251.1-1-arch" et au bout d'un moment ajoute :

Code : Tout sélectionner

ERROR: '/dev/disk/by-label' didn't show up after 30 seconds...
   Falling back to interactive prompt
   You can try to fix the problem manually, log out when you are finished
sh: can't access tty; job control turned off
Suivi d'une invite de commande '[rootfs ]#'

Le répertoire /dev de ma partition système est effectivement vide. Mais dans /etc/fstab les partitions sont appelées pas UUID=, pas par LABEL=.

Bon, bref, je vais voir comment faire pour relancer l'installation dans un arch-chroot comme tu dis.
LuX
benjarobin
Maître du Kyudo
Messages : 16481
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [MàJ] Plus de noyau aprés MàJ ??

Message par benjarobin »

Ce que tu as fait avait aucune chance de fonctionner...
Zsh | KDE | PC fixe : core i7, carte nvidia
Titre d'un sujet : [Thème] Sujet (état) / Règles du forum
Avatar de l’utilisateur
LuX
yeomen
Messages : 214
Inscription : lun. 17 mai 2010, 13:56
Localisation : Angers (France)

Re: [MàJ] Plus de noyau aprés MàJ ??

Message par LuX »

benjarobin a écrit : jeu. 02 juin 2022, 21:16 Ce que tu as fait avait aucune chance de fonctionner...
Sans doute, sans doute, mais faute de mieux ça ne coûtait rien d'essayer... :|

En tout cas, j'ai lancé un "pacman -Suy" dans un arch-chroot (après avoir effacé /var/lib/pacman/db.lck qui causait une erreur) et j'ai pu ensuite redemarrer jusqu'au bout, merci. :chinois:

Enfin... presque. :(
En effet, après un temps assez long il affiche une erreur :

Code : Tout sélectionner

[FAILED] Failed to start dhcpcd on wlan0
C'est sans doute dû au fait que je ne suis pas chez moi, donc pas sur ma box habituelle. Pourtant j'ai créé un fichier /etc/wpa_supplicant/wpa_supplicant-wlan0.conf mais bon...

Puis la session X démarre, et reste suspendue sur un écran noir. En passant aux tty, je peux me connecter, et en passant 'pacman -Suy' confirme que mon système est à jour. Le contenu de /var/log/Xorg.0.log se termine par une liste d'erreurs (EE) commençant par :

Code : Tout sélectionner

AIGLX error: unable to load driver i915
LuX
benjarobin
Maître du Kyudo
Messages : 16481
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [MàJ] Plus de noyau aprés MàJ ??

Message par benjarobin »

Tu n'as pas fait ce que j'avais indiqué : relances la mise à jour en spécifiant (en plus) tous les paquets qui n'ont pas été mise à jour.

Donc il ne fallait pas simplement faire :
pacman -Suy, mais plutôt : pacman -Suy linux ...

Bref, tu peux faire ceci depuis le chroot si tu ne sais pas obtenir la liste des paquets :
pacman -S $(pacman -Qnq)
Zsh | KDE | PC fixe : core i7, carte nvidia
Titre d'un sujet : [Thème] Sujet (état) / Règles du forum
Répondre