[Nano] enregister et quitter ne fonctionne plus (Résolu)

Questions et astuces concernant l'installation et la configuration d'archlinux
Avatar de l’utilisateur
banditblue
Elfe
Messages : 587
Inscription : dim. 10 janv. 2010, 10:19

[Nano] enregister et quitter ne fonctionne plus (Résolu)

Message par banditblue »

Salut la communauté

sur une nouvelle installation toute fraîche sur un nouveau pc portable, j'ai ce petit soucis avec nano (le dernier en date)
quand j’édite (peu importe) le fichier, que je le modifie, en utilisant les touche Contrôle + X je ne peu plus l’enregistrer et quitter le fichier

comment contourner ou rétablir ce problème ?
merci d'avance
La connaîssance n'a pas de limite.
Mais sa valeur, est d'autant plus grande, une fois partagé


Pc fixe --- MSI MPG Z490 Gaming Edge WiFi, I9-9900Kf, RTX3070Ti, 64Go DDR4, SSD 1Tera nvme gen4 Samsung 980 pro, SSD 1Tera WD Blacksn850X,3HDD 5Tera
Eeepc Asus 1015pem --- Intel Atom N550 Dual-core 1.5Ghz / DD 1Tera 7200rpm / Ram 2Go

Screenshot + Les Conky ===> http://forums.archlinux.fr/post85405.html#p85405
JeanBon
Hankyu
Messages : 16
Inscription : ven. 16 déc. 2022, 19:34

Re: [Nano] enregister et quitter ne fonctionne plus (en cours)

Message par JeanBon »

Bonjour,
c'est
"ctrl + x"
"o" pour oui ou "y" pour yes
et "n" pour non/no
Tu bloques à quelle étape ?
Es tu bien en fr partout ?
Avatar de l’utilisateur
banditblue
Elfe
Messages : 587
Inscription : dim. 10 janv. 2010, 10:19

Re: [Nano] enregister et quitter ne fonctionne plus (en cours)

Message par banditblue »

JeanBon a écrit : ven. 09 févr. 2024, 11:56 Bonjour,
c'est
"ctrl + x"
"o" pour oui ou "y" pour yes
et "n" pour non/no
Tu bloques à quelle étape ?
Es tu bien en fr partout ?
je connais toutes ces commande que tu cite, oui je suis bien en français de partout
je bloque uniquement sur cette opération de quitter nano, a croire que ctrl + x ne fonctionne pas (alors que toutes les autres fonction ctrl + ... ne me pose pas de problème )
La connaîssance n'a pas de limite.
Mais sa valeur, est d'autant plus grande, une fois partagé


Pc fixe --- MSI MPG Z490 Gaming Edge WiFi, I9-9900Kf, RTX3070Ti, 64Go DDR4, SSD 1Tera nvme gen4 Samsung 980 pro, SSD 1Tera WD Blacksn850X,3HDD 5Tera
Eeepc Asus 1015pem --- Intel Atom N550 Dual-core 1.5Ghz / DD 1Tera 7200rpm / Ram 2Go

Screenshot + Les Conky ===> http://forums.archlinux.fr/post85405.html#p85405
Avatar de l’utilisateur
banditblue
Elfe
Messages : 587
Inscription : dim. 10 janv. 2010, 10:19

Re: [Nano] enregister et quitter ne fonctionne plus (en cours)

Message par banditblue »

bon beh c'est toujours pareil
Pas de possibilité d'enregistrer le fichier avec la commande "ctrl + x" dans nano le seul moyen que j'ai de quitter, c'est de faire un hard reset "ctrl + alt+suppr"

pour info j'ai tenté avec vim mais c'est pareil pour quitter, il ne veux rien savoir
La connaîssance n'a pas de limite.
Mais sa valeur, est d'autant plus grande, une fois partagé


Pc fixe --- MSI MPG Z490 Gaming Edge WiFi, I9-9900Kf, RTX3070Ti, 64Go DDR4, SSD 1Tera nvme gen4 Samsung 980 pro, SSD 1Tera WD Blacksn850X,3HDD 5Tera
Eeepc Asus 1015pem --- Intel Atom N550 Dual-core 1.5Ghz / DD 1Tera 7200rpm / Ram 2Go

Screenshot + Les Conky ===> http://forums.archlinux.fr/post85405.html#p85405
Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 17156
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Nano] enregister et quitter ne fonctionne plus (en cours)

Message par benjarobin »

Bonjour,
Tu es dans un tty ou dans une console virtuelle (si oui laquelle, et sous Xorg ou Wayland, bref le maximum de détails) ?
Quelle est la sortie depuis le terminal où tu lances nano ou vim :

Code : Tout sélectionner

localectl
cat /etc/vconsole.conf
locale -a
locale
env | grep -E "LANG|LC"
Pour vim tu n'arrives pas à utiliser la touche echap ? Car pour quitter vim, sans être entré en édition, tu n'as besoin d'aucune séquence "magique", juste taper :q
Zsh | KDE | PC fixe : core i7, carte nvidia
Titre d'un sujet : [Thème] Sujet (état) / Règles du forum
Avatar de l’utilisateur
banditblue
Elfe
Messages : 587
Inscription : dim. 10 janv. 2010, 10:19

Re: [Nano] enregister et quitter ne fonctionne plus (en cours)

Message par banditblue »

Merci benjarobin, je vais tenter de répondre à tes questions
Tu es dans un tty ou dans une console virtuelle (si oui laquelle
Actuellement je ne suis qu’en tty1, mais c'est pareil sur tout les autre tty
et sous Xorg ou Wayland ?
je n’ai pas encore installé Xorg
bref le maximum de détails) ?
j'en suis au tout début de l'installation a peine installé la base depuis le dernier iso archlinux depuis la clef USB
me suis connecté en user et lancé nano pour pouvoir configurer grub depuis la détection de Windows et l’inscrire dans le fichier grub.cfg
Quelle est la sortie depuis le terminal où tu lances nano ?
Voilà ce que me renvoie ces commandes:

localectl

Code : Tout sélectionner

System locale: LANG=fr_FR.UTF-8
                       LC_COLLATE=C
    VC Keymap: fr-latin9
    X11 Layout: (unset)
cat /etc/vconsole.conf

Code : Tout sélectionner

KEYMAP=fr-latin9
FONT=eurlatgr
locale -a

Code : Tout sélectionner

C
C.utf8
POSIX 
fr_FR.UTF-8
locale

Code : Tout sélectionner

LANG=fr_FR.UTF-8
LC_CTYPE=« fr_FR.UTF-8 »
LC_NUMERIC=« fr_FR.UTF-8 »
LC_TIME=« fr_FR.UTF-8 »
LC_COLLATE=C
LC_MONETARY=« fr_FR.UTF-8 »
LC_PAPER=« fr_FR.UTF-8 »
LC_NAME=« fr_FR.UTF-8 »
LC_ADDRESS=« fr_FR.UTF-8 »
LC_TELEPHONE=« fr_FR.UTF-8 »
LC_MEASUREMENT=« fr_FR.UTF-8 »
LC_IDENTIFICATION=« fr_FR.UTF-8 »
LC_ALL=
env | grep -E "LANG|LC"

Code : Tout sélectionner

LANG=fr_FR.UTF-8
LC_COLLATE=C
Pour vim tu n'arrives pas à utiliser la touche echap ? Car pour quitter vim, sans être entré en édition, tu n'as besoin d'aucune séquence "magique", juste taper :q
J’avoue que je n’utilise que peu vim, mais je m’en souviendrai si je l’utilise
La connaîssance n'a pas de limite.
Mais sa valeur, est d'autant plus grande, une fois partagé


Pc fixe --- MSI MPG Z490 Gaming Edge WiFi, I9-9900Kf, RTX3070Ti, 64Go DDR4, SSD 1Tera nvme gen4 Samsung 980 pro, SSD 1Tera WD Blacksn850X,3HDD 5Tera
Eeepc Asus 1015pem --- Intel Atom N550 Dual-core 1.5Ghz / DD 1Tera 7200rpm / Ram 2Go

Screenshot + Les Conky ===> http://forums.archlinux.fr/post85405.html#p85405
Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 17156
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Nano] enregister et quitter ne fonctionne plus (en cours)

Message par benjarobin »

Remplace fr-latin9 par fr-latin1 (ou simplement fr). Je te conseil de reboot entre les changements de configuration...
J'ai exactement le même problème, et j'avoue n'avoir jamais pris le temps de debug la chose... Je n'ai pas vraiment besoin de taper le signe € dans un tty
Zsh | KDE | PC fixe : core i7, carte nvidia
Titre d'un sujet : [Thème] Sujet (état) / Règles du forum
Avatar de l’utilisateur
banditblue
Elfe
Messages : 587
Inscription : dim. 10 janv. 2010, 10:19

Re: [Nano] enregister et quitter ne fonctionne plus (en cours)

Message par banditblue »

benjarobin a écrit : dim. 11 févr. 2024, 21:05 Remplace fr-latin9 par fr-latin1 (ou simplement fr). Je te conseil de reboot entre les changements de configuration...
Ça se tente mon général 🤣🤣
La connaîssance n'a pas de limite.
Mais sa valeur, est d'autant plus grande, une fois partagé


Pc fixe --- MSI MPG Z490 Gaming Edge WiFi, I9-9900Kf, RTX3070Ti, 64Go DDR4, SSD 1Tera nvme gen4 Samsung 980 pro, SSD 1Tera WD Blacksn850X,3HDD 5Tera
Eeepc Asus 1015pem --- Intel Atom N550 Dual-core 1.5Ghz / DD 1Tera 7200rpm / Ram 2Go

Screenshot + Les Conky ===> http://forums.archlinux.fr/post85405.html#p85405
Avatar de l’utilisateur
banditblue
Elfe
Messages : 587
Inscription : dim. 10 janv. 2010, 10:19

Re: [Nano] enregister et quitter ne fonctionne plus (en cours)

Message par banditblue »

Bonjour la team,
Je ferme ce topic
La connaîssance n'a pas de limite.
Mais sa valeur, est d'autant plus grande, une fois partagé


Pc fixe --- MSI MPG Z490 Gaming Edge WiFi, I9-9900Kf, RTX3070Ti, 64Go DDR4, SSD 1Tera nvme gen4 Samsung 980 pro, SSD 1Tera WD Blacksn850X,3HDD 5Tera
Eeepc Asus 1015pem --- Intel Atom N550 Dual-core 1.5Ghz / DD 1Tera 7200rpm / Ram 2Go

Screenshot + Les Conky ===> http://forums.archlinux.fr/post85405.html#p85405
Répondre