[loadaverage] charge système anormalement élevé [résolu]

Xorg, Compiz, KDE / Gnome / Xfce / Fluxbox / e17 / fvwm ... GDM/KDM/XDM...
Avatar de l’utilisateur
onyx67
Elfe
Messages : 734
Inscription : dim. 06 nov. 2011, 18:12
Localisation : Alsace

[loadaverage] charge système anormalement élevé [résolu]

Message par onyx67 » sam. 12 mai 2018, 13:28

Salut,

J'ai depuis ce matin un soucis de charge système qui s'est subitement emballé. Ralentissement important et partition / qui qui a augmenté de 10% en l'espace de 45 mn (log?).
Je n'ai aucun soucis avec mon utilisateur Test. Je n'ai pas modifié ma config depuis des lustres et ma dernière màj date du 09/05 et n'ai pas eu de soucis ni pendant ni après.

Voici quelques (maigres) éléments:

Code : Tout sélectionner

w
 13:19:18 up 10 min,  3 users,  load average: 9,32, 8,06, 4,59
UTIL.    TTY        LOGIN@   IDLE   JCPU   PCPU QUOI
jockerma tty1      13:09   10:34  21.64s  0.02s /bin/sh /usr/bin/startkde
jockerma pts/0     13:09    9:47   0.00s  0.95s kded5 [kdeinit5]                                      
jockerma pts/1     13:19    4.00s  0.00s  0.00s w

Code : Tout sélectionner

top - 13:24:18 up 15 min,  3 users,  load average: 6,83, 7,58, 5,37
Tâches: 190 total,   1 en cours, 189 en veille,   0 arrêté,   0 zombie
%Cpu(s):  4,5 ut,  7,8 sy,  1,3 ni, 52,3 id, 33,7 wa,  0,2 hi,  0,2 si,  0,0 st
MiB Mem :   3929,2 total,    287,9 libr,   1196,1 util,   2445,3 tamp/cache
MiB Éch :      0,0 total,      0,0 libr,      0,0 util.   2497,2 dispo Mem 

Je ne sais pas trop où chercher ni dans quels logs, un peu d'aide sera bienvenue.

Merci d'avance
Dernière édition par onyx67 le lun. 14 mai 2018, 19:54, édité 1 fois.
"La complication est un effet de la simplicité mal acquise"

Intel i5-2320; Nvidia GeForce GT 520; ATA Hitachi 2To; Windows7/ArchLinux-Kde5

Avatar de l’utilisateur
papajoke
Elfe
Messages : 518
Inscription : sam. 30 août 2014, 19:54
Contact :

Re: [loadaverage] charge système anormalement élevé

Message par papajoke » sam. 12 mai 2018, 14:36

Bonjour,
Nous n'avons qu'un seul fichier log : journald
Sous plasma, avec ton mauvais user faire un journalctl -b0 -p3
Arch stable - Kde 5 / zsh - btrfs/mbr - Intel Core i3 - 6Go RAM - GeForce 405 video-nouveau

Avatar de l’utilisateur
onyx67
Elfe
Messages : 734
Inscription : dim. 06 nov. 2011, 18:12
Localisation : Alsace

Re: [loadaverage] charge système anormalement élevé

Message par onyx67 » sam. 12 mai 2018, 14:47

Salut,

Code : Tout sélectionner

journalctl -b0 -p3
-- Logs begin at Wed 2017-12-27 16:01:01 CET, end at Sat 2018-05-12 14:43:36 CEST. --
mai 12 14:38:51 bluebox kernel: kvm: disabled by bios
mai 12 14:38:51 bluebox kernel: kvm: disabled by bios
mai 12 14:38:51 bluebox kernel: kvm: disabled by bios
mai 12 14:38:51 bluebox kernel: kvm: disabled by bios
mai 12 14:39:51 bluebox kactivitymanagerd[646]: KActivities: Database can not be opened in WAL mode. Check the SQLite version (required >3.7.0). And whether your filesystem supports shared memory
mai 12 14:39:54 bluebox kactivitymanagerd[717]: KActivities: Database can not be opened in WAL mode. Check the SQLite version (required >3.7.0). And whether your filesystem supports shared memory
mai 12 14:40:00 bluebox kmix[681]: org.kde.kmix: Cannot load profile  "PulseAudio.Périphériques_de_lecture.1.default"  . It was removed by the user, or the KMix config file is defective.
mai 12 14:40:00 bluebox kmix[681]: org.kde.kmix: Cannot load profile  "PulseAudio.Périphériques_de_capture.1.default"  . It was removed by the user, or the KMix config file is defective.
mai 12 14:40:00 bluebox kmix[681]: org.kde.kmix: Cannot load profile  "PulseAudio.Flux_de_lecture.1.default"  . It was removed by the user, or the KMix config file is defective.
mai 12 14:40:00 bluebox kmix[681]: org.kde.kmix: Cannot load profile  "PulseAudio.Flux_de_capture.1.default"  . It was removed by the user, or the KMix config file is defective.
mai 12 14:40:00 bluebox kactivitymanagerd[763]: KActivities: Database can not be opened in WAL mode. Check the SQLite version (required >3.7.0). And whether your filesystem supports shared memory
mai 12 14:40:00 bluebox systemd-coredump[707]: Process 646 (kactivitymanage) of user 1000 dumped core.
                                               
                                               Stack trace of thread 646:
                                               #0  0x00007fd580bab86b raise (libc.so.6)
                                               #1  0x00007fd580b9640e abort (libc.so.6)
                                               #2  0x00007fd581353868 _ZNK14QMessageLogger5fatalEPKcz (libQt5Core.so.5)
                                               #3  0x00007fd56517a1bc n/a (kactivitymanagerd_plugin_sqlite.so)
                                               #4  0x00007fd56516816a n/a (kactivitymanagerd_plugin_sqlite.so)
                                               #5  0x00007fd5651684e1 n/a (kactivitymanagerd_plugin_sqlite.so)
                                               #6  0x00007fd56516f067 n/a (kactivitymanagerd_plugin_sqlite.so)
                                               #7  0x0000561253f6e410 n/a (kactivitymanagerd)
                                               #8  0x0000561253f6eef9 n/a (kactivitymanagerd)
                                               #9  0x0000561253f7f096 n/a (kactivitymanagerd)
                                               #10 0x00007fd581588052 _ZN7QObject5eventEP6QEvent (libQt5Core.so.5)
                                               #11 0x00007fd58223f9f5 _ZN15QGuiApplication5eventEP6QEvent (libQt5Gui.so.5)
                                               #12 0x00007fd582a53f30 _ZN12QApplication5eventEP6QEvent (libQt5Widgets.so.5)
                                               #13 0x00007fd582a4dfec _ZN19QApplicationPrivate13notify_helperEP7QObjectP6QEvent (libQt5Widgets.so.5)
                                               #14 0x00007fd582a559c6 _ZN12QApplication6notifyEP7QObjectP6QEvent (libQt5Widgets.so.5)
                                               #15 0x00007fd581556ce0 _ZN16QCoreApplication15notifyInternal2EP7QObjectP6QEvent (libQt5Core.so.5)
                                               #16 0x00007fd581559946 _ZN23QCoreApplicationPrivate16sendPostedEventsEP7QObjectiP11QThreadData (libQt5Core.so.5)
                                               #17 0x00007fd5815b3c44 n/a (libQt5Core.so.5)
                                               #18 0x00007fd57da1d368 g_main_context_dispatch (libglib-2.0.so.0)
                                               #19 0x00007fd57da1d5b1 n/a (libglib-2.0.so.0)
                                               #20 0x00007fd57da1d63e g_main_context_iteration (libglib-2.0.so.0)
                                               #21 0x00007fd5815b3231 _ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE (libQt5Core.so.5)
                                               #22 0x00007fd57975c482 n/a (libQt5XcbQpa.so.5)
                                               #23 0x00007fd58155531b _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE (libQt5Core.so.5)
                                               #24 0x00007fd58155e718 _ZN16QCoreApplication4execEv (libQt5Core.so.5)
                                               #25 0x0000561253f6cf60 n/a (kactivitymanagerd)
                                               #26 0x00007fd580b9806b __libc_start_main (libc.so.6)
                                               #27 0x0000561253f6d1ba _start (kactivitymanagerd)
                                               
                                               Stack trace of thread 649:
                                               #0  0x00007fd580c62ea9 __poll (libc.so.6)
                                               #1  0x00007fd580414180 n/a (libxcb.so.1)
                                               #2  0x00007fd580415e4b xcb_wait_for_event (libxcb.so.1)
                                               #3  0x00007fd5796d482a n/a (libQt5XcbQpa.so.5)
                                               #4  0x00007fd581369abd n/a (libQt5Core.so.5)
                                               #5  0x00007fd57ffee075 start_thread (libpthread.so.0)
                                               #6  0x00007fd580c6d53f __clone (libc.so.6)
                                               
                                               Stack trace of thread 678:
                                               #0  0x00007fd580c62ea9 __poll (libc.so.6)
                                               #1  0x00007fd57da1d523 n/a (libglib-2.0.so.0)
                                               #2  0x00007fd57da1d63e g_main_context_iteration (libglib-2.0.so.0)
                                               #3  0x00007fd5815b3231 _ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE (libQt5Core.so.5)
                                               #4  0x00007fd58155531b _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE (libQt5Core.so.5)
                                               #5  0x00007fd58136471e _ZN7QThread4execEv (libQt5Core.so.5)
                                               #6  0x0000561253f6f29b n/a (kactivitymanagerd)
                                               #7  0x00007fd581369abd n/a (libQt5Core.so.5)
                                               #8  0x00007fd57ffee075 start_thread (libpthread.so.0)
                                               #9  0x00007fd580c6d53f __clone (libc.so.6)
Peut-être un soucis avec le processus Process 646 (kactivitymanage) of user 1000 dumped core ?
"La complication est un effet de la simplicité mal acquise"

Intel i5-2320; Nvidia GeForce GT 520; ATA Hitachi 2To; Windows7/ArchLinux-Kde5

Avatar de l’utilisateur
onyx67
Elfe
Messages : 734
Inscription : dim. 06 nov. 2011, 18:12
Localisation : Alsace

Re: [loadaverage] charge système anormalement élevé

Message par onyx67 » dim. 13 mai 2018, 13:50

J'ai tenté de réinitialiser mes configs, d'abord via les modules en graphique puis en faisant une backup comme indiqué sur le wiki anglais. En vain, le problème persiste.

Que pourrait-il y avoir comme autre soucis sur mon utilisateur?
"La complication est un effet de la simplicité mal acquise"

Intel i5-2320; Nvidia GeForce GT 520; ATA Hitachi 2To; Windows7/ArchLinux-Kde5

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 1945
Inscription : jeu. 15 mars 2012, 05:08

Re: [loadaverage] charge système anormalement élevé

Message par waitnsea » dim. 13 mai 2018, 15:39

onyx67 a écrit :
sam. 12 mai 2018, 13:28
J'ai depuis ce matin un soucis de charge système qui s'est subitement emballé. Ralentissement important et partition / qui qui a augmenté de 10% en l'espace de 45 mn (log?).
Bonjour,
Baloo me semble reprendre ses fantaisies en ce moment, j'ai du le (re) désactiver après l'avoir vu occuper 350 G dans VIRT de Htop !
Quel est ton retour de $ du -sh .local/share/baloo/index ?
LENOVO Y700-341SH i7-6700 3.4gHZ 1 SSD + 2HDD - Arch/KDE - NVidia GeForce GeForce GTX 750 T
Sauvegardes quotidiennes de mes système et données par BORG

Avatar de l’utilisateur
onyx67
Elfe
Messages : 734
Inscription : dim. 06 nov. 2011, 18:12
Localisation : Alsace

Re: [loadaverage] charge système anormalement élevé

Message par onyx67 » dim. 13 mai 2018, 15:46

@ waitnsea: merci pour ta réponse. Voici le retour de la commande:

Code : Tout sélectionner

du -sh .local/share/baloo/index
60M     .local/share/baloo/index
"La complication est un effet de la simplicité mal acquise"

Intel i5-2320; Nvidia GeForce GT 520; ATA Hitachi 2To; Windows7/ArchLinux-Kde5

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 1945
Inscription : jeu. 15 mars 2012, 05:08

Re: [loadaverage] charge système anormalement élevé

Message par waitnsea » dim. 13 mai 2018, 16:55

onyx67 a écrit :
dim. 13 mai 2018, 15:46
@ waitnsea: merci pour ta réponse. Voici le retour de la commande:

Code : Tout sélectionner

du -sh .local/share/baloo/index
60M     .local/share/baloo/index
Raté, j'avais 2,5G !!! Chez toi ce n'est pas ça !
Tu as essayé de trouver les fichiers récents qui avaient grossi comme ça ? $ du -sh $(find -maxdepth 1 -type f -mtime -1) (ou -mtime -2 pour 2 jours)
LENOVO Y700-341SH i7-6700 3.4gHZ 1 SSD + 2HDD - Arch/KDE - NVidia GeForce GeForce GTX 750 T
Sauvegardes quotidiennes de mes système et données par BORG

Avatar de l’utilisateur
onyx67
Elfe
Messages : 734
Inscription : dim. 06 nov. 2011, 18:12
Localisation : Alsace

Re: [loadaverage] charge système anormalement élevé

Message par onyx67 » dim. 13 mai 2018, 17:32

Je cherchais en effet à trouver quel fichier avait gonflé autant:

Code : Tout sélectionner

du -sh $(find -maxdepth 1 -type f -mtime -2)
16K     ./.viminfo
4,0K    ./.Xauthority
4,0K    ./.bash_history
Ça ne me semble pas très parlant, pourtant:

Code : Tout sélectionner

df -h
Sys. de fichiers Taille Utilisé Dispo Uti% Monté sur
dev                2,0G       0  2,0G   0% /dev
run                2,0G    1,1M  2,0G   1% /run
/dev/sda6           30G     17G   12G  58% /
tmpfs              2,0G    4,7M  2,0G   1% /dev/shm
tmpfs              2,0G       0  2,0G   0% /sys/fs/cgroup
tmpfs              2,0G     24K  2,0G   1% /tmp
/dev/sda7          756G    356G  362G  50% /home
/dev/sda5          2,1G     93M  1,9G   5% /boot
tmpfs              393M       0  393M   0% /run/user/1001
tmpfs              393M     12K  393M   1% /run/user/1000
Alors qu'auparavant j'avais 50% de disponible sur /
"La complication est un effet de la simplicité mal acquise"

Intel i5-2320; Nvidia GeForce GT 520; ATA Hitachi 2To; Windows7/ArchLinux-Kde5

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 1945
Inscription : jeu. 15 mars 2012, 05:08

Re: [loadaverage] charge système anormalement élevé

Message par waitnsea » dim. 13 mai 2018, 18:51

onyx67 a écrit :
dim. 13 mai 2018, 17:32

Code : Tout sélectionner

df -h
...
/dev/sda6           30G     17G   12G  58% /
...
Alors qu'auparavant j'avais 50% de disponible sur /
Tu as un système "léger", pour comparer, la taille de mes logs :

Code : Tout sélectionner

du -sh /var/log/journal 
4,1G	/var/log/journal
Tu peux déjà la limiter chez toi : https://wiki.archlinux.org/index.php/Sy ... size_limit (je devrais peut-être en faire autant :lol: )
Pour ton "ralentissement" par contre, ton "top" n'ayant pas mentionné de charge particulière, tu devrais donner la réponse que te demande papajoke
LENOVO Y700-341SH i7-6700 3.4gHZ 1 SSD + 2HDD - Arch/KDE - NVidia GeForce GeForce GTX 750 T
Sauvegardes quotidiennes de mes système et données par BORG

Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 15216
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [loadaverage] charge système anormalement élevé

Message par benjarobin » dim. 13 mai 2018, 18:52

Je pense que tu as déjà pointé la raison du problème, regarde la taille de /var/log ainsi que la taille de /var/lib/systemd/coredump
waitnsea a écrit :
dim. 13 mai 2018, 18:51

Code : Tout sélectionner

4,1G	/var/log/journal
Ouch, ceci n'est pas du tout une taille normal... Personnellement

Code : Tout sélectionner

du -sh /var/lib/systemd/coredump /var/log/
12K     /var/lib/systemd/coredump
155M    /var/log/
Après j'ai configuré un peu mon système :

Code : Tout sélectionner

ls -l /etc/sysctl.d/50-coredump.conf
lrwxrwxrwx 1 root root 9 22 mars   2016 /etc/sysctl.d/50-coredump.conf -> /dev/null

Code : Tout sélectionner

grep -Ev "^ *#|^ *$" /etc/systemd/journald.conf
/etc/systemd/journald.conf:[Journal]
/etc/systemd/journald.conf:SystemMaxUse=128M
/etc/systemd/journald.conf:SystemMaxFileSize=32M
Mais dans tous les cas 4Go me semble énorme
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 1945
Inscription : jeu. 15 mars 2012, 05:08

Re: [loadaverage] charge système anormalement élevé

Message par waitnsea » dim. 13 mai 2018, 19:01

@benjarobin ...eh oui, négligence liée à pléthore d'espace sur la dernière bécane, vite corrigé...
LENOVO Y700-341SH i7-6700 3.4gHZ 1 SSD + 2HDD - Arch/KDE - NVidia GeForce GeForce GTX 750 T
Sauvegardes quotidiennes de mes système et données par BORG

Avatar de l’utilisateur
onyx67
Elfe
Messages : 734
Inscription : dim. 06 nov. 2011, 18:12
Localisation : Alsace

Re: [loadaverage] charge système anormalement élevé

Message par onyx67 » dim. 13 mai 2018, 19:21

waitnsea a écrit :
dim. 13 mai 2018, 18:51
Pour ton ralentissement" par contre, ton "top" n'ayant pas mentionné de charge particulière, tu devrais donner la réponse que te demande papajoke
J'ai déjà posté le retour de la commande de papajoke (journalctl -b0 -p3). La charge système est quand même 10 fois plus élevé que sur mon utilisateur test (du moins selon mon interprétation)

13:19:18 up 10 min, 3 users, load average: 9,32, 8,06, 4,59

Sinon avec un du -sh /var/log/journal , je me retrouve aussi avec une taille similaire:

Code : Tout sélectionner

$ du -sh /var/log/journal 
3,1G    /var/log/journal
Je vais voir demain si les paramétrages système proposé par benjarobin apporte une amélioration.
"La complication est un effet de la simplicité mal acquise"

Intel i5-2320; Nvidia GeForce GT 520; ATA Hitachi 2To; Windows7/ArchLinux-Kde5

Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 15216
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [loadaverage] charge système anormalement élevé

Message par benjarobin » dim. 13 mai 2018, 20:51

Et la taille de /var/lib/systemd/coredump ?
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
onyx67
Elfe
Messages : 734
Inscription : dim. 06 nov. 2011, 18:12
Localisation : Alsace

Re: [loadaverage] charge système anormalement élevé

Message par onyx67 » dim. 13 mai 2018, 20:58

@ benjarobin: largement plus que ce qu tu avais posté:

Code : Tout sélectionner

du -sh /var/lib/systemd/coredump
3,0G    /var/lib/systemd/coredump
"La complication est un effet de la simplicité mal acquise"

Intel i5-2320; Nvidia GeForce GT 520; ATA Hitachi 2To; Windows7/ArchLinux-Kde5

Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 15216
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [loadaverage] charge système anormalement élevé

Message par benjarobin » dim. 13 mai 2018, 21:02

Ton problème est ici... Tu as des applications qui plantent (je ne connais pas la raison), et cela créé ces fichiers coredump que tu peux supprimer. Personnellement les coredump sont désactivé
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
onyx67
Elfe
Messages : 734
Inscription : dim. 06 nov. 2011, 18:12
Localisation : Alsace

Re: [loadaverage] charge système anormalement élevé

Message par onyx67 » dim. 13 mai 2018, 21:23

Merci pour ta réponse. Donc je peux sans risque faire un simple rm /var/lib/systemd/coredump ?
C'est avec les commandes de ton précédent poste pour désactiver coredump?

J'ai assez souvent des plantage d'akonadi au démarrage (je l'ai pourtant désactivé...) et kwin aussi, mais moins fréquemment.
"La complication est un effet de la simplicité mal acquise"

Intel i5-2320; Nvidia GeForce GT 520; ATA Hitachi 2To; Windows7/ArchLinux-Kde5

Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 15216
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [loadaverage] charge système anormalement élevé

Message par benjarobin » dim. 13 mai 2018, 21:29

Ne supprime pas le dossier, mais son contenu. Pour désactiver coredump il suffit de créer le lien symbolique /etc/sysctl.d/50-coredump.conf pointant vers /dev/null
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
onyx67
Elfe
Messages : 734
Inscription : dim. 06 nov. 2011, 18:12
Localisation : Alsace

Re: [loadaverage] charge système anormalement élevé

Message par onyx67 » dim. 13 mai 2018, 21:41

OK merci.
Sinon je peux utiliser quelle commande pour vider le contenu de coredump ?

EDIT:

Code : Tout sélectionner

truncate -s 0 /var/lib/systemd/coredump
ça peut le faire?
"La complication est un effet de la simplicité mal acquise"

Intel i5-2320; Nvidia GeForce GT 520; ATA Hitachi 2To; Windows7/ArchLinux-Kde5

Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 15216
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [loadaverage] charge système anormalement élevé

Message par benjarobin » dim. 13 mai 2018, 22:40

Euh /var/lib/systemd/coredump est un dossier !!!!! Pas un fichier
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
onyx67
Elfe
Messages : 734
Inscription : dim. 06 nov. 2011, 18:12
Localisation : Alsace

Re: [loadaverage] charge système anormalement élevé

Message par onyx67 » lun. 14 mai 2018, 15:47

Bon en cherchant un peu à tête reposé j'ai réussi à vider mon dossier coredump (rm -R /var/lib/systemd/coredump/*).
Du coup:

Code : Tout sélectionner

du -sh /var/lib/systemd/coredump
528K    /var/lib/systemd/coredump
En revanche je n'ai pas de /50-coredump.conf pour créer le lien symbolique:

Code : Tout sélectionner

sysctl.d]$ ls
99-sysctl.conf
"La complication est un effet de la simplicité mal acquise"

Intel i5-2320; Nvidia GeForce GT 520; ATA Hitachi 2To; Windows7/ArchLinux-Kde5

Répondre