[XFCE] écran noir et crash au démarrage

Xorg, Compiz, KDE / Gnome / Xfce / Fluxbox / e17 / fvwm ... GDM/KDM/XDM...
Avatar de l’utilisateur
tuxmain
Hankyu
Messages : 14
Inscription : dim. 18 févr. 2018, 15:32

[XFCE] écran noir et crash au démarrage

Message par tuxmain » jeu. 24 mai 2018, 19:00

Bonsoir,

J'utilise XFCE depuis plusieurs mois sans trop de soucis, mais depuis quelques semaines il se met à planter dès que je passe d'un terminal vers le terminal graphique, et des processus font planter le système quand j'éteins ou que je ferme XFCE (et aussi que le son bug, le pilote wifi ne veut pas s'installer et il y a des glitches... mais bon c'est pas si grave). Ça n'a fait qu'empirer.

Et depuis deux jours, tout plante quand je lance XFCE : j'ai d'abord le message habituel qui s'affiche, puis au bout d'une minute (avant c'était une seconde) un écran noir et plus rien ne réagit.
Je fais toutes les mises à jour assez souvent (peut-être que c'est justement le problème :/).

Est-ce que c'est dû à une mise à jour et il faut attendre ou c'est un problème chez moi ? Et comment réparer tout ça ?
Merci.

Edit: XFCE a réussi à démarrer mais il plante toujours sans raison (là il a planté quand j'ai ouvert la fenêtre de déconnexion) et le prompt du login ne s'affiche pas quand je passe sur un autre terminal, avec le message "[TTM] buffer eviction failed" et plein de traits qui semblent être la mémoire...

JuanicoV
Hankyu
Messages : 46
Inscription : mar. 07 nov. 2017, 20:59
Localisation : Espagne-Valencia

Re: [XFCE] écran noir et crash au démarrage

Message par JuanicoV » jeu. 24 mai 2018, 19:56

bonjour,

il va falloir donner un peu plus d'information sur ta machine

carte graphique et driver utilisé
comment tu lances XFCE
tu utilises Linux ou linux-lts
et un log de la session qui plante

Code : Tout sélectionner

journalctl -b -1
pour avoir la session n-1
HP Pavillon - AMD Phenom 9600 - 6Go - SSD
Nvidia GT 520
Dual boot : Archlinux Gnome -Ubuntu Mate

Avatar de l’utilisateur
tuxmain
Hankyu
Messages : 14
Inscription : dim. 18 févr. 2018, 15:32

Re: [XFCE] écran noir et crash au démarrage

Message par tuxmain » ven. 25 mai 2018, 00:11

Carte graphique Intel HD, le pilote je sais pas, j'en ai pas installé. (ça doit être celui de base de Linux ?)
Je lance XFCE avec `startxfce4`, et Linux pas lts je pense (j'ai juste téléchargé l'archiso depuis le site).

Un truc en rouge qui revient tout le temps quand ça plante, et qui est effectivement dans le log :
kernel: NMI watchdog: Watchdog detected hard LOCKUP on cpu 3
et plus loin aussi en rouge :
kernel: INFO: rcu_preempt detected stalls on CPUs/tasks:
juste après, tout à la fin, qui apparaît plein de fois en blanc :
rtkit-daemon[3609]: The canary thread is apparently starving. Taking action.
rtkit-daemon[3609]: Demoting known real-time threads.
rtkit-daemon[3609]: Successfully demoted thread 3661 of process 3601 (/usr/bin/pulseaudio).
rtkit-daemon[3609]: Successfully demoted thread 3660 of process 3601 (/usr/bin/pulseaudio).
rtkit-daemon[3609]: Successfully demoted thread 3601 of process 3601 (/usr/bin/pulseaudio).
rtkit-daemon[3609]: Demoted 3 threads.

Ce serait donc à cause de pulseaudio ?

JuanicoV
Hankyu
Messages : 46
Inscription : mar. 07 nov. 2017, 20:59
Localisation : Espagne-Valencia

Re: [XFCE] écran noir et crash au démarrage

Message par JuanicoV » sam. 02 juin 2018, 17:18

bonjour tuxmain,

je te donne quelques idées (si tu ne les a déjà pas testées)

tu peux essayer de créer un autre utilisateur et de lancer XFCE depuis celui-ci pour voir s'il s'agit d'un problème de conf de ton utilisateur,

tu peux aussi supprimer pulse-audio pour voir si le problème disparaît (si avec l'autre utilisateur le système plante aussi )

Code : Tout sélectionner

kernel: NMI watchdog: Watchdog detected hard LOCKUP on cpu 3
. A priori un CPU qui est chargé a fond et qui ne répond plus/pas

teste aussi en installant le driver video intel libre

Code : Tout sélectionner

xf86-video-intel 


et enfin tu as un CPU intel, as tu besoin d'installer le microcode intel ?
HP Pavillon - AMD Phenom 9600 - 6Go - SSD
Nvidia GT 520
Dual boot : Archlinux Gnome -Ubuntu Mate

Avatar de l’utilisateur
tuxmain
Hankyu
Messages : 14
Inscription : dim. 18 févr. 2018, 15:32

Re: [XFCE] écran noir et crash au démarrage

Message par tuxmain » lun. 04 juin 2018, 08:01

Bonjour,

J'ai supprimé pulseaudio et installé le pilote intel, mais ça plante toujours quand je quitte XFCE. Si je vais sur un autre terminal, le login met très longtemps à s'afficher et quand je reviens sur le graphique, ça plante au bout de quelques secondes (enfin c'est assez aléatoire).
Je vais essayer d'installer ce microcode et je reviens.

Edit: Ce truc n'est même pas open-source, donc je n'ai absolument pas envie de booter dessus. (le chiffrement de mon disque dur ne servirait plus à rien sinon)
Je vais d'abord voir ce qu'il y a dedans (même si c'est interdit).

Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 15163
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [XFCE] écran noir et crash au démarrage

Message par benjarobin » lun. 04 juin 2018, 09:17

Le microcode du cpu est une mise à jour du firmware du cpu. Il est déjà mis à jour via ta carte mère, mais si cette dernière n'a pas un "BIOS" contenant la dernière mise à jour, alors le microcode fournit par les dépôt arch le mettra à jour.

Ce paquet contient un initramfs qui est exécuté avant l'initramfs principal.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

JuanicoV
Hankyu
Messages : 46
Inscription : mar. 07 nov. 2017, 20:59
Localisation : Espagne-Valencia

Re: [XFCE] écran noir et crash au démarrage

Message par JuanicoV » lun. 04 juin 2018, 20:02

Bonjour,

As-tu fait le test avec un nouvel utilisateur?
HP Pavillon - AMD Phenom 9600 - 6Go - SSD
Nvidia GT 520
Dual boot : Archlinux Gnome -Ubuntu Mate

Avatar de l’utilisateur
tuxmain
Hankyu
Messages : 14
Inscription : dim. 18 févr. 2018, 15:32

Re: [XFCE] écran noir et crash au démarrage

Message par tuxmain » mar. 05 juin 2018, 21:15

Bonsoir,
Avec un autre utilisateur ça plante aussi.

Répondre