[ffmpeg] cible PAL SVCD ne fonctionne pas

Applications, problèmes de configuration réseau
morice69
Daikyu
Messages : 85
Inscription : sam. 18 janv. 2014, 10:59

[ffmpeg] cible PAL SVCD ne fonctionne pas

Message par morice69 » mer. 13 juin 2018, 22:07

Bonjour, je voudrai compresser des videos mpeg2, qui font 80 Mo par minutes pour avoir 8mo par minutes ( devrait etre possible sans avoir de dégradation visible sur un ecran 1600 par 1200)
J'essaie de faire

Code : Tout sélectionner

ffmpeg -i input.mpg -cible PAL SVCD target.mpg 
comme indiqué ici http://www.ordinateur.cc/Logiciel/Compr ... 11606.html
Mais ca me balance l'erreur

Code : Tout sélectionner

erreur: [NULL @ 0x2663b40] Unable to find a suitable output format for 'pipe:'
pipe:: Invalid argument
Que manque t il comme arguments pour que ca fonctionne?

Quelle serait la meilleur méthode de compression pour ffmpeg ( sans que ca pixelise avec 100 carrés de 5 cm de coté) avec le même resultat et bps qu'un divx de 3heures qui tiens sur 700mo sans perte visible sur du 15 pouces. Essayé l'argument -vf scale=960:-2 mais ça pixelise a mort et encode en mpeg1.


Merci d'avance.
sous Ubuntu 16.04 UNITY-XFCE/Arch Linux XFCE-GNOME / Porteus linux KDE
Too Style-Note 15-i5 HDD_500_Go
8Go DDR III
Intel Core I5-4330M (2,8 Ghz)(2x2 cores) Intel® HM86
Intel HD Graphic 4600
Wifi Intel 7260 (300Mb)

Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 14953
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [ffmpeg] cible PAL SVCD ne fonctionne pas

Message par benjarobin » mer. 13 juin 2018, 22:23

Bonjour,
Le site que tu cites est totalement dépassé, cela bien longtemps que l'on n'utilise plus ce format de sortie...
Tu ne peux pas obtenir le même ratio qualité/taille avec du mpg qu'avec du divx, déjà que divx est totalement dépassé...
Pourquoi ne pas compresser en x264 voir même en x265, car c'est la seule bonne solution aujourd'hui pour compresser bien plus sans perdre de qualité ?
Et je te recommande handbrake qui est un super logiciel avec une interface graphique. Si cela te convient on regardera comment automatiser la chose (avec ffmpeg ou avec handbrake)
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

morice69
Daikyu
Messages : 85
Inscription : sam. 18 janv. 2014, 10:59

Re: [ffmpeg] cible PAL SVCD ne fonctionne pas

Message par morice69 » jeu. 14 juin 2018, 06:33

Bonjour, je voudrais compresser 600 videos de 1 minutes contenues dans 1 dossier: je voudrais le faire par lot, donc j'exclue handbrake...
sous Ubuntu 16.04 UNITY-XFCE/Arch Linux XFCE-GNOME / Porteus linux KDE
Too Style-Note 15-i5 HDD_500_Go
8Go DDR III
Intel Core I5-4330M (2,8 Ghz)(2x2 cores) Intel® HM86
Intel HD Graphic 4600
Wifi Intel 7260 (300Mb)

hopimet
Elfe
Messages : 824
Inscription : mer. 14 mars 2012, 22:48

Re: [ffmpeg] cible PAL SVCD ne fonctionne pas

Message par hopimet » jeu. 14 juin 2018, 13:12

morice69 a écrit :
jeu. 14 juin 2018, 06:33
Bonjour, je voudrais compresser 600 videos de 1 minutes contenues dans 1 dossier: je voudrais le faire par lot, donc j'exclue handbrake...
Pourquoi ? Il y a un cli pour handbrake, donc le moyen de faire le travail en série.
https://handbrake.fr/docs/en/latest/cli ... tions.html

avi3000
Chu Ko Nu
Messages : 308
Inscription : dim. 19 juin 2011, 18:53
Localisation : dans le neuf trois

Re: [ffmpeg] cible PAL SVCD ne fonctionne pas

Message par avi3000 » ven. 15 juin 2018, 10:44

morice69 a écrit :
mer. 13 juin 2018, 22:07
J'essaie de faire

Code : Tout sélectionner

ffmpeg -i input.mpg -cible PAL SVCD target.mpg 
comme indiqué ici http://www.ordinateur.cc/Logiciel/Compr ... 11606.html
Mais ca me balance l'erreur

La page qui te sert de source d'information est un ramassis de conneries monumentales.

Il n'y a pas de paramètre -cible pour ffmpeg, mais le paramètre -target.

D'une manière générale, tu ne peux pas passer 2 arguments pour un paramètre sans les mettre entre des guillements.

Si tu avais lu le man de ffmpeg, tu aurais vu que ce que tu veux faire s'écrit :

Code : Tout sélectionner

ffmpeg -i input.mpg -target pal-svcd output.mpg

Code : Tout sélectionner

       -target type (output)
           Specify target file type ("vcd", "svcd", "dvd", "dv", "dv50").
                   type may be prefixed with "pal-", "ntsc-" or "film-" to use the corresponding standard. 
                   All the format options (bitrate, codecs, buffer sizes) are then set automatically. You can just type:
                    ffmpeg -i myfile.avi -target vcd /tmp/vcd.mpg

           Nevertheless you can specify additional options as long as you know they do not conflict with the standard, as in:
                   ffmpeg -i myfile.avi -target vcd -bf 2 /tmp/vcd.mpg
http://ffmpeg.org/documentation.html
https://trac.ffmpeg.org/wiki

Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 14953
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [ffmpeg] cible PAL SVCD ne fonctionne pas

Message par benjarobin » ven. 15 juin 2018, 17:48

En effet, mais re-encoder en mpg n'apportera aucune amélioration significative. Après on peut encoder en x264 avec ffmpeg, mais c'est plus simple pour faire les tests d'utiliser handbrake
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Répondre