[montage de partition] Partition /boot ne se monte pas au démarrage (RÉSOLU)

Reconnaissance et configuration du matériel / kernel linux
Hyperion
Hankyu
Messages : 16
Inscription : dim. 01 juil. 2018, 18:14

[montage de partition] Partition /boot ne se monte pas au démarrage (RÉSOLU)

Message par Hyperion » dim. 08 juil. 2018, 01:02

Bonsoir, voila mon problème : au démarrage, ma partition /boot n'est pas montée, donc je doit le faire manuellement à chaque fois... j'ai déjà fait des recherches et les forums qui touche ce problème conseillent de réinstaller grub ou le kernel, ce que j'ai fait deux fois chacun (une fois normallement et une autre en chroot). Auriez-vous un moyen de remédier à ce problème ? Peut-être l'installation d'un programme, la réinstallation ou le rajout de texte dans un fichier ?
Dernière édition par Hyperion le lun. 09 juil. 2018, 23:49, édité 1 fois.

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 1828
Inscription : jeu. 15 mars 2012, 05:08

Re: [montage de partition] Partition /boot ne se monte pas au démarrage

Message par waitnsea » dim. 08 juil. 2018, 03:07

Hyperion a écrit :
dim. 08 juil. 2018, 01:02
Bonsoir, voila mon problème : au démarrage, ma partition /boot n'est pas montée
Bonjour,
Ce n'est donc sans doute pas une installation par la méthode normale, pas à pas, qui explique bien cette notion de base,...
.... et tu n'as pas non plus fait (ou pas suffisamment) de recherche sur ce forum où ce sujet a déjà été traité maintes et maintes fois...
1. Une partition boot séparée est plus nuisible qu'utile, sauf cas particuliers (certains cryptages par exemple)
2. Ceci concerne la partition /boot, qu'il ne faut surtout pas confondre avec l'esp dans le cas d'un boot en UEFI, et qui, en ce cas, doit être séparée et se monter sur /boot/efi
LENOVO Y700-341SH i7-6700 3.4gHZ 1 SSD + 2HDD - Arch/KDE - NVidia GeForce GeForce GTX 750 T
Sauvegardes quotidiennes de mes système et données par BORG

Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 15019
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [montage de partition] Partition /boot ne se monte pas au démarrage

Message par benjarobin » dim. 08 juil. 2018, 10:52

Bonjour,
Quelle est la sortie de :

Code : Tout sélectionner

fdisk -l
blkid
cat /etc/fstab
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Hyperion
Hankyu
Messages : 16
Inscription : dim. 01 juil. 2018, 18:14

Re: [montage de partition] Partition /boot ne se monte pas au démarrage

Message par Hyperion » dim. 08 juil. 2018, 11:47

Bonjour benjorabin. Respectivement on a :
fdisk -l :

Code : Tout sélectionner

Disque /dev/mmcblk0 : 29,1 GiB, 31268536320 octets, 61071360 secteurs
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Type d'étiquette de disque : gpt
Identifiant de disque : 45DD273D-2A0F-4841-8577-9F6D99B99A80

Périphérique     Début      Fin Secteurs Taille Type
/dev/mmcblk0p1      34  1048609  1048576   512M Système EFI
/dev/mmcblk0p2 1048610 61071326 60022717  28,6G Système de fichiers Linux


Disque /dev/mmcblk0boot1 : 4 MiB, 4194304 octets, 8192 secteurs
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets


Disque /dev/mmcblk0boot0 : 4 MiB, 4194304 octets, 8192 secteurs
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
blkid :

Code : Tout sélectionner

/dev/mmcblk0: PTUUID="45dd273d-2a0f-4841-8577-9f6d99b99a80" PTTYPE="gpt"
/dev/mmcblk0p1: UUID="8436-5270" TYPE="vfat" PARTUUID="8854c30c-c57b-4e60-b44e-56074657050d"
/dev/mmcblk0p2: UUID="fae58237-8a95-420b-83d1-da664af4b2ba" TYPE="ext4" PARTUUID="92e7505a-103f-45cc-b7a7-433fc6561974
et dans /etc/fstab toutes les lignes sont des commentaires et il n'y en a que 3.

Je vous demande pardon pour mon manque d'expérience cet ordinateur avec ArchLinux est fait pour que j'apprenne, donc je suis newbie évidemment...

Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 15019
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [montage de partition] Partition /boot ne se monte pas au démarrage

Message par benjarobin » dim. 08 juil. 2018, 12:00

Quel est le chargeur de démarrage / bootloader installé ? Et comment l'as tu installé ?
Quelle est la sortie de :

Code : Tout sélectionner

efibootmgr -v
Alors pour information ce n'est pas une partition de boot, mais une partition ESP associé à l'EFI. Cela ne change tout fois pas grand chose au problème.
Tu as pour information oublié au moins une étape lors de l'installation : La génération du fstab...
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Hyperion
Hankyu
Messages : 16
Inscription : dim. 01 juil. 2018, 18:14

Re: [montage de partition] Partition /boot ne se monte pas au démarrage

Message par Hyperion » dim. 08 juil. 2018, 12:02

waitnsea a écrit :
dim. 08 juil. 2018, 03:07
1. Une partition boot séparée est plus nuisible qu'utile, sauf cas particuliers (certains cryptages par exemple)
2. Ceci concerne la partition /boot, qu'il ne faut surtout pas confondre avec l'esp dans le cas d'un boot en UEFI, et qui, en ce cas, doit être séparée et se monter sur /boot/efi
C'est vrai que pour l'installation je n'ai pas tout lu... et comble je pense pour vous, je l'ai fait avec le tuto de Frederic Bezies (d'abord sur une vieille machine 32 bytes pour apprendre puis sur mon petit notebook, bizarement c'est sur le second que je rencontre ces réels problèmes)
Je suis en UEFI (obligation de mon appareil aux capacités réduites) et je n'ai que 2 partitions sachant que le tuto en prévois 4 (les partitions pour les applications séparée et la swap que je n'ai pas).
Je vous remercie pour vos conseils, pensez-vous donc qu'il faudra changer le montage de cette partition vers /boot/efi ? Puis-je le faire sans recommencer une installation complète ?

Hyperion
Hankyu
Messages : 16
Inscription : dim. 01 juil. 2018, 18:14

Re: [montage de partition] Partition /boot ne se monte pas au démarrage

Message par Hyperion » dim. 08 juil. 2018, 12:04

Cela me donne :

Code : Tout sélectionner

Timeout: 1 seconds
Boot0000* arch_grub	HD(1,GPT,8854c30c-c57b-4e60-b44e-56074657050d,0x22,0x100000)/File(\EFI\ARCH_GRUB\GRUBX64.EFI)
Boot0001* Android-IA	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot0002* Android-IA	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot0003* Android-IA	HD(1,GPT,8854c30c-c57b-4e60-b44e-56074657050d,0x22,0x100000)/File(\EFI\BOOT\BOOTX64.EFI)

Avatar de l’utilisateur
papajoke
Chu Ko Nu
Messages : 494
Inscription : sam. 30 août 2014, 19:54
Contact :

Re: [montage de partition] Partition /boot ne se monte pas au démarrage

Message par papajoke » dim. 08 juil. 2018, 12:05

bonjour
Hyperion a écrit :
dim. 08 juil. 2018, 01:02
je doit le faire manuellement à chaque fois... conseillent de réinstaller grub ou le kernel, ce que j'ai fait deux fois chacun (une fois normallement et une autre en chroot).
Bon tu n'as pas de partition boot, ce qui est bien.
Tu as l'air de dire que tu boot bien (pas qu'en chroot) ! donc quel est le problème ? tu as une erreur au boot ou non ? si oui laquelle ?

-----------------
Edit: tu avais avant un andoid d'installé ? il faut supprimer ces entrées dans efi (efibootmgr)
Arch stable - Kde 5 / zsh - btrfs/mbr - Intel Core i3 - 6Go RAM - GeForce 405 video-nouveau

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 1828
Inscription : jeu. 15 mars 2012, 05:08

Re: [montage de partition] Partition /boot ne se monte pas au démarrage

Message par waitnsea » dim. 08 juil. 2018, 12:10

Hyperion a écrit :
dim. 08 juil. 2018, 12:02

C'est vrai que pour l'installation je n'ai pas tout lu... et comble je pense pour vous, je l'ai fait avec le tuto de Frederic Bezies (d'abord sur une vieille machine 32 bytes pour apprendre puis sur mon petit notebook, bizarement c'est sur le second que je rencontre ces réels problèmes)
Je suis en UEFI (obligation de mon appareil aux capacités réduites) et je n'ai que 2 partitions sachant que le tuto en prévois 4 (les partitions pour les applications séparée et la swap que je n'ai pas).
Je vous remercie pour vos conseils, pensez-vous donc qu'il faudra changer le montage de cette partition vers /boot/efi ? Puis-je le faire sans recommencer une installation complète ?
Le tuto de Fred suit la méthode officielle en la détaillant, l'expliquant, et il le met à jour mensuellement, c'est donc excellent... à condition de bien le lire, et, comme toujours, de ne rien faire qu'on n'aie compris - pas de copier-coller aveugle
Le 32bits n'est plus supporté -sauf contorsions, donc pas pour les nouveaux arrivés
Tu ne peux être en UEFI avec deux partitions que si la première contient l'esp toute seule et la deuxième le / complet avec son /boot, son /home, etc...
Et tu montes l'esp (par exemple /dev/sda1) sur /boot/efi
LENOVO Y700-341SH i7-6700 3.4gHZ 1 SSD + 2HDD - Arch/KDE - NVidia GeForce GeForce GTX 750 T
Sauvegardes quotidiennes de mes système et données par BORG

Hyperion
Hankyu
Messages : 16
Inscription : dim. 01 juil. 2018, 18:14

Re: [montage de partition] Partition /boot ne se monte pas au démarrage

Message par Hyperion » dim. 08 juil. 2018, 12:14

En fait les informations pour le boot sont sur cette partition, je boot bien mais lsblk montre que cette partition n'est pas montée après lightdm. Vous pensez donc qu'il faudrait que je réinstalle le kernel et grub sans avoir montée la partition, puis la suprimer avec gparted et allonger la seule réstante de ces quelques Mo ? Parce qu'il n'y a rien dans /boot si la partition n'est pas montée

Hyperion
Hankyu
Messages : 16
Inscription : dim. 01 juil. 2018, 18:14

Re: [montage de partition] Partition /boot ne se monte pas au démarrage

Message par Hyperion » dim. 08 juil. 2018, 12:18

waitnsea a écrit :
dim. 08 juil. 2018, 12:10

Le tuto de Fred suit la méthode officielle en la détaillant, l'expliquant, et il le met à jour mensuellement, c'est donc excellent... à condition de bien le lire, et, comme toujours, de ne rien faire qu'on n'aie compris - pas de copier-coller aveugle
Le 32bits n'est plus supporté -sauf contorsions, donc pas pour les nouveaux arrivés
Tu ne peux être en UEFI avec deux partitions que si la première contient l'esp toute seule et la deuxième le / complet avec son /boot, son /home, etc...
Et tu montes l'esp (par exemple /dev/sda1) sur /boot/efi
J'ai installé archlinux32 comme il le proposait, je vous jure avoir tout bien lu dans ce tuto et tout compris puisque je l'ai installé plusieurs fois sur ma vieille machine (celle dont je rapporte le problème n'est pas en 32 bit).

Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 15019
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [montage de partition] Partition /boot ne se monte pas au démarrage

Message par benjarobin » dim. 08 juil. 2018, 12:22

Oula, beaucoup de chose ont été dites... Il ne faut surtout pas supprimer cette première partition: La partition ESP est nécessaire...
Je pense que tu n'as besoin de rien faire de plus... Il est inutile de monter la partition ESP si elle ne contient pas le kernel.
Le problème c'est que l'on ne sait toujours pas comment tu as installé Grub, donc difficile de t'aider...
Mais si tu avais monté la partition ESP dans /boot/efi alors tout devrais être bon (il faudrait quand même rajouter dans le fstab la ligne associé à la partition racine)

Donc quelle est le contenu de

Code : Tout sélectionner

find /boot
mount /dev/mmcblk0p1 /mnt
find /mnt
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Hyperion
Hankyu
Messages : 16
Inscription : dim. 01 juil. 2018, 18:14

Re: [montage de partition] Partition /boot ne se monte pas au démarrage

Message par Hyperion » dim. 08 juil. 2018, 12:30

benjarobin, elle contient nécessairement le kernel puisque j'ai réinstallé kernel et grub avec la partition montée. Je vais réinstaller l'ensemble pour plus de sécurité avec la première partition montée sur /boot/efi au lieu de /boot (ce qui est indiqué dans le tuto de Frederic Bezies), pensez-vous qu'en changeant ce paramètre et en n'oubliant pas de générer fstab (ce que je crois avoir fait), il n'y aura plus de problème de montage ?

Hyperion
Hankyu
Messages : 16
Inscription : dim. 01 juil. 2018, 18:14

Re: [montage de partition] Partition /boot ne se monte pas au démarrage

Message par Hyperion » dim. 08 juil. 2018, 12:33

find /boot donne ce long résultat (avec la partition montée) :

Code : Tout sélectionner

 /boot
/boot/vmlinuz-linux
/boot/initramfs-linux.img
/boot/initramfs-linux-fallback.img
/boot/grub
/boot/grub/grub.cfg
/boot/grub/x86_64-efi
/boot/grub/x86_64-efi/gcry_tiger.mod
/boot/grub/x86_64-efi/usbserial_common.mod
/boot/grub/x86_64-efi/pcidump.mod
/boot/grub/x86_64-efi/lsefi.mod
/boot/grub/x86_64-efi/reboot.mod
/boot/grub/x86_64-efi/dm_nv.mod
/boot/grub/x86_64-efi/ohci.mod
/boot/grub/x86_64-efi/appleldr.mod
/boot/grub/x86_64-efi/mdraid09_be.mod
/boot/grub/x86_64-efi/search_fs_uuid.mod
/boot/grub/x86_64-efi/help.mod
/boot/grub/x86_64-efi/play.mod
/boot/grub/x86_64-efi/cryptodisk.mod
/boot/grub/x86_64-efi/cacheinfo.mod
/boot/grub/x86_64-efi/pbkdf2_test.mod
/boot/grub/x86_64-efi/mpi.mod
/boot/grub/x86_64-efi/relocator.mod
/boot/grub/x86_64-efi/iorw.mod
/boot/grub/x86_64-efi/tr.mod
/boot/grub/x86_64-efi/backtrace.mod
/boot/grub/x86_64-efi/ata.mod
/boot/grub/x86_64-efi/mul_test.mod
/boot/grub/x86_64-efi/tar.mod
/boot/grub/x86_64-efi/zfsinfo.mod
/boot/grub/x86_64-efi/minix_be.mod
/boot/grub/x86_64-efi/gzio.mod
/boot/grub/x86_64-efi/gcry_des.mod
/boot/grub/x86_64-efi/cbtable.mod
/boot/grub/x86_64-efi/gcry_dsa.mod
/boot/grub/x86_64-efi/squash4.mod
/boot/grub/x86_64-efi/raid6rec.mod
/boot/grub/x86_64-efi/gfxterm_background.mod
/boot/grub/x86_64-efi/efinet.mod
/boot/grub/x86_64-efi/xnu_uuid.mod
/boot/grub/x86_64-efi/msdospart.mod
/boot/grub/x86_64-efi/minicmd.mod
/boot/grub/x86_64-efi/loadenv.mod
/boot/grub/x86_64-efi/gcry_md5.mod
/boot/grub/x86_64-efi/cat.mod
/boot/grub/x86_64-efi/minix2_be.mod
/boot/grub/x86_64-efi/usb.mod
/boot/grub/x86_64-efi/serial.mod
/boot/grub/x86_64-efi/udf.mod
/boot/grub/x86_64-efi/gcry_rmd160.mod
/boot/grub/x86_64-efi/pbkdf2.mod
/boot/grub/x86_64-efi/videotest_checksum.mod
/boot/grub/x86_64-efi/cbfs.mod
/boot/grub/x86_64-efi/gcry_rijndael.mod
/boot/grub/x86_64-efi/gcry_blowfish.mod
/boot/grub/x86_64-efi/nilfs2.mod
/boot/grub/x86_64-efi/ufs1.mod
/boot/grub/x86_64-efi/cmp.mod
/boot/grub/x86_64-efi/ntfs.mod
/boot/grub/x86_64-efi/regexp.mod
/boot/grub/x86_64-efi/video_bochs.mod
/boot/grub/x86_64-efi/lssal.mod
/boot/grub/x86_64-efi/usbserial_usbdebug.mod
/boot/grub/x86_64-efi/fixvideo.mod
/boot/grub/x86_64-efi/exfat.mod
/boot/grub/x86_64-efi/configfile.mod
/boot/grub/x86_64-efi/priority_queue.mod
/boot/grub/x86_64-efi/cbmemc.mod
/boot/grub/x86_64-efi/exfctest.mod
/boot/grub/x86_64-efi/blocklist.mod
/boot/grub/x86_64-efi/ahci.mod
/boot/grub/x86_64-efi/memdisk.mod
/boot/grub/x86_64-efi/spkmodem.mod
/boot/grub/x86_64-efi/mdraid1x.mod
/boot/grub/x86_64-efi/div_test.mod
/boot/grub/x86_64-efi/archelp.mod
/boot/grub/x86_64-efi/procfs.mod
/boot/grub/x86_64-efi/gcry_md4.mod
/boot/grub/x86_64-efi/romfs.mod
/boot/grub/x86_64-efi/part_plan.mod
/boot/grub/x86_64-efi/lzopio.mod
/boot/grub/x86_64-efi/lvm.mod
/boot/grub/x86_64-efi/ufs2.mod
/boot/grub/x86_64-efi/multiboot2.mod
/boot/grub/x86_64-efi/tga.mod
/boot/grub/x86_64-efi/gfxterm_menu.mod
/boot/grub/x86_64-efi/legacycfg.mod
/boot/grub/x86_64-efi/linux.mod
/boot/grub/x86_64-efi/uhci.mod
/boot/grub/x86_64-efi/reiserfs.mod
/boot/grub/x86_64-efi/bitmap.mod
/boot/grub/x86_64-efi/gcry_sha256.mod
/boot/grub/x86_64-efi/lspci.mod
/boot/grub/x86_64-efi/echo.mod
/boot/grub/x86_64-efi/hexdump.mod
/boot/grub/x86_64-efi/all_video.mod
/boot/grub/x86_64-efi/read.mod
/boot/grub/x86_64-efi/ntfscomp.mod
/boot/grub/x86_64-efi/loopback.mod
/boot/grub/x86_64-efi/efi_uga.mod
/boot/grub/x86_64-efi/odc.mod
/boot/grub/x86_64-efi/date.mod
/boot/grub/x86_64-efi/xzio.mod
/boot/grub/x86_64-efi/halt.mod
/boot/grub/x86_64-efi/tftp.mod
/boot/grub/x86_64-efi/random.mod
/boot/grub/x86_64-efi/hdparm.mod
/boot/grub/x86_64-efi/sleep_test.mod
/boot/grub/x86_64-efi/lsmmap.mod
/boot/grub/x86_64-efi/nativedisk.mod
/boot/grub/x86_64-efi/gcry_twofish.mod
/boot/grub/x86_64-efi/minix.mod
/boot/grub/x86_64-efi/crypto.mod
/boot/grub/x86_64-efi/gptsync.mod
/boot/grub/x86_64-efi/gcry_camellia.mod
/boot/grub/x86_64-efi/video.mod
/boot/grub/x86_64-efi/xnu_uuid_test.mod
/boot/grub/x86_64-efi/cs5536.mod
/boot/grub/x86_64-efi/geli.mod
/boot/grub/x86_64-efi/elf.mod
/boot/grub/x86_64-efi/disk.mod
/boot/grub/x86_64-efi/efi_gop.mod
/boot/grub/x86_64-efi/part_msdos.mod
/boot/grub/x86_64-efi/progress.mod
/boot/grub/x86_64-efi/usbserial_pl2303.mod
/boot/grub/x86_64-efi/syslinuxcfg.mod
/boot/grub/x86_64-efi/extcmd.mod
/boot/grub/x86_64-efi/mmap.mod
/boot/grub/x86_64-efi/part_apple.mod
/boot/grub/x86_64-efi/keylayouts.mod
/boot/grub/x86_64-efi/part_acorn.mod
/boot/grub/x86_64-efi/offsetio.mod
/boot/grub/x86_64-efi/trig.mod
/boot/grub/x86_64-efi/xnu.mod
/boot/grub/x86_64-efi/usbserial_ftdi.mod
/boot/grub/x86_64-efi/gcry_arcfour.mod
/boot/grub/x86_64-efi/minix2.mod
/boot/grub/x86_64-efi/zfscrypt.mod
/boot/grub/x86_64-efi/gcry_rsa.mod
/boot/grub/x86_64-efi/cbls.mod
/boot/grub/x86_64-efi/cmdline_cat_test.mod
/boot/grub/x86_64-efi/memrw.mod
/boot/grub/x86_64-efi/diskfilter.mod
/boot/grub/x86_64-efi/font.mod
/boot/grub/x86_64-efi/cpio_be.mod
/boot/grub/x86_64-efi/usb_keyboard.mod
/boot/grub/x86_64-efi/gcry_whirlpool.mod
/boot/grub/x86_64-efi/fat.mod
/boot/grub/x86_64-efi/test.mod
/boot/grub/x86_64-efi/videoinfo.mod
/boot/grub/x86_64-efi/part_dvh.mod
/boot/grub/x86_64-efi/at_keyboard.mod
/boot/grub/x86_64-efi/datehook.mod
/boot/grub/x86_64-efi/verify.mod
/boot/grub/x86_64-efi/zfs.mod
/boot/grub/x86_64-efi/part_amiga.mod
/boot/grub/x86_64-efi/http.mod
/boot/grub/x86_64-efi/net.mod
/boot/grub/x86_64-efi/scsi.mod
/boot/grub/x86_64-efi/bswap_test.mod
/boot/grub/x86_64-efi/part_sun.mod
/boot/grub/x86_64-efi/boottime.mod
/boot/grub/x86_64-efi/hfs.mod
/boot/grub/x86_64-efi/video_fb.mod
/boot/grub/x86_64-efi/ext2.mod
/boot/grub/x86_64-efi/btrfs.mod
/boot/grub/x86_64-efi/jfs.mod
/boot/grub/x86_64-efi/hfspluscomp.mod
/boot/grub/x86_64-efi/cbtime.mod
/boot/grub/x86_64-efi/macbless.mod
/boot/grub/x86_64-efi/test_blockarg.mod
/boot/grub/x86_64-efi/setjmp.mod
/boot/grub/x86_64-efi/part_gpt.mod
/boot/grub/x86_64-efi/testload.mod
/boot/grub/x86_64-efi/luks.mod
/boot/grub/x86_64-efi/search_label.mod
/boot/grub/x86_64-efi/gcry_crc.mod
/boot/grub/x86_64-efi/efifwsetup.mod
/boot/grub/x86_64-efi/gcry_seed.mod
/boot/grub/x86_64-efi/video_colors.mod
/boot/grub/x86_64-efi/ehci.mod
/boot/grub/x86_64-efi/hfsplus.mod
/boot/grub/x86_64-efi/gfxmenu.mod
/boot/grub/x86_64-efi/acpi.mod
/boot/grub/x86_64-efi/terminal.mod
/boot/grub/x86_64-efi/iso9660.mod
/boot/grub/x86_64-efi/adler32.mod
/boot/grub/x86_64-efi/xfs.mod
/boot/grub/x86_64-efi/true.mod
/boot/grub/x86_64-efi/datetime.mod
/boot/grub/x86_64-efi/aout.mod
/boot/grub/x86_64-efi/div.mod
/boot/grub/x86_64-efi/bitmap_scale.mod
/boot/grub/x86_64-efi/bufio.mod
/boot/grub/x86_64-efi/usbtest.mod
/boot/grub/x86_64-efi/bfs.mod
/boot/grub/x86_64-efi/ctz_test.mod
/boot/grub/x86_64-efi/time.mod
/boot/grub/x86_64-efi/setjmp_test.mod
/boot/grub/x86_64-efi/password.mod
/boot/grub/x86_64-efi/macho.mod
/boot/grub/x86_64-efi/lsefisystab.mod
/boot/grub/x86_64-efi/cmp_test.mod
/boot/grub/x86_64-efi/gcry_sha1.mod
/boot/grub/x86_64-efi/morse.mod
/boot/grub/x86_64-efi/jpeg.mod
/boot/grub/x86_64-efi/testspeed.mod
/boot/grub/x86_64-efi/loadbios.mod
/boot/grub/x86_64-efi/gettext.mod
/boot/grub/x86_64-efi/video_cirrus.mod
/boot/grub/x86_64-efi/setpci.mod
/boot/grub/x86_64-efi/eval.mod
/boot/grub/x86_64-efi/gcry_serpent.mod
/boot/grub/x86_64-efi/ldm.mod
/boot/grub/x86_64-efi/gcry_rfc2268.mod
/boot/grub/x86_64-efi/signature_test.mod
/boot/grub/x86_64-efi/raid5rec.mod
/boot/grub/x86_64-efi/bsd.mod
/boot/grub/x86_64-efi/part_sunpc.mod
/boot/grub/x86_64-efi/search_fs_file.mod
/boot/grub/x86_64-efi/search.mod
/boot/grub/x86_64-efi/minix3.mod
/boot/grub/x86_64-efi/afs.mod
/boot/grub/x86_64-efi/part_dfly.mod
/boot/grub/x86_64-efi/crc64.mod
/boot/grub/x86_64-efi/fshelp.mod
/boot/grub/x86_64-efi/password_pbkdf2.mod
/boot/grub/x86_64-efi/part_bsd.mod
/boot/grub/x86_64-efi/legacy_password_test.mod
/boot/grub/x86_64-efi/file.mod
/boot/grub/x86_64-efi/usbms.mod
/boot/grub/x86_64-efi/ufs1_be.mod
/boot/grub/x86_64-efi/newc.mod
/boot/grub/x86_64-efi/hello.mod
/boot/grub/x86_64-efi/gfxterm.mod
/boot/grub/x86_64-efi/gcry_sha512.mod
/boot/grub/x86_64-efi/gcry_cast5.mod
/boot/grub/x86_64-efi/lsefimmap.mod
/boot/grub/x86_64-efi/ls.mod
/boot/grub/x86_64-efi/sfs.mod
/boot/grub/x86_64-efi/lsacpi.mod
/boot/grub/x86_64-efi/affs.mod
/boot/grub/x86_64-efi/linux16.mod
/boot/grub/x86_64-efi/sleep.mod
/boot/grub/x86_64-efi/keystatus.mod
/boot/grub/x86_64-efi/minix3_be.mod
/boot/grub/x86_64-efi/videotest.mod
/boot/grub/x86_64-efi/png.mod
/boot/grub/x86_64-efi/probe.mod
/boot/grub/x86_64-efi/cpio.mod
/boot/grub/x86_64-efi/normal.mod
/boot/grub/x86_64-efi/gcry_idea.mod
/boot/grub/x86_64-efi/cpuid.mod
/boot/grub/x86_64-efi/pata.mod
/boot/grub/x86_64-efi/mdraid09.mod
/boot/grub/x86_64-efi/shift_test.mod
/boot/grub/x86_64-efi/terminfo.mod
/boot/grub/x86_64-efi/functional_test.mod
/boot/grub/x86_64-efi/parttool.mod
/boot/grub/x86_64-efi/multiboot.mod
/boot/grub/x86_64-efi/boot.mod
/boot/grub/x86_64-efi/chain.mod
/boot/grub/x86_64-efi/hashsum.mod
/boot/grub/x86_64-efi/moddep.lst
/boot/grub/x86_64-efi/command.lst
/boot/grub/x86_64-efi/fs.lst
/boot/grub/x86_64-efi/partmap.lst
/boot/grub/x86_64-efi/parttool.lst
/boot/grub/x86_64-efi/video.lst
/boot/grub/x86_64-efi/crypto.lst
/boot/grub/x86_64-efi/terminal.lst
/boot/grub/x86_64-efi/modinfo.sh
/boot/grub/x86_64-efi/core.efi
/boot/grub/x86_64-efi/grub.efi
/boot/grub/grub.cfg.example
/boot/grub/locale
/boot/grub/locale/en@hebrew.mo
/boot/grub/locale/gl.mo
/boot/grub/locale/ast.mo
/boot/grub/locale/de.mo
/boot/grub/locale/en@arabic.mo
/boot/grub/locale/de_CH.mo
/boot/grub/locale/zh_TW.mo
/boot/grub/locale/pt_BR.mo
/boot/grub/locale/sl.mo
/boot/grub/locale/hu.mo
/boot/grub/locale/pa.mo
/boot/grub/locale/nb.mo
/boot/grub/locale/pl.mo
/boot/grub/locale/en@piglatin.mo
/boot/grub/locale/id.mo
/boot/grub/locale/en@quot.mo
/boot/grub/locale/ru.mo
/boot/grub/locale/uk.mo
/boot/grub/locale/eo.mo
/boot/grub/locale/ca.mo
/boot/grub/locale/ja.mo
/boot/grub/locale/fi.mo
/boot/grub/locale/sv.mo
/boot/grub/locale/it.mo
/boot/grub/locale/zh_CN.mo
/boot/grub/locale/tr.mo
/boot/grub/locale/nl.mo
/boot/grub/locale/es.mo
/boot/grub/locale/de@hebrew.mo
/boot/grub/locale/hr.mo
/boot/grub/locale/sr.mo
/boot/grub/locale/da.mo
/boot/grub/locale/lt.mo
/boot/grub/locale/fr.mo
/boot/grub/locale/ko.mo
/boot/grub/locale/vi.mo
/boot/grub/themes
/boot/grub/themes/starfield
/boot/grub/themes/starfield/terminal_box_c.png
/boot/grub/themes/starfield/terminal_box_sw.png
/boot/grub/themes/starfield/boot_menu_nw.png
/boot/grub/themes/starfield/boot_menu_sw.png
/boot/grub/themes/starfield/terminal_box_n.png
/boot/grub/themes/starfield/dejavu_12.pf2
/boot/grub/themes/starfield/dejavu_10.pf2
/boot/grub/themes/starfield/dejavu_16.pf2
/boot/grub/themes/starfield/slider_s.png
/boot/grub/themes/starfield/README
/boot/grub/themes/starfield/terminal_box_se.png
/boot/grub/themes/starfield/dejavu_bold_14.pf2
/boot/grub/themes/starfield/terminal_box_w.png
/boot/grub/themes/starfield/boot_menu_ne.png
/boot/grub/themes/starfield/boot_menu_s.png
/boot/grub/themes/starfield/starfield.png
/boot/grub/themes/starfield/boot_menu_se.png
/boot/grub/themes/starfield/terminal_box_nw.png
/boot/grub/themes/starfield/slider_c.png
/boot/grub/themes/starfield/boot_menu_c.png
/boot/grub/themes/starfield/dejavu_14.pf2
/boot/grub/themes/starfield/terminal_box_e.png
/boot/grub/themes/starfield/COPYING.CC-BY-SA-3.0
/boot/grub/themes/starfield/boot_menu_n.png
/boot/grub/themes/starfield/terminal_box_s.png
/boot/grub/themes/starfield/boot_menu_w.png
/boot/grub/themes/starfield/theme.txt
/boot/grub/themes/starfield/blob_w.png
/boot/grub/themes/starfield/terminal_box_ne.png
/boot/grub/themes/starfield/boot_menu_e.png
/boot/grub/themes/starfield/slider_n.png
/boot/grub/fonts
/boot/grub/fonts/unicode.pf2
/boot/grub/grubenv
/boot/EFI
/boot/EFI/arch_grub
/boot/EFI/arch_grub/grubx64.efi
/boot/EFI/boot
/boot/EFI/boot/bootx64.efi

Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 15019
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [montage de partition] Partition /boot ne se monte pas au démarrage

Message par benjarobin » dim. 08 juil. 2018, 12:34

Il est je pense parfaitement inutile de réinstaller, mais c'est toi qui voit.
Grub ne supporte pas forcément bien les devices de ce type: mmcblk0 (quoique normalement maintenant cela devrait fonctionner), ta méthode était très bien.
Mon unique problème, c'est que je ne sais pas depuis le début où est monté cette partition ESP (/boot ou /boot/efi), sinon ton problème serait déjà résolu...
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Hyperion
Hankyu
Messages : 16
Inscription : dim. 01 juil. 2018, 18:14

Re: [montage de partition] Partition /boot ne se monte pas au démarrage

Message par Hyperion » dim. 08 juil. 2018, 12:37

il n'y a que 2 partitions, une montée en / et l'autre en /boot, donc il n'y a pas de partition dédiée à /boot/efi

Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 15019
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [montage de partition] Partition /boot ne se monte pas au démarrage

Message par benjarobin » dim. 08 juil. 2018, 12:37

Ok au vu de la sortie fait ceci:

Code : Tout sélectionner

umount /boot
rm -rf /boot/*
mount /dev/mmcblk0p1 /boot
pacman -S arch-install-scripts
genfstab -U -p / >> /etc/fstab
reboot
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Hyperion
Hankyu
Messages : 16
Inscription : dim. 01 juil. 2018, 18:14

Re: [montage de partition] Partition /boot ne se monte pas au démarrage

Message par Hyperion » dim. 08 juil. 2018, 12:38

Je vais essayer de ce pas

Hyperion
Hankyu
Messages : 16
Inscription : dim. 01 juil. 2018, 18:14

Re: [montage de partition] Partition /boot ne se monte pas au démarrage

Message par Hyperion » dim. 08 juil. 2018, 12:42

Ca n'a pas marché, au démarrage lsblk donne :

Code : Tout sélectionner

mmcblk0      179:0    0 29,1G  0 disk 
├─mmcblk0p1  179:1    0  512M  0 part 
└─mmcblk0p2  179:2    0 28,6G  0 part /

Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 15019
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [montage de partition] Partition /boot ne se monte pas au démarrage

Message par benjarobin » dim. 08 juil. 2018, 12:44

As tu eu une erreur dans l’exécution des commandes demandées ?
Peux tu donner les sorties (juste après un reboot) de :

Code : Tout sélectionner

ls -la /boot
mount | grep /dev/mm
cat /etc/fstab
which genfstab
genfstab -U -p /
Mais il est possible qu'il y est un bug dans le script genfstab, d'où ton problème de départ...

Si genfstab ne t'affiche rien, ce n'est pas grave, on peut le faire à la main. Rajoute ceci dans ton /etc/fstab après les 3 commentaires :

Code : Tout sélectionner

# /dev/mmcblk0p2
UUID=fae58237-8a95-420b-83d1-da664af4b2ba    /        ext4   rw,relatime,data=ordered   0 1

# /dev/mmcblk0p1
UUID=8436-5270                               /boot    vfat   defaults                   0 0
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Répondre