[Openvpn] connexion auto au démarrage

Applications, problèmes de configuration réseau
carl11
yeomen
Messages : 225
Inscription : mer. 21 oct. 2015, 15:00

[Openvpn] connexion auto au démarrage

Message par carl11 » ven. 13 juil. 2018, 11:47

Bonjour ,

Ayant réussi à installer mon client openvpn sur mon archlinux avec l'environnement graphique "gnome" je souhaite maintenant qu'il se connecte automatiquement au démarrage.
Dans paramètres réseau et paramètres VPN il n'y a pas d'option permettant de mettre sur connexion auto.
Y a t'il une autre possibilité ?
Merci.
CPU : Core i3 6100 @ 3.70ghz | RAM : 8Go DDR4
HD : Sandisk SSD Plus 120Go | CG : ATI Radeon 5450

KDE-Plasma
Archlinux , Firefox , thunderbird.

Avatar de l’utilisateur
RoyalPanda
archer de cavalerie
Messages : 179
Inscription : lun. 19 mai 2014, 09:08

Re: [Openvpn] connexion auto au démarrage

Message par RoyalPanda » ven. 13 juil. 2018, 11:58

Bonjour,

Cette page devrait t'aider :

https://wiki.archlinux.org/index.php/Ne ... plugged_in

Panda

carl11
yeomen
Messages : 225
Inscription : mer. 21 oct. 2015, 15:00

Re: [Openvpn] connexion auto au démarrage

Message par carl11 » ven. 13 juil. 2018, 13:10

Merci RoyalPanda ,

si j'ai bien compris je dois installer wireless_tools ce que je viens de faire , dans etc networmanager j'ai 3 dossiers no wait.d , pre down.d et preup.
Je pense que je dois copier le script et le coller dans /etc/NetworkManager/dispatcher.d/vpn-up c'est bien ça ??
CPU : Core i3 6100 @ 3.70ghz | RAM : 8Go DDR4
HD : Sandisk SSD Plus 120Go | CG : ATI Radeon 5450

KDE-Plasma
Archlinux , Firefox , thunderbird.

Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 15197
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Openvpn] connexion auto au démarrage

Message par benjarobin » ven. 13 juil. 2018, 18:49

Bonjour, Si tu utilises NetworkManager il est tout a fait possible de configurer ce dernier pour réaliser une connexion automatique sans toucher au moindre fichier de configuration. Il y a bien une option dans l'interface graphique. Après j'ai celle de KDE, donc je ne vois pas pourquoi elle ne serait pas sur celle de Gnome.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

carl11
yeomen
Messages : 225
Inscription : mer. 21 oct. 2015, 15:00

Re: [Openvpn] connexion auto au démarrage

Message par carl11 » sam. 14 juil. 2018, 09:10

Oui c'est bien ce que je pensais Benjaroben , mais je ne trouve pas cette option dans les paramètres , est-ce qu'il me manquerais un paquet ?



Image

Image

Image
CPU : Core i3 6100 @ 3.70ghz | RAM : 8Go DDR4
HD : Sandisk SSD Plus 120Go | CG : ATI Radeon 5450

KDE-Plasma
Archlinux , Firefox , thunderbird.

Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 15197
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Openvpn] connexion auto au démarrage

Message par benjarobin » sam. 14 juil. 2018, 11:26

L'option n'est pas dans les options du VPN, mais dans les options de la connexion Wifi ou Ethernet.
Personnellement j'ai créer un profil pour ma connexion Ethernet, et dans la section "Configuration générale" (attention c'est l'interface graphique de KDE) de cette connexion Ethernet, j'ai une case à cocher "Se connecter automatiquement à un VPN lorsque cette connexion est utilisée", avec juste en dessous un menu déroulant permettant de sélectionner cette connexion VPN.

Dans ton interface graphique pourquoi as tu autant de "Connexion filaire" ?
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

carl11
yeomen
Messages : 225
Inscription : mer. 21 oct. 2015, 15:00

Re: [Openvpn] connexion auto au démarrage

Message par carl11 » sam. 14 juil. 2018, 16:09

Je ne vois cette option ni dans la connexion Wifi ni dans Ethernet.
Je cherche encore , pour mes connexion filaire j'ai fait un peu de nettoyage ; )
CPU : Core i3 6100 @ 3.70ghz | RAM : 8Go DDR4
HD : Sandisk SSD Plus 120Go | CG : ATI Radeon 5450

KDE-Plasma
Archlinux , Firefox , thunderbird.

carl11
yeomen
Messages : 225
Inscription : mer. 21 oct. 2015, 15:00

Re: [Openvpn] connexion auto au démarrage

Message par carl11 » mer. 18 juil. 2018, 09:51

Bon j'ai un peu avancé j'ai maintenant trouvé dans outils réseau de Gnome l'option pour activer automatiquement le vpn , mais si je coche cette option la connexion wifi plante alors qu'en manuel ça fonctionne...

Image

Je précise que je me connecte à l'aide d'un point d'acces mobile n'ayant pas de connexion ADSL.
CPU : Core i3 6100 @ 3.70ghz | RAM : 8Go DDR4
HD : Sandisk SSD Plus 120Go | CG : ATI Radeon 5450

KDE-Plasma
Archlinux , Firefox , thunderbird.

carl11
yeomen
Messages : 225
Inscription : mer. 21 oct. 2015, 15:00

Re: [Openvpn] connexion auto au démarrage

Message par carl11 » mer. 18 juil. 2018, 15:00

Je pense qu'au démarrage de ma session le vpn se connecte avant le wifi ce qui expliquerais l'échec de la connexion...
Si vous connaissez un moyen de rallonger le délais de connexion du vpn ?
CPU : Core i3 6100 @ 3.70ghz | RAM : 8Go DDR4
HD : Sandisk SSD Plus 120Go | CG : ATI Radeon 5450

KDE-Plasma
Archlinux , Firefox , thunderbird.

Répondre