[scim] Beaucoup de bugs

Applications, problèmes de configuration réseau
Avatar de l’utilisateur
reflets de vert
yeomen
Messages : 284
Inscription : mar. 23 mars 2010, 15:17
Localisation : Strasbourg
Contact :

[scim] Beaucoup de bugs

Message par reflets de vert » jeu. 26 juil. 2018, 13:16

Bonjour,

Alors j'utilise xdm comme gestionnaire de connexion, dwm comme gestionnaire de fenêtres, et j'ai voulu tester scim, pour écrire un petit peu en chinois.

J'ai aussi testé ibus, fcitx et un autre. SCIM m'avait l'air mieux fait.

Ça bugge sec. Une fois le chinois est actif, la fois d'après il ne marche pas alors qu'il est dans l'interface de configuration, et puis aujourd'hui mon ordi rame et je me rends compte via top que le scim-launcher bouffe toute la mémoire vive! Quand on tue le processus il revient, etc…

Pourtant quand ça marche ça écrit correctement et tout.

Je comprends pas trop comment/pourquoi, mais ça déconne bien.
J'utilise xdm, dwm, …
(bon moi aussi j'écris en bépo - même si ça se voit pas)

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 1851
Inscription : jeu. 15 mars 2012, 05:08

Re: [scim] Beaucoup de bugs

Message par waitnsea » jeu. 26 juil. 2018, 13:22

reflets de vert a écrit :
jeu. 26 juil. 2018, 13:16
Je comprends pas trop comment/pourquoi, mais ça déconne bien.
Bonjour,
pas concerné, mais, par curiosité, as-tu essayé avec un environnement deepin ?
LENOVO Y700-341SH i7-6700 3.4gHZ 1 SSD + 2HDD - Arch/KDE - NVidia GeForce GeForce GTX 750 T
Sauvegardes quotidiennes de mes système et données par BORG

Avatar de l’utilisateur
reflets de vert
yeomen
Messages : 284
Inscription : mar. 23 mars 2010, 15:17
Localisation : Strasbourg
Contact :

Re: [scim] Beaucoup de bugs

Message par reflets de vert » jeu. 26 juil. 2018, 20:58

Ben pour la science je devrais le faire, et je peux le faire, mais je ne supporte pas ce que j'appelle les alourdiciels… je sais c'est très têtu et pénible d'aimer dwm, dmenu, 9menu, le recyclage de vieux ordis et les choses de ce style, mais je ne comprends pas pourquoi la saisie du chinois n'utilise pas correctement les standards de xorg!

Mais je vais le faire, et je vous dis.
En attendant, je désinstalle cette m***de de scim.
J'utilise xdm, dwm, …
(bon moi aussi j'écris en bépo - même si ça se voit pas)

Avatar de l’utilisateur
reflets de vert
yeomen
Messages : 284
Inscription : mar. 23 mars 2010, 15:17
Localisation : Strasbourg
Contact :

Re: [scim] Beaucoup de bugs

Message par reflets de vert » jeu. 26 juil. 2018, 23:13

J'ai essayé deepin.
Bon, mis à part que c'est lourd et que je ne supporte pas ses menus.

Le chinois ne marche pas "out of the box", et j'ai pas réussi à faire marcher scim dessus. (j'ai pas non plus trop insisté et tout testé)
J'utilise xdm, dwm, …
(bon moi aussi j'écris en bépo - même si ça se voit pas)

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 1851
Inscription : jeu. 15 mars 2012, 05:08

Re: [scim] Beaucoup de bugs

Message par waitnsea » ven. 27 juil. 2018, 08:03

reflets de vert a écrit :
jeu. 26 juil. 2018, 23:13
Le chinois ne marche pas "out of the box", et j'ai pas réussi à faire marcher scim dessus. (j'ai pas non plus trop insisté et tout testé)
Si le but est d'utiliser le chinois il te reste l'original en VM ?
LENOVO Y700-341SH i7-6700 3.4gHZ 1 SSD + 2HDD - Arch/KDE - NVidia GeForce GeForce GTX 750 T
Sauvegardes quotidiennes de mes système et données par BORG

bobo
Elfe
Messages : 512
Inscription : mar. 08 avr. 2014, 22:47

Re: [scim] Beaucoup de bugs

Message par bobo » jeu. 09 août 2018, 19:56

qu'as-tu fait de particulier pour installer scim? pourrais-tu décrire les manips supplémentaires que tu as faites pour l'installation?

Il y a l'air d'y avoir des comportements dépendant des locales
https://wiki.archlinux.org/index.php/Sm ... ated_files

Autres questions:


les comportements bizarres sont-ils vraiment aléatoires? se produisent-ils pour les mêmes scénario d'utilisation? n'est-il pas possible d'identifier un pattern reproductible qui provoque les soucis?
je suppose que tu as du essayer un peu de comprendre, qu'as-tu fait?

j'utilise dwm sans gestionnaire de connection: login en tty puis utilisation de startx, ça pourrait être intéressant de voir si les comportements bizarre disparaissent sans utiliser xdm, as-tu essayé ça ou un autre gestionnaire de connection?

serait-il possible que dwm en bave avec les caractères chinois avec ses ~2000 lignes de code?
dwm — BÉPO — vim — “more is less !”

Répondre