[dw_mac/TMP] Missing DT data / can't request region for ressource

Reconnaissance et configuration du matériel / kernel linux
Iusildra
newbie
Messages : 5
Inscription : lun. 30 juil. 2018, 16:07

[dw_mac/TMP] Missing DT data / can't request region for ressource

Message par Iusildra » sam. 04 août 2018, 21:44

Bonjour,
(Les erreurs suivantes n'ont aucun effets)
Je suis nouveau sur Arch et j'ai aussi 2 messages d'erreurs lors de mon boot qui m'ont ammené à entrer dmesg.
J'ai pu retrouver les 2 erreurs que je retrouve au boot, juste avant le loggin.

Code : Tout sélectionner

dw_dmac INTL9C60:01: Missing DT data

et

Code : Tout sélectionner

MSFT0101:00: can't request region for resource [mem 0x76dcc000-0x76dcc02f]
tpm_crb: probe of MSFT0101:00 failed with error -16
Pour dw_dmac, tout ce que j'ai trouvé comme réponses était de régler le loglevel mais j'aimerais bien faire disparaître ça pour de bon, pas le masquer.

Et pour MSFT, c'est en rapport avec tmp_crb donc après recherche j'ai vu que c'était un module qui était automatiquemet chargé (habituellement). J'ai essayer de le charger pour voir:

Code : Tout sélectionner

[lucas@Arch ~]$ modprobe tmp
modprobe: FATAL: Module tmp not found in directory /lib/modules/4.17.11-arch1
Je croyais les modules tous disponibles, juste qu'il fallait les charger :?:

Kernel 4.17.11-arch1
Ordinateur Hp x360-310 G2

Merci d'avance

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10398
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [dw_mac/TMP] Missing DT data / can't request region for ressource

Message par FoolEcho » dim. 05 août 2018, 10:07

Salut,
Iusildra a écrit :
sam. 04 août 2018, 21:44
Pour dw_dmac, tout ce que j'ai trouvé comme réponses était de régler le loglevel mais j'aimerais bien faire disparaître ça pour de bon, pas le masquer.
Tu te réfères à https://bbs.archlinux.org/viewtopic.php?id=236757 , j'imagine...

Délicat... C'est un module builtin (pour info, cf. /lib/modules/4.17.11-arch1/modules.builtin), tu ne pourras donc que masquer le message ou blacklister le module je pense (ce qui n'est pas forcément une solution non plus).
Pour le reste, le rapport de bug et le sujet semblent suggérer que ce n'est pas une régression... et comme tu prétends ne pas avoir de problème, ben... :mrgreen:

------------
Iusildra a écrit :
sam. 04 août 2018, 21:44

Code : Tout sélectionner

MSFT0101:00: can't request region for resource [mem 0x76dcc000-0x76dcc02f]
tpm_crb: probe of MSFT0101:00 failed with error -16
Iusildra a écrit :
sam. 04 août 2018, 21:44

Code : Tout sélectionner

[lucas@Arch ~]$ modprobe tmp
modprobe: FATAL: Module tmp not found in directory /lib/modules/4.17.11-arch1
tpm_crb pas tmp:

Code : Tout sélectionner

$ modinfo tpm_crb
filename:       /lib/modules/4.17.11-arch1/kernel/drivers/char/tpm/tpm_crb.ko.xz
license:        GPL
version:        0.1
description:    TPM2 Driver
author:         Jarkko Sakkinen <jarkko.sakkinen@linux.intel.com>
srcversion:     50CB603B987B1B1802B9A22
alias:          acpi*:MSFT0101:*
depends:        tpm
retpoline:      Y
intree:         Y
name:           tpm_crb
vermagic:       4.17.11-arch1 SMP preempt mod_unload modversions 
«The following statement is not true. The previous statement is true.» :nage:

Iusildra
newbie
Messages : 5
Inscription : lun. 30 juil. 2018, 16:07

Re: [dw_mac/TMP] Missing DT data / can't request region for ressource

Message par Iusildra » dim. 05 août 2018, 11:05

En effet, ca marche mieux avec tpm... :oops:
Merci de ta réponse :)

Répondre