[Scite] Paquet non supporté

Questions et astuces concernant l'installation et la configuration d'archlinux
Viserion
newbie
Messages : 9
Inscription : jeu. 12 juil. 2018, 09:04

[Scite] Paquet non supporté

Message par Viserion » dim. 12 août 2018, 12:27

Bonjour,
Je souhaite installer Scite mais j'obtiens ceci :

Code : Tout sélectionner

Mot de passe : 
[root@fab aragorn]# yaourt -S scite

==> Téléchargement du PKGBUILD de scite depuis AUR...
x .SRCINFO
x PKGBUILD
fhdk commented on 2018-04-07 15:00			 

TrialnError commented on 2018-04-07 18:29			 

scite 4.1.0-1  (2018-06-19 22:15)
( Paquet non supporté : peut être dangereux ! )
==> Éditer PKGBUILD ? [O/n] ("A" pour annuler)
==> ------------------------------------------
==> 
Oui ou non ?
Merci.

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 1851
Inscription : jeu. 15 mars 2012, 05:08

Re: [Scite] Paquet non supporté

Message par waitnsea » dim. 12 août 2018, 15:21

Viserion a écrit :
dim. 12 août 2018, 12:27
Bonjour,
Je souhaite installer Scite mais j'obtiens ceci :

Code : Tout sélectionner

Mot de passe : 
[root@fab aragorn]# yaourt -S scite

==> Téléchargement du PKGBUILD de scite depuis AUR...
x .SRCINFO
x PKGBUILD
fhdk commented on 2018-04-07 15:00			 

TrialnError commented on 2018-04-07 18:29			 

scite 4.1.0-1  (2018-06-19 22:15)
( Paquet non supporté : peut être dangereux ! )
==> Éditer PKGBUILD ? [O/n] ("A" pour annuler)
==> ------------------------------------------
==> 
Oui ou non ?
Merci.
Bonjour,
Oui à l'édition du PKGBUILD, bien sûr, et les .install aussi, toujours jeter un œil sur ce que tu installes depuis AUR
Ton post m'a poussé à faire l'ajout de Vérification au Wiki, ceci figure dans le Wiki inter mais était omis dans le francophone - traité plus loin
J'ai vu une fois (pas retrouvé hélas) un post sur le forum inter où un utilisateur s'était fait infecter par un paquet AUR.
Avec les mining et autres hack malicieux du moment, ne pas installer de paquets tout neufs, non votés, etc...
LENOVO Y700-341SH i7-6700 3.4gHZ 1 SSD + 2HDD - Arch/KDE - NVidia GeForce GeForce GTX 750 T
Sauvegardes quotidiennes de mes système et données par BORG

Viserion
newbie
Messages : 9
Inscription : jeu. 12 juil. 2018, 09:04

Re: [Scite] Paquet non supporté

Message par Viserion » lun. 13 août 2018, 00:02

Salut,
Voici ce que j'obtiens en répondant oui :

Code : Tout sélectionner

[aragorn@fab ~]$ su
Mot de passe : 
[root@fab aragorn]# yaourt -S scite

==> Téléchargement du PKGBUILD de scite depuis AUR...
x .SRCINFO
x PKGBUILD
fhdk commented on 2018-04-07 15:00			 

TrialnError commented on 2018-04-07 18:29			 

scite 4.1.0-1  (2018-06-19 22:15)
( Paquet non supporté : peut être dangereux ! )
==> Éditer PKGBUILD ? [O/n] ("A" pour annuler)
==> ------------------------------------------
==> o

Merci d'ajouter $VISUAL à vos variables d'environnement.
par exemple :
export VISUAL="vim" (dans ~/.bashrc)
(remplacez vim par votre éditeur favori)

==> Éditer PKGBUILD avec :  emacs

==> ERREUR : Exécuter makepkg en tant qu’administrateur n’est pas autorisé car cela pourrait
causer des dommages catastrophiques et permanents à votre système.
Impossible de lire le PKGBUILD
[root@fab aragorn]# 

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 1851
Inscription : jeu. 15 mars 2012, 05:08

Re: [Scite] Paquet non supporté

Message par waitnsea » lun. 13 août 2018, 05:42

Viserion a écrit :
lun. 13 août 2018, 00:02
Voici ce que j'obtiens en répondant oui :
==> ERREUR : Exécuter makepkg en tant qu’administrateur n’est pas autorisé car cela pourrait
causer des dommages catastrophiques et permanents à votre système.
C'est très clair !
Mais c'est vrai que le Wiki ne le dit pas clairement - je fais un ajout - : toutes les manipulations de construction/compilation du paquet doivent être effectuées en "user". Ce n'est qu'à l'étape finale d'installation que le paquet compilé doit être installé én root.
Si tu utilises un assistant AUR (yay ou trizen plutôt que yaourt dont le développement est arrêté) tu le lances en user, il te demandera un mot de passe à la fin, mais un assistant/AUR n'est absolument pas nécessaire:

Code : Tout sélectionner

$ git clone https://aur.archlinux.org/scite.git
$ cd scite    
$ makepkg -si
... compilation ...
Demande du mot de passe
:: Procéder à l’installation ? [O/n]
et une fois le paquet installé:

Code : Tout sélectionner

$ cd && rm -rf scite
LENOVO Y700-341SH i7-6700 3.4gHZ 1 SSD + 2HDD - Arch/KDE - NVidia GeForce GeForce GTX 750 T
Sauvegardes quotidiennes de mes système et données par BORG

Viserion
newbie
Messages : 9
Inscription : jeu. 12 juil. 2018, 09:04

Re: [Scite] Paquet non supporté

Message par Viserion » mar. 14 août 2018, 00:35

Salut,
Merci pour ces explications très claires ; il ne me reste plus qu'à apprivoiser scite !
Fabrice

Répondre