[Audio] Plus de son en HDMI

Applications multimedia / jeux
Avatar de l’utilisateur
eyome
archer
Messages : 132
Inscription : mar. 04 oct. 2011, 16:35

[Audio] Plus de son en HDMI

Message par eyome » dim. 12 août 2018, 17:37

Bonjour,

Depuis quelques temps, je n'ai plus de son en HDMI lorsque je connecte mon PC à un écran. Je ne vois même plus ma carte son dans gnome-center ; il n'y a que ma carte son par défaut de disponible.

Code : Tout sélectionner

aplay -l
**** Liste des Périphériques Matériels PLAYBACK ****
carte 0: MID [HDA Intel MID], périphérique 0: ALC269 Analog [ALC269 Analog]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 1: HDMI [HDA ATI HDMI], périphérique 3: HDMI 0 [HDMI 0]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
Lorsque je joue ça le son va bien vers le téléviseur :

Code : Tout sélectionner

aplay -D plughw:1,3 /usr/share/sounds/alsa/Front_Center.wav
Lecture WAVE '/usr/share/sounds/alsa/Front_Center.wav' : Signed 16 bit Little Endian, Fréquence 48000 Hz, Mono
Du coup j'ai édité le fichier asound comme suit :

Code : Tout sélectionner

pcm.!default {
    type hw
    card 1
    device 3
}
Mais au redémarrage, je n'ai toujours pas de son sur la TV et ma carte HDMI n'est toujours pas disponible dans Gnome-center.
Je ne sais pas ce qui s'est passé et je ne sais pas trop ce qu'il faut que je fasse. Si quelqu'un peut m'aider, ça serait cool.
Merci d'avance :D

Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 15214
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Audio] Plus de son en HDMI

Message par benjarobin » mar. 14 août 2018, 11:28

Bonjour, tu devrais utiliser pulseaudio et supprimer toute configuration manuelle que tu as pu réaliser. Installe aussi alsa-pulseaudio.

Puis il suffit de configurer via l'interface de contrôle de pulseaudio la carte son de sortie
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
eyome
archer
Messages : 132
Inscription : mar. 04 oct. 2011, 16:35

Re: [Audio] Plus de son en HDMI

Message par eyome » mer. 15 août 2018, 21:01

Bonsoir,

Merci pour ta réponse.
J'ai réinstallé alsa-pulseaudio ainsi que pulseaudio (histoire de faire bonne figure) j'ai supprimé le fichier asound que j'ai mis plus haut et redémarré et je n'ai toujours pas de son en HDMI :-(.
J'ai aussi essayé aprés avoir créé un nouvel utilisateur et le problème reste le même ; pas de sortie son HDMI listée dans gnome-center et pas de son HDMI de manière générale.

Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 15214
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Audio] Plus de son en HDMI

Message par benjarobin » jeu. 16 août 2018, 19:38

As tu essayé avec pavucontrol ? Normalement ta carte avec une sortie HDMI devrait être listée
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
eyome
archer
Messages : 132
Inscription : mar. 04 oct. 2011, 16:35

Re: [Audio] Plus de son en HDMI

Message par eyome » ven. 17 août 2018, 00:45

Effectivement, ma carte est visible dans la section "Configuration" et est sur "éteint".
Lorsque je change pour "Sortie digitale Stereo (HDMI) (unplugged) (unavailable)", la carte apparait alors dans Gnome-center et cela fonctionne correctement.
Par contre, au redémarage du PC, ma carte est encore vu comme "éteinte" dans Pavucontrol.
Comme rendre ça pérenne ?

bitgid
newbie
Messages : 2
Inscription : sam. 17 févr. 2018, 15:28

Re: [Audio] Plus de son en HDMI

Message par bitgid » mer. 29 août 2018, 22:57

Comme le titre l'indique, je ne peux pas faire fonctionner l'audio HDMI. Et je ne peux pas passer à travers ça.

Ce que j'ai:

Code : Tout sélectionner

#aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC887-VD Analog [ALC887-VD Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA Intel HDMI], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA Intel HDMI], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
lspci -v:

00:00.0 Host bridge: Intel Corporation 4th Gen Core Processor DRAM Controller (rev 06)
    Subsystem: ASUSTeK Computer Inc. Device 8534
    Flags: bus master, fast devsel, latency 0
    Capabilities: <access denied>
    Kernel driver in use: hsw_uncore

00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller (rev 06) (prog-if 00 [Normal decode])
    Flags: bus master, fast devsel, latency 0, IRQ 26
    Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
    I/O behind bridge: None
    Memory behind bridge: None
    Prefetchable memory behind bridge: None
    Capabilities: <access denied>
    Kernel driver in use: pcieport
    Kernel modules: shpchp

00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06) (prog-if 00 [VGA controller])
    Subsystem: ASUSTeK Computer Inc. Device 8534
    Flags: bus master, fast devsel, latency 0, IRQ 32
    Memory at f7800000 (64-bit, non-prefetchable) [size=4M]
    Memory at e0000000 (64-bit, prefetchable) [size=256M]
    I/O ports at f000 [size=64]
    [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
    Capabilities: <access denied>
    Kernel driver in use: i915
    Kernel modules: i915

00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06)
    Subsystem: ASUSTeK Computer Inc. Device 8534
    Flags: bus master, fast devsel, latency 0, IRQ 34
    Memory at f7c14000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel

00:14.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI (rev 05) (prog-if 30 [XHCI])
    Subsystem: ASUSTeK Computer Inc. Device 8534
    Flags: bus master, medium devsel, latency 0, IRQ 29
    Memory at f7c00000 (64-bit, non-prefetchable) [size=64K]
    Capabilities: <access denied>
    Kernel driver in use: xhci_hcd
    Kernel modules: xhci_pci

00:16.0 Communication controller: Intel Corporation 8 Series/C220 Series Chipset Family MEI Controller #1 (rev 04)
    Subsystem: ASUSTeK Computer Inc. Device 8534
    Flags: bus master, fast devsel, latency 0, IRQ 31
    Memory at f7c1f000 (64-bit, non-prefetchable) [size=16]
    Capabilities: <access denied>
    Kernel driver in use: mei_me
    Kernel modules: mei_me

00:1a.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #2 (rev 05) (prog-if 20 [EHCI])
    Subsystem: ASUSTeK Computer Inc. Device 8534
    Flags: bus master, medium devsel, latency 0, IRQ 20
    Memory at f7c1c000 (32-bit, non-prefetchable) [size=1K]
    Capabilities: <access denied>
    Kernel driver in use: ehci-pci
    Kernel modules: ehci_pci

00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)
    Subsystem: ASUSTeK Computer Inc. Device 8576
    Flags: bus master, fast devsel, latency 0, IRQ 33
    Memory at f7c10000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel

00:1c.0 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #1 (rev d5) (prog-if 00 [Normal decode])
    Flags: bus master, fast devsel, latency 0, IRQ 27
    Bus: primary=00, secondary=02, subordinate=02, sec-latency=0
    I/O behind bridge: 00002000-00002fff [size=4K]
    Memory behind bridge: de200000-de3fffff [size=2M]
    Prefetchable memory behind bridge: 00000000de400000-00000000de5fffff [size=2M]
    Capabilities: <access denied>
    Kernel driver in use: pcieport
    Kernel modules: shpchp

00:1c.2 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #3 (rev d5) (prog-if 00 [Normal decode])
    Flags: bus master, fast devsel, latency 0, IRQ 28
    Bus: primary=00, secondary=03, subordinate=03, sec-latency=0
    I/O behind bridge: 0000e000-0000efff [size=4K]
    Memory behind bridge: None
    Prefetchable memory behind bridge: 00000000f0000000-00000000f00fffff [size=1M]
    Capabilities: <access denied>
    Kernel driver in use: pcieport
    Kernel modules: shpchp

00:1c.3 PCI bridge: Intel Corporation 82801 PCI Bridge (rev d5) (prog-if 01 [Subtractive decode])
    Flags: bus master, fast devsel, latency 0, IRQ 15
    Bus: primary=00, secondary=04, subordinate=05, sec-latency=0
    I/O behind bridge: None
    Memory behind bridge: None
    Prefetchable memory behind bridge: None
    Capabilities: <access denied>

00:1d.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #1 (rev 05) (prog-if 20 [EHCI])
    Subsystem: ASUSTeK Computer Inc. Device 8534
    Flags: bus master, medium devsel, latency 0, IRQ 23
    Memory at f7c1b000 (32-bit, non-prefetchable) [size=1K]
    Capabilities: <access denied>
    Kernel driver in use: ehci-pci
    Kernel modules: ehci_pci

00:1f.0 ISA bridge: Intel Corporation B85 Express LPC Controller (rev 05)
    Subsystem: ASUSTeK Computer Inc. Device 8534
    Flags: bus master, medium devsel, latency 0
    Capabilities: <access denied>
    Kernel driver in use: lpc_ich
    Kernel modules: lpc_ich

00:1f.2 SATA controller: Intel Corporation 8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode] (rev 05) (prog-if 01 [AHCI 1.0])
    Subsystem: ASUSTeK Computer Inc. Device 8534
    Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 30
    I/O ports at f0b0 [size=8]
    I/O ports at f0a0 [size=4]
    I/O ports at f090 [size=8]
    I/O ports at f080 [size=4]
    I/O ports at f060 [size=32]
    Memory at f7c1a000 (32-bit, non-prefetchable) [size=2K]
    Capabilities: <access denied>
    Kernel driver in use: ahci
    Kernel modules: ahci

00:1f.3 SMBus: Intel Corporation 8 Series/C220 Series Chipset Family SMBus Controller (rev 05)
    Subsystem: ASUSTeK Computer Inc. Device 8534
    Flags: medium devsel, IRQ 18
    Memory at f7c19000 (64-bit, non-prefetchable) [size=256]
    I/O ports at f040 [size=32]
    Kernel driver in use: i801_smbus
    Kernel modules: i2c_i801

03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 09)
    Subsystem: ASUSTeK Computer Inc. P8 series motherboard
    Flags: bus master, fast devsel, latency 0, IRQ 35
    I/O ports at e000 [size=256]
    Memory at f0004000 (64-bit, prefetchable) [size=4K]
    Memory at f0000000 (64-bit, prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: r8169
    Kernel modules: r8169

04:00.0 PCI bridge: ASMedia Technology Inc. ASM1083/1085 PCIe to PCI Bridge (rev 03) (prog-if 01 [Subtractive decode])
    Flags: bus master, fast devsel, latency 0, IRQ 15
    Bus: primary=04, secondary=05, subordinate=05, sec-latency=32
    I/O behind bridge: None
    Memory behind bridge: None
    Prefetchable memory behind bridge: None
    Capabilities: <access denied>

Répondre