[install de arch] petit ennui avec deux navigateurs ]

Questions et astuces concernant l'installation et la configuration d'archlinux
Avatar de l’utilisateur
jibel
Hankyu
Messages : 46
Inscription : sam. 04 juin 2016, 18:30
Localisation : bxls
Contact :

[install de arch] petit ennui avec deux navigateurs ]

Message par jibel » dim. 16 sept. 2018, 14:10

Bonjour,
Cela fait très longtemps que je n'avais pas oser l'installe de arch; J'ai installé "arch-zen" j'en suis très satisfait , mais j'ai voulu installer dans cet OS le navigateur "falkon 3.0.1-5" avec succès mais il y a une confusion avec l'autre navigateur "firefox.quantum 62". a cause de ces deux navigateurs j'ai un soucis pour que ça soit Firefox comme navigateur en 1er a chaque ouverture de lien. de mon courrielleur, .malheureusement c'est falkon qui se lance ! Aie, je voudrais supprimer falkon de manière a ce que ça soit firefox qui lancera le lien... J'ai essayé de supprimer falkon avec pacman? Je crois que j'ai fais que falkon soit supprimé.. Merci de me rappeler quel est la commande pour supprimer falkon ou qu'il soit viré avec le logiciel installation/suppression ?? J'ai QQs oublies de certaines commandes a effectuer avec "yaourt ou pacman ou spooky" si c'est possible avec arch-zen KDE 4.18.7-zen1-1-zen ? merci ! cordialement :roll:
Dernière édition par jibel le ven. 21 sept. 2018, 12:03, édité 1 fois.

hopimet
Elfe
Messages : 895
Inscription : mer. 14 mars 2012, 22:48

Re: [theme] petit ennui avec deux navigateurs ]

Message par hopimet » dim. 16 sept. 2018, 16:21

Salut,
pacman -Rsn paquet

C'est bien aussi de chercher un peu par soi même. D'autant qu'il y a un wiki et que ça prend 5 secondes de trouver l'info que tu demandes.
https://wiki.archlinux.fr/Pacman#Suppression_de_paquets

Avatar de l’utilisateur
jibel
Hankyu
Messages : 46
Inscription : sam. 04 juin 2016, 18:30
Localisation : bxls
Contact :

Re: [theme] petit ennui avec deux navigateurs ]

Message par jibel » dim. 16 sept. 2018, 18:00

hopimet a écrit :
dim. 16 sept. 2018, 16:21
Salut,
pacman -Rsn paquet

C'est bien aussi de chercher un peu par soi même. D'autant qu'il y a un wiki et que ça prend 5 secondes de trouver l'info que tu demandes.
https://wiki.archlinux.fr/Pacman#Suppression_de_paquets
@hopimet,
Merci, c'est de ma faute , suis resté avec les commandes similaires de mes installes de "manjaro", par exemple, effectivement j'aurais du voir dans le "wiki" ce qu'il aurait fallu faire :dodo:
J'ai eu tellement de PBs avec la "manjaro" , car je suis pour le moment en dual-boot et j'ai cru avoir un solide PB avec "panic-kernel" ce qui n'est pas arrivé après l'installe de arch-zen.. Ouf ! coup de bol :chinois: merci je promets de bouger vers le wiki.... C'est ce que j'ai lu correctement, je crois ! Mais sans réussir a installer deux logiciels "vokoscreen et kazam"?
Sont-ils avec aur ou un autre dépôt? Bon dac-o-dac pour supprimer le falkon c'est ce que j'aurais du faire avec le terminal, mais je l'avais supprimer avec le gestionnaire de paquets ou il était installé @ + :lol: :kimouss:

hopimet
Elfe
Messages : 895
Inscription : mer. 14 mars 2012, 22:48

Re: [theme] petit ennui avec deux navigateurs ]

Message par hopimet » dim. 16 sept. 2018, 21:39

Je n'utilise que la ligne de commande pour installer ou supprimer des paquet.

Pour ce qui est d'AUR tu peux utiliser yay ou yaourt par exemple.
Ainsi en 2 secondes tu sais où sont les paquets que tu cherches. Par exemple :

Code : Tout sélectionner

yay -Ss vokoscreen
aur/vokoscreen-git 2.5.8.beta.27.g5b1f17a-2 (+6 0.03%) 
    An easy to use screencast creator. Development version.
aur/vokoscreen 2.5.8.beta-1 (+87 0.74%) 
    An easy to use screencast creator

Code : Tout sélectionner

yay -Ss kazam
aur/kazam 1.4.5-6 (+116 1.78%) 
    A screencasting program with design in mind
Inutile de s'encombrer d'un gestionnaire graphique de paquet. C'est beaucoup plus simple en CLI et c'est bien plus dans l'esprit d'Archlinux.

Avatar de l’utilisateur
jibel
Hankyu
Messages : 46
Inscription : sam. 04 juin 2016, 18:30
Localisation : bxls
Contact :

Re: [theme] petit ennui avec deux navigateurs ]

Message par jibel » dim. 16 sept. 2018, 22:31

hopimet a écrit :
dim. 16 sept. 2018, 21:39
Je n'utilise que la ligne de commande pour installer ou supprimer des paquet.

Pour ce qui est d'AUR tu peux utiliser yay ou yaourt par exemple.
Ainsi en 2 secondes tu sais où sont les paquets que tu cherches. Par exemple :

Code : Tout sélectionner

yay -Ss vokoscreen
aur/vokoscreen-git 2.5.8.beta.27.g5b1f17a-2 (+6 0.03%) 
    An easy to use screencast creator. Development version.
aur/vokoscreen 2.5.8.beta-1 (+87 0.74%) 
    An easy to use screencast creator

Code : Tout sélectionner

yay -Ss kazam
aur/kazam 1.4.5-6 (+116 1.78%) 
    A screencasting program with design in mind
Inutile de s'encombrer d'un gestionnaire graphique de paquet. C'est beaucoup plus simple en CLI et c'est bien plus dans l'esprit d'Archlinux.
C'est vraiment étrange, mais bénéfique ?
[jibel@jibel ~]$ yay -Ss vokoscreen
bash: yay : commande introuvable
[jibel@jibel ~]$ sudo su
[sudo] Mot de passe de jibel : 
[root@jibel jibel]# yay -Ss vokoscreen
bash: yay : commande introuvable
[root@jibel jibel]# yaourt -Ss vokoscreen
package-query: error while loading shared libraries: libalpm.so.10: cannot open shared object file: No such file or directory
[
Qu'est-ce que j'ai pu raté pour installe ces deux recorders ? j'ai pourtant installé green-recorder sans PB ...tiens , qu'est-ce que CLI dans l'esprit archilinux ? J'utilise pourtant "guake" comme terminal en root ou non ? qu'est-ce que j'ai pu oublier encore , mince ? :humour: j'dois être :?

hopimet
Elfe
Messages : 895
Inscription : mer. 14 mars 2012, 22:48

Re: [theme] petit ennui avec deux navigateurs ]

Message par hopimet » dim. 16 sept. 2018, 22:45

Euh... je ne vois pas ce qui te pose problème.
Le message en console : bash: yay : commande introuvable t'indique que yay n'est pas installé. C'est donc logique d'avoir une erreur.
yay est disponible sur aur : https://aur.archlinux.org/packages/yay/

CLI : command line interface. Très peu de monde sous Arch utilise un gestionnaire graphique de paquet dans la mesure où la console suffit largement pour tout faire.

Et sinon quel rapport avec guake ?

Je te conseille de lire un peu le wiki avant de continuer avec Arch qui n'est pas une distribution qu'on peut qualifier de user friendly et qui nécessite de comprendre ce qu'on fait plutôt que d'appliquer des recettes.

Avatar de l’utilisateur
jibel
Hankyu
Messages : 46
Inscription : sam. 04 juin 2016, 18:30
Localisation : bxls
Contact :

Re: [theme] petit ennui avec deux navigateurs ]

Message par jibel » dim. 16 sept. 2018, 23:04

@Hopimet,
Ça y est...tout bêtement je n'avais pas coché "aur" dans le "gestionnaire de paquets" je suppose qu'avec guake qui lui ne bouge pas , je pourrais installer , maintenant, ces deux recorders , kazam lui est déjà présent ! ;-)
Je vais suivre tes conseils. il me suffit de me bouger un peu.. Je dois dire qu'avec manjaro , Arch-zen me parait nettement plus mieux davantage yéyé ... C'était pour cette raison, la plus gênante le fumeux "panic-kernel" en étant en multiboot, j'ai eu des solides ennuis avec la manjaro...Merci de toutes façons, a moi de jouer :lol: cordialement 8)

Répondre