[Mise à Jour] Keepass ne démarre plus (RESOLU)

Questions et astuces concernant l'installation et la configuration d'archlinux
Avatar de l’utilisateur
bowmore
Daikyu
Messages : 76
Inscription : mar. 21 déc. 2010, 12:55

[Mise à Jour] Keepass ne démarre plus (RESOLU)

Message par bowmore » mar. 02 avr. 2019, 13:22

Bonjour à toutes et tous,

Suite à une mise à jour ce matin, je me rends compte que l'application Keepass ne démarre plus.
Je m'en suis servi hier...
Si je lance Keepass dans un terminal, voici le retour:

Code : Tout sélectionner

$ keepass
System.TypeInitializationException: The type initializer for 'KeePass.App.AppDefs' threw an exception. ---> System.TypeInitializationException: The type initializer for 'System.Drawing.KnownColors' threw an exception. ---> System.TypeInitializationException: The type initializer for 'System.Drawing.GDIPlus' threw an exception. ---> System.DllNotFoundException: libgdiplus.so.0
  at (wrapper managed-to-native) System.Drawing.GDIPlus.GdiplusStartup(ulong&,System.Drawing.GdiplusStartupInput&,System.Drawing.GdiplusStartupOutput&)
  at System.Drawing.GDIPlus..cctor () [0x000b0] in <1e4953d3f193474c8978b56dfb08ac80>:0 
   --- End of inner exception stack trace ---
  at (wrapper managed-to-native) System.Object.__icall_wrapper_mono_generic_class_init(intptr)
  at System.Drawing.Graphics.FromHdcInternal (System.IntPtr hdc) [0x00000] in <1e4953d3f193474c8978b56dfb08ac80>:0 
  at System.Windows.Forms.XplatUIX11.SetDisplay (System.IntPtr display_handle) [0x00073] in <e9a8e33836984081803639fada9a0f56>:0 
  at System.Windows.Forms.XplatUIX11..ctor () [0x00077] in <e9a8e33836984081803639fada9a0f56>:0 
  at System.Windows.Forms.XplatUIX11.GetInstance () [0x00019] in <e9a8e33836984081803639fada9a0f56>:0 
  at System.Windows.Forms.XplatUI..cctor () [0x000c0] in <e9a8e33836984081803639fada9a0f56>:0 
   --- End of inner exception stack trace ---
  at (wrapper managed-to-native) System.Object.__icall_wrapper_mono_generic_class_init(intptr)
  at System.Drawing.Color.FromKnownColor (System.Drawing.KnownColor color) [0x00007] in <1e4953d3f193474c8978b56dfb08ac80>:0 
  at System.Drawing.Color.get_Black () [0x00000] in <1e4953d3f193474c8978b56dfb08ac80>:0 
  at System.Windows.Forms.ThemeWin32Classic..cctor () [0x00000] in <e9a8e33836984081803639fada9a0f56>:0 
   --- End of inner exception stack trace ---
  at KeePass.Program.Main (System.String[] args) [0x00000] in <f814c08bdd6f4df38563b04ce57b6fe8>:0 

Unhandled Exception:
System.TypeInitializationException: The type initializer for 'System.Drawing.GDIPlus' threw an exception. ---> System.DllNotFoundException: libgdiplus.so.0
  at (wrapper managed-to-native) System.Drawing.GDIPlus.GdiplusStartup(ulong&,System.Drawing.GdiplusStartupInput&,System.Drawing.GdiplusStartupOutput&)
  at System.Drawing.GDIPlus..cctor () [0x000b0] in <1e4953d3f193474c8978b56dfb08ac80>:0 
   --- End of inner exception stack trace ---
  at (wrapper managed-to-native) System.Object.__icall_wrapper_mono_generic_class_init(intptr)
  at System.Drawing.Graphics.FromHdcInternal (System.IntPtr hdc) [0x00000] in <1e4953d3f193474c8978b56dfb08ac80>:0 
  at System.Windows.Forms.XplatUIX11.Finalize () [0x00000] in <e9a8e33836984081803639fada9a0f56>:0 
[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeInitializationException: The type initializer for 'System.Drawing.GDIPlus' threw an exception. ---> System.DllNotFoundException: libgdiplus.so.0
  at (wrapper managed-to-native) System.Drawing.GDIPlus.GdiplusStartup(ulong&,System.Drawing.GdiplusStartupInput&,System.Drawing.GdiplusStartupOutput&)
  at System.Drawing.GDIPlus..cctor () [0x000b0] in <1e4953d3f193474c8978b56dfb08ac80>:0 
   --- End of inner exception stack trace ---
  at (wrapper managed-to-native) System.Object.__icall_wrapper_mono_generic_class_init(intptr)
  at System.Drawing.Graphics.FromHdcInternal (System.IntPtr hdc) [0x00000] in <1e4953d3f193474c8978b56dfb08ac80>:0 
  at System.Windows.Forms.XplatUIX11.Finalize () [0x00000] in <e9a8e33836984081803639fada9a0f56>:0 
Visiblement, il manque quelque chose.
libgdiplus est installé et à jour. :-?

Là, je sèche, d'autant que j'ai d'autre applications qui ne se lance plus, mais à priori, ce n'est pas lié.
Je vais ouvrir un autre post pour cet autre problème.
Dernière édition par bowmore le mer. 03 avr. 2019, 08:29, édité 1 fois.
Attendez vous au pire, vous ne serez jamais déçu...
Chaque mois, je suis seeder du torrent archlinux dual.iso. C'est une façon simple de participer à la communauté!

Avatar de l’utilisateur
CoudUr
Daikyu
Messages : 67
Inscription : sam. 06 avr. 2013, 17:12

Re: [Mise à Jour] Keepass ne démarre plus

Message par CoudUr » mar. 02 avr. 2019, 16:05

Bonjour,

Selon ce sujet qui se réfère a ce rapport de bug, la mise a jour de giflib dans sa version 5.1.9-2 devrait résoudre ton problème, une simple mise à jour devrait corriger le problème.

Je ne savais même pas que keepass était encore dans les dépôts, je suis avec keepassxc depuis quelques années maintenant parce qu'à l'époque son développement était plus actif mais je suis content de voir que keepass reçoit toujours de l'attention, et les mises à jours ont l'air d'être régulières.

Avatar de l’utilisateur
bowmore
Daikyu
Messages : 76
Inscription : mar. 21 déc. 2010, 12:55

Re: [Mise à Jour] Keepass ne démarre plus

Message par bowmore » mer. 03 avr. 2019, 08:28

Bonjour,

Effectivement, la mise à jour de giflib a résolu mon problème.
C'est curieux, car la mise à jour que j'ai faite hier ne concernait pas giflib, mais ce matin, il était dans la liste des paquets à mettre à jour...

Merci pour ce tuyau. :wink:
Attendez vous au pire, vous ne serez jamais déçu...
Chaque mois, je suis seeder du torrent archlinux dual.iso. C'est une façon simple de participer à la communauté!

Répondre