[Installation logiciel] problème de paquet corrompu (résolu)

Questions et astuces concernant l'installation et la configuration d'archlinux
Répondre
Avatar de l’utilisateur
Lagoutte
Hankyu
Messages : 13
Inscription : mer. 15 mai 2019, 19:13

[Installation logiciel] problème de paquet corrompu (résolu)

Message par Lagoutte » mar. 04 juin 2019, 17:40

Bonjour,
j'ai un petit problème lorsque je veux installer firefox. L'install pacman se finit par :

"erreur: giflib : la signature de "Levente Polyak (anthraxx) <levente@leventepolyak.net> est de confiance inconnue
:: Le fichier /var/cache/pacman/pkg/giflib-5.1.9-3-x86_64.pkg.tar.xz est corrompu (paquet non valide ou corrompu (signature PGP)
Voulez-vous le supprimer ? [O/n]
erreur : la validation de la transaction a échoué (paquet non valide ou corrompu)
Des erreurs se sont produites, aucun paquet n'a été mis à jour."

Que faire ?
Bien à vous
Jeff
Dernière modification par Lagoutte le mar. 04 juin 2019, 23:19, modifié 3 fois.

benjarobin
Maître du Kyudo
Messages : 15397
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Installation Firefox] problème de paquet corrompu

Message par benjarobin » mar. 04 juin 2019, 18:19

Bonjour,
Met à jour archlinux-keyring au préalable
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
Lagoutte
Hankyu
Messages : 13
Inscription : mer. 15 mai 2019, 19:13

Re: [Installation Firefox] problème de paquet corrompu

Message par Lagoutte » mar. 04 juin 2019, 18:47

Merci benjarobin,

j'ai mis à jour archlinux-keyring
j'ai vidé le cache avec pacman -Scc (curieusement le paquet en question n'était pas présent)
j'ai changé de miroir (mais c'est le même qui reviens malgré ça)
j'ai refait un pacman -Syyu

Rien n'a changé
Il faut peut-être changer les clés comme le suggère un post que j'ai trouvé sur le forum...

benjarobin
Maître du Kyudo
Messages : 15397
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Installation Firefox] problème de paquet corrompu

Message par benjarobin » mar. 04 juin 2019, 18:52

Surtout ne supprime pas / change pas les clés... Tu as presque 100% de chance de casser ton système.
Il ne faut jamais modifier le keyring à la main, uniquement utiliser le paquet pour cela.
mais c'est le même qui reviens malgré ça
Que veux tu dire par là ? Tu as bien changé l'URL du miroir ?
Quel est le rapport avec giflib (Le titre parle de firefox)
Peux tu donner la sortie de :

Code : Tout sélectionner

uname -a
pacman -Q linux giflib firefox archlinux-keyring
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
Lagoutte
Hankyu
Messages : 13
Inscription : mer. 15 mai 2019, 19:13

Re: [Installation Firefox] problème de paquet corrompu

Message par Lagoutte » mar. 04 juin 2019, 19:43

pour le miroir j'ai fait :
reflector --country France --age 12 --protocol https --sort rate --save etc/pacman.d/.mirrorlist
et j'ai d'autres miroirs

C'est quand j'installe firefox que la séquence se finit par le giflib corrompu

uname -a donne :
Linux archlinuxtest10 4.19.47-1-lts

et pacman -Q linux giflib firefox archlinux-keyring donne :
linux 5.1.6.arch1-1
erreur : le paquet "giflib" n'a pas été trouvé
erreur : le paquet firefox n'a pas été trouvé
archlinux-keyring 20190123-2

benjarobin
Maître du Kyudo
Messages : 15397
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Installation Firefox] problème de paquet corrompu

Message par benjarobin » mar. 04 juin 2019, 19:56

Donc change de miroir... Il suffit de modifier /etc/pacman.d/mirrorlist, prend n'importe quel autre miroir.
Tu n'as besoin d'avoir qu'un seul miroir dans ce fichier, tu peux en ajouter un 2ième éventuellement, mais cela ne sert à rien d'en mettre plus.

Sinon peux tu donner toute la sortie de pacman -Syu, normalement il demande d'ajouter une clé, il faut répondre oui.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
Lagoutte
Hankyu
Messages : 13
Inscription : mer. 15 mai 2019, 19:13

Re: [Installation Firefox] problème de paquet corrompu

Message par Lagoutte » mar. 04 juin 2019, 20:40


Avatar de l’utilisateur
Lagoutte
Hankyu
Messages : 13
Inscription : mer. 15 mai 2019, 19:13

Re: [Installation Firefox] problème de paquet corrompu

Message par Lagoutte » mar. 04 juin 2019, 21:00

j'ai modifié mon miroir pour n'en avoir plus qu'un.
En faites je ne peux plus rien installer du tout c'est tjs la même erreur qui m'est retournée...

Essai avec autre chose que firefox, mc
Dernière modification par Lagoutte le mar. 04 juin 2019, 21:04, modifié 1 fois.

Avatar de l’utilisateur
Lagoutte
Hankyu
Messages : 13
Inscription : mer. 15 mai 2019, 19:13

Re: [Installation Firefox] problème de paquet corrompu

Message par Lagoutte » mar. 04 juin 2019, 21:04

Essai avec autre chose que firefox, mc par exemple:
[img]https://drive.google.com/file/d/1uy9Pso ... haring[img]

Avatar de l’utilisateur
Lagoutte
Hankyu
Messages : 13
Inscription : mer. 15 mai 2019, 19:13

Re: [Installation] problème de paquet corrompu

Message par Lagoutte » mar. 04 juin 2019, 21:08

j'ai changé le thème

Avatar de l’utilisateur
Lagoutte
Hankyu
Messages : 13
Inscription : mer. 15 mai 2019, 19:13

Re: [Installation] problème de paquet corrompu

Message par Lagoutte » mar. 04 juin 2019, 21:21

Mais je viens d'installer thunderbird et tor et ça marche bien...
Pff... je comprend plus rien !!

Avatar de l’utilisateur
Lagoutte
Hankyu
Messages : 13
Inscription : mer. 15 mai 2019, 19:13

Re: [Installation] problème de paquet corrompu

Message par Lagoutte » mar. 04 juin 2019, 21:43

Je sens que je vais faire une réinstall VM complète en faisant bien attention aux miroirs...

benjarobin
Maître du Kyudo
Messages : 15397
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Installation] problème de paquet corrompu

Message par benjarobin » mar. 04 juin 2019, 21:58

Ce n'est pas les miroirs le problème, toute précipitation est perte de temps... Je ne suis pas encore sûr de comprendre ce qui se passe, il y a un problème lié à ton trousseau de clé, mais cela ne devrait pas arriver...
Peux tu donner la sortie (en root) de :

Code : Tout sélectionner

pacman-key -l | grep -iE -A 8 -B 8 "Levente|Alad"
pacman-key --refresh-keys
pacman-key -l | grep -iE -A 8 -B 8 "Levente|Alad"
Et via pastebin la sortie complète de

Code : Tout sélectionner

pacman-key -l 
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
Lagoutte
Hankyu
Messages : 13
Inscription : mer. 15 mai 2019, 19:13

Re: [Installation logiciel] problème de paquet corrompu

Message par Lagoutte » mar. 04 juin 2019, 23:17

Et bien suite à ses commandes, tout fonctionne ! j'ai pu installer firefox et mc...
Merci beaucoup mais que s'est-il passé ?
Jeff

benjarobin
Maître du Kyudo
Messages : 15397
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Installation logiciel] problème de paquet corrompu (résolu)

Message par benjarobin » mar. 04 juin 2019, 23:45

Il est normalement inutile de lancer pacman-key --refresh-keys car normalement c'est fait automatiquement par pacman quand il découvre une nouvelle clé. Tu as peut être refusé lorsque pacman te la demandé... Bref, c'est le résultat qui compte.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Répondre