[Grub] Pas coopératif

Questions et astuces concernant l'installation et la configuration d'archlinux
Bel Riose
Hankyu
Messages : 20
Inscription : mer. 19 déc. 2018, 09:52
Localisation : Toulon

[Grub] Pas coopératif

Message par Bel Riose » jeu. 11 juil. 2019, 23:33

Bonsoir,
En voulant installer arch sur mon nouveau pc, au moment de l"installation du grub après avoir rentré ceci mount | grep efivars &> /dev/null || mount -t efivarfs efivarfs /sys/firmware/efi/efivars je tombe à chaque fois sur ceci ; [mount: /sys/firmware/efi/efivars : mount point does not exist archlinux/c]

J'ai vérifier je suis bien sur un uefi, je ne pense pas que l'absence de swap en est la cause j'ai déjà essayer cette solution: https://superuser.com/questions/678976/installing-arch-linux-issue-with-modprobe-efivars

L'erreur doit être triviale mais vu que je suis en plein apprentissage je ne la trouve pas.

En vous remerciant de votre aide.

benjarobin
Maître du Kyudo
Messages : 15406
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Grub] Pas coopératif

Message par benjarobin » ven. 12 juil. 2019, 06:20

Bonjour,
Les cartes mères UEFI ont en faite 2 modes de boot nommés :
- Legacy / MBR
- UEFI

Au niveau de la configuration du firmware de l'uefi (anciennement nommé BIOS), tu peux avoir plusieurs options :
- Toujours démarrer en UEFI
- Toujours en Legacy
- Hybrid (qui est très souvent l'option par défaut)

Pour faire une installation d'un système qui démarrera en UEFI, tu dois forcément le faire depuis un système qui a démarré au préalable en mode UEFI. Car en UEFI tout chargeur de démarrage doit pouvoir enregistrer une entrée dans la NVRAM associé au firmware UEFI (C'est en gros ce qui est représenté par les efivars sous Linux). Si tu démarres en mode Legacy tu ne pourras pas enregistrer cette entrée dans la NVRAM, et donc l'installation de GRUB ne sera pas complète (mais tu peux arriver à le faire fonctionner après, c'est juste un peu plus compliqué).

Quand tu boot depuis un device externe, souvent tu dois afficher un menu du firmware UEFI via un raccourci clavier, qui permet de sélectionner sur quoi tu veux démarrer et souvent, pour une clé USB de boot Arch Linux tu as 2 entrées (si tu es bien configuré en hybride) :
- Une pour démarrer en mode Legacy depuis la clé USB
- Une pour démarrer en UEFI

Une question : As tu déjà un système d'installé, si oui démarre-t-il en UEFI ou MBR ? Quelle la table de partition sur le disque existant (GPT ou MBR/BIOS) ? Ou est-ce une installation sur un PC vierge de tout système ?
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Bel Riose
Hankyu
Messages : 20
Inscription : mer. 19 déc. 2018, 09:52
Localisation : Toulon

Re: [Grub] Pas coopératif (résolu)

Message par Bel Riose » ven. 12 juil. 2019, 11:26

La solution au probléme était simple, c'etait en legacy à cause du clear cmos que j'ai fait

Répondre