[Disposition clavier] Sddm en qwerty (Résolu)

Questions et astuces concernant l'installation et la configuration d'archlinux
Répondre
Avatar de l’utilisateur
Fif91
yeomen
Messages : 207
Inscription : lun. 17 janv. 2011, 13:23

[Disposition clavier] Sddm en qwerty (Résolu)

Message par Fif91 » sam. 03 août 2019, 15:45

Bonjour
Depuis une certaine mise à jour, mes dispositions clavier sous SDDM à la connexion sont en qwerty.
J'ai vérifié les locales et je suis bien en fr

Code : Tout sélectionner

locale -a
C
french
fr_FR
fr_FR@euro
fr_FR.iso88591
fr_FR.iso885915@euro
fr_FR.utf8
POSIX
Le problème se pose uniquement sur l'écran de login, le reste est en Fr et Ok.

Code : Tout sélectionner

09-keyboard.conf
Section "InputClass"
    Identifier             "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    MatchProduct           "MX5000"
    MatchVendor            "Logitech, Inc."
    MatchDevicePath        "/dev/input/event6"
    Option "XkbLayout"     "fr"
    Option "XkbVariant"    "oss"
    Option "XkbOptions"    "compose:menu,terminate:ctrl_alt_bksp"
EndSection

Code : Tout sélectionner

cat /etc/sddm.conf
[Autologin]
Relogin=false
Session=
User=

[General]
HaltCommand=
InputMethod=
Numlock=none
RebootCommand=

[Theme]
Current=breeze
CursorTheme=Adwaita
DisableAvatarsThreshold=7
EnableAvatars=true
FacesDir=/usr/share/sddm/faces
ThemeDir=/usr/share/sddm/themes

[Users]
DefaultPath=/bin:/usr/bin:/usr/local/bin
HideShells=
HideUsers=
MaximumUid=65000
MinimumUid=1000
RememberLastSession=true
RememberLastUser=true
ReuseSession=false

[Wayland]
EnableHiDPI=false
SessionCommand=/usr/share/sddm/scripts/wayland-session
SessionDir=/usr/share/wayland-sessions
SessionLogFile=.local/share/sddm/wayland-session.log

[X11]
DisplayCommand=/usr/share/sddm/scripts/Xsetup
DisplayStopCommand=/usr/share/sddm/scripts/Xstop
EnableHiDPI=false
MinimumVT=1
ServerArguments=-nolisten tcp
ServerPath=/usr/bin/X
SessionCommand=/usr/share/sddm/scripts/Xsession
SessionDir=/usr/share/xsessions
SessionLogFile=.local/share/sddm/xorg-session.log
UserAuthFile=.Xauthority
XauthPath=/usr/bin/xauth
XephyrPath=/usr/bin/Xephyr
Un extrait de mon xorg-session.log


Une idée ?
Dernière modification par Fif91 le dim. 04 août 2019, 11:49, modifié 1 fois.
Mageia 4 x64 | ArchLinux x64 | KDE
MSI P45 Neo-F - Intel E8500 @3.16 GHz - 7 Go RAM - ATI HD Radeon 3850

laurent85
yeomen
Messages : 259
Inscription : mar. 16 oct. 2018, 21:05

Re: [Disposition clavier] Sddm en qwerty

Message par laurent85 » sam. 03 août 2019, 16:27

Bonjour,
Regarde le retour de localectl :

Code : Tout sélectionner

localectl

Avatar de l’utilisateur
Fif91
yeomen
Messages : 207
Inscription : lun. 17 janv. 2011, 13:23

Re: [Disposition clavier] Sddm en qwerty

Message par Fif91 » sam. 03 août 2019, 16:33

Bonjour laurent85

Code : Tout sélectionner

localectl
   System Locale: LANG=fr_FR.utf8
                  LC_COLLATE=C
       VC Keymap: fr-latin9
      X11 Layout: n/a
Mageia 4 x64 | ArchLinux x64 | KDE
MSI P45 Neo-F - Intel E8500 @3.16 GHz - 7 Go RAM - ATI HD Radeon 3850

laurent85
yeomen
Messages : 259
Inscription : mar. 16 oct. 2018, 21:05

Re: [Disposition clavier] Sddm en qwerty

Message par laurent85 » sam. 03 août 2019, 17:03

Renomme 09-keyboard.conf en 00-keyboard.conf pour voir d'après le wiki anglais.

Avatar de l’utilisateur
Fif91
yeomen
Messages : 207
Inscription : lun. 17 janv. 2011, 13:23

Re: [Disposition clavier] Sddm en qwerty

Message par Fif91 » sam. 03 août 2019, 18:05

laurent85 a écrit :
sam. 03 août 2019, 17:03
Renomme 09-keyboard.conf en 00-keyboard.conf pour voir d'après le wiki anglais.
Aucun effet, toujours le même problème après reboot
Mageia 4 x64 | ArchLinux x64 | KDE
MSI P45 Neo-F - Intel E8500 @3.16 GHz - 7 Go RAM - ATI HD Radeon 3850

laurent85
yeomen
Messages : 259
Inscription : mar. 16 oct. 2018, 21:05

Re: [Disposition clavier] Sddm en qwerty

Message par laurent85 » sam. 03 août 2019, 18:22

Ton retour de localectl n'a pas de clavier configuré pour X :?:
J'ai :

Code : Tout sélectionner

% localectl
   System Locale: LANG=fr_FR.UTF-8
       VC Keymap: fr-latin1
      X11 Layout: fr

Avatar de l’utilisateur
Fif91
yeomen
Messages : 207
Inscription : lun. 17 janv. 2011, 13:23

Re: [Disposition clavier] Sddm en qwerty

Message par Fif91 » sam. 03 août 2019, 19:59

Suite au reboot, et la manipulation que tu m'as proposé plus haut, j'ai ceci :

Code : Tout sélectionner

localectl
   System Locale: LANG=fr_FR.utf8
                  LC_COLLATE=C
       VC Keymap: fr-latin9
      X11 Layout: fr
     X11 Variant: oss
     X11 Options: compose:menu,terminate:ctrl_alt_bksp
Mageia 4 x64 | ArchLinux x64 | KDE
MSI P45 Neo-F - Intel E8500 @3.16 GHz - 7 Go RAM - ATI HD Radeon 3850

laurent85
yeomen
Messages : 259
Inscription : mar. 16 oct. 2018, 21:05

Re: [Disposition clavier] Sddm en qwerty

Message par laurent85 » dim. 04 août 2019, 00:10

C'est pas uniquement un problème d'affichage ? J'ai clavier drapeau us à l'affichage de l'écran de connexion sddm et quand je saisis mon premier caractère de mot de passe l'affichage s'actualise en clavier drapeau fr.

Avatar de l’utilisateur
Fif91
yeomen
Messages : 207
Inscription : lun. 17 janv. 2011, 13:23

Re: [Disposition clavier] Sddm en qwerty

Message par Fif91 » dim. 04 août 2019, 09:07

Bizarrement, je n'ai pas ce drapeau à l'écran de connexion. Serait-ce un problème lié au thème ? J'utilise breeze. :shock:
Mageia 4 x64 | ArchLinux x64 | KDE
MSI P45 Neo-F - Intel E8500 @3.16 GHz - 7 Go RAM - ATI HD Radeon 3850

Avatar de l’utilisateur
Kristen
Elfe
Messages : 614
Inscription : ven. 14 oct. 2011, 10:24
Localisation : Finistère France

Re: [Disposition clavier] Sddm en qwerty

Message par Kristen » dim. 04 août 2019, 09:18

Essaie en changeant de thème pour voir.
Depuis le 14 octobre 2011 sur archlinux
actuellement avec XFCE sur
PC fixe : i5 - CG GeForce GTX 750 Ti - Mémoire 12 Go - SSD128 Go - DD1000 Go
et
PC portable : Lenovo ThinkPad T520i

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10513
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [Disposition clavier] Sddm en qwerty

Message par FoolEcho » dim. 04 août 2019, 09:23

Le drapeau va dépendre du thème.

Pour ton problème il faudrait plutôt le log de X (/var/log/Xorg.0.log) puisque ça ne concerne que sddm.

Néanmoins he serais tenté de te dire de tester avec un keyboard.conf plus light (même si je ne vois pas pourquoi ton environnement aurait le bon par la suite... mais vu que kde peut avoir ses propres réglages aussi...):

Code : Tout sélectionner

09-keyboard.conf
Section "InputClass"
    Identifier             "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    Option "XkbLayout"     "fr"
    Option "XkbVariant"    "oss"
    Option "XkbOptions"    "compose:menu,terminate:ctrl_alt_bksp"
EndSection
«The following statement is not true. The previous statement is true.» :nage:

Avatar de l’utilisateur
Fif91
yeomen
Messages : 207
Inscription : lun. 17 janv. 2011, 13:23

Re: [Disposition clavier] Sddm en qwerty

Message par Fif91 » dim. 04 août 2019, 11:48

Je confirme donc, le drapeau dépend du thème.
Avec un autre, il apparaît bien, avec l'unique valeur US.

J'ai simplifié mon 00-keyboard.conf, comme suggéré; et rétabli le thème breeze initialement utilisé.
Et ça semble fonctionner :bravo:

/var/log/Xorg.0.log au besoin.

Encore merci à tous les 3 et bon dimanche !
Mageia 4 x64 | ArchLinux x64 | KDE
MSI P45 Neo-F - Intel E8500 @3.16 GHz - 7 Go RAM - ATI HD Radeon 3850

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10513
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [Disposition clavier] Sddm en qwerty (Résolu)

Message par FoolEcho » dim. 04 août 2019, 19:20

Pour info, c'est l'entrée qui correspondait à ton clavier qui a bougé:

Code : Tout sélectionner

[    16.167] (II) config/udev: Adding input device PC Speaker (/dev/input/event6)

Code : Tout sélectionner

[    32.101] (II) config/udev: Adding input device Logitech Wireless Keyboard PID:b305 (/dev/input/event16)
Du coup ta configuration spécifique au clavier ne pouvait être rattachée correctement.
«The following statement is not true. The previous statement is true.» :nage:

Répondre