[install] Le disque dur n'apparait pas dans fdisk, idem pour parted (en cours)

Questions et astuces concernant l'installation et la configuration d'archlinux
ouroboros
Hankyu
Messages : 36
Inscription : mar. 21 avr. 2015, 10:50

[install] Le disque dur n'apparait pas dans fdisk, idem pour parted (en cours)

Message par ouroboros » dim. 01 sept. 2019, 16:03

Bonjour tout le monde. J'ai un nouveau laptop et je voudrais virer windows 10 pour mettre arch à la place.
Problème, je n'arrive pas à afficher mon disque dur avec fdisk et parted.
Le système windows est tout à fait fonctionnel

Voici la sortie de 'fdisk -l && dmesg | tail -11' (y'a rien sur la sortie d'erreur): http://ix.io/1TZ3
Et celle de 'lsblk': http://ix.io/1TZ7

Merci d'avance !

benjarobin
Maître du Kyudo
Messages : 15446
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [install] Le disque dur n'apparait pas dans fdisk, idem pour parted (en cours)

Message par benjarobin » dim. 01 sept. 2019, 16:07

Bonjour, ce n'est pas mmcblk0 ton disque ? Quelle est la sortie de :

Code : Tout sélectionner

fdisk -l /dev/mmcblk0
Quelle est la référence exacte de ton PC ? Quelle est la taille du disque sous Windows (ainsi que la taille des partitions, ...) ? Peux tu donner aussi depuis Windows la référence de ton disque ?
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

ouroboros
Hankyu
Messages : 36
Inscription : mar. 21 avr. 2015, 10:50

Re: [install] Le disque dur n'apparait pas dans fdisk, idem pour parted (en cours)

Message par ouroboros » dim. 01 sept. 2019, 16:21

La sortie de 'fdisk -l /dev/mmcblk0':

Cannot open /dev/mmcblk0 Input Output error

Sinon la sortie de 'dmesg':

http://ix.io/1TZf

C'est un SanDisk DF4032
Je viens d'apprendre que c'est un SSD, est ce la source des problèmes ?

benjarobin
Maître du Kyudo
Messages : 15446
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [install] Le disque dur n'apparait pas dans fdisk, idem pour parted (en cours)

Message par benjarobin » dim. 01 sept. 2019, 17:49

Non ce n'est pas cela le problème. Il y a soit un problème matériel, BIOS ou driver linux... En gros c'est un peu la merde à comprendre ce qui se passe.
Le mieux est d'essayer de démarrer avec un Ubuntu (essaye avec le maximum de distribution / version kernel), et de voir si tu as toujours un problème avec fdisk.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
CoudUr
Daikyu
Messages : 99
Inscription : sam. 06 avr. 2013, 17:12

Re: [install] Le disque dur n'apparait pas dans fdisk, idem pour parted (en cours)

Message par CoudUr » dim. 01 sept. 2019, 18:04

Bonjour,

La dénomination /dev/mmcblk ce n'est pas que pour les cartes SD en principe ?

Avatar de l’utilisateur
Kristen
Elfe
Messages : 615
Inscription : ven. 14 oct. 2011, 10:24
Localisation : Finistère France

Re: [install] Le disque dur n'apparait pas dans fdisk, idem pour parted (en cours)

Message par Kristen » dim. 01 sept. 2019, 19:09

Non c'est pareil pour un de mes PC avec un eMMC
Depuis le 14 octobre 2011 sur archlinux
actuellement avec XFCE sur
PC fixe : i5 - CG GeForce GTX 750 Ti - Mémoire 12 Go - SSD128 Go - DD1000 Go
et
PC portable : Lenovo ThinkPad T520i

ouroboros
Hankyu
Messages : 36
Inscription : mar. 21 avr. 2015, 10:50

Re: [install] Le disque dur n'apparait pas dans fdisk, idem pour parted (en cours)

Message par ouroboros » lun. 02 sept. 2019, 14:18

benjarobin a écrit :
dim. 01 sept. 2019, 17:49
Non ce n'est pas cela le problème. Il y a soit un problème matériel, BIOS ou driver linux... En gros c'est un peu la merde à comprendre ce qui se passe.
Le mieux est d'essayer de démarrer avec un Ubuntu (essaye avec le maximum de distribution / version kernel), et de voir si tu as toujours un problème avec fdisk.
Bien je vais essayer alors mais pas immediatement. Pour l'instant je n'ai que mon forfait mobile comme acces internet...
Aujourd'hui j'installe arch sur une clé usb 3 de 32GO.

Avatar de l’utilisateur
CoudUr
Daikyu
Messages : 99
Inscription : sam. 06 avr. 2013, 17:12

Re: [install] Le disque dur n'apparait pas dans fdisk, idem pour parted (en cours)

Message par CoudUr » sam. 07 sept. 2019, 20:15

Kristen a écrit :
dim. 01 sept. 2019, 19:09
Non c'est pareil pour un de mes PC avec un eMMC
Effectivement merci pour l'information :)

Répondre