[GDM] GDM ne se lance pas

Xorg, Compiz, KDE / Gnome / Xfce / Fluxbox / e17 / fvwm ... GDM/KDM/XDM...
sertus
newbie
Messages : 5
Inscription : mer. 04 sept. 2019, 19:25

[GDM] GDM ne se lance pas

Message par sertus » mer. 04 sept. 2019, 19:48

Bonjour.


Depuis peu, j'ai installé Archlinux sur un vieux pc contenant une chipset graphique Nvidia GeForce 6150LE.
Seulement, je sais par expérience que le pilote nouveau ne marche pas très bien sur ma config (glitchs graphique, performances, etc...). J'ai donc essayé d'installer le seul pilote compatible : le 304.137 patché (https://adufray.com/blog/2018/06/02/nvi ... -on-bionic). L'installation ayant échoué, j'ai regardé sur Google et j'ai modifié les lignes de codes fautives au fur et à mesure en fonction de patchs trouvés sur Github. Ensuite, aucun problème, le driver est correctement chargé :

Code : Tout sélectionner

lspci -k
donne "Module used: nvidia").

Mais lors du lancement de GDM, j'ai un écran noir avec un curseur (type console, pas la souris) en haut à gauche de l'écran, et quoiqu'il arrive, rien ne bouge. Je suis obligé de redémarrer le pc avec le bouton d'alim.
Je précise que j'ai dû utiliser Xorg-server 1.19, et pas 1.20.


Si il y a besoin d'une précision au niveau de ma config ou d'un log, je peux vous les transmettre.
Merci.

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10518
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [GDM] GDM ne se lance pas

Message par FoolEcho » jeu. 05 sept. 2019, 12:04

Salut,

Le paquet nvidia-304xx-dkms n'est plus disponible sur AUR mais tu peux récupérer les différents éléments nécessaires avec le lien fourni dans https://wiki.archlinux.fr/NVIDIA#Installation_2, à savoir https://github.com/felixonmars/aur3-mir ... 304xx-dkms . Ça t'évitera de trop bidouiller (il est 304.125).

Néanmoins tu devrais tout de même essayer avec le pilote nouveau pour ne pas avoir à bloquer la version de X.
«The following statement is not true. The previous statement is true.» :nage:

Avatar de l’utilisateur
RoyalPanda
archer de cavalerie
Messages : 193
Inscription : lun. 19 mai 2014, 09:08

Re: [GDM] GDM ne se lance pas

Message par RoyalPanda » jeu. 05 sept. 2019, 12:07

Bonjour,

Maintenant par défaut GDM utilise Wayland, Gnome aussi.
J'imagine que tu souhaites utiliser Gnome ?
Veux-tu particulièrement utiliser Xorg ?
As-tu configuré le retour à Xorg dans la configuration de GDM ? : /etc/gdm/custom.conf

Si tu veux particulièrement utiliser Xorg, pourquoi ne pas avoir utiliser https://github.com/felixonmars/aur3-mir ... 304xx-dkms renseigné ici : https://wiki.archlinux.fr/NVIDIA#Pilote ... C3.A9taire ?

sertus
newbie
Messages : 5
Inscription : mer. 04 sept. 2019, 19:25

Re: [GDM] GDM ne se lance pas

Message par sertus » jeu. 05 sept. 2019, 18:00

Bonjour,

Je me souviens d'avoir télécharger sur ce lien mais je ne l'ai pas installé. Je ne suis pas chez moi mais je vais réessayer de l'installer et je vous tient au courant.

EDIT: je ne peux pas l'installer car il manque nvidia-304xx-utils, et en cherchant un peu je n'ai pas trouvé de moyen pour l'installer. Quelqu'un aurait une info ?

EDIT 2: j'ai rien dit en fouillant un peu plus je viens de le trouver

EDIT 3: Lors de l'installation de nvidia-304xx-dkms il n'arrive pas à build le module ( kernel 5.2.11-arch1-1-ARCH x86_x64), voici les logs /var/lib/dkms/nvidia/304.125/build/make.log :
https://pastebin.com/y67Tpz40

sertus
newbie
Messages : 5
Inscription : mer. 04 sept. 2019, 19:25

Re: [GDM] GDM ne se lance pas

Message par sertus » dim. 08 sept. 2019, 20:29

UP

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10518
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [GDM] GDM ne se lance pas

Message par FoolEcho » mar. 10 sept. 2019, 09:29

Tu vas trop au devant de problèmes avec un paquet qui n'est plus supporté... :?
Tu peux essayer de le recompiler en ne traitant pas les alertes remontées en tant qu'erreur mais c'est bof (le plus simple en rajoutant temporairement à CFLAGS dans /etc/makepkg.conf "-Wno-error=implicit-function-declaration -Wno-error=incompatible-pointer-types" -- en me basant sur ton log).

Mais-tu devrais vraiment tenter avec le pilote nouveau... :chinois:
«The following statement is not true. The previous statement is true.» :nage:

sertus
newbie
Messages : 5
Inscription : mer. 04 sept. 2019, 19:25

Re: [GDM] GDM ne se lance pas

Message par sertus » mar. 10 sept. 2019, 12:04

Le problème est que je l'ai essayé en lançant gdm de la même manière (avec et sans Wayland), mais j'ai le droit au même résultat.

laurent85
yeomen
Messages : 297
Inscription : mar. 16 oct. 2018, 21:05

Re: [GDM] GDM ne se lance pas

Message par laurent85 » mar. 10 sept. 2019, 13:15

Bonjour,
As-tu essayé avec lightdm à la place de gdm ?

Je pense aussi que nouveau est la meilleure option. Le problème est que l'état actuel du système a déjà pas mal divergé comparé à un système Arch, entre la version d'xorg et tout le reste.

As-tu essayé de démarrer sur un live avec environnement graphique ? Ça devrait marcher normalement, ce qui confirmerait que ton installation est à revoir. Un live archuseriso c'est ce qui sera le plus proche de ton installation finale (sauf pour lightdm qui remplace gdm sur le live), essaie avec une des iso gnome ou xfce que tu peux télécharger en suivant le lien donné sur la page github https://github.com/laurent85v/archuseriso

Répondre