[appimage] erreur au lancement d'une appimage

Mise à jour / Création /debug de paquetages
clapas
yeomen
Messages : 227
Inscription : sam. 08 sept. 2012, 07:23
Localisation : Comtat Venaissin

[appimage] erreur au lancement d'une appimage

Message par clapas » sam. 07 sept. 2019, 13:47

Bonjour,
Ma médiathèque permet de télécharger des vidéos à condition de passer par une application maison fournie sous forme d'une appimage. Il s'agit de mednum-offline-player.AppImage

Quand je la lance dans un terminal j'ai l'erreur suivante et tout s'arrête.

Code : Tout sélectionner

[clapas@ds81 ~]$ /home/clapas/Bureau/mednum-offline-player.AppImage
installed: X-AppImage-BuildId=71f28e60-134a-11a9-2954-499dceea7f3c image: X-AppImage-BuildId=71f28e60-134a-11a9-2954-499dceea7f3c

(mednum offline player:19595): Pango-ERROR **: 13:44:47.474: Harfbuzz version too old (1.4.2)

Trappe pour point d'arrêt et de trace (core dumped)
[clapas@ds81 ~]$ 
J'ai cru comprendre qu'une appimage contient toutes ses dépendances. D'autre part, j'ai testé en live-usb sur une iso ubuntu-18.04 et ça fonctionne bien.
Je précise que mon archlinux est à jour.

Avez-vous une idée sur la façon de faire fonctionner cette application sur mon PC ? Merci.

Avatar de l’utilisateur
CoudUr
Daikyu
Messages : 99
Inscription : sam. 06 avr. 2013, 17:12

Re: [appimage] erreur au lancement d'une appimage

Message par CoudUr » sam. 07 sept. 2019, 20:13

J'ai cru comprendre qu'une appimage contient toutes ses dépendances. D'autre part, j'ai testé en live-usb sur une iso ubuntu-18.04 et ça fonctionne bien.
C'est ce que je croyais aussi, bon je n'y connais rien mais de ce que j'ai compris c'est la diversité des distributions qui pose problème. Celui qui crée l'appimage doit tenir compte de toutes ces subtilités c'est sûrement ce qui fait que les distributions les plus communes sont favorisées et qu'avec Ubuntu ton appimage fonctionne.
https://github.com/AppImage/pkg2appimage/issues/110
https://discourse.appimage.org/t/create ... olved/1115
https://gitlab.com/probono/platformissues

Du coup le paquet "pour tous" perd un peu de son intérêt je dois dire ...
Je ne sais pas si c'est propre à Appimage ou si c'est pareil pour Snap et Flatpak mais ce serait intéressant d'avoir l'avis d'un packageur.

Le mieux pour toi serait de contacter le packageur pour lui faire part de ton problème.
Je voulais aller jeter un œil au dépôt de l'application mais je ne l'ai pas trouvé sur appimagehub.com où l'as-tu téléchargé ?

clapas
yeomen
Messages : 227
Inscription : sam. 08 sept. 2012, 07:23
Localisation : Comtat Venaissin

Re: [appimage] erreur au lancement d'une appimage

Message par clapas » sam. 07 sept. 2019, 20:55

Merci de t'intéresser à ce cas.
Je voulais mettre un lien vers le téléchargement, mais je n'a pas pu trouver l'url. Elle est cachée sur la fenêtre. Je vais voir en cherchant autrement.

Répondre