[update] arrêt du pc pendant update

Questions et astuces concernant l'installation et la configuration d'archlinux
Korkene
newbie
Messages : 3
Inscription : mer. 11 sept. 2019, 10:12

[update] arrêt du pc pendant update

Message par Korkene » mer. 11 sept. 2019, 10:19

Bonjour,
Je faisais une mise à joour des paquets et le PC s'est éteint, voilà les paquets en question :

Code : Tout sélectionner

35007 [2019-09-11 08:05] [ALPM] upgraded at-spi2-core (2.32.1-1 -> 2.34.0-1)
35008 [2019-09-11 08:05] [ALPM] upgraded atk (2.32-1 -> 2.34.1-1)
35009 [2019-09-11 08:05] [ALPM] upgraded at-spi2-atk (2.32.0-1 -> 2.34.0-1)
35010 [2019-09-11 08:05] [ALPM] upgraded dconf (0.32.0-3 -> 0.34.0-1)                                                                                                                                                                                                                                                     
35011 [2019-09-11 08:05] [ALPM] upgraded librsvg (2:2.44.15-1 -> 2:2.46.0-1)
35012 [2019-09-11 08:05] [ALPM] upgraded gsettings-desktop-schemas (3.32.0-2 -> 3.34.0-1)
35013 [2019-09-11 08:05] [ALPM] upgraded libsoup (2.66.2+4+g716acf96-1 -> 2.67.93-1)
35014 [2019-09-11 08:05] [ALPM] upgraded gcr (3.28.1-1 -> 3.33.4+6+g35df18d-1)
35015 [2019-09-11 08:05] [ALPM] upgraded libmypaint (1.3.0-6 -> 1.4.0-1)
35016 [2019-09-11 08:05] [ALPM] upgraded gimp (2.10.12-2 -> 2.10.12-3)
35017 [2019-09-11 08:05] [ALPM] upgraded gnome-online-accounts (3.32.0-1 -> 3.33.92-1)
35018 [2019-09-11 08:05] [ALPM] installed fuse3 (3.6.2-1)
35019 [2019-09-11 08:05] [ALPM] upgraded gvfs (1.40.2-1 -> 1.42.0-1)
35020 [2019-09-11 08:05] [ALPM] upgraded gvfs-mtp (1.40.2-1 -> 1.42.0-1)
35021 [2019-09-11 08:05] [ALPM] upgraded gvfs-nfs (1.40.2-1 -> 1.42.0-1)
35022 [2019-09-11 08:05] [ALPM] upgraded gvfs-smb (1.40.2-1 -> 1.42.0-1)
35023 [2019-09-11 08:05] [ALPM] upgraded lib32-openssl (1:1.1.1.c-1 -> 1:1.1.1.d-1)
35024 [2019-09-11 08:05] [ALPM] upgraded mpg123 (1.25.11-1 -> 1.25.12-1)
35025 [2019-09-11 08:05] [ALPM] upgraded ncrack (0.6.0-1 -> 0.7-1)
35040 [2019-09-11 08:45] [ALPM] upgraded qt5-base (5.13.0-7 -> 5.13.1-2)
35041 [2019-09-11 08:45] [ALPM] upgraded qt5-declarative (5.13.0-1 -> 5.13.1-1)
35042 [2019-09-11 08:45] [ALPM] upgraded qt5-location (5.13.0-1 -> 5.13.1-1)
35043 [2019-09-11 08:45] [ALPM] upgraded qt5-quickcontrols (5.13.0-1 -> 5.13.1-1)
35044 [2019-09-11 08:45] [ALPM] upgraded qt5-sensors (5.13.0-1 -> 5.13.1-1)
35045 [2019-09-11 08:45] [ALPM] upgraded qt5-styleplugins (5.0.0.20170311-15 -> 5.0.0.20170311-16)
35046 [2019-09-11 08:45] [ALPM] upgraded qt5-svg (5.13.0-1 -> 5.13.1-1)
35047 [2019-09-11 08:45] [ALPM] upgraded qt5-webchannel (5.13.0-1 -> 5.13.1-1)
35048 [2019-09-11 08:45] [ALPM] upgraded qt5-webengine (5.13.0-4 -> 5.13.1-2)

J'avais ces erreurs :

Code : Tout sélectionner

35332 [2019-09-11 08:50] [ALPM-SCRIPTLET] ldconfig: Fichier /usr/lib/libQt5Svg.so.5 est vide, n'a pas été vérifié.
35333 [2019-09-11 08:50] [ALPM-SCRIPTLET] ldconfig: Fichier /usr/lib/libQt5PositioningQuick.so est vide, n'a pas été vérifié.
35334 [2019-09-11 08:50] [ALPM-SCRIPTLET] ldconfig: Fichier /usr/lib/libQt5WebChannel.so.5.13 est vide, n'a pas été vérifié.
35335 [2019-09-11 08:50] [ALPM-SCRIPTLET] ldconfig: Fichier /usr/lib/libQt5WebChannel.so.5.13.1 est vide, n'a pas été vérifié.
35336 [2019-09-11 08:50] [ALPM-SCRIPTLET] ldconfig: Fichier /usr/lib/libQt5PositioningQuick.so.5 est vide, n'a pas été vérifié.
35337 [2019-09-11 08:50] [ALPM-SCRIPTLET] ldconfig: Fichier /usr/lib/libQt5QuickWidgets.so.5 est vide, n'a pas été vérifié.
35338 [2019-09-11 08:50] [ALPM-SCRIPTLET] ldconfig: Fichier /usr/lib/libQt5WebEngineCore.so.5.13 est vide, n'a pas été vérifié.
35339 [2019-09-11 08:50] [ALPM-SCRIPTLET] ldconfig: Fichier /usr/lib/libQt5Location.so.5.13.1 est vide, n'a pas été vérifié.
35340 [2019-09-11 08:50] [ALPM-SCRIPTLET] ldconfig: Fichier /usr/lib/libQt5Location.so.5.13 est vide, n'a pas été vérifié.
35341 [2019-09-11 08:50] [ALPM-SCRIPTLET] ldconfig: Fichier /usr/lib/libQt5Sensors.so est vide, n'a pas été vérifié.
35342 [2019-09-11 08:50] [ALPM-SCRIPTLET] ldconfig: Fichier /usr/lib/libQt5WebKit.so est vide, n'a pas été vérifié.
35343 [2019-09-11 08:50] [ALPM-SCRIPTLET] ldconfig: Fichier /usr/lib/libQt5X11Extras.so.5 est vide, n'a pas été vérifié.
35344 [2019-09-11 08:50] [ALPM-SCRIPTLET] ldconfig: Fichier /usr/lib/libQt5Sensors.so.5.13 est vide, n'a pas été vérifié.
35345 [2019-09-11 08:50] [ALPM-SCRIPTLET] ldconfig: Fichier /usr/lib/libQt5Svg.so.5.13 est vide, n'a pas été vérifié.
35346 [2019-09-11 08:50] [ALPM-SCRIPTLET] ldconfig: Fichier /usr/lib/libQt5WebEngineCore.so.5.13.1 est vide, n'a pas été vérifié.
35347 [2019-09-11 08:50] [ALPM-SCRIPTLET] ldconfig: Fichier /usr/lib/libQt5Positioning.so.5 est vide, n'a pas été vérifié.
35348 [2019-09-11 08:50] [ALPM-SCRIPTLET] ldconfig: Fichier /usr/lib/libQt5WebKitWidgets.so.5.212.0 est vide, n'a pas été vérifié.
35349 [2019-09-11 08:50] [ALPM-SCRIPTLET] ldconfig: Fichier /usr/lib/libQt5Location.so.5 est vide, n'a pas été vérifié.
Du coup j'ai fait un sudo pacman -S $(pacman -Qqn) --force

Je vouais savoir ce que vous en pensiez, et aussi si ça remplaçait les fichiers de configuration modifiés, comme /etc/pacman.d/mirrorlist, ou /etc/lightdm/lightdm.conf, lightdm-gtk-greeter.conf (j'ai vérifié pour ceux-là, c'est bon mais c'est une question générale)

benjarobin
Maître du Kyudo
Messages : 15446
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [update] arrêt du pc pendant update

Message par benjarobin » mer. 11 sept. 2019, 11:43

Tu as fait ce qu'il fallait, mais je croyais que l'option --force n'existait plus, car remplacé par une autre --overwrite
Et non normalement pour la configuration tout devrait être bon
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Korkene
newbie
Messages : 3
Inscription : mer. 11 sept. 2019, 10:12

Re: [update] arrêt du pc pendant update

Message par Korkene » mer. 11 sept. 2019, 15:33

Ah super merci pour ta réponse, oui j'ai vu que l'option --force était dépréciée, mais avec l'option overwrite j'aurais du écrire tous les chemins des fichiers, c'est peut-être pour des situations comme ça que l'option --force existe encore

benjarobin
Maître du Kyudo
Messages : 15446
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [update] arrêt du pc pendant update

Message par benjarobin » mer. 11 sept. 2019, 16:04

Tu peux très bien utiliser --overwrite "*" qui devrait en théorie faire la même chose que --force
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Korkene
newbie
Messages : 3
Inscription : mer. 11 sept. 2019, 10:12

Re: [update] arrêt du pc pendant update

Message par Korkene » jeu. 12 sept. 2019, 11:36

Justement, je pensais aussi j'ai essayé avant de faire un --force, sauf qu'il prends tous les fichiers présent dans le dossier et il dit qu'ils sont pas présents dans le paquet

benjarobin
Maître du Kyudo
Messages : 15446
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [update] arrêt du pc pendant update

Message par benjarobin » jeu. 12 sept. 2019, 14:28

Les guillemets ont une très grande importance.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Répondre