[gnome] Problème installation linux

Questions et astuces concernant l'installation et la configuration d'archlinux
Répondre
niiox
newbie
Messages : 8
Inscription : jeu. 12 sept. 2019, 19:23

[gnome] Problème installation linux

Message par niiox » jeu. 12 sept. 2019, 19:30

Bonjour,
Je dispose d'un ordinateur acer nitro 5 an515-51-53ht, je suis actuellement sous windows 10.
Lors de l'installation d'archlinux tout se passe pour le mieux, mais des que je mets une interface graphique et que je reboot, au redémarrage l'écran reste bloqué sur le fond de gnome et le curseur de la souris bloqué en bas à droite.
J'ai alors essayé d'installer ubuntu, linux mint mais j'ai toujours le même problème au redémarrage juste après l'installation.

laurent85
yeomen
Messages : 297
Inscription : mar. 16 oct. 2018, 21:05

Re: [gnome] Problème installation linux

Message par laurent85 » jeu. 12 sept. 2019, 19:51

Bonjour,
Il y a une carte graphique Nvidia ?
Si le pilote nvidia n'est pas installé et que le pilote nouveau est utilisé, as-tu essayé en ajoutant nomodeset aux paramètres de démarrage ? autre possibilité le paramètre nouveau.noaccel=1

niiox
newbie
Messages : 8
Inscription : jeu. 12 sept. 2019, 19:23

Re: [gnome] Problème installation linux

Message par niiox » jeu. 12 sept. 2019, 22:45

Merci pour votre réponse, oui j'ai une nvidia geforce gtx, j'ai essayé avec nomodeset au démarrage.
Sur arch j'ai installé xf86-video-nouveau ainsi que nvidia.
Je ne connaissais pas le dernier paramètre je vais essayer.

benjarobin
Maître du Kyudo
Messages : 15446
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [gnome] Problème installation linux

Message par benjarobin » jeu. 12 sept. 2019, 23:05

Bonjour,
Tu ne dois pas installer en même temps xf86-video-nouveau et nvidia. C'est soit l'un soit l'autre. De plus je te conseil les drivers propriétaires : Il te faut aussi installer nvidia-utils.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

niiox
newbie
Messages : 8
Inscription : jeu. 12 sept. 2019, 19:23

Re: [gnome] Problème installation linux

Message par niiox » jeu. 12 sept. 2019, 23:09

Je dois donc prendre nvidia et nvidia-utils ?

benjarobin
Maître du Kyudo
Messages : 15446
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [gnome] Problème installation linux

Message par benjarobin » ven. 13 sept. 2019, 09:12

Oui tu peux essayer avec ces paquets, en désinstallant xf86-video-nouveau. Après je ne te promet rien, je dis juste que tu as plus de chance que cela fonctionne
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

niiox
newbie
Messages : 8
Inscription : jeu. 12 sept. 2019, 19:23

Re: [gnome] Problème installation linux

Message par niiox » ven. 13 sept. 2019, 11:57

Bonjour
Après j'ai relancé une installation arch en installant juste Nvidia et Nvidia-utils.
Tout fonctionne mais le clavier est en.
Quand je créer un fichier xorg.conf ( dans X11) pour mettre le clavier en fr je me retrouve avec un black screen.
Je pense donc que je m'y prends mal pour le clavier.

laurent85
yeomen
Messages : 297
Inscription : mar. 16 oct. 2018, 21:05

Re: [gnome] Problème installation linux

Message par laurent85 » ven. 13 sept. 2019, 15:09

Pour le clavier supprime le fichier xorg.conf créé et utilise en ligne de commande :

Code : Tout sélectionner

sudo localectl set-x11-keymap fr

niiox
newbie
Messages : 8
Inscription : jeu. 12 sept. 2019, 19:23

Re: [gnome] Problème installation linux

Message par niiox » ven. 13 sept. 2019, 20:37

Merci pour la reponse.
La commande me dit qu'elle n'existe pas.
Et quand je lance un localectl status, pour X11 layout j'obtiens n/a.

niiox
newbie
Messages : 8
Inscription : jeu. 12 sept. 2019, 19:23

Re: [gnome] Problème installation linux

Message par niiox » ven. 13 sept. 2019, 20:55

J'ai finalement trouvé en utilisant la commande "setxkbmap fr"
Merci de votre aide

laurent85
yeomen
Messages : 297
Inscription : mar. 16 oct. 2018, 21:05

Re: [gnome] Problème installation linux

Message par laurent85 » ven. 13 sept. 2019, 21:09

niiox a écrit :
ven. 13 sept. 2019, 20:37
La commande me dit qu'elle n'existe pas.
setxkbmap c'est pour la session, localectl configure xorg en créant le fichier qui va bien /etc/X11/xorg.conf.d/00-keyboard.conf
Copie-colle la commande pour ne pas faire d'erreur de saisie. As-tu redémarré xorg ensuite ?
Tu peux utiliser localectl --help, la liste des agencements disponibles est donnée par localectl list-x11-keymap-layouts

niiox
newbie
Messages : 8
Inscription : jeu. 12 sept. 2019, 19:23

Re: [gnome] Problème installation linux

Message par niiox » ven. 13 sept. 2019, 21:58

Après avoir reboot, la commande a bien fonctionné.
Dans mon localectl status je dispose bien de X11 layout : fr.
Le fichier 00-keyboard.conf est bien en fr aussi
Mais le clavier est toujours en englais.

laurent85
yeomen
Messages : 297
Inscription : mar. 16 oct. 2018, 21:05

Re: [gnome] Problème installation linux

Message par laurent85 » ven. 13 sept. 2019, 22:11

Il y a quoi d'affiché comme configuration dans Paramètres > Pays et langue > Sources de saisie ?

niiox
newbie
Messages : 8
Inscription : jeu. 12 sept. 2019, 19:23

Re: [gnome] Problème installation linux

Message par niiox » ven. 13 sept. 2019, 22:20

Je te remercie, anglais était sélectionné par défaut.

Répondre