[eclipse] problème de lancement (Résolu)

Applications, problèmes de configuration réseau
Avatar de l’utilisateur
Eikichi
Daikyu
Messages : 63
Inscription : jeu. 07 janv. 2010, 01:04

[eclipse] problème de lancement (Résolu)

Message par Eikichi » mar. 08 oct. 2019, 09:47

Bonjour,

je suis passé sur gnome 3.34 et eclipse 4.13 (avec pdt, devstyle et www), depuis j'ai des problèmes avec eclipse au démarrage (Attention c'est pas simple!)

Quand je lance eclipse :
- il mets plus de 5 minutes pour se lancer et le pc est figé (je peux rien faire d'autre).
- Une fois qu'il me rend la main, workspace to the dock(extension gnome) ne fonctionne plus et eclipse est instable (voir gnome aussi).
- Un Alt + F2 + r refait fonctionner workspace to the dock mais eclipse se ferme.

Solution mise ne oeuvre mais sans résultat:
- Rajout dans eclipse.ini des lignes:
--launcher.GTK_version
2 -> eclipse répond qu'il ne peut utiliser gtk2 et utilisera gtk3 (il me semble que cette option n'était valable que jusqu’à la version néon)
- Purge complète d'eclipse (suppression des workspaces et de la config), dés que je réinstalle mes différentes applications dans le workspaces et ma configuration eclipse, le problème revient.
- Aucun message d'erreur dans journalctl pour lui tous est ok
- Je suis revenue à la version 4.12 d'eclipse et le problème est toujours présent.

Solution de contournement:
-Création d'un workspace vide, que je lance par défaut ensuite je switch de workspace et la tous fonctionne correctement.

Je n'avais aucun soucis avec gnome 3.32 et eclipse 4.12.

Si quelqu'un à une idée, ou s'il vous faut d'autres informations.

:wink:
Dernière modification par Eikichi le mar. 08 oct. 2019, 11:09, modifié 1 fois.

Avatar de l’utilisateur
Eikichi
Daikyu
Messages : 63
Inscription : jeu. 07 janv. 2010, 01:04

Re: [eclipse] problème de lancement

Message par Eikichi » mar. 08 oct. 2019, 11:09

J'ai trouvé le problème, il s'agit de l'extension devStyle (Darkest Dark Theme with DevStyle). Une fois celle ci supprimée eclipse fonctionne correctement. J'ai du installer un thème sombre à la main..

Répondre