[nvidia-utils-beta] : échec de l'installation (résolu)

Xorg, Compiz, KDE / Gnome / Xfce / Fluxbox / e17 / fvwm ... GDM/KDM/XDM...
Thomasb
Daikyu
Messages : 50
Inscription : dim. 28 avr. 2019, 14:49

[nvidia-utils-beta] : échec de l'installation (résolu)

Message par Thomasb » mer. 09 oct. 2019, 19:19

En suivant le manuel pour l'installation du pilote Nvidia, j'aboutis sur l'installation de nvidia-beta, qui dépend de nvidia-utils-beta. Seulement, l'installation de ce dernier échoue :

Code : Tout sélectionner

$ makepkg -si
==> Making package: nvidia-utils-beta 435.21-2 (mer. 09 oct. 2019 18:51:45 CEST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Downloading NVIDIA-Linux-x86_64-435.21-no-compat32.run...
** Resuming transfer from byte position 15367343
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
 17 83.4M   17 14.5M    0     0  1914k      0  0:00:44  0:00:07  0:00:37 2033k
curl: (56) OpenSSL SSL_read: SSL_ERROR_SYSCALL, errno 104
==> ERROR: Failure while downloading https://download.nvidia.com/XFree86/Linux-x86_64/435.21/NVIDIA-Linux-x86_64-435.21-no-compat32.run
    Aborting...
Pourtant, le manuel ne mentionne rien de spécial de plus... Est-ce quelqu'un aurait une idée de ce qu'il se passe ?
Dernière modification par Thomasb le jeu. 10 oct. 2019, 18:38, modifié 1 fois.

benjarobin
Maître du Kyudo
Messages : 15475
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [nvidia-utils-beta] : échec de l'installation

Message par benjarobin » mer. 09 oct. 2019, 19:45

Bonjour,
Pourquoi installer nvidia-beta et pas tout simplement nvidia ? Tu as quoi comme carte graphique ?
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Thomasb
Daikyu
Messages : 50
Inscription : dim. 28 avr. 2019, 14:49

Re: [nvidia-utils-beta] : échec de l'installation

Message par Thomasb » mer. 09 oct. 2019, 22:52

Salut,
Le paquet nvidia ne fonctionne pas : lorsque je lance l'environnement graphique, il n'y a ni menus ni barres... Heureusement, j'ai un term qui se lance en autostart, mais nvidia-xconfig renvoie un message d'erreur. La carte est une Quadro Fx 370

benjarobin
Maître du Kyudo
Messages : 15475
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [nvidia-utils-beta] : échec de l'installation

Message par benjarobin » mer. 09 oct. 2019, 23:04

C'est quoi que tu lances comme environnement graphique ? Car par défaut un startx ne lance presque rien... Changer de driver graphique ne va pas te lancer plus de chose.
Tu ne dois surtout pas utiliser nvidia-xconfig, par contre je serais curieux de connaître le message d'erreur...

Mais si on regarde sur le site de Nvidia, ta carte est bien trop vielle (elle à 12 ans exactement...), elle n'est plus supporté sous ArchLinux, il te faudrait la version 340.107 : https://www.nvidia.com/Download/driverR ... 5161/en-us
La version 390.129 ne supporte pas ta carte : https://www.nvidia.com/download/driverR ... 9145/en-us
Ni la version 435.21 : https://www.nvidia.com/download/driverR ... 0803/en-us
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Thomasb
Daikyu
Messages : 50
Inscription : dim. 28 avr. 2019, 14:49

Re: [nvidia-utils-beta] : échec de l'installation

Message par Thomasb » jeu. 10 oct. 2019, 18:38

Le message d'erreur :

Code : Tout sélectionner

$ nvidia-xconfig 

WARNING: Unable to locate/open X configuration file.


WARNING: Unable to parse X.Org version string.


ERROR: Unable to write to directory '/etc/X11'.
Tant pis pour nvidia alors, mais merci.

Répondre