[INSTALLATION] Ecran noir lors de l'installation

Questions et astuces concernant l'installation et la configuration d'archlinux
Répondre
Theokt62
newbie
Messages : 6
Inscription : sam. 12 oct. 2019, 18:57

[INSTALLATION] Ecran noir lors de l'installation

Message par Theokt62 » sam. 12 oct. 2019, 19:08

Bonjour à tous,
J'essaie actuellement d'installer Archlinux (Windows 10 déja installé sur un autre SSD, les 2 OS auront chacun leur SSD). J'ai récupéré la dernière iso et l'ai copié sur ma clé usb. Lorsque je branche ma clé, je dis a mon UEFI de booter dessus. Jusque là tout va ! Je vois apparaître un écran de séléction et je choisis la première entrée : Arch Linux [...] UEFI USB. A partir de là, je vois apparaître dans le coin supérieur gauche "sha256 validated" qui reste affiché 5 secondes, ensuite il disparait et plus rien, écran noir !
Je n'arrive pas à comprendre où est le problème. Pour information ma carte mère est une : Gigabyte H370 HD3.

Merci d'avance à ceux qui pourront m'aider.

Theokt62
newbie
Messages : 6
Inscription : sam. 12 oct. 2019, 18:57

Re: [INSTALLATION] Ecran noir lors de l'installation

Message par Theokt62 » sam. 12 oct. 2019, 19:31

Je viens de faire un essai avec une iso Debian (latest) et tout fonctionne je peux installer Debian si je le souhaite. Je ne rencontre donc ce problème qu'avec Arch. Je suis vraiment embété...

nico88
archer
Messages : 108
Inscription : mar. 17 juil. 2012, 16:41
Localisation : 88 (Vosges)

Re: [INSTALLATION] Ecran noir lors de l'installation

Message par nico88 » sam. 12 oct. 2019, 21:37

Bonsoir,

Comment a tu créer ton média d'installation ?, à tu désactivé le secure boot dans le bios ?

Theokt62
newbie
Messages : 6
Inscription : sam. 12 oct. 2019, 18:57

Re: [INSTALLATION] Ecran noir lors de l'installation

Message par Theokt62 » dim. 13 oct. 2019, 08:20

Bonjour,
J’ai créé mon média d’installation avec le logiciel rufus pour Windows (de la même façon que le j’ai fait pour debian). Par contre je ne trouve aucune option secure boot dans les paramètres de mon UEFI Gigabyte.

Theokt62
newbie
Messages : 6
Inscription : sam. 12 oct. 2019, 18:57

Re: [INSTALLATION] Ecran noir lors de l'installation

Message par Theokt62 » dim. 13 oct. 2019, 08:22

Ne trouvant pas l’option secure boot j’ai désactivé le CSM mais cela ne change rien

Theokt62
newbie
Messages : 6
Inscription : sam. 12 oct. 2019, 18:57

[RESOLU] Ecran noir lors de l'installation

Message par Theokt62 » dim. 13 oct. 2019, 11:36

Resolu ! Il suffisait de rajouter nomodeset dans la l'instruction de boot du live CD !

nico88
archer
Messages : 108
Inscription : mar. 17 juil. 2012, 16:41
Localisation : 88 (Vosges)

Re: [INSTALLATION] Ecran noir lors de l'installation

Message par nico88 » dim. 13 oct. 2019, 22:29

Bonjour,

:resolu:

Merci

benjarobin
Maître du Kyudo
Messages : 15475
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [INSTALLATION] Ecran noir lors de l'installation

Message par benjarobin » dim. 13 oct. 2019, 23:46

L'utilisation de nomodeset à des conséquences non négligeable. Il aura sûrement d'autres soucis par la suite pour lancer une interface graphique avec accélération matérielle.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

nico88
archer
Messages : 108
Inscription : mar. 17 juil. 2012, 16:41
Localisation : 88 (Vosges)

Re: [INSTALLATION] Ecran noir lors de l'installation

Message par nico88 » lun. 14 oct. 2019, 14:13

Bonjour,

@benjarobin : j'ai toujours vu qu'il fallait utiliser nomodeset dans ce genre de problème, après c'est vrai que je n'ai jamais eu de problème de démarrage de l'Installation, y'aurai t'il une autre solution ?
Est ce que sa pose problème si j'essaye d'aider un peu ?

benjarobin
Maître du Kyudo
Messages : 15475
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [INSTALLATION] Ecran noir lors de l'installation

Message par benjarobin » lun. 14 oct. 2019, 19:30

Toute personne est le bienvenue pour aider :-)
Faire l'installation avec nomodeset n'est clairement pas un problème, je prédis juste les soucis à venir... Sauf s'il a une carte graphique nvidia et qu'il utilise les drivers propriétaires.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Theokt62
newbie
Messages : 6
Inscription : sam. 12 oct. 2019, 18:57

Re: [INSTALLATION] Ecran noir lors de l'installation

Message par Theokt62 » lun. 14 oct. 2019, 21:58

benjarobin a écrit :
lun. 14 oct. 2019, 19:30
Toute personne est le bienvenue pour aider :-)
Faire l'installation avec nomodeset n'est clairement pas un problème, je prédis juste les soucis à venir... Sauf s'il a une carte graphique nvidia et qu'il utilise les drivers propriétaires.
C'est le cas :D

nico88
archer
Messages : 108
Inscription : mar. 17 juil. 2012, 16:41
Localisation : 88 (Vosges)

Re: [INSTALLATION] Ecran noir lors de l'installation

Message par nico88 » lun. 14 oct. 2019, 22:44

Bonjour

@benjarobin : merci :)

@Theokt62 : le moment venu, tu pourra rouvrir un nouveau post, et je te laisserai voir ça avec un expert comme @benjarobin car je ne suis pas sûr que d'éditer le GRUB.cfg et d'enlever nomodeset dans le GRUB_CMDLINE_LINUX soit suffisant

Bonne continuation

Répondre