[Xorg et fonts] Xorg déclare inexistants des répertoires pourtant présents

Questions et astuces concernant l'installation et la configuration d'archlinux
dauriac
newbie
Messages : 7
Inscription : dim. 17 févr. 2019, 12:09

[Xorg et fonts] Xorg déclare inexistants des répertoires pourtant présents

Message par dauriac » sam. 02 nov. 2019, 17:41

Bonjour,

Mon problème dejà exposé voir [font pour lightdm] fonts cassées après mise à jour
était contourné jusqu’à présent en ré-installant une version plus ancienne de pango.
Ce moyen ne marche plus, mais j'ai constaté :

Code : Tout sélectionner

grep /fonts ~/.local/share/xorg/Xorg.0.log
[     4.234] (WW) The directory "/usr/share/fonts/misc" does not exist.
[     4.234] (WW) The directory "/usr/share/fonts/TTF" does not exist.
[     4.234] (WW) The directory "/usr/share/fonts/OTF" does not exist.
[     4.234] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[     4.234] (WW) The directory "/usr/share/fonts/100dpi" does not exist.
[     4.234] (WW) The directory "/usr/share/fonts/75dpi" does not exist.
or ces répertoires existent

Code : Tout sélectionner

ls /usr/share/fonts/
100dpi  adobe-source-code-pro  cyrillic   gsfonts   misc  noto-cjk  TTF    util
75dpi   cantarell              encodings  mathjax2  noto  OTF       Type1
et j'ai bien exécuté mkfontdir.
D'où peut bien venir ce problème ?
Merci

laurent85
Chu Ko Nu
Messages : 362
Inscription : mar. 16 oct. 2018, 21:05

Re: [Xorg et fonts] Xorg déclare inexistants des répertoires pourtant présents

Message par laurent85 » sam. 02 nov. 2019, 19:18

Bonjour,
T'es sûr de regarder dans le bon fichier de log ?

Code : Tout sélectionner

grep -e Log -e tty ~/.local/share/xorg/Xorg.0.log /var/log/Xorg.0.log

dauriac
newbie
Messages : 7
Inscription : dim. 17 févr. 2019, 12:09

Re: [Xorg et fonts] Xorg déclare inexistants des répertoires pourtant présents

Message par dauriac » sam. 02 nov. 2019, 19:56

voila:

Code : Tout sélectionner

dauriac@megajack:~$ grep -e Log -e tty ~/.local/share/xorg/Xorg.0.log /var/log/Xorg.0.log
/home/dauriac/.local/share/xorg/Xorg.0.log:[     4.221] (--) Log file renamed from "/home/dauriac/.local/share/xorg/Xorg.pid-479.log" to "/home/dauriac/.local/share/xorg/Xorg.0.log"
/home/dauriac/.local/share/xorg/Xorg.0.log:[     4.222] (==) Log file: "/home/dauriac/.local/share/xorg/Xorg.0.log", Time: Fri Dec 28 19:21:47 2018
/var/log/Xorg.0.log:[     4.862] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Nov  2 18:00:37 2019
/var/log/Xorg.0.log:[     4.868] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
dauriac@megajack:~$ 

laurent85
Chu Ko Nu
Messages : 362
Inscription : mar. 16 oct. 2018, 21:05

Re: [Xorg et fonts] Xorg déclare inexistants des répertoires pourtant présents

Message par laurent85 » sam. 02 nov. 2019, 20:43

dauriac a écrit :
sam. 02 nov. 2019, 19:56
/home/dauriac/.local/share/xorg/Xorg.0.log:[ 4.222] (==) Log file: "/home/dauriac/.local/share/xorg/Xorg.0.log", Time: Fri Dec 28 19:21:47 2018
Il date de décembre 2018 le log dans ton home. Le bon fichier de log est /var/log/Xorg.0.log

dauriac
newbie
Messages : 7
Inscription : dim. 17 févr. 2019, 12:09

Re: [Xorg et fonts] Xorg déclare inexistants des répertoires pourtant présents

Message par dauriac » dim. 03 nov. 2019, 10:35

Merci laurent85 !
effectivement /var/log/Xorg.0.log ne mentionne plus de problème de fonte.

Mais il reste que restaurer une vieille version de pango ne marche plus depuis
la dernière mise à jour (hier) pour résoudre le problème des caractères remplacés
par des carrés dans tous les menus.

Répondre