[virtualbox] boot en uefi

Questions et astuces concernant l'installation et la configuration d'archlinux
celp
Hankyu
Messages : 16
Inscription : mar. 14 août 2018, 11:57

[virtualbox] boot en uefi

Message par celp » mar. 03 déc. 2019, 19:10

Bonjour,

j'ai installé en manuel une archlinux dans virtualbox. Par contre pour etre fidele à mon installation en dur, je l'ai mis en dur. Celle-ci me permet de faire des tests.

par contre j'ai un soucis. Je tombe sur le menu de efi lors du reboot de celle-ci.
la première fois l'archlinux démarre normalement par contre si je l’éteint. elle démarre plus.

mon fstab

Code : Tout sélectionner

# Static information about the filesystems.
# See fstab(5) for details.

# <file system> <dir> <type> <options> <dump> <pass>
# /dev/mapper/ARCH--LVM-ARCH--ROOT LABEL=ROOT
UUID=7df66081-3106-41c7-b734-3458f8bfb4b5	/         	ext4      	rw,relatime	0 1

# /dev/sda2 LABEL=BOOT
UUID=fb5c1218-90f3-417e-959b-d1a5f41ea754	/boot     	ext2      	rw,relatime	0 2

# /dev/sda1 LABEL=ESP
UUID=B0B0-5CEE      	/boot/efi 	vfat      	rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro	0 2

# /dev/mapper/ARCH--LVM-ARCH--HOME LABEL=HOME
UUID=da8bfcad-bb02-4fe8-8dd5-4992aa8a2259	/home     	ext4      	rw,relatime	0 2

# /dev/mapper/ARCH--LVM-ARCH--SWAP LABEL=SWAP
UUID=2330a7cc-263a-4d8e-8c9a-f790209e55e8	none      	swap      	defaults  	0 0
voici l'image lors du premier reboot :

Image

et enfin lors de l'extinction de la machine et le démarrage de celle-ci

Image

Avatar de l’utilisateur
Qwaser
Hankyu
Messages : 19
Inscription : jeu. 23 févr. 2017, 13:29
Contact :

Re: [virtualbox] boot en uefi

Message par Qwaser » mar. 03 déc. 2019, 20:42

J'ai eu le même problème et je l'ai réglé en créant un fichier startup.nsh dans /boot contenant ceci :

Code : Tout sélectionner

efi\EFI\syslinux\syslinux.efi
Il faut adapter en fonction du bootloader que tu as choisis ;)

celp
Hankyu
Messages : 16
Inscription : mar. 14 août 2018, 11:57

Re: [virtualbox] boot en uefi

Message par celp » mar. 03 déc. 2019, 21:17

Merci de ta réponse.

J'ai testé ce que tu m'a dis mais ça me fais planter virtualbox.

fichier efi dans /boot

Code : Tout sélectionner

/boot/efi/EFI/arch/grubx64.efi
/boot/grub/x86_64-efi/core.efi
/boot/grub/x86_64-efi/grub.efi
j'ai taper ceci dans le fichier que tu m' fais créer

Code : Tout sélectionner

efi\EFI\arch\grubx64.efi
ps : le problème ne manifeste pas dans vmware player.

Avatar de l’utilisateur
Qwaser
Hankyu
Messages : 19
Inscription : jeu. 23 févr. 2017, 13:29
Contact :

Re: [virtualbox] boot en uefi

Message par Qwaser » mar. 03 déc. 2019, 22:04

Pour GRUB, je ne connais pas tellement... As-tu essayer comme indiqué ici : https://www.linuxbabe.com/virtualbox/in ... virtualbox (partie "How to Exit the EFI Shell") ?

Sinon tu as aussi la documentation officielle d'Arch sur le sujet, mais elle ne précise pas en fonction du bootloader : https://wiki.archlinux.org/index.php/EF ... nsh_script

Oui avec VMWare on n'a pas se problème, c'est uniquement avec Virtualbox ! Surement suite à leur façon différente de gérer l'EFI :?:

benjarobin
Maître du Kyudo
Messages : 15565
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [virtualbox] boot en uefi

Message par benjarobin » mar. 03 déc. 2019, 22:31

Bonjour, le plus simple étant d'installer Grub normalement pour de l'UEFI mais d'ajouter l'option --removable
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Répondre