[accès réseau] Perte d'accès lors d'une installation (contourné)

Questions et astuces concernant l'installation et la configuration d'archlinux
papa6
archer de cavalerie
Messages : 168
Inscription : mar. 08 juil. 2008, 22:40

[accès réseau] Perte d'accès lors d'une installation (contourné)

Message par papa6 » mar. 04 févr. 2020, 19:45

Bonjour,
J'ai suivi le wiki https://wiki.archlinux.fr/Installation sans trop de difficultés (le réseau était accessible). J'ai dû m'y reprendre une seconde fois à cause de Grub mal installé. J'avais sélectionné un dépôt français dans ma mirrorlist et ça s'était bien déroulé (base, linux, linux-firmware uniquement).

Mais depuis, alors que linux se lance, je n'ai plus accès au réseau : je peux pinguer en local mais sans sortir vers le réseau (ex : un ping 8.8.8.8 me donne : "connect: Network is unreachable")

Le service dhcpcd répond "could not be found".

Je ne peux plus rien installer puisque pacman n'a pas accès au réseau.

Mon hostname est défini. J'ai édité à la main /etc/hosts :

Code : Tout sélectionner

127.0.0.1        localhost
::1              localhost
127.0.1.1        myhostname.localdomain        myhostname
Un ip link show montre, pour l'eth (ce qui m'intéresse) un "state DOWN".
Je l'active avec un (l'eth0 est remplacé par la forme enp.etc) :

Code : Tout sélectionner

ip link set dev eth0 up
Là, ça passe en "state UP".

Je continue comme indiqué sur https://wiki.archlinux.fr/Connexions_reseau

Code : Tout sélectionner

ip addr add dev eth0 broadcast 172.16.255.255 local 172.16.0.4
C'est OK.

Code : Tout sélectionner

ip route add default via 172.16.0.1 dev eth0
Ça m'affiche :

Code : Tout sélectionner

Error: Nexthop has invalid gateway.
Merci à vous pour vos idées 🙂
Dernière modification par papa6 le mar. 04 févr. 2020, 21:42, modifié 2 fois.

papa6
archer de cavalerie
Messages : 168
Inscription : mar. 08 juil. 2008, 22:40

Re: [accès réseau] Perte d'accès lors d'une installation

Message par papa6 » mar. 04 févr. 2020, 21:41

J'ai contourné le problème : j'ai chrooté, puis installé dhcpcd et dhclient. Je suis sorti du chroot et j'ai relancé. Ensuite (de retour dans mon environnement) :

Code : Tout sélectionner

systemctl enable dhcpcd
Maintenant j'ai accès au réseau à partir des adresses IP (c'est déjà ça). Pour la suite, ça devrait aller 😉

Répondre