[Défaillance] Arch ne démarre plus

Reconnaissance et configuration du matériel / kernel linux
Avatar de l’utilisateur
mimile
Maître du Kyudo
Messages : 1507
Inscription : lun. 14 nov. 2011, 10:21
Localisation : Seraing (Belgique)

[Défaillance] Arch ne démarre plus

Message par mimile » sam. 08 févr. 2020, 12:43

Bonjour

Voici quelques jours, je démarre mon PC (tour) qui aussitôt affiche mon menu Grub lequel affiche les OS installés sur /dev/sda (Arch, Arch LTS, W7 SP1, Linux Mint).
Et là, la cata : Arch et W7 plantent tandis que Linux Mint démarre normalement.

Je redémarre sur Arch LTS qui à mon soulagement démarre normalement.

J'en profite pour vérifier l'état du disque qui est déclaré sain.

Je commets l'erreur fatale de faire un pacman -Syu, après quoi, je n'ai plus du tout accès à Arch.

Comme j'ai un besoin essentiel de W7, je porte mon PC là où je l'ai fait monter mais en vain : le réparateur me confirme que le disque est sain et qu'il ne s'explique pas ce qui se passe.

Pour me dépanner, il me suggère d'installer un petit SSD (250 Go) pour y installer W7 ce que j'accepte et, de retour chez moi, je remets à peu près tout en état.

En ce qui concerne Arch qui permet un démarrage avec fonctions avancées, au démarrage, je vois défiler la longue liste habituelle des différents éléments mais au lieu de démarrer Arch, la liste disparaît (écran noir) et il m'est demandé mon login et mon mot de passe et même en passant en root, je n'ai que peu de fonctions disponibles (cd, nano, ls, et quelques autres).

Ce qui est étrange, c'est que, aléatoirement, c'est mon menu grub qui s'affiche qui ne me permet qu'une chose : démarrer Linux Mint. Pendant la phase de démarrage, j'arrête le PC à l'arraché et quand je le redémarre, c'est W7 sur le SSD qui démarre normalement.

Mon système utilise GDM et mon pilote graphique est "nouveau".

Que dois-je faire pour qu'enfin Arch démarre ?

Désolé d'avoir été long mais je voulais fournir un max de précisions.

Merci d'avance

Cordialement
La TV ? J'adore la TV. Je peux rester des heures devant la TV ... et même, parfois, il m'arrive de l'allumer ...
Image
(Jean-Luc GODARD)

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10564
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [Défaillance] Arch ne démarre plus

Message par FoolEcho » sam. 08 févr. 2020, 16:43

Salut,
mimile a écrit :
sam. 08 févr. 2020, 12:43
Je commets l'erreur fatale de faire un pacman -Syu, après quoi, je n'ai plus du tout accès à Arch.
Tu as eu des erreurs, qu'est-ce qui a été mis à jour ? (cf. /var/log/pacman.log -- donc possiblement il te faudra monter la partition racine d'Arch dans Mint pour récupérer l'info)
mimile a écrit :
sam. 08 févr. 2020, 12:43
En ce qui concerne Arch qui permet un démarrage avec fonctions avancées, au démarrage, je vois défiler la longue liste habituelle des différents éléments mais au lieu de démarrer Arch, la liste disparaît (écran noir) et il m'est demandé mon login et mon mot de passe et même en passant en root, je n'ai que peu de fonctions disponibles (cd, nano, ls, et quelques autres).
... pige pas, tu dis que ça démarre pas... mais en fait si... ... c'est quoi tes «fonctions avancées» ? ... Tu sembles dire qu'en fait tu démarres sans mode graphique en gros... ou en mode rescue... pas clair...

Ton windows ne démarre pas du tout ? ... Quel est le système d'exploitation qui te gère grub ? Mint ?
Il faudrait voir le contenu du grub.cfg généré par lui (depuis Mint: /boot/grub/grub.cfg ?) ainsi que la sortie de blkid (en root). Si tu pouvais fournir le /etc/fstab d'Arch également (tu devras donc monter la partition racine d'Arch dans Mint).

Pour essayer d'y voir plus clair déjà...
«The following statement is not true. The previous statement is true.» :nage:

Avatar de l’utilisateur
mimile
Maître du Kyudo
Messages : 1507
Inscription : lun. 14 nov. 2011, 10:21
Localisation : Seraing (Belgique)

Re: [Défaillance] Arch ne démarre plus

Message par mimile » dim. 09 févr. 2020, 11:33

Bonjour et merci d'intervenir.

Mon menu grub (crée depuis Linux Mint) se présente comme ceci :

Entête : GNU GRUB Version 2.02~beta2-9ubuntu1.17

Contenu :

- Linux Mint 17.3 Cinnamon 64-bit,4.4.0-148-generic (/dev/sda7)
- Linux Mint 17.3 Cinnamon 64-bit,4.4.0-148-generic (/dev/sda7) -- RECOVERY MODE
- Previous Linux Version (en fait toutes une série de versions antérieures de Mint résultant de mises à jour que j'ai effectuées avec apt-get)
- Memory test (memtest86+)
- Windows 7 (loader) (sur /dev/sda1)
- Archlinux (sur /dev/sda5)
- options avancées pour Archlinux (sur /dev/sda5)
- Arch /boot/grub/grub.cfg (cette ligne m'a été suggérée par Paul Lalonde dont j'ai oublié le pseudo)

Voici un extrait de grub.cfg (sur Mint) :

Code : Tout sélectionner

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.

menuentry 'Windows 7 (loader) (sur /dev/sda1)' --class windows --class os $menuentry_id_option 'osprober-chain-70CCF2F90F3ED419' {
	insmod part_msdos
	insmod ntfs
	set root='hd0,msdos1'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos1 --hint-efi=hd0,msdos1 --hint-baremetal=ahci0,msdos1  70CCF2F90F3ED419
	else
	  search --no-floppy --fs-uuid --set=root 70CCF2F90F3ED419
	fi
	parttool ${root} hidden-
	chainloader +1
}
menuentry 'Archlinux (sur /dev/sda5)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-simple-cea34bcd-d5ed-4887-8bcb-dc6974e84f3d' {
	gfxmode $linux_gfx_mode	
	insmod part_msdos
	insmod ext2
	set root='hd0,msdos5'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos5 --hint-efi=hd0,msdos5 --hint-baremetal=ahci0,msdos5  cea34bcd-d5ed-4887-8bcb-dc6974e84f3d
	else
	  search --no-floppy --fs-uuid --set=root cea34bcd-d5ed-4887-8bcb-dc6974e84f3d
	fi
	linux /boot/vmlinuz-linux loglevel=0 acpi_enforce_resources=no root=UUID=cea34bcd-d5ed-4887-8bcb-dc6974e84f3d rw 
	initrd /boot/intel-ucode.img /boot/initramfs-linux.img
}
submenu 'Options avancées pour Archlinux (sur /dev/sda5)' $menuentry_id_option 'osprober-gnulinux-advanced-cea34bcd-d5ed-4887-8bcb-dc6974e84f3d' {
	menuentry 'Archlinux (sur /dev/sda5)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-/boot/vmlinuz-linux--cea34bcd-d5ed-4887-8bcb-dc6974e84f3d' {
		gfxmode $linux_gfx_mode		
		insmod part_msdos
		insmod ext2
		set root='hd0,msdos5'
		if [ x$feature_platform_search_hint = xy ]; then
		  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos5 --hint-efi=hd0,msdos5 --hint-baremetal=ahci0,msdos5  cea34bcd-d5ed-4887-8bcb-dc6974e84f3d
		else
		  search --no-floppy --fs-uuid --set=root cea34bcd-d5ed-4887-8bcb-dc6974e84f3d
		fi
		linux /boot/vmlinuz-linux loglevel=0 acpi_enforce_resources=no root=UUID=cea34bcd-d5ed-4887-8bcb-dc6974e84f3d rw
		initrd /boot/intel-ucode.img /boot/initramfs-linux.img
	}
	menuentry 'Archlinux LTS (sur /dev/sda5)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-/boot/vmlinuz-linux-lts--cea34bcd-d5ed-4887-8bcb-dc6974e84f3d' {
		gfxmode $linux_gfx_mode	
		insmod part_msdos
		insmod ext2
		set root='hd0,msdos5'
		if [ x$feature_platform_search_hint = xy ]; then
		  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos5 --hint-efi=hd0,msdos5 --hint-baremetal=ahci0,msdos5  cea34bcd-d5ed-4887-8bcb-dc6974e84f3d
		else
		  search --no-floppy --fs-uuid --set=root cea34bcd-d5ed-4887-8bcb-dc6974e84f3d
		fi
		linux /boot/vmlinuz-linux-lts loglevel=0 acpi_enforce_resources=no root=UUID=cea34bcd-d5ed-4887-8bcb-dc6974e84f3d rw
		initrd /boot/intel-ucode.img /boot/initramfs-linux-lts.img
	}
}
	menuentry "Arch /boot/grub/grub.cfg" {
		set root=(hd0,5)
		configfile /boot/grub/grub.cfg
}

### END /etc/grub.d/40_custom ###
NB : J'ai vérifié les UUID qui sont correctes.

Lorsque j'ai effectué Pacman -Suy et que j'ai vu défiler la longue liste de démarrage, aucune erreur n"est apparue.

Pour ce qui est de /var/log/pacman.log : il est interminable car j'ai effectué à plusieurs reprises Pacman -Syu qui, à chaque fois m'a suggéré de nouveaux paquets et n'a jamais signalé d'erreur.

En fait, je pense qu'effectivement le mode graphique ne démarre pas puisque à l'issue de la liste de démarrage, j'arrive à un écran noir où il m'est demandé mon login et mon mot de passe.

Je ne sais pas comment faire pour lancer le mode graphique.
Dernière modification par FoolEcho le lun. 10 févr. 2020, 19:50, modifié 1 fois.
Raison : lisibilité: balise code
La TV ? J'adore la TV. Je peux rester des heures devant la TV ... et même, parfois, il m'arrive de l'allumer ...
Image
(Jean-Luc GODARD)

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10564
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [Défaillance] Arch ne démarre plus

Message par FoolEcho » lun. 10 févr. 2020, 20:06

mimile a écrit :
dim. 09 févr. 2020, 11:33
En fait, je pense qu'effectivement le mode graphique ne démarre pas puisque à l'issue de la liste de démarrage, j'arrive à un écran noir où il m'est demandé mon login et mon mot de passe.

Je ne sais pas comment faire pour lancer le mode graphique.
...
Pour voir l'état du truc:

Code : Tout sélectionner

systemctl -t service -a --full | grep error
systemctl status gdm.
Pour tenter un lancement: systemctl start gdm revérifier la sortie de status. https://wiki.archlinux.fr/Systemd#Diagnostic
Aussi il faut voir du côté des logs: si ça n'a pas changé, avec ton utilisateur: ~/.cache/gdm/session.log ; /var/log/Xorg.0.log (si tu passes par Wayland, je ne sais pas où c'est) ... Jeter un oeil dans journalctl --since="today".
«The following statement is not true. The previous statement is true.» :nage:

Avatar de l’utilisateur
mimile
Maître du Kyudo
Messages : 1507
Inscription : lun. 14 nov. 2011, 10:21
Localisation : Seraing (Belgique)

Re: [Défaillance] Arch ne démarre plus

Message par mimile » mar. 11 févr. 2020, 17:29

Salut FoolEcho

J'ai un peu essayé toutes les options que tu m'as indiquées (merci pour ton obstination à me venir en aide) mais rien n'a fonctionné.

Lors de mes tentatives, la constante que j'ai constatée a été que gdm (ou gdm.service) étaient inconnus.

Donc, tant qu'à faire, j'ai fait un bête Pacman -S gdm et ... voilà-t'y pas qu'après avoir exécuté systemctl start gdm, mon écran noir passe au gris avec, au milieu, ma bouille (en français : mon visage pour le cas où ...) avec mon nom d'utilisateur (okapi) et la demande de mot de passe que je lui fournit évidemment.

Pendant quelques secondes, mon écran repasse au noir (sauf que la flèche de ma souris reste en place et est pilotable) mais malheureusement, après quelques secondes, retour à la case départ (ma bouille et une demande de mot de passe).

La réponse est à chaque fois négative (comme si mon mot de passe n'était pas le bon).

Je vérifie et mon clavier est bel et bien confirmé comme étant belge ce qui implque que mon clavier est bien en azerty.

A tout hasard, je tente de confirmer mon mot de passe à la british (comme si mon clavier était en qwerty) mais là, c'est directement le brexit :humour:

Donc, il y a un (petit) mieux mais qui ne mène à rien.

Il doit y a probablement une manip qui m'échappe.

Une idée ?

cordialement

Mimile
La TV ? J'adore la TV. Je peux rester des heures devant la TV ... et même, parfois, il m'arrive de l'allumer ...
Image
(Jean-Luc GODARD)

Répondre