[linux] Arch ne démarre pas après update du paquet linux (kernel)

Reconnaissance et configuration du matériel / kernel linux
Répondre
kndeye
newbie
Messages : 8
Inscription : mar. 29 mai 2018, 01:49

[linux] Arch ne démarre pas après update du paquet linux (kernel)

Message par kndeye » jeu. 13 févr. 2020, 16:40

Bonjour à tous, je suis nouveau sur archlinux mais j'étais avant sur du antergos et par la suite manjaro. j'ai un problème récurent avec la mis à jour de linux.
A chaque mis à jour de linux, il y a une erreur sur les files systems qui empêche ma partition de données de se monter et donc le système ne démarre pas.
A chaque fois je démarre avec une clé d'installation, je chroot, je réinstalle le paquet linux et je refais la configuration de grub, je suis sur du dual boot avec win 10.

Image


Si quelqu'un a une idée ?

benjarobin
Maître du Kyudo
Messages : 15623
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [linux] Arch ne démarre pas après update du paquet linux (kernel)

Message par benjarobin » jeu. 13 févr. 2020, 17:27

Bonjour,
Essaye déjà d'enlever le montage de "donnees" de ton fstab. Car je ne suis pas sûre que la réinstallation du paquet linux est le moindre lien
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

kndeye
newbie
Messages : 8
Inscription : mar. 29 mai 2018, 01:49

Re: [linux] Arch ne démarre pas après update du paquet linux (kernel)

Message par kndeye » ven. 14 févr. 2020, 10:02

Bonjour,
Si je l'enlève ça marche, j'avais déjà essayé. Mais quand je le remet, à la prochaine mis à jour de linux le problème revient encore.
Quand je fais un

Code : Tout sélectionner

systemctl status mnt3-Donnees.mount 
il m'indique que le module fuse est introuvable dans /lib/modules

benjarobin
Maître du Kyudo
Messages : 15623
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [linux] Arch ne démarre pas après update du paquet linux (kernel)

Message par benjarobin » ven. 14 févr. 2020, 12:08

Peux tu donner le contenu de ton fstab, la sortie (en root) de blkid, et la sortie de fdisk -l

As tu une partition de boot ?
Tu démarres en UEFI ? So oui où est monté la partition ESP ?
Qu'est ce que tu fais pour réparer en chroot, en détail s'il te plaît.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

kndeye
newbie
Messages : 8
Inscription : mar. 29 mai 2018, 01:49

Re: [linux] Arch ne démarre pas après update du paquet linux (kernel)

Message par kndeye » ven. 14 févr. 2020, 13:55

Code : Tout sélectionner

root@user]# blkid
/dev/sda1: LABEL="RM-CM-)cupM-CM-)ration" BLOCK_SIZE="512" UUID="B69EA75A9EA71243" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="ab347e9f-12bb-4d13-be2f-14d657fd9f06"
/dev/sda2: UUID="BEA9-4DE2" BLOCK_SIZE="512" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="255129bc-06eb-4526-a58a-6cddc2f722b2"
/dev/sda4: BLOCK_SIZE="512" UUID="FE40AC7840AC3973" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="dffd4c0e-40df-487d-86fb-ac4d940d0acc"
/dev/sda5: LABEL="Donnees" BLOCK_SIZE="512" UUID="AAFA0290FA025949" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="7a493020-7b78-4036-b9b9-4d4d288413f0"
/dev/sda6: UUID="5294-7237" BLOCK_SIZE="512" TYPE="vfat" PARTUUID="0c0c7ea5-2b8f-2d42-810d-0803b4d9aca0"
/dev/sda7: UUID="af931a27-71a4-4510-ace8-59dd34150d75" TYPE="swap" PARTUUID="d4fe8cee-379c-f344-b71c-783b0a6e961a"
/dev/sda8: UUID="f8139aff-1ff3-4d71-a85c-5278fc036123" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="5ee5c02c-5572-c742-a7b7-ce2aa2b5732b"
/dev/sda3: PARTLABEL="Microsoft reserved partition" PARTUUID="542c7e8e-9982-489e-95eb-95c0bdceaf25"

Code : Tout sélectionner

[root@user]# fdisk -l
Disque /dev/sda : 931,53 GiB, 1000204886016 octets, 1953525168 secteurs
Modèle de disque : ST1000LM035-1RK1
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 4096 octets
taille d'E/S (minimale / optimale) : 4096 octets / 4096 octets
Type d'étiquette de disque : gpt
Identifiant de disque : 8CDFA0C6-2281-41C3-80A6-C367515F2350

Périphérique      Début        Fin   Secteurs Taille Type
/dev/sda1          2048    1085439    1083392   529M Environnement de récupération Windows
/dev/sda2       1085440    1290239     204800   100M Système EFI
/dev/sda3       1290240    1323007      32768    16M Réservé Microsoft
/dev/sda4       1323008  420753407  419430400   200G Données de base Microsoft
/dev/sda5     420753408 1469329407 1048576000   500G Données de base Microsoft
/dev/sda6    1469329408 1470377983    1048576   512M Système EFI
/dev/sda7    1470377984 1487155199   16777216     8G Partition d'échange Linux
/dev/sda8    1487155200 1953525134  466369935 222,4G Système de fichiers Linux


kndeye
newbie
Messages : 8
Inscription : mar. 29 mai 2018, 01:49

Re: [linux] Arch ne démarre pas après update du paquet linux (kernel)

Message par kndeye » ven. 14 févr. 2020, 14:01

Oui j'ai une partition de boot sur sda6 pour arch et sda2 pour windows
je démarre sur UEFI, mais j'ai aucune idée du montage de la partition ESP
En chroot je réinstalle linux
après je fais grub-install --target=x86_64-efi --efi-directory=/boot/ --bootloader-id=GRUB
et puis grub-mkconfig -o /boot/grub/grub.cfg

benjarobin
Maître du Kyudo
Messages : 15623
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [linux] Arch ne démarre pas après update du paquet linux (kernel)

Message par benjarobin » ven. 14 févr. 2020, 17:31

sad2 comme sda6 sont des partitions ESP. Donc à priori tu n'as pas de partition de boot, mais une partition ESP.
Ce qui est tout à fait acceptable comme façon de faire. Par contre avoir 2 partitions ESP sur le même disque est un peu étrange...

Tu montes comment et quelles partitions pour ton chroot (c'est ce que je voulais dire, quand j'ai indiqué "en détails"). Je veux toutes les commandes que tu exécutes lorsque tu veux réparer.
Sinon ce n'est pas non plus une façon standard d'installer Grub, mais cela fonctionne aussi...
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

kndeye
newbie
Messages : 8
Inscription : mar. 29 mai 2018, 01:49

Re: [linux] Arch ne démarre pas après update du paquet linux (kernel)

Message par kndeye » ven. 14 févr. 2020, 18:01

je monte la partition sda8 sur /mnt et sda6 sur /mnt/boot après je chroot sur /mnt
Pour les partitions ESP, comme je suis un petit nouveau je savais pas exactement comment configurer pour avoir le dualboot

benjarobin
Maître du Kyudo
Messages : 15623
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [linux] Arch ne démarre pas après update du paquet linux (kernel)

Message par benjarobin » ven. 14 févr. 2020, 18:43

Peux tu donner le contenu de ton fstab comme demandé précédement
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

kndeye
newbie
Messages : 8
Inscription : mar. 29 mai 2018, 01:49

Re: [linux] Arch ne démarre pas après update du paquet linux (kernel)

Message par kndeye » lun. 17 févr. 2020, 09:48

Voici mon fstab

Code : Tout sélectionner

# Static information about the filesystems.
# See fstab(5) for details.

# <file system> <dir> <type> <options> <dump> <pass>

# /dev/sda7
UUID=af931a27-71a4-4510-ace8-59dd34150d75       none            swap            defaults        0 0
#/dev/sda5
/dev/sda5       /mnt3/Donnees   ntfs    default,noatime 0       0
# /dev/sda8
UUID=f8139aff-1ff3-4d71-a85c-5278fc036123       /               ext4            rw,relatime     0 1

none    /tmp          tmpfs    mode=01777,noatime,nodev,nosuid    0    0


benjarobin
Maître du Kyudo
Messages : 15623
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [linux] Arch ne démarre pas après update du paquet linux (kernel)

Message par benjarobin » lun. 17 févr. 2020, 10:11

Tu as plusieurs problèmes :
- /mnt3/Donnees devrait être monté via l'UUID
- /mnt3/Donnees devrait être monté via ntfs-3g
- Tu ne devrait pas avoir de point de montage pour /tmp
- Tu n'as pas d'entrée (de point de montage) pour ta partition ESP
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

kndeye
newbie
Messages : 8
Inscription : mar. 29 mai 2018, 01:49

Re: [linux] Arch ne démarre pas après update du paquet linux (kernel)

Message par kndeye » lun. 17 févr. 2020, 10:23

ok je vais corriger ça en attendant une mis à jour pour voir si c'est bon.
Et merci pour l'assistance

Répondre