[pacman] error: failed to initialize alpm library (could not find or read directory) (résolu)

Questions et astuces concernant l'installation et la configuration d'archlinux
ignace72
Chu Ko Nu
Messages : 305
Inscription : ven. 09 sept. 2011, 14:21

[pacman] error: failed to initialize alpm library (could not find or read directory) (résolu)

Message par ignace72 » sam. 15 févr. 2020, 12:40

Bonjour à tous.
J'installe ArchLinux par chroot et la commande suivante me donne l’erreur suivante :

Code : Tout sélectionner

# pacman -r /mnt --cachedir /mnt/var/cache/pacman/pkg -Sy base syslinux
error: failed to initialize alpm library (could not find or read directory)
Si quelqu'un a une idée pour résoudre mon problème  ?
Merci
Dernière modification par ignace72 le sam. 15 févr. 2020, 18:07, modifié 1 fois.
AMD Phenom II X6 1100T, 16 Go de ram DDR3, bluetooth, Wifi, USB3, S-ATA 3
21,5" LCD tn (16/9) x2 sur AMD HD 7750 fanless (pilote libre).
XFce et BÉPO.
Site perso : https://ignace72.eu

benjarobin
Maître du Kyudo
Messages : 15724
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [pacman] error: failed to initialize alpm library (could not find or read directory)

Message par benjarobin » sam. 15 févr. 2020, 13:57

Bonjour,
L'installation de base se fait en chroot, et ce n'est pas la méthode décrite dans le Wiki. Il suffit de suivre le Wiki...
Qu'est ce que tu essayes de faire de différent ?
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

ignace72
Chu Ko Nu
Messages : 305
Inscription : ven. 09 sept. 2011, 14:21

Re: [pacman] error: failed to initialize alpm library (could not find or read directory)

Message par ignace72 » sam. 15 févr. 2020, 14:10

Bonjour benjarobin.
J'ai suivi le Wiki suivant https://wiki.archlinux.fr/install_chroot ni plus ni moins.
Je ne vois pas ce que j'aurai pu faire différemment.
La ligne de commande que j'ai tapé est celle du Wiki dans la partie installation (la troisième commande)
AMD Phenom II X6 1100T, 16 Go de ram DDR3, bluetooth, Wifi, USB3, S-ATA 3
21,5" LCD tn (16/9) x2 sur AMD HD 7750 fanless (pilote libre).
XFce et BÉPO.
Site perso : https://ignace72.eu

benjarobin
Maître du Kyudo
Messages : 15724
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [pacman] error: failed to initialize alpm library (could not find or read directory)

Message par benjarobin » sam. 15 févr. 2020, 14:16

Hum, ce wiki n'est pas à jour... Le fichier dans http://mir.archlinux.fr/~tuxce/chroot/ date de 2012...
Et il est bien précisé de préférer l'utilisation de pacstrap.
Bref, le plus simple est de suivre le Wiki pour une installation classique et d'utiliser archlinux-bootstrap tel que décrit ici : https://wiki.archlinux.org/index.php/In ... commended)
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

ignace72
Chu Ko Nu
Messages : 305
Inscription : ven. 09 sept. 2011, 14:21

Re: [pacman] error: failed to initialize alpm library (could not find or read directory)

Message par ignace72 » sam. 15 févr. 2020, 18:06

Bon… j'ai essayé avec la nouvelle méthode mais ça bloque avec vagrant.
Je me grave le CD et ça ira mieux comme ça.
Merci de ton aide.
AMD Phenom II X6 1100T, 16 Go de ram DDR3, bluetooth, Wifi, USB3, S-ATA 3
21,5" LCD tn (16/9) x2 sur AMD HD 7750 fanless (pilote libre).
XFce et BÉPO.
Site perso : https://ignace72.eu

Répondre